fesco
LOGS
14:00:13 <dcantrell> #startmeeting FESCO (2021-03-24)
14:00:13 <zodbot> Meeting started Wed Mar 24 14:00:13 2021 UTC.
14:00:13 <zodbot> This meeting is logged and archived in a public location.
14:00:13 <zodbot> The chair is dcantrell. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:13 <zodbot> The meeting name has been set to 'fesco_(2021-03-24)'
14:00:13 <dcantrell> #meetingname fesco
14:00:14 <dcantrell> #chair nirik, ignatenkobrain, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, cverna, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
14:00:14 <zodbot> The meeting name has been set to 'fesco'
14:00:14 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku cverna dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
14:00:16 <dcantrell> #topic init process
14:00:26 <mhroncok> .hello churchyard
14:00:27 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
14:00:28 <Eighth_Doctor> .hello ngompa
14:00:30 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
14:00:32 <dcantrell> .hello2
14:00:33 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
14:00:40 <dcantrell> hi, Miro.  hi, Neal.
14:01:30 <zbyszek> .hello2
14:01:31 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
14:02:03 <dcantrell> hi, Zbigniew
14:02:14 <mhroncok> hi, David
14:02:21 <nirik> morning
14:02:38 <dcantrell> hi
14:02:49 <dcantrell> and that's 5?
14:02:51 * dcantrell counts
14:02:53 <zbyszek> Hi David, hi everyone.
14:03:36 <dcantrell> I forget, do we need 5 or 6 to proceed?
14:03:38 * decathorpe 's ghost hovers around
14:03:40 <zbyszek> 5
14:03:50 <dcantrell> ok, and there's 6 anyway.  very good
14:04:09 <zbyszek> We should also talk about the meeting time.
14:04:10 <dcantrell> Alright everyone, I think this will be short today.  Hopefully.  Thanks for joining.  let's get going
14:04:21 <dcantrell> zbyszek: let's do that after the two topics here
14:04:36 <dcantrell> #2582 F35 Change: rpmautospec - removing release and changelog fields from spec files
14:04:39 <dcantrell> .fesco 2582
14:04:40 <zodbot> dcantrell: Issue #2582: F35 Change: rpmautospec - removing release and changelog fields from spec files - fesco - Pagure.io - https://pagure.io/fesco/issue/2582
14:04:42 <sgallagh> Oops, I have this on my calendar in an hour.
14:04:44 <sgallagh> I'm here now
14:04:44 * cverna waves
14:04:51 <dcantrell> welcome, sgallagh and cverna
14:05:15 <cverna> sgallagh: same here, calendar playing tricks on me :)
14:06:08 * Eighth_Doctor sighs
14:06:19 <dcantrell> for 2582, we've got feedback from zbyszek and Eighth_Doctor.  not sure if you two have anything else to add
14:06:51 <zbyszek> I'm typing in the ticket now.
14:07:22 <dcantrell> ok, I will wait.  I'm also ok with this one just continuing in the ticket.  zbyszek was the final vote I believe
14:07:34 <zbyszek> I think I understand where Eighth_Doctor is coming from, but I don't share his view.
14:07:55 <sgallagh> I haven't had time to review the latest chatter.
14:08:18 <Eighth_Doctor> I used to have zbyszek's position, then I spent a couple of years in openSUSE where it doesn't work that way
14:08:35 <Eighth_Doctor> and it's really freeing and makes it easier to do bigger things
14:08:47 <mhroncok> I haven't had time to read thie either
14:09:02 <Eighth_Doctor> that part of the openSUSE workflow is what I want to bring into Fedora, because I think it'll make things much better
14:09:27 <dcantrell> ok, I think then maybe we should all continue this one outside the meeting and followup in the ticket
14:09:34 <Eighth_Doctor> honestly, my opinion is that if that isn't part of the goal, I'm inclined to reject the whole proposal
14:09:37 <dcantrell> it feels like we're converging on a decision but not everyone is caught up right now
14:09:53 <Eighth_Doctor> because tbh, it's not worth it for changelog merge conflicts
14:10:02 <zbyszek> Eighth_Doctor: but the thing you want to make easier is something that our guidelines say shoudln't be done. So if you want to convince me that it is a good thing, please start with the motiviation.
14:10:52 <Eighth_Doctor> zbyszek: well, I don't think soname bumps should happen in stable branches without exceptional need, I'm referring to rawhide
14:10:54 <Eighth_Doctor> remember that everything uses bodhi now
14:10:55 <mhroncok> note that if we make it work ina  way that requires the commit, we can later revisit this
14:11:06 <Eighth_Doctor> there's no reasonable way to make this work with commits
14:11:10 <mhroncok> but if we build multiple builds from single commit from the start, it will be problematic to revisit that
14:11:34 <Eighth_Doctor> because if we have to make commits, someone has to have write privileges
14:11:57 <mhroncok> that is not necessarily a bad thing
14:11:59 <Eighth_Doctor> and also the commit sequence doesn't imply the order of merging either
14:12:07 <zbyszek> Without a commit, there is no commit message, and this is an anti-feature for me.
14:12:08 <Eighth_Doctor> yes it is
14:12:15 <mhroncok> zbyszek: +1
14:12:41 <Eighth_Doctor> if you want commits and commit messages for every build
14:12:48 <Eighth_Doctor> there's no point in doing rpmautospec at all
14:13:01 <mhroncok> Eighth_Doctor: not true
14:13:07 <mhroncok> the point is: no more bloody conflicts
14:13:17 <Eighth_Doctor> wrong
14:13:18 <zbyszek> Eighth_Doctor: that's an overstatement. There is a lot of value in having that, even if the particular feature you care about, which we don't currently use in Fedora, is not supported.
14:13:21 <mhroncok> you can have more PRs open at the same time and marge them in any order
14:13:41 <mhroncok> Eighth_Doctor: wrong how?
14:13:47 <zbyszek> Exactly. And trivially cherry-pick patches between branches.
14:13:56 <mhroncok> or between distros
14:14:25 <Eighth_Doctor> how many people actually have that problem?
14:14:32 <Eighth_Doctor> because I don't
14:14:35 <zbyszek> "that problem"?
14:14:46 <mhroncok> Eighth_Doctor: I don't know how many
14:14:48 <Eighth_Doctor> I can probably bet that closer to 80% of packagers maintain their packages with a single effective branch
14:15:11 <mhroncok> Eighth_Doctor: e.g. entire pytohn-maint has this problem
14:15:35 <mhroncok> Eighth_Doctor: packagers that maintain their packages with a single effective branch don't need a solution
14:15:38 <Eighth_Doctor> yeah, because your packages are different per branch, which is rare
14:15:46 <mhroncok> packagers that acually follow the update policy need the solution
14:16:32 <zbyszek> Eighth_Doctor: the packages that are multi-branch are often very important packages with a lot of commits. So optimizing for them, even if it's a small chunk of the overall package count, is still worth it.
14:16:50 <Eighth_Doctor> uh huh, but the existence of changelog files that must exist in the repo means that you're still screwed
14:16:52 <mhroncok> let's have a look at https://fedoraproject.org/wiki/Changes/rpmautospec#Benefit_to_Fedora
14:17:00 <mhroncok> Eighth_Doctor: no
14:17:05 <Eighth_Doctor> and if you have to edit the changelog, you're back to square one again
14:17:22 <Eighth_Doctor> because we don't have a git-data based way to do it
14:17:32 <mhroncok> the benefit does not tell: "anyone can rebuild anything anytime without write permissions"
14:18:06 <Eighth_Doctor> because rpmautospec itself doesn't do it, that would be a follow-on automation change
14:18:07 <mhroncok> Eighth_Doctor: as long as you keep the changelog-edit commits separate, you don't have a problem
14:18:27 <Eighth_Doctor> yeah, that's not going to happen
14:18:37 <Eighth_Doctor> nobody does that now with changelogs in spec files
14:18:42 <Eighth_Doctor> you could do that if you wanted, but you don't
14:18:54 <mhroncok> Eighth_Doctor: for editing the old ones? sure I do that
14:19:08 <Eighth_Doctor> dude, you have to regenerate that file every time you need to edit it
14:19:08 <mhroncok> Eighth_Doctor: why would I edit an old changelog entyr together with other changes in the spec file?
14:19:13 <dcantrell> the point is valid, that would be more self-discipline than anything
14:19:16 <Eighth_Doctor> otherwise you lose changelog entries
14:19:33 <mhroncok> yes, how often do we need to do this?
14:19:37 <Eighth_Doctor> the changelog part of the system is the poorly designed part
14:19:56 <Eighth_Doctor> mhroncok: how often do people actually maintain packages with differing branches?
14:20:04 <mhroncok> oftne
14:20:06 <mhroncok> *often
14:20:10 <mhroncok> big, complicated stuff
14:20:10 <Eighth_Doctor> the point is, if you want to solve the 1% cases, you really need to justify it
14:20:17 <Eighth_Doctor> and you really aren't selling me on it
14:20:22 <mhroncok> Eighth_Doctor: rigth back at you, really :D
14:20:32 <dcantrell> ok guys, let's keep it civil  :)
14:20:37 <mhroncok> Eighth_Doctor: both of us wants to solve "their" problem
14:20:49 <mhroncok> dcantrell: sorry, I thought the :D makes it less horrible
14:20:49 <zbyszek> Eighth_Doctor: but the packages with differing branches are the ones we are solving here. Mono-branch packages don't need this and don't care.
14:21:08 <dcantrell> mhroncok: it did, but I just wanted to restate the obvious.  tone is difficult in irc
14:21:22 <Eighth_Doctor> zbyszek: literally the reason for %autorelease is for non-commit rebuilds
14:21:29 <mhroncok> Eighth_Doctor: apologies, no harm intended
14:21:36 <mhroncok> Eighth_Doctor: no
14:21:38 <Eighth_Doctor> yes
14:21:39 <zbyszek> Eighth_Doctor: not for me
14:21:50 <mhroncok> Eighth_Doctor: the reason for %autorelease  is for non-conflicitng commits
14:21:53 <Eighth_Doctor> well, that's why myself, pingou, and nils designed it
14:22:17 <Eighth_Doctor> it came out of the conversation at flock in 2019
14:22:19 <mhroncok> clearly said in https://fedoraproject.org/wiki/Changes/rpmautospec#Benefit_to_Fedora
14:22:41 <mhroncok> The Release and %changelog fields are the two  most conflicting fields in RPM spec files. They impact most pull  requests if they involve updating the package or if the package is  updated/rebuilt while pull-request are being reviewed.
14:23:11 <Eighth_Doctor> it's clearly omitted is what it is :(
14:23:40 <mhroncok> let me wrap it up
14:23:46 <Eighth_Doctor> it was even mentioned in the nest talk last year :(
14:23:47 <mhroncok> Eighth_Doctor wants one thing
14:23:56 <mhroncok> me, decathorpe, zbyszek want another thing
14:24:18 <mhroncok> Eighth_Doctor says our thing is not worth doing alone and let's not even approve it if the other thing is not possible
14:24:25 <zbyszek> Also, there's the following issue: this scheme is opt-in. If we were to accomodate what Eighth_Doctor wants, we would need to require all packages to follow the new scheme. This is another reason not to do that.
14:24:54 <mhroncok> we say let's have our thing first and if the other thing really is needed, it can be discussed and added later
14:25:20 <Eighth_Doctor> well if I know all of you are going to vote it down, why I would I bother to write the other half to make it possible?
14:25:37 <zbyszek> Yeah, I think we should consider Neal's approach separately. Maybe it's a good thing in some scenarios, but we shouldn't mix it.
14:25:58 <dcantrell> heads up, we're almost at 15 minutes on this topic.
14:26:00 <mhroncok> Eighth_Doctor: not necessarily if you show how it's better than not having it
14:26:10 <dcantrell> (2 minutes away by my stopwatch)
14:26:19 <mhroncok> Eighth_Doctor: I've even voted +1 for the proposal as is, becasue I disagree about this, but I don't want to block progress
14:26:46 * Eighth_Doctor shrugs
14:26:53 <mhroncok> but let's not block the benefits of %autorel(ease) and %autochangelog just because one other thing would not be included
14:27:05 <zbyszek> Yeah, I'm ready to move on too. I'll vote in the ticket if that's ok.
14:27:42 <Eighth_Doctor> if we're going to do this, my condition is that we need a more uniform workflow for changelogs
14:27:52 <Eighth_Doctor> the current proposed workflow is awful
14:28:27 <dcantrell> ok, that's 15 minutes.  we'll continue in the ticket
14:28:45 <mhroncok> if everybody keeps projecting their own little disagreements here and there, we  will never have this
14:29:08 * mhroncok stops
14:29:24 <dcantrell> #action everyone read and add additional comments to the ticket; hopefully voting takes place there
14:29:30 <dcantrell> #2589 Disallow "Block Un-Signed commits" hook in dist-git
14:29:30 <dcantrell> .fesco 2589
14:29:31 <zodbot> dcantrell: Issue #2589: Disallow "Block Un-Signed commits" hook in dist-git - fesco - Pagure.io - https://pagure.io/fesco/issue/2589
14:29:57 <dcantrell> this one I left on the agenda, but I'm prepared to vote +1 now
14:29:58 <Eighth_Doctor> I think we pretty much agree that we should do this
14:30:18 <dcantrell> thanks for the feedback after my comment
14:30:22 <Eighth_Doctor> aside from dcantrell everyone voted +1
14:30:25 <mhroncok> dcantrell: I appreciate the "we should have asked trousers mainatainers why they do this in the first place" thought
14:30:53 <dcantrell> mhroncok: thanks.  for future items, I would like to make sure we do try to get input from the example package in question
14:31:03 <mhroncok> dcantrell: but OTOH I cannot even imagine a reason they'd give that I'd consider and say: yes, sure, let's keep this
14:31:22 <dcantrell> mhroncok: true, but I never want to assume  :)
14:31:38 <dcantrell> so, uh vote here or in the ticket?
14:31:54 <mhroncok> we need to vote here
14:31:58 <zbyszek> dcantrell: more people voted in the ticket. If you vote there too, it'll be +9.
14:31:59 <mhroncok> ticket cannot pass if it has -1
14:32:22 <dcantrell> alright
14:32:31 <mhroncok> dcantrell: unless you want to withdraw that vote
14:32:42 <zbyszek> mhroncok: it's already been superseded
14:32:43 <dcantrell> I just voted +1 in the comment thread
14:32:51 <dcantrell> or did while talking here
14:32:54 <mhroncok> oh
14:33:27 <mhroncok> let's call it approved +9 here, so we can announce and close?
14:33:40 <zbyszek> ack
14:33:44 <nirik> also should file a infra/pagure ticket to do it. ;)
14:33:51 <dcantrell> #agreed (+9,0,-0)
14:34:04 <mhroncok> #action mhroncok to open infra ticket to do it
14:34:37 <dcantrell> #topic Next week's chair
14:35:06 <zbyszek> I can.
14:35:13 <dcantrell> thanks, zbyszek
14:35:24 <dcantrell> #action zbyszek will chair next meeting
14:35:30 <dcantrell> #topic Open Floor
14:35:44 <zbyszek> Meeting time?
14:35:54 <mhroncok> impossible
14:35:58 <dcantrell> heh
14:36:05 <nirik> Just a reminder that the new account system is rolling out. Thanks in advance for everyone's patience as we deploy.
14:36:35 <dcantrell> nirik: thank you.  I look forward to the improvements
14:36:49 <dcantrell> zbyszek: did you want to change the meeting time or discuss changing it?
14:37:06 <zbyszek> We had a poll, the results are here https://whenisgood.net/raqpfhx/results/wjshcxp
14:37:21 <zbyszek> Myself, I'm OK with the current time.
14:37:51 <Eighth_Doctor> I'm pretty much stuck at the current time :/
14:38:14 <Eighth_Doctor> nirik, dcantrell: also a packaged version of the new account system has landed in Fedora for other people to use for their own deployments :)
14:38:15 <dcantrell> looking at the results, I don't really see a better option.  everything appears to be not ideal
14:38:30 <dcantrell> Eighth_Doctor: nice
14:39:10 <mhroncok> we won't have decathorpe and ignatenkobrain
14:39:18 <mhroncok> ^ if we keep it now
14:39:18 <cverna> current time is Ok for me, not ideal but OK :)
14:39:29 <mhroncok> and if we move it, we loose different people
14:39:51 <mhroncok> "ideal" time for this meeting is like an unicorn
14:40:11 <mhroncok> all we need is a time that is mostly OK
14:40:29 <dcantrell> reading the results on this url is difficult
14:40:38 <dcantrell> trying to find the best options, that is
14:40:52 <zbyszek> dcantrell: look for the one with least red dots
14:41:09 <zbyszek> also you can click on a person to exclude their vote.
14:41:19 <zbyszek> People are sorted by the number of slots they entered.
14:41:36 <zbyszek> And if you're logged in, the times are in your own timezone.
14:42:02 <sgallagh> Not so
14:42:10 <sgallagh> I'm logged in and they're definitely in UTC
14:42:20 <sgallagh> They're in my TZ when I edit my replies, though
14:42:21 <zbyszek> Yeah, UTC. Sorry, I was confused by DST.
14:42:21 <dcantrell> wow, so Eighth_Doctor has the most restrictive time options here in the results
14:42:46 <Eighth_Doctor> yep
14:43:05 <Eighth_Doctor> over the past half year, so many meetings have built up in my calendar that I have no wiggle room
14:43:07 <sgallagh> I can probably make that Monday slot where Neal and I are the only exceptions
14:43:20 <Eighth_Doctor> I had to drop out of EPEL meetings because it moved from Friday to Tuesday
14:43:48 <sgallagh> I won't be able to chair, but it's a conflict with a meeting I can probably dual-attend.
14:43:48 <Eighth_Doctor> I can maybe show up on the Tuesday slot where it overlaps with the OKD WG meeting
14:43:58 <Eighth_Doctor> no chairing, like sgallagh said
14:44:08 <Eighth_Doctor> but I could attend since it's an IRC meeting and the other is a video meeting
14:44:15 <Eighth_Doctor> but being double-booked sucks
14:44:28 <dcantrell> ok, so moving to Mon at 16:00 UTC could possibly work for all of us?
14:44:30 <zbyszek> Dunno, if nobody is too unhappy with the current time, let's just keep it.
14:44:43 <Eighth_Doctor> I literally can't do Monday
14:44:44 <Eighth_Doctor> ever
14:45:05 <Eighth_Doctor> that's my $dayjob weekly scrum meeting
14:45:08 <Eighth_Doctor> 11am US/ET on Monday and Friday
14:45:11 <zbyszek> dcantrell: 16 UTC monday is pretty bad for me.
14:45:15 <dcantrell> I'm beginning to think you are only in meetings  :)
14:45:16 <nirik> Eighth_Doctor: it moved to wed afternoon. ;)
14:45:33 <sgallagh> zbyszek: This time doesn't permit decathorpe or ignatenkobrain to attend.
14:45:47 <sgallagh> The Monday time would "only" exclude Eighth_Doctor
14:45:55 <Eighth_Doctor> yep
14:46:03 <sgallagh> From a purely utilitarian standpoint, that would seem to be preferable. (Sorry, Neal)
14:46:04 <mhroncok> we could have both
14:46:10 <sgallagh> .fire mhroncok
14:46:10 <zodbot> adamw fires mhroncok
14:46:16 <Eighth_Doctor> if you want to move it to Monday, I'll just never be able to show up, which if you're okay with that, sure
14:46:18 <mhroncok> sgallagh: I mean, every toher week
14:46:25 <mhroncok> *other
14:46:34 <zbyszek> sgallagh: Hmm, I see Can't make it: David Cantrell, Neal Gompa, Stephen Gallagher, cverna, nirik, zbyszek
14:46:37 <sgallagh> That seems complicated, but it's an option.
14:46:43 <Eighth_Doctor> the Tuesday one I can at least sanely double book because work doesn't really care (as it's a community timeslot anyway)
14:46:47 <mhroncok> Eighth_Doctor would never meet decathorpe, but otherwise...
14:47:05 <sgallagh> zbyszek: ?
14:47:34 <sgallagh> zbyszek: Monday at 1500 UTC on the results page is free for everyone but Neal and I
14:47:49 <sgallagh> But I can probably make it work for me (albeit double-booked)
14:48:12 <zbyszek> sgallagh: Oh, 15:00, not 16:00 UTC.
14:48:25 <dcantrell> oh, I goofed on that.  15, not 16
14:48:40 <Eighth_Doctor> 5pm UTC on Tuesday excludes only cverna
14:48:49 <Eighth_Doctor> as I can double-book for that
14:49:12 <zbyszek> I'd vote for Tuesday over Monday.
14:49:28 <Eighth_Doctor> that's 1pm EDT, and that collides with OKD WG, but this is an IRC meeting, so I can be half-present on weeks when that's going
14:51:01 * nirik is fine with 17UTC tue
14:51:07 <dcantrell> so is there a proposed meeting time slot move?
14:51:19 * dcantrell looks at zbyszek, Eighth_Doctor, sgallagh
14:51:46 <zbyszek> dcantrell: 17UTC tue
14:52:32 <dcantrell> zbyszek: alright, I'm fine with that.  everyone else?
14:52:35 <sgallagh> Looks like that only blocks cverna on WhenIsGood.
14:52:38 <sgallagh> I'm fine with it.
14:53:13 <nirik> cverna: any chance you could move something and make that?
14:55:19 <dcantrell> cverna: ?
14:55:21 <cverna> let me look
14:55:58 <cverna> 17UTC is kind of late for me, but don't block on me
14:56:15 <cverna> so that's fine for me
14:56:20 <dcantrell> thanks
14:56:31 <dcantrell> zbyszek: can I action you to update the meeting time in the docs?
14:56:38 <zbyszek> yes
14:57:00 <dcantrell> #action zbyszek will update the FESCo meeting times to 17UTC on Tuesdays
14:57:03 <dcantrell> thanks
14:57:07 <dcantrell> anyone else for open floor?
14:57:22 <mhroncok> yes
14:57:30 <mhroncok> zbyszek will chair next meeting
14:57:34 <mhroncok> even on Tuesday?
14:57:51 <zbyszek> Reluctantly
14:58:07 <Eighth_Doctor> are we still in f-m-2?
14:58:35 <dcantrell> Eighth_Doctor: we should verify, zbyszek can you check that as well?
14:59:05 <zbyszek> dcantrell: I'm not sure if I know how.
14:59:22 <dcantrell> when stuck, we can always #action bcotton
14:59:42 <dcantrell> #action bcotton will help us verify irc meeting room we can use on Tuesdays at 17UTC
14:59:50 <zbyszek> https://apps.fedoraproject.org/calendar/location/fedora-meeting-2%40irc.freenode.net/
14:59:57 <zbyszek> 17tue seems free
15:00:03 <dcantrell> fantastic
15:00:13 <dcantrell> alright, anyone else for open floor?
15:00:16 <mhroncok> so is #fedora-meeting
15:00:21 <mhroncok> let's move there?
15:00:27 <Eighth_Doctor> sure, I suppose
15:00:33 <dcantrell> I'm fine with either room
15:00:34 <Eighth_Doctor> might as well
15:00:51 <zbyszek> Yeah, let's move back to #fedora-meeting.
15:00:57 <mhroncok> 90 more people idle in #fedora-meeting :)
15:01:01 <mhroncok> (ATM)
15:01:14 <mhroncok> that's it from me
15:01:24 <mhroncok> thanks all
15:01:30 <dcantrell> thanks, anyone else?
15:01:32 <mhroncok> Eighth_Doctor: nic arguing with you :)
15:01:36 <mhroncok> *nice
15:01:49 <mhroncok> let's repeat that some day :P
15:01:53 * Eighth_Doctor sighs
15:02:25 <dcantrell> thanks all!
15:02:28 <dcantrell> #endmeeting