java-maint-sig
LOGS
15:00:10 <decathorpe> #startmeeting java-maint-sig Meeting (2021-03-04)
15:00:10 <zodbot> Meeting started Thu Mar  4 15:00:10 2021 UTC.
15:00:10 <zodbot> This meeting is logged and archived in a public location.
15:00:10 <zodbot> The chair is decathorpe. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:10 <zodbot> The meeting name has been set to 'java-maint-sig_meeting_(2021-03-04)'
15:00:17 <decathorpe> #meetingname java-maint-sig
15:00:17 <zodbot> The meeting name has been set to 'java-maint-sig'
15:00:22 <decathorpe> #topic Roll Call
15:00:44 <mizdebsk> hi
15:00:48 <loganjerry> hello
15:01:00 <decathorpe> hello! :)
15:01:04 <decathorpe> #chair mizdebsk
15:01:04 <zodbot> Current chairs: decathorpe mizdebsk
15:01:07 <decathorpe> #chair loganjerry
15:01:07 <zodbot> Current chairs: decathorpe loganjerry mizdebsk
15:02:13 <decathorpe> I only have three short things for today, so the meeting should be over quickly.
15:02:18 <decathorpe> #link https://pagure.io/java-maint-sig/issue/16 Agenda
15:02:34 <FranciscoD> hello
15:02:46 <decathorpe> #chair FranciscoD
15:02:46 <zodbot> Current chairs: FranciscoD decathorpe loganjerry mizdebsk
15:02:49 <decathorpe> hello!
15:03:03 <FranciscoD> I'm in another video meeting, but will also lurk here to see if I can help :)
15:03:16 <decathorpe> great, thanks
15:03:25 <decathorpe> let's start
15:03:33 <decathorpe> #topic maven-antrun-plugin 3.0.0
15:03:37 <decathorpe> #link https://src.fedoraproject.org/rpms/maven-antrun-plugin/pull-request/2
15:03:55 <decathorpe> I've rebased and updated the PR and re-run the test rebuild
15:04:32 <decathorpe> there's 5 packages that need the task -> target quickfix, and maven-invoker plugin has a new test failure that I can't decipher ...
15:06:03 <decathorpe> if anybody can help cross off any of those 6 items that would be great. other than that, I have no news here.
15:07:19 <loganjerry> Do you have a pointer to the maven-invoker plugin test failure?
15:07:41 <mizdebsk> fixing maven-invoker also involves replacing "tasks" with "target"
15:08:25 <mizdebsk> in maven-invoker-3.0.1/src/test/resources/test-space-properties/pom.xml maven-antrun-plugin is called with <tasks>
15:08:30 <decathorpe> loganjerry: https://copr.fedorainfracloud.org/coprs/decathorpe/maven-antrun-plugin-3.0.0-pr/build/2049779/
15:08:37 <decathorpe> yeah then that's probably the same quickfix.
15:10:06 <decathorpe> if we can collect PRs for those 6 packages, I can do a coordinated merge + build once everything is ready.
15:13:10 <decathorpe> #topic guava CVE-2020-8908
15:13:11 <decathorpe> #link https://bugzilla.redhat.com/show_bug.cgi?id=1906920
15:13:39 <decathorpe> that's the only CVE issue open against Java SIG packages AFAICT
15:14:28 <decathorpe> also affects the maven:3.6 module
15:14:44 <mizdebsk> this one is low severity and at the time i don't have any plans of fixing it
15:15:07 <decathorpe> right
15:16:09 <decathorpe> though guava is really old in Fedora right now, so we should update it at some point anyway
15:16:55 <decathorpe> #info CVE is low priority but might be addressed at a later point
15:17:23 <decathorpe> #topic Orphan unnecessary SIG packages
15:17:50 <decathorpe> so, there's now two packages in @java-maint-sig that are depended on by nothing: jakarta-messaging, maven-verifier
15:17:59 <decathorpe> and three that are depended on by nothing of use: jboss-el-3.0-api, jboss-servlet-3.1-api, saxpath
15:18:53 <decathorpe> maven-verifier was freed up by the update to surefire 3, jakarta-messaging by dropping log4j12, I think
15:19:32 <decathorpe> jboss-el-3.0-api, jboss-servlet-3.1-api are only required by one other jboss-foo-x.y-api package each and nothing else
15:19:35 <decathorpe> saxpath used to be required by eclipse-cdt, but it has been retired
15:19:54 <decathorpe> are there any objections to orphaning those 5 packages and removing them from the @java-maint-sig group?
15:22:06 <FranciscoD> not from me :)
15:25:05 <decathorpe> #action decathorpe to orphan the five leaf packages and remove them from @java-maint-sig group
15:25:10 <decathorpe> #topic Open Floor
15:31:08 <decathorpe> alright, that's it from my side. thanks guys
15:31:11 <decathorpe> #endmeeting