fesco
LOGS
15:00:24 <zbyszek> #startmeeting FESCO (2021-02-10)
15:00:24 <zodbot> Meeting started Wed Feb 10 15:00:24 2021 UTC.
15:00:24 <zodbot> This meeting is logged and archived in a public location.
15:00:24 <zodbot> The chair is zbyszek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:24 <zodbot> The meeting name has been set to 'fesco_(2021-02-10)'
15:00:24 <zbyszek> #meetingname fesco
15:00:24 <zodbot> The meeting name has been set to 'fesco'
15:00:24 <zbyszek> #chair nirik, ignatenkobrain, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, cverna, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
15:00:24 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku cverna dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
15:00:27 <zbyszek> #topic init process
15:00:30 <zbyszek> .hello2
15:00:30 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:00:41 <zbyszek> We have just one topic today, so this should be quick.
15:01:12 <zbyszek> mhroncok said he will be late.
15:01:14 <dcantrell> .hello2
15:01:14 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
15:01:20 <bcotton> .hello2
15:01:22 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:01:22 <cverna> hello o/
15:01:34 <zbyszek> bcotton: do you want to take over?
15:02:09 <bcotton> zbyszek: only if you need me to :-)
15:02:25 <zbyszek> Nah. Looks like we might not even have the meeting.
15:02:54 * King_InuYasha hwaves
15:02:55 <King_InuYasha> .hello ngompa
15:02:56 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
15:03:02 <zbyszek> That's 4.
15:03:04 <King_InuYasha> yay laggy keyboard :D
15:03:23 <decathorpe> .hello2
15:03:23 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
15:03:27 <zbyszek> That's 5.
15:03:34 <decathorpe> I AM FIVE
15:03:38 <nirik> morning
15:03:42 <zbyszek> We are SIX!
15:03:47 <nirik> .hello kevin
15:03:48 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:03:49 <zbyszek> #topic #2572 Proposal: Abstain (0) votes should be split evenly between +1 and -1 votes
15:03:52 <zbyszek> .fesco 2572
15:03:53 <zodbot> zbyszek: Issue #2572: Proposal: Abstain (0) votes should be split evenly between +1 and -1 votes - fesco - Pagure.io - https://pagure.io/fesco/issue/2572
15:04:36 <nirik> I'd still prefer we just leave it the way it is. :) but perhaps everyone else wants to change it.
15:04:44 <decathorpe> I agree with bcotton, this is overengineering things.
15:04:45 <dcantrell> I'm a -1 on this proposal.  absent vs. present should be handled separately, bcotton had a good explanation in the ticket
15:04:47 <zbyszek> If there's no strong agreement to change this, I'd leave it as is.
15:05:13 <King_InuYasha> Let's leave it as-is
15:05:22 <zbyszek> dcantrell: well, this means that there's still a misunderstanding of the proposal.
15:05:30 <cverna> yes +1 leave it as-is :)
15:05:48 <zbyszek> dcantrell: because the proposal is about treating absent vs. present (and voting 0), differently.
15:06:24 <zbyszek> But yeah, maybe it's not worth spending time on.
15:06:46 <zbyszek> OK, let's make this formal: proposal: reject
15:06:51 <zbyszek> +1 (reject)
15:07:03 <dcantrell> with the difference being the proposal doesn't adjust the total votes and you get in to this whole majority vs. plurality stuff and it's likely more trouble than it's worth
15:07:17 <nirik> +1 (reject)
15:07:30 <dcantrell> +1 (reject)
15:07:32 <cverna> +1 reject
15:07:46 <zbyszek> dcantrell: we'll schedule a slot with a bunch of napkins and beer in devconf2022 and figure it out then ;)
15:08:02 <dcantrell> zbyszek: I'm fine with that  :)
15:08:27 <zbyszek> decathorpe?
15:08:51 <zbyszek> King_InuYasha?
15:09:17 <decathorpe> I am +1 to keep current rules
15:09:35 <zbyszek> #agreed REJECTED (+5, 0, 0)
15:09:40 <zbyszek> #topic Next week's chair
15:09:52 <zbyszek> volunteers?
15:10:13 <King_InuYasha> zbyszek: sorry, I'm in two meetings at once
15:10:16 <King_InuYasha> like sgallagh :)
15:10:18 <dcantrell> I'll do if no one else wants to
15:10:23 <dcantrell> do it
15:10:46 <zbyszek> Seems so.
15:10:51 <dcantrell> works for me
15:10:54 <zbyszek> #action dcantrell will chair next meeting
15:10:58 <zbyszek> #topic Open Floor
15:11:39 <zbyszek> Any big status updates?
15:11:55 <sgallagh> I have a quick note
15:12:01 <zbyszek> The floor is yours.
15:12:47 <sgallagh> ELN will continue to track the Rawhide branch, so as of this week's branching of F34, ELN is now developing for RHEL 10
15:12:50 <nirik> #info f34 branching is done, branched compose syncing now.
15:13:21 <zbyszek> nirik: congrats and thanks on the master→main rename (and everyone else involved)
15:13:59 <nirik> which reminds me...
15:14:07 <dcantrell> sgallagh: next week begins RHEL 11?  :)
15:14:10 <zbyszek> sgallagh: basically, you're saying that all the mistakes we make count even more ;)
15:14:16 <dcantrell> nirik: yes, thank you for all the hard work on the renaming
15:14:16 <nirik> .fesco 2573
15:14:17 <zodbot> nirik: Issue #2573: master to main followups - fesco - Pagure.io - https://pagure.io/fesco/issue/2573
15:14:26 <King_InuYasha> sgallagh: so where's EL9? :)
15:14:32 <sgallagh> zbyszek: I don't follow. What do you mean?
15:14:59 <nirik> is everyone ok with what I suggested in https://pagure.io/fesco/issue/2573#comment-714037
15:15:02 <sgallagh> King_InuYasha: EL9 will be derived from Fedora 34.
15:15:28 <zbyszek> sgallagh: I'm just saying that the stuff we do in Fedora has a closer connection to what will in RHEL, i.e. impacts more than just Fedora.
15:15:41 <decathorpe> nirik: +1 sounds good
15:16:09 <sgallagh> zbyszek: While accurate, that's been true for a couple decades, so I'm not sure where you're going with it :)
15:16:32 <zbyszek> sgallagh: I'm not sure either. Just ignore me.
15:16:41 <sgallagh> Will do!
15:16:53 <sgallagh> nirik: Seems reasonable to me. +1
15:17:02 <dcantrell> nirik: I'm ok with that proposal
15:17:49 <zbyszek> nirik: +1
15:18:02 <nirik> cool. thanks.
15:18:27 <sgallagh> Oh, one other thing
15:18:48 <sgallagh> .fesco 2575
15:18:49 <zodbot> sgallagh: Issue #2575: Clarification on default service start guidelines - fesco - Pagure.io - https://pagure.io/fesco/issue/2575
15:18:52 <bcotton> +1 ignoring sgallagh  :p
15:19:22 <mhroncok> hey. sorry for missing the entire meeting
15:19:32 <dcantrell> sgallagh: I'm waiting for that on the devel list
15:19:43 <sgallagh> I raised it because of a preset request that came up on BZ since it wasn't clear at the time whether the associated software was in Fedora.
15:19:49 <zbyszek> sgallagh: wouldn't it be a bit like Recommends on a foreign rpm, which is not allowed?
15:19:50 <sgallagh> It's not, so the urgency isn't there.
15:20:02 <sgallagh> err, sorry. Miswrote that.
15:20:19 <sgallagh> It's under review right now, so it's not specifically problematic in the way I thought.
15:20:39 <sgallagh> And yes, I'll get something together on the mailing list soon.
15:21:08 <dcantrell> thanks
15:21:10 <nirik> I wonder if in this case the vendor should not ship their own preset file... since it's a instance in their env? but would want to ponder on it more
15:21:10 <sgallagh> Since it's still an important question, just not an urgent one
15:21:38 <zbyszek> What is the software in question?
15:22:04 <sgallagh> .bug 1926331
15:22:07 <zodbot> sgallagh: 1926331 – systemd presets request - google-guest-agent.service google-startup-scripts.service google-shutdown-scripts.service - https://bugzilla.redhat.com/1926331
15:22:31 <zbyszek> Oh, I'd be more worried about the "keeps running in background" part.
15:22:45 <King_InuYasha> do we actually *have* guidelines anywhere specifically about these requests?
15:22:49 <sgallagh> Yes
15:22:59 <sgallagh> https://docs.fedoraproject.org/en-US/packaging-guidelines/DefaultServices/
15:23:04 <King_InuYasha> I couldn't find them, only that we have to make a bug
15:23:08 <King_InuYasha> not the form for the bug
15:23:19 <zbyszek> King_InuYasha: it's all linked there ;)
15:23:29 <King_InuYasha> ah there it is
15:23:39 <zbyszek> https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&format=fedora-systemd-request
15:23:41 <King_InuYasha> for some reason, I couldn't find it before
15:24:05 <nirik> yeah, staying running is not good at all.
15:24:51 <sgallagh> I also think this example is dubious on the "Must not listen for outside connections" section and the "Must not alter other services" rules, so I plan to bring this to a FESCo vote.
15:26:03 <sgallagh> Anyway, we don't need to debate it right now, I just wanted to note that the other question had no urgency associated with it.
15:26:36 <zbyszek> .fpc 688
15:26:37 <zodbot> zbyszek: Issue #688: The Council banned weak forward dependencies to third party repositories - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/688
15:26:49 <zbyszek> I think we should consider this too.
15:27:14 <sgallagh> For the first question, sure. Wouldn't apply in this case.
15:27:22 <sgallagh> (For the preset decision)
15:28:13 <decathorpe> sgallagh: still, why not just ship their presets with the package itself? wouldn't that work?
15:28:45 <sgallagh> decathorpe: That is expressly forbidden
15:29:00 <zbyszek> decathorpe: that defeats the purpose of presets to a large extent. You can just enable it unconditionally in that case.
15:29:25 <zbyszek> (almost. The user may still provide a local preset that overrides the packaged one.)
15:29:26 <sgallagh> "If the service should be enabled by default, it must be added to one of the distribution presets files (see above)."
15:29:46 <decathorpe> I mean for a third-party package ...
15:29:56 <decathorpe> they don't care about those rules?
15:30:01 <King_InuYasha> I'm not sure why we banned weak forward dependencies like this?
15:30:11 <mhroncok> King_InuYasha: council has, legal has
15:30:20 <decathorpe> King_InuYasha: probably Recommends: ffmpeg or something
15:30:28 <sgallagh> King_InuYasha: The third party repos can just use the reverse forms anyway.
15:30:51 <mhroncok> King_InuYasha: a depndency that cannot be met by fedora content whether weak or strong has been declared illegal
15:31:00 <nirik> also forward makes us 'endorse' some particular repo (by using their naming)
15:32:58 <King_InuYasha> makes sense
15:33:05 <zbyszek> OK, let's continue the discussion in the ticket and -devel?
15:33:16 <mhroncok> devel please
15:33:19 <sgallagh> Yes, I'll move it there probably this afternoon
15:33:33 <zbyszek> So, let's move on. Anything else to discuss?
15:33:45 <dcantrell> I just wanted to say that I'm here and I'm not a cat.
15:33:58 <zbyszek> Noted.
15:34:05 <sgallagh> That sounds like something a cat would say 😑
15:34:09 <King_InuYasha> dcantrell: are you a dog then?
15:34:12 <dcantrell> https://www.youtube.com/watch?v=lGOofzZOyl8
15:34:33 <bcotton> dcantrell++
15:34:34 <bcotton> FYI: I'm about to send the first-ever "we're going to take away your provenpackager status" email
15:34:35 <decathorpe> dcantrell: but how can we be sure?
15:34:45 <bcotton> Also, once I'm not in two meetings at once, I'll be preparing the list of incomplete changes and filing that ticket
15:35:22 <sgallagh> bcotton: That's a sad day.
15:35:27 <King_InuYasha> I guess we're not keeping the "largest Fedora release ever" title for F34
15:35:33 <decathorpe> bcotton++
15:35:42 <bcotton> King_InuYasha: oh heavens no :-)
15:36:01 <zbyszek> bcotton: sounds good
15:36:11 * zbyszek goes back to working on the unfinished stuff
15:36:25 <zbyszek> OK, let's wrap this up.
15:36:31 <zbyszek> I'll close in a minute.
15:37:36 <zbyszek> See y'all next week.
15:37:37 <zbyszek> #endmeeting