workstation
LOGS
08:18:43 <cmurf> #startmeeting Workstation WG (2021-01-26)
08:18:43 <zodbot> Meeting started Thu Jan 28 08:18:43 2021 UTC.
08:18:43 <zodbot> This meeting is logged and archived in a public location.
08:18:43 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:18:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
08:18:43 <zodbot> The meeting name has been set to 'workstation_wg_(2021-01-26)'
08:18:45 <cmurf> #meetingname workstation
08:18:45 <zodbot> The meeting name has been set to 'workstation'
08:18:47 <cmurf> #chair mcatanzaro
08:18:47 <zodbot> Current chairs: cmurf mcatanzaro
08:19:14 <cmurf> #topic Rollcall
08:19:16 <cmurf> #info present: mcatanzaro, otaylor, Neil, cmurf, aday, kalev, tpopela
08:19:18 <cmurf> #info regrets: langdon, mclasen
08:19:20 <cmurf> #info present guests: zbigniew
08:19:22 <cmurf> #topic Approval of 19 Jan minutes:
08:19:24 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2021-01-21/workstation.2021-01-21-03.16.log.html
08:19:26 <cmurf> #agreed no objections
08:19:28 <cmurf> #topic Announcements, follow-ups, status reports
08:19:30 <cmurf> Michael: nm-connection-editor getting pulled in by Anaconda - has been looking into this. Currently no way to avoid it getting dragged in on update.
08:19:32 <cmurf> Allan: doesn't sound like a great solution.
08:19:34 <cmurf> Owen: could they move the desktop file to a separate package?
08:19:36 <cmurf> Michael: this wouldn't require changes in Anaconda.
08:19:38 <cmurf> #action Michael to follow-up with the proposal to create a nm-connection-editor-core package
08:19:40 <cmurf> #topic Updated activities overview design for GNOME 40 / F34
08:19:42 <cmurf> #link https://pagure.io/fedora-workstation/issue/210
08:19:44 <cmurf> Update from Allan:
08:19:46 <cmurf> Workspace issue has been resolved since last week with a new workspace switcher
08:19:48 <cmurf> #info The bulk of the changes are being rebased this week, ahead of merge into master
08:19:50 <cmurf> #info 3 weeks until UI freeze upstream - that gives us 2 weeks to polish. Help would be appreciated with this.
08:19:52 <cmurf> #topic Review some older open issues
08:19:54 <cmurf> #topic Replace Rhythmbox with GNOME Music in default install
08:19:56 <cmurf> #link https://pagure.io/fedora-workstation/issue/33
08:19:58 <cmurf> Allan has responded in the ticket. Main concern is lack of progress - if we switch and the rough edges never go away, or the missing features aren't filled in, that wouldn't be great.
08:20:00 <cmurf> Would switching to Music help to give them attention? Could we put out a call for help?
08:20:02 <cmurf> #action Allan to write call for help blog post
08:20:04 <cmurf> #topic Redesign Anaconda installation progress page
08:20:06 <cmurf> #link https://pagure.io/fedora-workstation/issue/48
08:20:08 <cmurf> Allan is still hoping to get the ball rolling on Anaconda changes in general.
08:20:10 <cmurf> #topic Fix placement of Welcome to Fedora application in live boot
08:20:12 <cmurf> #link https://pagure.io/fedora-workstation/issue/79
08:20:14 <cmurf> The window only centers itself in X11. gnome-initial-setup and gnome-tour are always centered, so there must be a way to do it.
08:20:16 <cmurf> Allan: the fedora welcome app would be obsoleted if the
08:20:18 <cmurf> #action Michael to investigate how gnome-tour centers its window
08:20:20 <cmurf> #action Allan to create a ticket for installer session proposal for further discussion
08:20:22 <cmurf> #topic 2m shutdown timer is too long
08:20:24 <cmurf> #link https://pagure.io/fedora-workstation/issue/163
08:20:26 <cmurf> We have 2 services that often don't shutdown in a timely fashion. 1. PackageKit - difficult to debug. 2. A mystery user service whose identity we can't find out (systemd only shows the ID of system services).
08:20:28 <cmurf> When these timeout, we get a 2m shutdown timer. Seems the answer is to reduce the timeout. However, the challenge is that we don't want to kill databases or VMs.
08:20:30 <cmurf> Zbigniew - the last thing you want to do is reduce the timeout. You don't want to shutdown the user manager while units are running. We could give units 15s or 10s to shutdown, and then reduce the limit for the manager. The real solution is to make sure that the services shutdown in a timely fashion. A timer of 30s is still too long. Reducing the timer is just going to hide the real
08:20:32 <cmurf> issues.
08:20:34 <cmurf> #info The user manager should propagate info to the system manager so it can be shown in the shutdown menu.
08:20:36 <cmurf> The infrastructure is mostly there - it just needs to be plumbed together. The patch for that would be happily accepted.
08:20:38 <cmurf> Langdon - doesn't disagree, but is it better than someone force powering off because it's taking so long to power off? That's what's happening after 30s.
08:20:40 <cmurf> Zbigniew - why is it 2 minutes? It's arbitrary. Yes we should set it to a lower value. But what we should do is change the user units to a lower value and make that publicly known. We need to tell people to explicitly set a higher timeout value if they need longer.
08:20:42 <cmurf> Owen: it would be useful to differentiate between a unit that is stuck and unresponsive, and a unit that is still working but has a lot to do. Would it make sense to give units a way to tell systemd that they are responding to the shutdown instruction?
08:20:44 <cmurf> Zbigniew - you need watchdogs. The unit needs to regularly tell systemd that they are still running. This was disabled in Fedora because of buggy disks - units got stuck on read. It doesn't really work.
08:20:46 <cmurf> Zbigniew - there was a patch to allow units to tell systemd that they are busy shutting down, but that needs action from the units to implement that behaviour.
08:20:48 <cmurf> Owen - maybe the answer is for problematic services to make use of that to more accurately report their status.
08:20:50 <cmurf> Owen: running a database is relatively rare on a laptop and we should focus on improving the common cases.
08:20:52 <cmurf> #agreed We need action on systemd on getting the ID of user services.
08:20:54 <cmurf> #agreed Action to debug PackageKit is needed.
08:20:56 <cmurf> #action Zbigniew to reduce the timeout for F34.
08:20:58 <cmurf> #topic Open Floor
08:21:03 <cmurf> #endmeeting