workstation
LOGS
07:52:10 <cmurf> #startmeeting Workstation WG (2021-01-12)
07:52:10 <zodbot> Meeting started Thu Jan 14 07:52:10 2021 UTC.
07:52:10 <zodbot> This meeting is logged and archived in a public location.
07:52:10 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:52:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
07:52:10 <zodbot> The meeting name has been set to 'workstation_wg_(2021-01-12)'
07:52:12 <cmurf> #meetingname workstation
07:52:12 <zodbot> The meeting name has been set to 'workstation'
07:52:14 <cmurf> #chair mcatanzaro
07:52:14 <zodbot> Current chairs: cmurf mcatanzaro
07:52:33 <cmurf> #topic
07:52:35 <cmurf> #info present: cmurf, aday, neil, mclasen, mcatanzaro, langdon, kalev, tpopela, otaylor, petersen,
07:52:37 <cmurf> #info regrets:
07:52:39 <cmurf> #info present guests: salimma, javier martinez, zac
07:52:41 <cmurf> #topic Approval of 05 Jan minutes:
07:52:43 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2021-01-07/workstation.2021-01-07-04.57.log.html
07:52:45 <cmurf> #agreed Approved - no objections
07:52:47 <cmurf> #topic Announcements, follow-ups, status reports
07:52:49 <cmurf> Matthias: discussed overview changes with Florian. We're aiming to merge upstream by end Jan and will make an alpha with the changes at the point. If the changes aren't merged by that point a release will be made off the development branch, so people can try it that way.
07:52:51 <cmurf> There's also a copr available that some people are using - http://copr.fedorainfracloud.org/coprs/haeckerfelix/gnome-shell-40.
07:52:53 <cmurf> Neil: has fixed the packaging for Pipewire again. Rawhide nightlies will start using it once this work has landed. Neil has also been backporting fixes to F33.
07:52:55 <cmurf> #topic Potential issue with Hidden GRUB menu + boot on btrfs
07:52:57 <cmurf> #link https://pagure.io/fedora-workstation/issue/206
07:52:59 <cmurf> Boot partition is still on ext4. Plan was to switch it to btrfs for F34.
07:53:01 <cmurf> salimma: grubenv is currently on /boot (not writable on btrfs) on BIOS systems, /boot/EFI (separate partition) on EFI systems. it needs to be modifiable by GRUB to support the hidden boot menu
07:53:03 <cmurf> Do we want to keep the hidden boot menu?
07:53:05 <cmurf> We need a writable location for grub. One suggestion is a dedicated partition that isn't boot.
07:53:07 <cmurf> Having /boot use btrfs will allow snapshotting and rollback - could be nice.
07:53:09 <cmurf> Allan: hidden grub menu is desirable from a UX/design perspective.
07:53:11 <cmurf> Javier: there are different issues here:
07:53:13 <cmurf> 1. Unified configuration - already used by CoreOS, others.
07:53:15 <cmurf> 2. Grub not being saved as a file on the filesystem. Not safe on journaled fs, including btrfs/xfs. Solution is to store the grub <n>? in a place that can be safely modified by grub.
07:53:17 <cmurf> 3. Snapshotting - we should work with systemd to see how this can be supported.
07:53:19 <cmurf> #link https://fedoraproject.org/wiki/Changes/UnifyGrubConfig
07:53:21 <cmurf> Which one are we interested in? :D
07:53:23 <cmurf> Neil: how do we fix grub and keep the hidden menu working? The problem here is that grub cannot write.
07:53:25 <cmurf> Chris suggested a special partition that grub can read and write to without a filesystem driver. Functionally similar to the bios boot partition - small, 1 MB. It's just storing 1 kb - whether the system successfully booted last time or not.
07:53:27 <cmurf> Javier: we want to avoid having yet another downstream feature - whatever we do needs to be agreed upstream. Means that it will have to wait until at least F35.
07:53:29 <cmurf> Neil: it's hard to migrate boot config so we don't want to have to do multiple migrations. Javier: this is only likely to be for new installs, since it will involve a new partition layout.
07:53:31 <cmurf> Neil: GNOME and KDE are going to need to know how to manipulate grubenv another reason to reduce flux.
07:53:33 <cmurf> #action Javier to share a link to the upstream discussion when it happens.
07:53:35 <cmurf> #agreed We will wait for the grub proposal to be agreed upstream before proceeding.
07:53:37 <cmurf> #topic GNOME Software is recommending proprietary software
07:53:39 <cmurf> #link https://pagure.io/fedora-workstation/issue/203
07:53:41 <cmurf> The original concern in #111 was that the origin of the banners for proprietary apps wasn't clear. Allan suggested indicating the source of the apps (eg. Source: Flathub) but it was subsequently pointed out that the banners don't come from the repo - they come from gnome-software. Allan isn't convinced about saying "Source: GNOME" instead of "Source: Flathub" for two reasons: 1. GNOME
07:53:43 <cmurf> isn't supposed to be a meaningful concept to users, 2. it's passing the buck - if Fedora didn't want those banners, it could easily patch them out.
07:53:45 <cmurf> In #203 Allan has reviewed other potential solutions. Of these, he's most in favour of moving the proprietary banners to tiles further down the window. This would make them less prominent. It could also allow us to bring the selection of these apps downstream. This would make sense for us, since we will probably want to add apps to this set as we include them in the 3rd party repos.
07:53:47 <cmurf> #action Allan to draw a mockup of what his preferred solution would look like, so working group members can provide feedback.
07:53:49 <cmurf> #topic Updated activities overview design for GNOME 40 / F34
07:53:51 <cmurf> #link https://pagure.io/fedora-workstation/issue/210
07:53:53 <cmurf> #link https://copr.fedorainfracloud.org/coprs/haeckerfelix/gnome-shell-40/
07:53:55 <cmurf> Tight on time, lots to be done.
07:53:57 <cmurf> Responding to feedback. A few particular topics are regularly coming up in negative feedback.
07:53:59 <cmurf> 1) Increased mouse travel, hard to deal with in this release
07:54:01 <cmurf> 2) Workspace thumbnails, TBD, potentially more important? higher-risk portion of design
07:54:03 <cmurf> Need to document and substantiate concerns. Not easy to decide how to handle feedback.
07:54:05 <cmurf> Matthias: Can we do a Fedora Magazine article? Allan: would like to, but short on time.
07:55:36 <cmurf> #endmeeting