workstation
LOGS
04:57:05 <cmurf> #startmeeting Workstation WG (2021-01-05)
04:57:05 <zodbot> Meeting started Thu Jan  7 04:57:05 2021 UTC.
04:57:05 <zodbot> This meeting is logged and archived in a public location.
04:57:05 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:57:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
04:57:05 <zodbot> The meeting name has been set to 'workstation_wg_(2021-01-05)'
04:57:07 <cmurf> #meetingname workstation
04:57:07 <zodbot> The meeting name has been set to 'workstation'
04:57:09 <cmurf> #chair mcatanzaro
04:57:09 <zodbot> Current chairs: cmurf mcatanzaro
04:57:41 <cmurf> #topic Rollcall
04:57:42 <cmurf> #info present: chris, tomas, michael, matthias, allan, jens, neal, kalev, owen, langdon
04:57:44 <cmurf> #info regrets:
04:57:46 <cmurf> #info present guests:  michel salim, anita zhang, davide cavalca, alex gartrell, josef bacik
04:57:48 <cmurf> #topic Approval of 17 Dec minutes
04:57:50 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-12-17/workstation.2020-12-17-01.52.log.html
04:57:52 <cmurf> #agreed no objections
04:57:54 <cmurf> #topic Announcements, follow-ups, status reports
04:57:56 <cmurf> #info Allan: Major UI changes in GNOME 40 are slowly coming
04:57:58 <cmurf> - there will be a COPR repo to test the design in advance
04:58:00 <cmurf> - there is no way to do the changes only with using the GNOME Shell extensions as they require bigger changes,
04:58:02 <cmurf> - Neal is worried about communicating the changes to Fedora community
04:58:04 <cmurf> - Langdon worries about horizontal/vertical layout/philosophy changes, suggests to discuss this topic regularly during the next couple of meetings
04:58:06 <cmurf> #topic Enable transparent compression by default
04:58:08 <cmurf> #link https://pagure.io/fedora-workstation/issue/177
04:58:10 <cmurf> #link https://fedoraproject.org/wiki/Changes/BtrfsTransparentCompression
04:58:12 <cmurf> Chris: It was part of the original BTRFS change, then split off, recently discussed on fedora-devel, two options - enable it everywhere or just for some folders such as /usr or /var
04:58:14 <cmurf> kalev: Is there any CPU impact? No noticeable CPU impact for the users if enabled (with the level 1 as it's proposed)
04:58:16 <cmurf> Josef and Davide confirm positive results from Facebook internal testing
04:58:18 <cmurf> kalev: potential downsides for data recoverability? Josef says it doesn't affect it
04:58:20 <cmurf> owen: How we make users to understand the effects of this change? (the difference between the compressed and uncompressed size).
04:58:22 <cmurf> Chris: There will be a tool/utility that will give you the information, called compsize, it's in Fedora repo. But does it need to be reported somewhere in the UI (i.e. Nautilus)? Chris thinks that this is a weak point of the proposal.
04:58:24 <cmurf> Owen suggest that we should check whether the GNOME notification about running low space does work with this proposal - Chris tested it and it works.
04:58:26 <cmurf> According to Chris this proposal is taking a low hanging fruit and there can be more stuff that we can pursue.
04:58:28 <cmurf> #agreed this feature is a good idea, let's do it
04:58:30 <cmurf> #topic systemd-oomd
04:58:32 <cmurf> #link https://fedoraproject.org/wiki/Changes/EnableSystemdOomd
04:58:34 <cmurf> Anita: proposal to replace earlyoom with systemd-oomd
04:58:36 <cmurf> Kalev: There is no feedback to the user that something was fixed with earlyoom, is there anything planned for systemd-oomd? Will there be some hooks? Anita: There's a plan to have dbus API, not planned for F34, probably for F35. Allan wants to research the UX side of the notification.
04:58:38 <cmurf> #agreed from Fedora Workstation WG POV this is good to go
04:58:40 <cmurf> #topic GNOME Software is recommending proprietary software
04:58:42 <cmurf> #link https://pagure.io/fedora-workstation/issue/203
04:58:44 <cmurf> We don't have to for this today, moving to next meeting
04:58:46 <cmurf> #topic Open Floor
04:58:48 <cmurf> mclasen: VAAPI on Intel and improve the experience on Fedora (actually include it there). Asking for feedback/suggestions.
04:58:50 <cmurf> #link https://pagure.io/fedora-workstation/issue/209
04:59:41 <cmurf> #endmeeting