workstation
LOGS
08:33:14 <cmurf> #startmeeting Workstation WG (2020-12-08)
08:33:14 <zodbot> Meeting started Wed Dec  9 08:33:14 2020 UTC.
08:33:14 <zodbot> This meeting is logged and archived in a public location.
08:33:14 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:33:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
08:33:14 <zodbot> The meeting name has been set to 'workstation_wg_(2020-12-08)'
08:33:16 <cmurf> #meetingname workstation
08:33:16 <zodbot> The meeting name has been set to 'workstation'
08:33:18 <cmurf> #chair mcatanzaro
08:33:18 <zodbot> Current chairs: cmurf mcatanzaro
08:33:31 <cmurf> #topic Rollcall
08:33:33 <cmurf> #info present: chris, tomas, michael, matthias, allan, jens, langdon, neal, owen
08:33:35 <cmurf> #info missing wg members: kalev is sick
08:33:37 <cmurf> #info regrets wg members:
08:33:39 <cmurf> #info present guests:  james, mfabik, miroslav, michal zidek
08:33:41 <cmurf> #topic Approval of 01 Dec minutes
08:33:43 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-12-03/workstation.2020-12-03-03.01.log.html
08:33:45 <cmurf> #agree approved, no objections
08:33:47 <cmurf> #topic Announcements, follow-ups, status reports
08:33:49 <cmurf> #info none
08:33:51 <cmurf> #topic Give ABRT some ❤
08:33:53 <cmurf> #link https://pagure.io/fedora-workstation/issue/130
08:33:55 <cmurf> #info Special guest: Miroslav Suchy, Michal Zidek, Michal Fabik
08:33:57 <cmurf> #info Miroslav reviews issues in the ticket
08:33:59 <cmurf> * Flatpak crash support - some initial work done; blocking on Flatpak. Not expecting these blockers to be fixed.
08:34:01 <cmurf> * Gitlab issue reporting - not in scope seemingly?
08:34:03 <cmurf> * Pet peeve quality issues - mostly a result of gnome-abrt not being good. Requires a redesign. Not going to happen in the next 12 months.
08:34:05 <cmurf> * Coredump references 204 debuginfo files, 224 of them are not installed - in progress; fixed soon
08:34:07 <cmurf> * abrt-action-analyze-c crashes on every gnome-music crash - mid-priority, not a high priority because it doesn't always happen. Should be fixed in the near future ~months.
08:34:09 <cmurf> * False positives with sensitive words - Miroslav more concerned with false negatives rather than false positives. So it's low priority for him.
08:34:11 <cmurf> * Michael: this is an issue because every report gets flagged as sensitive, so we train users to click through.
08:34:13 <cmurf> * Michael: abrt defaults to reporting the private rather than the public report - causes duplicates, means that people can't  fix the issues.
08:34:15 <cmurf> * Miroslav still concerned about false negatives.
08:34:17 <cmurf> * Michael suggests removing common keywords that cause false positives.
08:34:19 <cmurf> * #agreed: have a followup discussion about false positive sensitivity warnings - can we come up with a better algorithm?
08:34:21 <cmurf> * Retrace server should not fail: the ABRT team is working on this nearly continuously, but there are issues.
08:34:23 <cmurf> * In the future, debuginfod will be used to mount the debuginfo
08:34:25 <cmurf> * ABRT very frequently fails to report crashes. Miroslav: in the past there were a lot of duplicates, so he's hesitant about accepting lower quality reports.
08:34:27 <cmurf> * Michael: ...
08:34:29 <cmurf> * Michael: often when ABRT fails to make a report, it doesn't provide useful information as to why.
08:34:31 <cmurf> #info ABRT project kanban
08:34:33 <cmurf> #link https://github.com/orgs/abrt/projects/1
08:34:35 <cmurf> * Don't offer to restart gnome-shell. Low priority for Miroslav - sees it as GNOME's responsibility. It's a useful feature for other processes.
08:34:37 <cmurf> * Matthias: this is a serious quality of implementation issue - causes users to lose their session. A reason to not to include ABRT.
08:34:39 <cmurf> * Michael: it should be a simple mechanism to check the process name before offering the restart option.
08:34:41 <cmurf> * Owen: would they accept a patch for that? Yes.
08:34:43 <cmurf> * Start faster. Miroslav - it starts fast for me. Low priority.
08:34:45 <cmurf> * Reporting too many duplicates
08:34:47 <cmurf> * Michael: this would be less severe if there were fewer private issues. ABRT knows that these are duplicates - it's doing it intentionally - can be fixed by changing the behaviour.
08:34:49 <cmurf> * Owen: are the flatpak blockers documented? Miroslav - there were a couple of blog posts.
08:34:51 <cmurf> #info ABRT: Reporting problems in Flatpak applications
08:34:53 <cmurf> #link https://abrt.github.io/abrt/container/exception/flatpak/python/2019/03/11/flatpak-problems/
08:34:55 <cmurf> * kernel core failure reported for userspace crashes. Miroslav - it's an incorrect classification issue. Sees it as a minor issue - hopefully will be addressed in the next 12 months.
08:34:57 <cmurf> #action Further discussion on too many duplicates
08:34:59 <cmurf> #action Further discussion on false positives due to sensitive keywords
08:35:01 <cmurf> #info Michael's summary/status update
08:35:03 <cmurf> #link https://pagure.io/fedora-workstation/issue/130#comment-705518
08:35:05 <cmurf> #topic Swap out Cheese for a more generic Camera app
08:35:07 <cmurf> #link https://pagure.io/fedora-workstation/issue/166
08:35:09 <cmurf> #agreed deferred
08:35:11 <cmurf> #topic Make use of malcontent in the default install?
08:35:13 <cmurf> #link https://pagure.io/fedora-workstation/issue/186
08:35:15 <cmurf> #agreed deferred
08:35:17 <cmurf> #topic Improve the user feedback for OOM situations
08:35:19 <cmurf> #link https://pagure.io/fedora-workstation/issue/202
08:35:21 <cmurf> #agreed deferred
08:35:31 <cmurf> #endmeeting