workstation
LOGS
03:01:54 <cmurf> #startmeeting Workstation WG (2020-12-01)
03:01:54 <zodbot> Meeting started Thu Dec  3 03:01:54 2020 UTC.
03:01:54 <zodbot> This meeting is logged and archived in a public location.
03:01:54 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
03:01:54 <zodbot> The meeting name has been set to 'workstation_wg_(2020-12-01)'
03:01:56 <cmurf> #meetingname workstation
03:01:56 <zodbot> The meeting name has been set to 'workstation'
03:01:58 <cmurf> #chair mcatanzaro
03:01:58 <zodbot> Current chairs: cmurf mcatanzaro
03:02:31 <cmurf> #topic Rollcall
03:02:33 <cmurf> #info present: Michael, Kalev, Langdon, Matthias, Neal, Tomas, Chris, Owen
03:02:35 <cmurf> #info missing wg members: Jens
03:02:37 <cmurf> #info regrets wg members: Allan
03:02:39 <cmurf> #info present guests: Felipe
03:02:41 <cmurf> #topic Approval of 24 Nov minutes:
03:02:43 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-11-25/workstation.2020-11-25-02.47.log.html
03:02:45 <cmurf> #agreed Approved
03:02:47 <cmurf> #topic Announcements, follow-ups, status reports
03:02:49 <cmurf> Michael says that Martin Stransky merged the firefox changes to avoid having to reboot after mozilla-openh264 installation.
03:02:51 <cmurf> #topic GNOME Software is recommending proprietary software
03:02:53 <cmurf> #link https://pagure.io/fedora-workstation/issue/203
03:02:55 <cmurf> Need Allan. Deferred.
03:02:57 <cmurf> #topic Automatically install the OpenH264 codecs
03:02:59 <cmurf> #link https://pagure.io/fedora-workstation/issue/84
03:03:01 <cmurf> Unresolved last week. How to handle installing a fixed set of packages from initial setup? Needs design changes to initial setup. We discussed how to do it and one of the issues is having to download 200 MB of repo metadata during initial setup.
03:03:03 <cmurf> Initial plan: have gnome-initial-setup call directly into packagekit (not gnome-software), disable all other repos besides openh264 (which hugely reduces metadata size), and then install the requires openh264 codes.
03:03:05 <cmurf> #info Michael's summary
03:03:07 <cmurf> #link https://pagure.io/fedora-workstation/issue/84#comment-704122
03:03:09 <cmurf> #action Michael to talk to Allan
03:03:11 <cmurf> #topic Give ABRT some ❤
03:03:13 <cmurf> #link https://pagure.io/fedora-workstation/issue/130
03:03:15 <cmurf> Michael is proposing whether abrt isn't a developer tool and not an end user one anymore.
03:03:17 <cmurf> Michael proposes to drop GUI app and only keep automatic reporting. Chris disagrees. Tomas says that we should reach out to ABRT team (msuchy) and discuss this (next meeting?).
03:03:19 <cmurf> Neal doesn't think that it's a good idea, because we lost a way of getting a feedback from user. Neal also adds that abrt is being praised in Fedora Workstation reviews. Tomas mentioned that together with Allan we were thinking about creating an app, where the users can provide feedback to us. Owen thinks that it might be a good move, but without assuring that we respond to feedback it
03:03:21 <cmurf> might not be a good move in the end.
03:03:23 <cmurf> Langdon finds abrt-filed reports useful. Langdon questions what's so wrong with the current GUI that we need to drop it? It's usually tech persons using it and they can handle the current UI. Neal agrees. Michael says it's very difficult to report a crash. Various people all agree that bugzilla account requirement makes it difficult.
03:03:25 <cmurf> Michael has a long-long list of bugs he wants fixed. Kalev suggests raising the bug where ABRT files all tickets as private as a prioritized Fedora bug.
03:03:27 <cmurf> Langdon asks if Windows and Mac bug reporting tools are any less technical? Bug reporting is a technical thing at its core. Matthias asks if it's frustrating to use for technical users as well?
03:03:29 <cmurf> Run out of time discussing this. No consensus here to remove ABRT.
03:03:31 <cmurf> #action neal and michael to further prioritize issues
03:03:33 <cmurf> #action tpopela to invite msuchy to a future meeting
03:03:35 <cmurf> #info Michael's summary
03:03:37 <cmurf> #link https://pagure.io/fedora-workstation/issue/130#comment-704127
03:03:39 <cmurf> #topic Open Floor
03:03:41 <cmurf> #agreed skip December 22 and 29 meetings
03:03:43 <cmurf> Chris to take notes next meeting.
03:03:54 <cmurf> #endmeeting