workstation
LOGS
01:40:29 <cmurf> #startmeeting Workstation WG (2020-11-17)
01:40:29 <zodbot> Meeting started Thu Nov 19 01:40:29 2020 UTC.
01:40:29 <zodbot> This meeting is logged and archived in a public location.
01:40:29 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:40:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:40:29 <zodbot> The meeting name has been set to 'workstation_wg_(2020-11-17)'
01:40:30 <cmurf> #meetingname workstation
01:40:30 <zodbot> The meeting name has been set to 'workstation'
01:40:32 <cmurf> #chair mcatanzaro
01:40:32 <zodbot> Current chairs: cmurf mcatanzaro
01:40:47 <cmurf> #topic Rollcall
01:40:49 <cmurf> #info present: Jens, Owen, Michael, Matthias, Kalev, Neal, Chris
01:40:51 <cmurf> #info regrets wg members: Tomas, Allan
01:40:53 <cmurf> #info present guests: James, Wim Taymans
01:40:55 <cmurf> #topic Approve of 10 November minutes
01:40:57 <cmurf> #link https://meetbot.fedoraproject.org/teams/workstation/workstation.2020-11-12-04.55.html
01:40:59 <cmurf> #agreed Approved - no objections
01:41:01 <cmurf> #topic Announcements, follow-ups, status reports
01:41:03 <cmurf> neal: more f33 review has come in, more of the same. Positive reviews
01:41:05 <cmurf> michael: vpn problems have quieted down a bit, he will write a blog post. caused by vpns not managed by nm
01:41:07 <cmurf> #topic 195: PulseAudio -> Pipewire migration
01:41:09 <cmurf> #link https://pagure.io/fedora-workstation/issue/195
01:41:11 <cmurf> wim: status:
01:41:13 <cmurf> lots of testers.
01:41:15 <cmurf> flatpak support not currently working, rethinking it using a pa server
01:41:17 <cmurf> smaller bugs in pa emulation need to be ironed out
01:41:19 <cmurf> should try to switch for f34, with an easy way to switch back
01:41:21 <cmurf> owen asks whether this is testable in f33. Answer: not currently, but we can backport the required fixes from f34.
01:41:23 <cmurf> neal suggests that we should write a change proposal to detail the fallback mechanism for users.
01:41:25 <cmurf> The template for change proposals is here: https://fedoraproject.org/wiki/Changes/EmptyTemplate
01:41:27 <cmurf> kalev asks for more details about the pa server. Wim explains that he made a passthrough pulseaudio server that also works for flatpaks. For jack applications, they need to be recompiled against the pipewire emulation, and then they only work with pipewire then.
01:41:29 <cmurf> neal suggests to make all fedora runtimes use pipewires jack and pulse emulation.
01:41:31 <cmurf> owen agrees that that is a good way to see if we're ready.
01:41:33 <cmurf> neals says: lets go ahead and get change proposal ready now
01:41:35 <cmurf> beta is end of february
01:41:37 <cmurf> wim will try, but asks for some help, also with packaging details
01:41:39 <cmurf> plan:
01:41:41 <cmurf> - wim will write a change proposal with help from wg members
01:41:43 <cmurf> - wim will do a new release with the pulse server
01:41:45 <cmurf> - neal will backport that to f33
01:41:47 <cmurf> - kalev will then update the flatpak runtime with that and rebuild jack apps
01:41:49 <cmurf> #topic 84: automatically install openh264 codecs
01:41:51 <cmurf> #link https://pagure.io/fedora-workstation/issue/84
01:41:53 <cmurf> mstransky has openh264 for mp4 working in firefox, in addition to webrtc
01:41:55 <cmurf> problem: you have to install mozilla openh264 from the cisco repo
01:41:57 <cmurf> kalev: we enable cisco repo by default. Every time firefox is updated it pulls in all recommends
01:41:59 <cmurf> totem has the same problem: you need an update to get the codec
01:42:01 <cmurf> owen asks about langpack installation compared to codec installation
01:42:03 <cmurf> some discussion around ways to make this better. Possible to do it in gnome-initial-setup, maybe.
01:42:05 <cmurf> michael points out that there are some quality issues in the openh264 implementation of h264. This supposedly goes away if you use the codec through ffmpeg.
01:42:07 <cmurf> https://github.com/cisco/openh264/issues/3350 is maybe related
01:42:09 <cmurf> neal points out that we could do other post-install cleanup in gnome-initial-setup, such as removing anaconda.
01:42:11 <cmurf> #topic open floor
01:42:13 <cmurf> some discussion about font rendering, since it came up in this review:
01:42:15 <cmurf> #link https://www.dedoimedo.com/computers/fedora-33.html
01:42:17 <cmurf> no conclusion
01:42:25 <cmurf> #endmeeting