fesco
LOGS
15:00:45 <dcantrell> #startmeeting FESCO (2020-11-11)
15:00:45 <zodbot> Meeting started Wed Nov 11 15:00:45 2020 UTC.
15:00:45 <zodbot> This meeting is logged and archived in a public location.
15:00:45 <zodbot> The chair is dcantrell. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:45 <zodbot> The meeting name has been set to 'fesco_(2020-11-11)'
15:00:45 <dcantrell> #meetingname fesco
15:00:45 <dcantrell> #chair nirik, ignatenkobrain, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, cverna, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
15:00:45 <zodbot> The meeting name has been set to 'fesco'
15:00:45 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku cverna dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
15:00:48 <dcantrell> #topic init process
15:00:59 <nirik> morning
15:01:03 <zbyszek> .hello2
15:01:04 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:01:10 <dcantrell> .hello2
15:01:11 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
15:01:49 <dcantrell> I'll give everyone some minutes here
15:02:18 <dcantrell> apologies for last week....it was a networking fun day for me
15:03:00 <nirik> it happens, no worries
15:03:03 * King_InuYasha waves
15:03:07 <King_InuYasha> .hello ngompa
15:03:08 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
15:03:15 <zbyszek> champagne flute and cucumber sandwitches kind of networking at least?
15:03:15 <dcantrell> morning, King_InuYasha
15:03:36 <dcantrell> zbyszek: I wish, it was on the floor and in the ceiling unfortunately
15:03:45 <mhroncok> hey, sorry for being late
15:03:53 <dcantrell> no worries
15:04:03 <dcantrell> I count 6.... ?
15:04:17 <dcantrell> nope, 5
15:05:24 <mhroncok> dcantrell: I received no reminder. maybe pinging peaople in #fedora-devel will help
15:05:41 <dcantrell> mhroncok: noted
15:06:03 <dcantrell> ah, thanks  :)
15:06:06 <mhroncok> done
15:06:23 <dcantrell> ok, so we don't have much to talk about and I sort of picked things I wanted to do a check in on for this meeting.  hopefully it's quick for us.
15:06:26 <nirik> did anyone hear anything from ignatenkobrain? I think someone was going to try and call him/contact him OOB?
15:06:33 <dcantrell> I have not
15:06:36 <decathorpe> hey, sorry for being late
15:06:44 <mhroncok> nirik: zbyszek talked to ignatenkobrain
15:06:44 <sgallagh> Sorry folks, I have a conflict and cannot attend today
15:06:44 <dcantrell> decathorpe: no worries
15:06:54 <dcantrell> sgallagh: ok, thanks and good luck
15:07:00 <mhroncok> #info Igor is alive, but busy
15:07:10 <nirik> ah, good. Glad he's ok.
15:07:11 <dcantrell> I'm glad someone got in touch with him
15:07:22 <zbyszek> yeah, ignatenkobrain is busy, but hopes that this will pass
15:08:05 <dcantrell> #topic #2495 Election Interview Questions — FESCo (Fedora 33)
15:08:05 <dcantrell> .fesco 2495
15:08:07 <zodbot> dcantrell: Issue #2495: Election Interview Questions — FESCo (Fedora 33) - fesco - Pagure.io - https://pagure.io/fesco/issue/2495
15:08:44 <dcantrell> the main reason I brought this one up is that mhroncok commented that he will abstain from proposing questions
15:08:47 <dcantrell> I agree with this
15:08:54 <dcantrell> but nearly all of us are self-nominated
15:09:11 <dcantrell> so should we try to get some other community member to wrangle some questions for this one to make it fairer for the community?
15:09:12 <mhroncok> we tried to as for new questions on devel several times in the past
15:09:12 <nirik> yeah
15:09:24 <mhroncok> *ask
15:09:31 <dcantrell> maybe bcotton could help us out here?
15:09:36 <mhroncok> the curret questions are only 1 release old
15:09:46 <mhroncok> I don't think ti's worth restarting now (also, it's late)
15:09:54 <nirik> yep. we revamped them not long back...
15:10:06 <dcantrell> good points, just wanted to check on that
15:10:17 <dcantrell> perhaps the process for collecting questions should be revisited later?
15:10:23 <mhroncok> +1
15:10:31 <dcantrell> I mean, that doesn't sound fun (i.e., not engineering), but could worthwhile
15:11:28 <dcantrell> I guess I like the idea of that, but don't have a good idea on how to proceed.  I don't have a proposal on that for now.
15:11:50 <King_InuYasha> I think the current questions are fine
15:11:57 <mhroncok> action bcotton to... :)
15:12:13 <dcantrell> mhroncok:  :)
15:12:15 <zbyszek> dcantrell: I think we (or bcotton) could just ask people to contribute questions when announcing elections. If people submit some nice ones, then we can include them. Otherwise, keep the old ones.
15:12:27 <King_InuYasha> unlike previous releases, there really hasn't been significant community churn to warrant significant change to them
15:12:51 <nirik> zbyszek: +1
15:13:01 <dcantrell> zbyszek: +1
15:13:41 <King_InuYasha> zbyszek: +1
15:13:54 <King_InuYasha> admittedly, time's up for getting new questions for this round, though
15:13:55 <dcantrell> ok, I'm going to followup with bcotton on this one later and update the issue
15:14:04 <dcantrell> sure, time is up for now, I was thinking about next time
15:14:07 <dcantrell> (next time, gadget)
15:14:08 <King_InuYasha> yup, makes sense
15:14:09 <King_InuYasha> :D
15:14:31 <dcantrell> #action dcantrell followup with bcotton regarding election question gathering process
15:14:37 <zbyszek> Also, I thinkthe questions are open-ended, so it doesn't matter that much.
15:15:21 <dcantrell> they are and that's fine, but maybe it's because I was sitting in a council meeting for a long time the other day and feel maybe the process could improve on engaging people for submitting questions
15:15:27 * nirik proposed last time we just make it an essay/freeform, but people didn't like that. ;)
15:15:41 <dcantrell> yeah, essay with a minimum word count  :)
15:15:50 <zbyszek> due Friday!
15:15:58 <King_InuYasha> it took me days to write the answers to the questions we have now anyway during the last cycle :P
15:15:59 <dcantrell> ok, moving on unless anyone has anything else to add on this one?
15:16:00 <nirik> :)
15:16:41 <dcantrell> #topic #2475 proposal: let's develop the idea of a new repo for lightly-maintained packages
15:16:44 <dcantrell> .fesco 2475
15:16:44 <zodbot> dcantrell: Issue #2475: proposal: let's develop the idea of a new repo for lightly-maintained packages - fesco - Pagure.io - https://pagure.io/fesco/issue/2475
15:16:58 <dcantrell> I tossed this on the meeting because I wanted to check with everyone on this one again
15:17:05 * mhroncok hates when ideas are discuces as fesco tickets
15:17:14 * nirik agrees with mhroncok there.
15:17:30 <mhroncok> that's why I suggested to move to devel
15:17:30 <dcantrell> how else do we do this then?
15:17:42 <mhroncok> devel list
15:17:47 <mhroncok> where the packagers actually are
15:17:59 <King_InuYasha> I'm ambivalent to this
15:18:09 <mhroncok> but after my suggestion, nothing happened
15:18:11 <dcantrell> ok, well I brought it up here because I wanted to see if any of you guys had any pending ideas before I posted to devel list
15:18:15 <dcantrell> but if no one wants to do that, fine
15:18:19 <King_InuYasha> but packager/community feedback is probably a good start
15:18:27 <zbyszek> I also think that someone should come up with a valid proposal. It may even be a strawman proposal to be struck down. But we need something to start the discussion.
15:19:33 <King_InuYasha> yeah
15:19:46 <King_InuYasha> since mattdm made the initial ticket, I'd expect something from him though :P
15:19:54 * nirik nods
15:20:04 <dcantrell> ok then, moving to the last one I grabbed.  I said I'd post an update but that was already in progress
15:20:08 <dcantrell> #topic #2473 updates policy is out of date
15:20:09 <dcantrell> .fesco 2473
15:20:10 <zodbot> dcantrell: Issue #2473: updates policy is out of date - fesco - Pagure.io - https://pagure.io/fesco/issue/2473
15:20:23 <dcantrell> I guess everyone look at it or something
15:20:28 <dcantrell> vote in the ticket
15:20:33 <nirik> I folded suggestions from zbyszek in...
15:20:53 <zbyszek> nirik: yeah, thanks. I think it looks good now.
15:21:00 <nirik> we should also get QA to chime in...
15:21:27 <mhroncok> nirik: the bodhi thing is now called "bodhi-change-point"
15:21:28 <mhroncok> ?
15:21:46 <mhroncok> that works
15:22:04 <decathorpe> mhroncok: +1
15:22:05 <mhroncok> you have my axe
15:22:06 * decathorpe prepares scathing response
15:22:07 <zbyszek> I think we should wait for QA ack before voting.
15:22:10 <nirik> yeah, but I guess bcotton has it as 'Bodhi updates-testing activation point' so perhaps we should sync terms.
15:22:54 <mhroncok> that works even better, either way not that important
15:23:02 <nirik> and possibly some time for comment on devel list? Nothing too radically changing here, but... shrug
15:23:11 <mhroncok> +1
15:23:18 <zbyszek> +1 too
15:23:25 <King_InuYasha> haven't we always called it Bodhi activation point?
15:23:29 <nirik> I can post a pointer to changes.
15:23:30 <King_InuYasha> otherwise, meh +1
15:23:42 <nirik> King_InuYasha: yes, but now we always have bodhi enabled since rawhide gating.
15:23:47 <decathorpe> well, bodhi is always active now, so "updates-testing activation point" is more accurate
15:23:53 <King_InuYasha> that's true
15:24:14 <King_InuYasha> I forget about that since all the important stuff refuses to use gating, so stuff breaks anyway :(
15:24:42 <dcantrell> ok, nirik, leave this with you to followup with qa and notify devel list?
15:24:42 <mhroncok> King_InuYasha: Python is gated on PR level
15:24:46 <mhroncok> King_InuYasha: bodhi i too late
15:24:51 <zbyszek> King_InuYasha: I'd love to use gating, but it's hard.
15:24:54 <nirik> yeah, perhaps we should look at pushing more gating... like enable some global tests for everything now.
15:25:16 <mhroncok> like - does this thing even install?
15:25:16 <zbyszek> nirik: I find the gating reports exteremely hard to understand.
15:25:17 <King_InuYasha> mhroncok, zbyszek: yeah, I know that it's difficult, but it sucks losing entire weekends to the compiler being broken :(
15:25:20 <mhroncok> that would be lovely :D
15:25:35 <zbyszek> I think the UI would need to improve before we make this opt out.
15:25:36 <King_InuYasha> and I agree that gating at Bodhi is too late (I wanted it at koji build time)
15:25:37 <nirik> mhroncok: yeah. Thats what I was thinking...
15:25:50 <dcantrell> King_InuYasha: +1
15:26:24 <King_InuYasha> someone said that it's impossible to make Koji fail a build task because of gating, which seems odd to me, but oh well...
15:26:37 <mhroncok> or https://pagure.io/fedora-ci/general/issue/46
15:26:40 <dcantrell> nothing is impossible, all of this is just made up anyway
15:26:59 <King_InuYasha> indeed
15:27:24 <nirik> dcantrell: yes, I can bring it up to qa and start a devel thread.
15:27:31 <dcantrell> thanks
15:27:37 <mhroncok> nirik: could you post the policy update proposal to devel please?
15:27:38 <decathorpe> dcantrell: well, there are undecidable problems, but I don't think koji has to deal with those :D
15:28:03 <dcantrell> #action nirik to followup with qa and devel list re: 2473
15:28:09 <dcantrell> decathorpe: true
15:28:52 <nirik> mhroncok: yep. on it.
15:29:02 <dcantrell> #topic Next week's chair
15:29:33 <zbyszek> I can.
15:29:37 <dcantrell> thanks!
15:29:47 <dcantrell> #action zbyszek will chair next meeting
15:29:57 <dcantrell> #topic Open Floor
15:31:10 <dcantrell> nothing for the open floor?
15:31:35 <dcantrell> alright, thanks everyone!
15:31:36 <King_InuYasha> I got nothing :)
15:31:45 <dcantrell> #endmeeting