fesco
LOGS
14:00:25 <zbyszek> #startmeeting FESCO (2020-09-09)
14:00:25 <zodbot> Meeting started Wed Sep  9 14:00:25 2020 UTC.
14:00:25 <zodbot> This meeting is logged and archived in a public location.
14:00:25 <zodbot> The chair is zbyszek. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:25 <zodbot> The meeting name has been set to 'fesco_(2020-09-09)'
14:00:26 <zbyszek> #meetingname fesco
14:00:26 <zbyszek> #chair nirik, ignatenkobrain, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, cverna, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
14:00:26 <zodbot> The meeting name has been set to 'fesco'
14:00:26 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku cverna dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
14:00:28 <zbyszek> #topic init process
14:00:33 <zbyszek> .hello2
14:00:34 <bcotton> .hello2
14:00:36 <dcantrell> .hello2
14:00:37 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
14:00:40 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:00:41 <King_InuYasha> .hello ngompa
14:00:43 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
14:00:46 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
14:00:47 <cverna> hello
14:00:55 <mhroncok> .hello churchyard
14:00:56 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
14:01:01 <zbyszek> quorum
14:01:03 <nirik> morning
14:01:07 <decathorpe> .hello2
14:01:08 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
14:01:46 <zbyszek> OK, let's start.
14:01:49 <zbyszek> #2470 F34 Self-Contained Change: Reduce installation media size by improving the compression ratio of SquashFS filesystem
14:01:52 <zbyszek> .fesco 2470
14:01:53 <zodbot> zbyszek: Issue #2470: F34 Self-Contained Change: Reduce installation media size by improving the compression ratio of SquashFS filesystem - fesco - Pagure.io - https://pagure.io/fesco/issue/2470
14:02:05 <zbyszek> #topic #2470 F34 Self-Contained Change: Reduce installation media size by improving the compression ratio of SquashFS filesystem
14:02:08 <zbyszek> .fesco 2470
14:02:09 <zodbot> zbyszek: Issue #2470: F34 Self-Contained Change: Reduce installation media size by improving the compression ratio of SquashFS filesystem - fesco - Pagure.io - https://pagure.io/fesco/issue/2470
14:02:17 <King_InuYasha> uhh
14:02:22 <zbyszek> A bunch of people voted -1
14:03:25 <cverna> after reading the devel list thread just before that meeting, I ll vote -1 too
14:03:29 <nirik> would be nice to hear from the change owner(s)
14:03:43 <zbyszek> proposal: ask the change owner to come up with a change that does decreases installation time to help QA and multiple installations.
14:03:52 <cverna> sounds like the QA concerns are valid to me
14:04:01 <cverna> zbyszek: +1
14:04:20 <decathorpe> zbyszek: didn't we do the same thing last time?
14:04:48 <zbyszek> So...
14:04:52 <King_InuYasha> I'm pretty sure someone asked in devel@ about that
14:05:00 <King_InuYasha> and I didn't see a response
14:05:20 <zbyszek> I think there is potential for improvement by playing with the compressin alg and options. But the Owner is focussing on the wrong metric.
14:05:31 <King_InuYasha> yeah
14:05:36 <dcantrell> this is a thing that people always came to us about in anaconda
14:05:47 * mhroncok feels we already had this discussion cou ple months ago
14:05:48 <King_InuYasha> I'd like to see roughly the same compression and reducing the time-to-live
14:05:49 <zbyszek> dcantrell: "this" ?
14:05:56 <dcantrell> install image size
14:06:14 <dcantrell> it's intractable within fedora.  focusing on the compression algorithm is more or less wasted effort
14:06:25 <dcantrell> a short term workaround
14:06:31 <dcantrell> with too many disadvantages
14:06:36 <zbyszek> dcantrell: hmm, but nobody said on fedora-devel that they care about image size. If you have that perspective, please share.
14:06:56 <dcantrell> the two things I read were about either (a) make the image smaller or (b) make it unpack faster
14:07:11 <dcantrell> the majority of people seem to be concerned with speed, which is fine
14:07:14 <zbyszek> dcantrell: so there's a PR to use unsquash instead of rsync that makes things faster, POC stage.
14:07:17 <dcantrell> talking about the compression algorithm impacts both of those
14:07:59 <decathorpe> the impression I got was that switching to zstd would greatly benefit installation time at almost no price in terms of image size, which sounds like a better trade off to me
14:08:07 <King_InuYasha> yup
14:08:18 <King_InuYasha> that's pretty much why we made the change for rpm, and why zchunk uses it
14:08:50 <nirik> well, in this case most of the install isn't on the media tho right?
14:09:16 * nirik re-reads again
14:09:44 <decathorpe> IMO if we really want to make images smaller, we should rather focus on Minimization rather than cranking up the compression further and further
14:09:54 <dcantrell> decathorpe++
14:09:59 <zbyszek> decathorpe: yep
14:10:04 <dcantrell> that's basically what I wanted to point out
14:10:16 <dcantrell> focusing on the compression ratio will never solve the size problem
14:10:52 <dcantrell> everyone who works on software that targets the install media needs to be aware of the concept of limited space and on board with enabling that, be it through disabling compile time options or creating subpackages to make it easier to construct smaller install images
14:11:11 <decathorpe> dcantrell++
14:11:40 <zbyszek> Yep, we also have some stuff that isn't necessary. There has some more discussion on fedora-devel recently.
14:11:54 <dcantrell> with regard to compression, I do favor zstd over xz for the speed and compression benefits.  xz is nice, but is super slow
14:11:55 <decathorpe> every time I install Workstation from live image I wonder why some huge packages are included ...
14:12:16 <zbyszek> Anyway, let's vote on the change.
14:12:31 <zbyszek> Does anyone *who didn't vote in the ticket* want to cast a vote?
14:12:44 <decathorpe> I think I didn't vote in ticket, so -1
14:12:49 <zbyszek> nirik?
14:13:00 <zbyszek> cverna?
14:13:20 <cverna> -1
14:13:27 <zbyszek> sgallagh?
14:13:36 <nirik> Sorry, I was getting confused by 'installer image'... but yes this definitely needs more/different work -1
14:13:52 <zbyszek> #agree REJECTED (0, 0, -8)
14:13:59 <zbyszek> #topic Next week's chair
14:14:03 <zbyszek> Volunteers?
14:14:24 * mhroncok might missthe next week
14:14:57 <cverna> I can take next week
14:15:15 <zbyszek> #action cverna will chair next meeting
14:15:17 <zbyszek> Thanks.
14:15:21 <zbyszek> #topic Open Floor
14:15:43 <zbyszek> Anything major work-needing items for F33?
14:16:29 <King_InuYasha> we seem to be okay for F33 so far
14:16:40 <decathorpe> tomorrow is the GitLab AMA, will some FESCo representative(s) be there?
14:16:45 <nirik> less blockers would be nice. ;)
14:16:49 <zbyszek> decathorpe: I plan to be there.
14:16:59 <mhroncok> decathorpe: I've voted on some questions there
14:17:14 <cverna> I ll be there also but mostly to answer questions :)
14:17:23 <decathorpe> yeah, I added some things to the hackmd thingie too
14:17:35 <King_InuYasha> I haven't had a chance to go over that hackmd yet
14:17:51 <King_InuYasha> mostly spent my time last weekend on Akademy 2020
14:17:58 <King_InuYasha> (and giving my talk on Fedora KDE!)
14:18:10 <decathorpe> nice :)
14:18:45 <zbyszek> #info https://qa.fedoraproject.org/blockerbugs/milestone/33/beta/buglist
14:18:50 <bcotton> King_InuYasha++
14:18:59 <zbyszek> King_InuYasha++
14:19:14 <decathorpe> ngompa++
14:19:14 <zodbot> decathorpe: Karma for ngompa changed to 17 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:19:51 <zbyszek> So... anything else?
14:20:08 <zbyszek> If not, I'll close in a minute.
14:20:25 <decathorpe> can't think of anything right now :)
14:20:51 <zbyszek> King_InuYasha: kudos for the KDE wayland change, seems to be another cool thing.
14:21:04 <King_InuYasha> zbyszek: :D
14:21:11 <King_InuYasha> I'm moving up the stack for the first time :D
14:21:24 <zbyszek> OK, thanks all, see you next week.
14:21:28 <zbyszek> #endmeeting