workstation
LOGS
01:51:09 <cmurf> #startmeeting Workstation WG (2020-07-28)
01:51:09 <zodbot> Meeting started Wed Jul 29 01:51:09 2020 UTC.
01:51:09 <zodbot> This meeting is logged and archived in a public location.
01:51:09 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:51:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:51:09 <zodbot> The meeting name has been set to 'workstation_wg_(2020-07-28)'
01:51:11 <cmurf> #meetingname workstation
01:51:11 <zodbot> The meeting name has been set to 'workstation'
01:51:13 <cmurf> #chair cmurf
01:51:13 <zodbot> Current chairs: cmurf
01:51:37 <cmurf> #topic Rollcall
01:51:39 <cmurf> #info present wg members: cmurf, neal, jens, mcatanzaro, aday, otaylor, mclasen, kalev, langon
01:51:41 <cmurf> #info regrets wg members:
01:51:43 <cmurf> #info present guests: salimma, cschalle, james
01:51:45 <cmurf> #topic Approve minutes from 21 July
01:51:47 <cmurf> https://meetbot.fedoraproject.org/teams/workstation/workstation.2020-07-22-02.54.log.html
01:51:49 <cmurf> #agreed No objections - approved
01:51:51 <cmurf> #topic Announcements
01:51:53 <cmurf> Michael: GNOME is considering a new version scheme. Likely going to go to GNOME 40, 40-alpha, 40-beta, 40-rc. RPM sorts the letters incorrectly.
01:51:55 <cmurf> Neal: use tildas.
01:51:57 <cmurf> Michael: OK.
01:51:59 <cmurf> #link https://docs.fedoraproject.org/en-US/packaging-guidelines/Versioning/#_versioning_prereleases_with_tilde
01:52:01 <cmurf> #topic Follow-ups & Status reports
01:52:03 <cmurf> #info Chris: has started doing weekly btrfs email status updates - to @desktop. Will also go to @devel too.
01:52:05 <cmurf> #info Allan: filtered view of Flathub rumbles on. Neal: there's a new PR here - https://pagure.io/fesco/fesco-docs/pull-request/34
01:52:07 <cmurf> Allan: https://pagure.io/fedora-workstation/issue/165 - will likely need to come back to the WG for a final decision
01:52:09 <cmurf> Allan: following on from last week, various discussions about how to evolve the default app set. Much of this is happening upstream, but we have tracking issues for each element and there will be decisions to make in the future. See tickets #164 to #171.
01:52:11 <cmurf> #topic General Topics
01:52:13 <cmurf> #topic Automatically install the OpenH264 codecs
01:52:15 <cmurf> #link https://pagure.io/fedora-workstation/issue/84
01:52:17 <cmurf> #info Kalev fixed the issue in dist-git months ago, but it needs work from releng to build and pass to Cisco
01:52:19 <cmurf> #topic Flatpak preferred over native (rpm) software in GNOME Software
01:52:21 <cmurf> #link https://pagure.io/fedora-workstation/issue/151
01:52:23 <cmurf> #info Michael: issues with Fedora Flatpaks - they're not localised. Kalev has been working on that. Not too concerned if the fix goes out quickly.
01:52:25 <cmurf> Kalev: that's all waiting on broken module build service. We have the pieces in place but can't get the builds out. Issue is https://pagure.io/fedora-infrastructure/issue/9066 . Releng seem to be having issues finding someone with knowledge of MBS.
01:52:27 <cmurf> It doesn't sound like there will be a quick fix. :(
01:52:29 <cmurf> The other issue with Fedora Flatpaks - there's no debuginfo. Means that they're not debuggable.
01:52:31 <cmurf> Owen: do we Flatpaks over RPMs on standard workstation? Clearly we do on Silverblue. It does give some lifecycle advantages.
01:52:33 <cmurf> Owen: debuginfo is hard to fix.
01:52:35 <cmurf> Christian: we want all apps to be flatpaks - goal is to build up the app ecosystem, it gives a better update experience, improves stability, etc. They do solve a lot of issues. They also allow a single build for RHEL, Fedora, CentOS.
01:52:37 <cmurf> Matthias: Alex will look into debuginfod when he's back from vacation. It could help with Fedora Flatpaks. It will require followup work.
01:52:39 <cmurf> Neal: people are reporting issues about the Flatpak versions. These are mostly the two issues already mentioned. Langpack extensions.
01:52:41 <cmurf> Matthias: Flatpak does have some "langpack support". Neal: sure, but it doesn't seem to be working.
01:52:43 <cmurf> Owen: upstream we have langpacks. The plan for Fedora is just to bundle all the language info in the flatpak, like we do for RPM. However, that's not happened due to a configuration issue - we just need to rebuild them with the languages included. And now we're stuck on broken infra.
01:52:45 <cmurf> Owen: knows how we could build debuginfo as extensions, but it would be a month or two of work, which he wants to avoid.
01:52:47 <cmurf> Neal: we need ABRT integration too.
01:52:49 <cmurf> Matthias: maybe users need to be able to configure their preferred app source/type.
01:52:51 <cmurf> Owen: this certainly needs to be
01:52:53 <cmurf> Allan: what's the expected relationship between Fedora flatpaks and flathub flatpaks?
01:52:55 <cmurf> Owen: background is Silverblue. Goal was to provide the apps that people expect to work out of the box. Goal was also to Flatpak all the apps in Fedora, but we haven't been very successful at that (80 apps out of ~800). The goal was a good out of the box experience on Silverblue. Most of the popular Flathub apps aren't something that Fedora can ship.
01:52:57 <cmurf> Neal: situation with MBS puts the whole Fedora Flatpak initiative in doubt.
01:52:59 <cmurf> Matthias: short term actions are to get MBS working, which will fix the locale issue.
01:53:01 <cmurf> #info short term: once MBS is working, locale issues will be fixed.
01:53:03 <cmurf> #topic NVIDIA driver and UEFI secure boot
01:53:05 <cmurf> #link https://pagure.io/fedora-workstation/issue/155
01:53:07 <cmurf> #info General discussion, nothing decided yet.
01:53:12 <cmurf> #endmeeting