workstation
LOGS
01:39:47 <cmurf> #startmeeting Workstation WG (2020-07-14)
01:39:47 <zodbot> Meeting started Wed Jul 15 01:39:47 2020 UTC.
01:39:47 <zodbot> This meeting is logged and archived in a public location.
01:39:47 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:39:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
01:39:47 <zodbot> The meeting name has been set to 'workstation_wg_(2020-07-14)'
01:39:49 <cmurf> #meetingname workstation
01:39:49 <zodbot> The meeting name has been set to 'workstation'
01:39:51 <cmurf> #chair cmurf
01:39:51 <zodbot> Current chairs: cmurf
01:40:09 <cmurf> #topic Rollcall
01:40:11 <cmurf> #info present wg members: cmurf, Neal, aday, mclasen, mcatanzaro, petersen, otaylor, langdon, tpopela
01:40:13 <cmurf> #info regrets wg members: kalev
01:40:15 <cmurf> #info present guests: Davide Cavalca, Alex, salimma, feborges, Josef
01:40:17 <cmurf> #topic Approve minutes for 7 Jun meeting
01:40:19 <cmurf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2020-07-08/workstation.2020-07-08-05.06.log.html
01:40:21 <cmurf> #agreed no objections
01:40:23 <cmurf> #topic Announcements
01:40:25 <cmurf> #info Neal: has proposed a btrfs talk for flock
01:40:27 <cmurf> Michael: abrt has been broken for 3 or 4 weeks due to the data center move. Retrace server broken, but local backtraces seem to be broken too. It's expected to be fixed in 3 (?) weeks.
01:40:29 <cmurf> #info: Abrt retrace server is down for several weeks, affects local backtraces
01:40:31 <cmurf> #action Michael to create a workstation issue
01:40:33 <cmurf> #info Davide: start of a btrfs getting started guide
01:40:35 <cmurf> it's currently in a Google Doc. Will hopefully land in Fedora Quick Docs soon.
01:40:37 <cmurf> #topic Follow-ups  & Status reports
01:40:39 <cmurf> #topic Nano by default
01:40:41 <cmurf> #link https://pagure.io/fedora-workstation/issue/103
01:40:43 <cmurf> #info F33 change approved by FESCo. What are the next steps?
01:40:45 <cmurf> #action Neal to implement the change
01:40:47 <cmurf> #topic Swap on zram
01:40:49 <cmurf> #link https://pagure.io/fedora-workstation/issue/127
01:40:51 <cmurf> #info F33 change approved by FESCo and we voted in favour. Changes on-track.
01:40:53 <cmurf> Next steps in the ticket - https://pagure.io/fedora-workstation/issue/127#comment-664475
01:40:55 <cmurf> Chris: most of what needs to happen has happened.
01:40:57 <cmurf> #topic general topics
01:40:59 <cmurf> #topic btrfs by default
01:41:01 <cmurf> #link https://pagure.io/fedora-workstation/issue/153
01:41:03 <cmurf> #info Davide and Neal have been working on image build infra with btrfs subvolumes
01:41:05 <cmurf> #info Test day happened last week
01:41:07 <cmurf> #link https://testdays.fedorainfracloud.org/events/88
01:41:09 <cmurf> One interesting bug relatd to automatic partitioning of multiple disks, this is going to get fixed by Btrfs upstream soon. Other results were as expected. More tests likely needed.
01:41:11 <cmurf> FESCo approved the change proposal +8 -1.
01:41:13 <cmurf> The WG never voted on the proposal, and there's the outstanding proposal from Owen to adopt in btrfs in f34.
01:41:15 <cmurf> Michael: would have preferred the change in f34, but can do f33. Questions about public relations to answer. More testing would have helped there.
01:41:17 <cmurf> Matthias: it would still be useful to consider some of the ideas from Owen's proposal.
01:41:19 <cmurf> Owen: has concerns that the change is happening too quickly. Isn't going to push for f34 though.
01:41:21 <cmurf> - Recovery experience is a concern, particularly without the testing that we wanted (to have concrete numbers to point to).
01:41:23 <cmurf> - Wants to know how many people are testing Fedora with btrfs.
01:41:25 <cmurf> - We need a good story about performance. It's very subjective so ne need numbers and need to write the performance story so someone else doesn't.
01:41:27 <cmurf> Josef:
01:41:29 <cmurf> - Expanding staffing to work on recovery experience.
01:41:31 <cmurf> - Agrees with Owen's description of the performance challenge - going to assemble tests.
01:41:33 <cmurf> Owen: wants to avoid people being stuck in dracut with a prompt and no guidance. We need to get out of that situation. It's the "doesn't boot" scenario.
01:41:35 <cmurf> - Josef: we can prepare for this but it requires systemd cooperation and a few rounds of testing and iteration.
01:41:37 <cmurf> - Matthias: can we test for this? Neal: yes, if we can have a programmatic way of demonstrating recovery, we can simulate the experience. Davide: there is a kernel flag for making devices read only. There was a thread on this.
01:41:39 <cmurf> Allan: who is managing this effort (in a product management sense - all aspects)?
01:41:41 <cmurf> - Neal: there's a tracking ticket
01:41:43 <cmurf> - Matthias: the change proposal process assumes that the wiki page is the main place
01:41:45 <cmurf> - What about non-technical issues? Let's use the Taiga instance.
01:41:47 <cmurf> Neal: do we want to vote on the proposal?
01:41:49 <cmurf> - Allan: that ship seems to have sailed.
01:41:51 <cmurf> - Matthias agrees
01:41:53 <cmurf> - Langdon: the FESCo vote was just an engineering decision, and we discussed workstation making its own decision afterwards
01:41:55 <cmurf> - Owen: the proposal that went to FESCo wasn't pitched in that way; it's going to be too confusing if workstation goes its own way
01:41:57 <cmurf> - Langdon: there are still some questions in this group as to whether btrfs should be adopted; we ought to allow those people to express their view
01:41:59 <cmurf> - Jens: whether we approve for f33 or f34 is a potential complication in the vote
01:42:01 <cmurf> - Chris: we should trust the existing Fedora development process to iron out any issues
01:42:03 <cmurf> - Owen: that only applies if release blockers are technical bugs. We have other requirements, like there being documentation for read-only filesystem recovery. We need to think about the criteria that we care about. The blocker process is good for avoiding obvious defects, but does not catch additional requirements.
01:42:05 <cmurf> #agreed Plan is to proceed with btrfs by identifying potential issues/blockers and tracking them individually, rather than have a go/no go vote. No objections.
01:42:07 <cmurf> #topic default partitioning: solving the competition for free space
01:42:09 <cmurf> #link https://pagure.io/fedora-workstation/issue/152
01:42:11 <cmurf> #agreed Deferred.
01:42:13 <cmurf> #topic Guidelines for preinstalled and non-removable apps
01:42:15 <cmurf> #link https://pagure.io/fedora-workstation/issue/125
01:42:17 <cmurf> #agreed Deferred.
01:42:30 <cmurf> #endmeeting