workstation
LOGS
05:06:24 <cmurf> #startmeeting Workstation WG (2020-07-07)
05:06:24 <zodbot> Meeting started Wed Jul  8 05:06:24 2020 UTC.
05:06:24 <zodbot> This meeting is logged and archived in a public location.
05:06:24 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:06:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:06:24 <zodbot> The meeting name has been set to 'workstation_wg_(2020-07-07)'
05:06:27 <cmurf> #meetingname workstation
05:06:27 <zodbot> The meeting name has been set to 'workstation'
05:06:29 <cmurf> #chair cmurf
05:06:29 <zodbot> Current chairs: cmurf
05:07:06 <cmurf> #topic Rollcall
05:07:09 <cmurf> #info present wg members: cmurf, mclasen, aday, neal, tpopela, jens, mcatanzaro, owen
05:07:11 <cmurf> #info regrets wg members: kalev
05:07:13 <cmurf> #info present guests: feborges, bberg, josef, michel salim, davide cavalca, jared dominguez, alex
05:07:15 <cmurf> #topic Approve minutes for 30 Jun meeting
05:07:17 <cmurf> #link https://meetbot.fedoraproject.org/teams/workstation/workstation.2020-07-01-04.41.log.html
05:07:19 <cmurf> #agreed no objections
05:07:21 <cmurf> #topic Announcements
05:07:23 <cmurf> Neal: some interest from someone who wants to help with the Disks app - looking to speak to Allan
05:07:25 <cmurf> #topic Follow-ups & Status reports
05:07:27 <cmurf> #info Swap on zram - please vote in ticket
05:07:29 <cmurf> Chris: swap on zram test day was yesterday; results are in
05:07:31 <cmurf> #link https://testdays.fedorainfracloud.org/events/86
05:07:33 <cmurf> and Chris has proposed a vote here
05:07:35 <cmurf> #link https://pagure.io/fedora-workstation/issue/127
05:07:37 <cmurf> #topic btrfs
05:07:39 <cmurf> Chris: btrfs test day is tomorrow
05:07:41 <cmurf> Owen: shares a proposal to switch to btrfs in F34. thinks that it is probably ready for F33, but thinks that we should be conservative. Would like us to have a widespread Fedora beta test. We don't have enough time to do widespread testing for F33.
05:07:43 <cmurf> Chris: this is a new proposal that is different from the one that's on the table. We should give people time to read and discuss it
05:07:45 <cmurf> #info btrfs test day tomorrow
05:07:47 <cmurf> #info Owen proposes Btrfs for F34
05:07:49 <cmurf> #link https://docs.google.com/document/d/1kzDhl56kS_YEjPtTGat3BYRyICGaOSSLHg1oJGh61tg/edit
05:07:51 <cmurf> #topic Should we include thermald by default?
05:07:53 <cmurf> #link https://pagure.io/fedora-workstation/issue/71
05:07:55 <cmurf> We have Jared and Ben here to talk about it.
05:07:57 <cmurf> Intro from Jared:
05:07:59 <cmurf> - Ubuntu has been shipping thermald without the extract bit since X. The proposal is to keep up with Windows in managing thermals.
05:08:01 <cmurf> - Cites experiences at Dell where some models weren't performing properly without thermald.
05:08:03 <cmurf> - The proposal is to ship thermald without dtfextract, which is possible thanks to some reverse engineering by Matthew Garrett.
05:08:05 <cmurf> - OEMs have been requesting thermald.
05:08:07 <cmurf> Neal: no issues with thermald. Had previous concerns about thermald doing the wrong thing (negative impact) without the data.
05:08:09 <cmurf> Jared: it is designed not to have a negative impact without the tables and it has been tested for a number of years in Ubuntu. There hasn't been terrible behaviour. It will just do nothing.
05:08:11 <cmurf> Ben: we can safely say that there won't be negative performance impact.
05:08:13 <cmurf> Michael: last time we had a report from Chris that it was causing issues. Was that fixed? Yes.
05:08:15 <cmurf> Michael: our previous negative decision was based on the idea that you needed the proprietary bits, but it seems that was incorrect information. Also didn't know this was being used by Ubuntu.
05:08:17 <cmurf> Chris: is the plan to install it an enable it by default? Jared: yes.
05:08:19 <cmurf> #agreed No objections - proposal approved.
05:08:21 <cmurf> #topic Reserve some I/O, CPU, and memory for critical session processes
05:08:23 <cmurf> #link https://pagure.io/fedora-workstation/issue/154
05:08:25 <cmurf> Ben: this is related to low memory handling - protecting critical processes when the system is loaded.
05:08:27 <cmurf> - We can use systemd to categorise parts of the system and allocate memory. There's a simple daemon which sets systemd properties at runtime. There's a copr repo which can be used to test this - protects 250MB which is protected for GNOME. There hasn't been extensive testing, but the shell shouldn't swap as much as other processes. It requires btrfs on bare metal to run properly. It's a
05:08:29 <cmurf> relatively minor change.
05:08:31 <cmurf> Chris: does the deamon change things dynamically? No - it's dependent on the session.
05:08:33 <cmurf> Allan: to what extent is btrfs required? The implementation prioritises I/O. btfrs allows prioritising the session. It would probably be enough to set the I/O controller on the main disk, but it requires the partitioning to be correct. We can still do memory and cpu prioritisation independently of btrfs.
05:08:35 <cmurf> Owen: it wouldn't be possible to do I/O control with encryption? Correct.
05:08:37 <cmurf> Michael: the daemon runs twice? For the system and the user. Ben: the user one doesn't do much.
05:08:39 <cmurf> Michael: what's the long-term plan? Ben: the GNOME bits will be upstreamed. The daemon could become part of system-oomd, system-logind; it's unclear. The separate daemon allows development without having to answer those questions.
05:08:41 <cmurf> Michael: the WG will want to keep an eye on this. Would like to get it packaged for F34, asap in rawhide after F33 branch. It would be good to figure out where the code will live.
05:08:43 <cmurf> Matthias: it might make sense to introduce the change at the same time as btrfs.
05:08:45 <cmurf> #topic Guidelines for preinstalled and non-removable apps
05:08:47 <cmurf> #link https://pagure.io/fedora-workstation/issue/125#comment-661584
05:08:49 <cmurf> #agreed Defer until next week
05:08:51 <cmurf> #topic Open btrfs floor
05:08:53 <cmurf> Neal: isn't sure where we'll be in 6 months. People have signed on to work on this now.
05:08:55 <cmurf> Owen: we can adjust the messaging to make it clear that the plan is to switch for F34 rather than kick the can down the road.
05:08:57 <cmurf> Michael: F33 branch is August - so we can switch straight after than - not long.
05:08:59 <cmurf> Chris: concerned about waiting for F34, just to flip the switch. People will be focused on F33, not rawhide/F34. Has time to work on this now, possibly not for F34.
05:09:01 <cmurf> #endmeeting