workstation
LOGS
17:11:27 <cmurf> #startmeeting Workstation WG (2020-05-19)
17:11:27 <zodbot> Meeting started Tue May 19 17:11:27 2020 UTC.
17:11:27 <zodbot> This meeting is logged and archived in a public location.
17:11:27 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:11:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:11:27 <zodbot> The meeting name has been set to 'workstation_wg_(2020-05-19)'
17:11:29 <cmurf> #meetingname workstation
17:11:29 <zodbot> The meeting name has been set to 'workstation'
17:11:37 <cmurf> #chair cmurf
17:11:37 <zodbot> Current chairs: cmurf
17:11:50 <cmurf> #topic Rollcall
17:11:52 <cmurf> #info present: aday, cmurf, owen, neal, jens, mcatanzaro, felipe
17:11:54 <cmurf> #info regrets: langdon, kalev, tomas, mattias
17:11:56 <cmurf> #topic Approve 12 May minutes
17:11:58 <cmurf> #link https://meetbot.fedoraproject.org/teams/workstation/workstation.2020-05-13-01.35.log.html
17:12:00 <cyberpear> (fakes me out every time :P)
17:12:00 <cmurf> #agreed Minutes approved - no objections
17:12:02 <cmurf> #topic Announcments
17:12:04 <cmurf> #info None raised
17:12:06 <cmurf> #topic Followups
17:12:08 <cmurf> #info sd-homed eval continues
17:12:10 <cmurf> #topic Approve filtered view of flathub as third-party repo?
17:12:12 <cmurf> #link https://pagure.io/fedora-workstation/issue/108
17:12:14 <cmurf> #info Allan has prepared a proposal to update the 3rd party repo policy, which he will present to the council: https://pagure.io/fedora-workstation/issue/108#comment-652261
17:12:16 <cmurf> Owen: what are the goals for the whitelist?
17:12:18 <cmurf> Allan: that's the question - which apps are we going to pick and on what basis? Are we going to have an upper limit on the number of apps? The 3rd party repo policy states that the app set should be auditable by Fedora Legal - this implies that the set isn't huge.
17:12:20 <cmurf> Owen: that raises the question - how to yank an app, if it becomes questionable from a legal perspective? Currently, if we remove an app it will remain on users' systems - it would just stop getting updates.
17:12:22 <cmurf> Allan: are the other 3rd party repos aren't any different? Owen: no. This issue's not a blocker, but it is a functionality gap.
17:12:24 <cmurf> Neal: it's obvious to the user if a 3rd party rpm repo gets removed. Owen: how? Neal: mostly on upgrade - it will complain.
17:12:26 <cmurf> Allan: what about this straw man proposal? A maximum number of 25 apps, including apps which aren't available from Fedora already, based on criteria of popularity and recognition. People seem OK with this.
17:12:28 <cmurf> Allan: other questions - what's the process for inclusion (how do we track and ensure testing)? How do we make users aware that the apps are available?
17:12:30 <cmurf> Neal: can we do automated testing? Owen: some, limited.
17:12:32 <cmurf> Neal: is aware of issues with apps that rely on Nvidia drivers etc - can fail in some situations. Doesn't know about testing for this.
17:12:34 <cmurf> Allan's suggestion: a human-driven basic approach - require a ticket and a small number of up votes.
17:12:36 <cmurf> Michael: we should just have basic requirements - it runs, it's not malware...
17:12:38 <cmurf> Allan: quality issues are more critical if we are going to advertise these apps are showcase apps.
17:12:40 <cmurf> #agreed Current approach seems OK
17:12:42 <cmurf> #action Owen to come up with an initial list of apps
17:12:44 <cmurf> Jens: do we want a review process?
17:12:46 <cmurf> #agreed It would be helpful to have a documented review process and inclusion criteria. Volunteers would be good.
17:12:48 <cmurf> #action Discuss advertising the apps in GNOME Software with Kalev and/or Richard.
17:12:50 <cmurf> #topic Open Floor
17:12:52 <cmurf> #info No issues raised, adjourned
17:13:16 <cmurf> #endmeeting