workstation
MINUTES

#fedora-meeting-2: Workstation WG (2020-04-07)

Meeting started by aday at 10:57:35 UTC (full logs).

Meeting summary

  1. Rollcall (aday, 10:57:36)
    1. present: aday, cmurf, feborges, jens, neal, tpopela, langdon, otaylor, mcatanzaro (aday, 10:57:38)
    2. regrets: (aday, 10:57:40)
    3. missing: kalev (aday, 10:57:42)

  2. Approve minutes for 24 & 31 March (aday, 10:57:46)
    1. https://meetbot.fedoraproject.org/fedora-meeting-2/2020-03-31/workstation.2020-03-31-13.07.html (aday, 10:57:50)
    2. The minutes for 24 March incorrectly say 17 March. (aday, 10:57:53)
    3. AGREED: Approve minutes of 24th March. Defer approval of 31st March minutes. (aday, 10:57:55)

  3. Announcements (aday, 10:57:57)
    1. Freeze will be Thursday (aday, 10:57:59)
    2. Suspend to RAM criterion https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/G26BI4DSMZ5HLBMLJESCCPJZPTHE6TR2/ (aday, 10:58:01)
    3. Terminal palette testing, if anyone wants to provide feedback: https://gitlab.gnome.org/Teams/Design/app-mockups/-/issues/20#test-it-yourself (aday, 10:58:04)
    4. Neal has spoken to Daniel Mach about installing on upgrade, we will need to use the supplements workaround for F32, and come up with something better for F33 (aday, 10:58:07)
    5. Michael has written the change proposal for systemd-resolved; it's nearly done - https://fedoraproject.org/wiki/Changes/systemd-resolved (aday, 10:58:10)

  4. Unprivileged users can install, but not remove, system software (aday, 10:58:15)
    1. https://pagure.io/fedora-workstation/issue/137 (aday, 10:58:17)
    2. Upon testing, it turns out that unprivileged users can't actually install without a password. (aday, 10:58:52)
    3. AGREED: There's probably not much to do here. (aday, 10:58:57)

  5. Disk encryption #136 (aday, 10:59:01)
    1. AGREED: We should invite speakers to discuss this with teh WG: someone from the security team, people from the boot team (Javier or Hans or Peter). (aday, 10:59:31)

  6. Disk partitioning #54 (aday, 10:59:36)
    1. Previous decision 18 months ago was to drop LVM and use a big EXT4 partition, but it was put aside until we decided about encryption. The main motivation for this was root partitions getting full. This plan shouldn't conflict with systemd-homed, however it wouldn't align with LUKS /home encryption. (aday, 10:59:38)
    2. Why drop LVM? There's no point in having it if there's just one partition. Add to that, difficulties with LVM resizes and a lack of easy tools. (aday, 10:59:42)


Meeting ended at 10:59:59 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. aday (58)
  2. zodbot (7)
  3. cmurf (0)


Generated by MeetBot 0.1.4.