workstation
LOGS
14:00:25 <cmurf> #startmeeting Workstation WG
14:00:25 <zodbot> Meeting started Mon Nov 25 14:00:25 2019 UTC.
14:00:25 <zodbot> This meeting is logged and archived in a public location.
14:00:25 <zodbot> The chair is cmurf. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:25 <zodbot> The meeting name has been set to 'workstation_wg'
14:00:27 <cmurf> #meetingname workstation
14:00:27 <zodbot> The meeting name has been set to 'workstation'
14:00:29 <cmurf> #topic Roll call
14:00:31 <cmurf> .hello chrismurphy
14:00:32 <zodbot> cmurf: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
14:00:35 <aday> .hello aday
14:00:36 <zodbot> aday: aday 'None' <aday@redhat.com>
14:00:47 <mcatanzaro> .hello catanzaro
14:00:47 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
14:00:49 <mclasen> .hello mclasen
14:00:50 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
14:00:54 * satellit listening
14:00:55 <Son_Goku> .hello ngompa
14:00:56 <zodbot> Son_Goku: ngompa 'Neal Gompa' <ngompa13@gmail.com>
14:01:08 <petersen> .hello2
14:01:09 <zodbot> petersen: petersen 'Jens Petersen' <petersen@redhat.com>
14:01:15 * mcatanzaro might have to step out partway through depending on when his plumber arrives
14:01:23 <cmurf> #chair aday mcatanzaro mclasen Son_Goku petersen
14:01:23 <zodbot> Current chairs: Son_Goku aday cmurf mcatanzaro mclasen petersen
14:01:32 <cmurf> We  have quorum
14:01:39 <aday> langdon seems to be here too
14:01:47 <petersen> Heads-up for next week - I will be away and I am scheduled to chair unfortunately
14:01:47 <aday> and otaylor
14:01:53 <langdon> .hello2
14:01:56 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
14:02:04 <cmurf> #chair otaylor langdon
14:02:04 <zodbot> Current chairs: Son_Goku aday cmurf langdon mcatanzaro mclasen otaylor petersen
14:02:09 <langdon> im just dbl booked so was logging in to other meeting
14:02:45 <cmurf> There are two issues I'd like to get to today, and I suspect it might be all we can mentally handle, even setting aside time.
14:02:51 <cmurf> #topic Issue 111 GNOME Software is recommending proprietary software
14:02:53 <cmurf> #link https://pagure.io/fedora-workstation/issue/111
14:03:27 <cmurf> So I just talked to mcatanzaro about this and Example 1 is a distraction, it's been this way for a while, is confusing, but should be handled separately.
14:03:46 <cmurf> The bigger issue is example 2, with the express advertising banners for proprietary software in GNOME Software in Fedora Workstation 31.
14:04:04 <cmurf> These appear as "Featured Applications" right at the top front and center
14:04:17 * satellit also in silverblue f32
14:04:18 <cmurf> I've seen both Dropbox and Slack banners
14:04:25 <mclasen> the way I see it, if you want to change what banners are shown, you need to step up and volunteer to curate them
14:04:54 <aday> i thought that this was supposed be solved by a free-only flathub
14:05:25 <mclasen> what banners are shown is independent of what apps can be installed, afaik
14:05:41 <mclasen> although I'd need hughsie to confirm the details
14:06:00 <aday> i discussed it with hughsie and thought that was how it would work
14:06:16 <aday> could do with my memory being refreshed though
14:06:26 <mclasen> ok
14:06:38 <langdon> can you define "what can be installed"?
14:06:50 <langdon> like why wouldn't you be able to install it?
14:06:52 * mclasen thought that was pretty self-evident
14:07:13 <mclasen> you can click on the install button, a progress bar appears, and then it gets replaced with a launch button...
14:07:32 <mcatanzaro> It's relevant that if we issue a decision allowing these banners today, somebody will inevitably appeal to FESCo or Council and our decision will very likely be overruled, which has never happened to the WG before. It seems so likely to be as to be almost certain; I don't see this ending any other way. So IMO it more useful to treat it as a bug to fix rather than arguing over whether we want to do it or not.
14:07:36 <cmurf> langdon: I'm guessing, but perhaps the banners are visible out of the box, but can't be installed if e.g. flathub.org isn't enabled because neither Dropbox nor Slack (as the only examples I have atm) are in Fedora repos
14:07:45 <Son_Goku> mclasen, I think what langdon means is if there's a scenario if metadata is visible but installability is disabled by default
14:07:55 <Son_Goku> like how we have for certain RPMs
14:08:20 <mcatanzaro> It's easy enough to remove banners in a downstream patch if aday wants to keep the banners upstream so I don't think volunteer manpower will be an issue here.
14:08:22 <langdon> maybe i am misreading what mclasen was saying in "what banners are shown is independent of what apps can be installed, afaik" < i read that as sometimes you can't install an advert'd thing
14:08:43 <aday> i would prefer not to go round and round discussing this without having an understanding of how it works
14:08:44 <cmurf> The banners appear to be hardcoded into GNOME Software; but I personally have only seen them on a system where flathub.org is enabled as a 3rd party repo.
14:08:49 <mclasen> a free flathub, even if we had it in place, can't affect this. Or was this bug filed with a flathub remote installed and enabled ?
14:08:54 <aday> let's not waste our time
14:08:57 <hughsie> gnome-software has to know how to install a nonfree app before it would show in the banner...
14:09:03 <mclasen> in that case, it seems pointless to complain that g-s shows you what you enabled
14:09:22 <Son_Goku> if it's user-enabled, I don't see what the problem is
14:09:41 <mclasen> mcatanzaro: I don't think basing our decisions on anticipated moves by fesco is a winning strategy
14:09:49 <cmurf> I can't agree that a user enabling flathub translates into an opt-in into seeing and installing proprietary/non-free software.
14:10:01 <cmurf> I have no way of knowing flathub means mixed license software.
14:10:14 <Son_Goku> cmurf, just visiting the flathub website tells you it does
14:10:24 <Son_Goku> I'd have to side with mclasen and hughsie here on this
14:10:29 <petersen> I think it would be good to only show free apps in the banner
14:10:32 <mclasen> cmurf: if you enable flathub and see things you don't like, just disable it again
14:10:41 <Son_Goku> if you installed the flathub remote, it should show you stuff available
14:10:42 <mclasen> I don't think that needs discussing
14:10:49 <hughsie> talking of which, you lot know that the KDE app center can install flathub with one click, right? no visit to the website required?
14:10:58 <Son_Goku> it's no different than if the snap plugin was installed, or if rpmfusion was activated
14:11:16 <Son_Goku> hughsie, I knew that was a recent upstream feature, I didn't know we have it in Fedora already
14:11:29 <cmurf> Son_Goku: RPM Fusion has explicit free and non-free repos, and it's in the name. I don't see that with flathub.
14:11:30 <Son_Goku> (unlike most of these guys, I primarily use KDE)
14:11:35 <langdon> there is a flag on the software indicating the license, right.. so it seems like a setting that would be easy to implement... like "only show banners for this license type(s)"
14:11:38 <hughsie> Son_Goku, *that* seems to be the thing that needs to be discussed, IMHO
14:11:48 <mclasen> hughsie: so, if we have a filtered flathub remote in place, g-s will only show banners for apps that pass the filter ?
14:12:01 <petersen> langdon: right
14:12:10 <langdon> but it is just the ads... which seems pretty simple
14:12:11 <Son_Goku> hughsie, yes, but who is going to talk to KDE upstream?
14:12:11 <hughsie> mclasen, no need for filtered remove, we can get the licence "freeness" from the metadata
14:12:21 <hughsie> Son_Goku, FE-LEGAL?
14:12:26 <mclasen> but we don't filter banners by freeness
14:12:30 <cmurf> langdon: I agree and that's what I'd like to see, is inhibit the banners on Fedora. I don't think users are asking to receive adverts for properietary software on Fedora.
14:12:43 <hughsie> counter question: have any complained?
14:12:46 <cmurf> Just because they've enabled a repo that allows them to install proprietary software.
14:12:53 <mclasen> the only one who complained is cmurf
14:12:54 <cmurf> hughsie: yes we have a bug
14:13:03 <Son_Goku> hughsie, maybe spotrh will talk to them...
14:13:10 <aday> it seems like we're slipping into some complex territory here. repos that only contain free/safe software are relevant beyond people's political sensibilities
14:13:11 <cmurf> mclasen: I complained because of a user bug and then I saw the same thing and I decided to raise it with the WG
14:13:24 <mclasen> I see
14:13:25 <mcatanzaro> I fear this is going to blow up once the Internet notices; I'd really like to get ahead of it...
14:13:25 <cmurf> Because it seems like a mistake.
14:13:32 <aday> i wouldn't want to design a solution before we'd considered all the angles
14:13:48 <mcatanzaro> I understand the argument is that the banners appear only when flathub is enabled; enabling flathub inherently opts-in to nonfree software since it's filled with nonfree stuff
14:13:56 <langdon> well.. this is the first /only example of "advertising" in fedora, right? (well, hard coded stuff in anaconda) ... so it makes sense there will be some bumps
14:14:04 <mclasen> mcatanzaro: thats a misrepresentation of flathub
14:14:20 <mclasen> it is not 'filled' with it. nonfree software is available there, yes
14:14:35 <petersen> .bug 1769967
14:14:36 <mcatanzaro> OK yes, reword: since it contains some nonfree stuff
14:14:39 <zodbot> petersen: 1769967 – gnome-software is recommending non-free software with large colourful banners - https://bugzilla.redhat.com/1769967
14:15:36 <mcatanzaro> But the banners are not metadata pushed from flathub, they are metadata provided by Fedora (via gnome-software upstream).
14:15:52 <hughsie> mcatanzaro, they could come from flathub too if we wanted
14:15:55 <aday> mcatanzaro, you volunteering to build a different mechanism?
14:16:06 <mcatanzaro> Certainly not
14:16:12 <aday> being able to advertise spotify and slack is kind of important
14:16:14 <Son_Goku> hughsie, I thought the banners _were_ populated by appstream metadata?
14:16:31 <aday> we are supposed to be reaching out to the young developer crowd
14:16:39 <hughsie> Son_Goku, sure, and everything except snap now ships AS metadata
14:16:47 <langdon> Son_Goku: yeah.. *fedora* is providing non-free software ads?
14:16:47 <cmurf> #info We think the banners do not appear in GNOME Software (example 2 in the topic issue, bug 1769967) unless the user enables flathub.org in
14:17:05 <cmurf> That needs clarification if it's possible these banners appear without enabling 3rd party repos.
14:17:10 <Son_Goku> hughsie, that's hopefully changing in the future (snap plugin not shipping AS md)
14:17:25 <hughsie> Son_Goku, i'm not going to hold my breath for that one :(
14:17:29 <mclasen> hughsie: do we have plumbing in place to use banners from appstream ?
14:17:50 <hughsie> mclasen, client side yes (but untested), in flathub, no.
14:18:08 <hughsie> it's also not great to scale
14:18:21 <mclasen> not great to scale ?
14:18:21 <hughsie> as 400,000 people all hit flathub/banner1.png on release day
14:18:42 <mclasen> why would they ? wouldn't this be bundled in the appstream ref ?
14:19:05 <hughsie> mclasen, we could do, but there's no support for that in any of the flatpak tools
14:19:12 <hughsie> ohh and images
14:19:19 <Son_Goku> hughsie, well, at least the upstream snap plugin won't even push banners :/
14:19:24 <Son_Goku> not until that happens
14:19:48 <cmurf> Question 1: Is it acceptable for GNOME Software to show advertising banners for proprietary software, in a default Fedora Workstation installation?
14:20:09 <mclasen> thats a hypothetical
14:20:32 <mclasen> since I believe we've established that it does not in fact do that
14:20:34 <hughsie> if i'm honest, i'm not sure what the problem is -- if the user has manually installed the flathub remote it's probably because they want something that flatphub provides. the most popular apps are going to be nonfree for end users and typical developers.
14:20:37 <aday> i don't think we should decouple advertising from availability
14:21:20 <aday> you can argue about what should and shouldn't be available, but levels of granularity for exposure is unnecessary complexity in my opinion
14:21:41 <mclasen> but anyway, to answer the question, it would be acceptable to me
14:21:42 <Son_Goku> I'm basically in the same boat
14:21:55 <langdon> i think i agree with aday.. but .. i would say.. i am not sure an ad for spotify in gnome-software is bringing someone to fedora.. like they already made that choice before they can see gnome-software :)
14:22:03 <Son_Goku> for similar reasons (if someone installs the snap plugin, they want to see snaps of all kinds)
14:22:14 <Son_Goku> and I think that rule applies equally to flatpaks
14:22:31 <mclasen> no add in g-s can bring anybody to fedora, by definition, since they've already installed fedora before they can see the ad
14:22:33 <hughsie> langdon, this is idealogical v.s. "I already pay for spotify" no?
14:23:00 <aday> langdon, advertising the best software that's available for a platform reinforces a positive view of that platform
14:23:56 <cmurf> Do the advertising banners detour users to using proprietary versions of software for which there are free equivalents?
14:23:59 <langdon> i am just saying having a banner ad for spotify in gnome-software as an attractor to fedora seems weird.. maybe if someone comes and asks me ? and I don't use spotify?
14:24:02 <aday> and maybe there are people that don't know that these big apps are available, in which case this will be a pleasant surprise for them :)
14:24:21 <cmurf> Is the banner encouraging the use of non-free over free?
14:24:35 <langdon> cmurf: that is the q the council will be worried about
14:24:36 <mclasen> langdon: I use spotify on my phone, and I pay for it. knowing that I can also use spotify on my laptop is useful information to me
14:25:00 <langdon> im just saying it didn't bring you to fedora though
14:25:00 <aday> cmurf, there are more banners for free than non-free
14:25:03 <mclasen> fedora refusing to show me that information is not going to make me stop using spotify
14:25:18 * hughsie agrees with mclasen there
14:26:20 <langdon> definitely not my point.. i was just disagreeing with aday's argument way back that a spotify banner ad in g-s wouldn't/couldn't encourage someone to install fedora in the first place
14:26:25 <mcatanzaro> There's also a trademark issue, we surely did not get permission from slack to overlay their logo on an advertisement they did not create... I'm not sure, but I suspect even doing it programatically where the logo isn't part of the underlying asset would probably not be approved by FE-legal
14:26:36 <langdon> but i am happy to drop it
14:26:57 <mclasen> mcatanzaro: you don't know that
14:27:13 <mcatanzaro> I suggest we consider this as a matter of strategy. Once this gets noticed we're going to get reamed with negative media coverage... and devel@ will blow up. Is it really worth it? Furthermore: we just locked in a precedent that we can present proprietary search results after user opt-in. Isn't it better to consolidate those gains rather than risk them by reopening debate?
14:27:16 <mclasen> our artists are generally mindful and careful about copyright
14:27:19 <aday> i think we've got 3 or 4 proprietary banners, out of 24
14:27:21 <hughsie> mcatanzaro, that's covered in fair use, no?
14:27:34 <mcatanzaro> mclasen, well yes, that's what I said: "I'm not sure"
14:27:58 <cmurf> We are way deep into the weeds in areas none of us are experts in, including internationl trademark and copyright law.
14:28:11 <mclasen> mcatanzaro: get noticed ? again, we don't show the banners on a default install unless you enable flathub
14:28:20 <mclasen> mcatanzaro: you said 'surely'
14:28:26 <cmurf> I propose we get more information on the facts. I put them in the issue. And we agree to punt this to Council to decide of it's a problem or not. And then follow that guidance.
14:28:36 <mclasen> which sounded like the opposite of 'i'm not sure'
14:28:38 <aday> people have to add flathub themselves, then they see the things that in flathub. i don't see the controversy
14:29:05 <langdon> i also think the "origin" of the ads is important.. if they are coming from flathub is very different than if they are coming from fedora
14:29:14 <mclasen> cmurf: I disagree with actively raising a non-issue to the council
14:29:32 <cmurf> aday: Nope, on a clean install I'm actively encouraged by GNOME Software to enable 3rd party repos and enabling it enables flathub and now I'm seeing proprietary software in banners and searches.
14:29:41 <mcatanzaro> langdon: The ads are coming from Fedora, not from Flathub
14:29:53 <mcatanzaro> They come from Fedora, but are only shown once Flathub is enabled.
14:29:54 <hughsie> cmurf, no, that's just the council approved nonfree software
14:29:55 <cmurf> And nothing informed me that adding a 3rd party repo also means opting into non-free software.
14:30:07 <mclasen> cmurf: we do want to help users find software, right ? thats the purpose of g-s
14:30:08 <aday> cmurf, 3rd party repos don't enable flathub
14:30:09 <hughsie> cmurf, flathub has to be manually enabled by going to the website
14:30:23 <hughsie> else we get in all kinds of trouble with patented software
14:30:28 <mcatanzaro> Yeah cmurf, enabling the third-party repos does not *currently* enable flathub
14:30:34 <cmurf> I have no problem with helping them. I have a problem with them not being informed. 3rd party repo does not state non-free is included.
14:30:41 <cmurf> There are examples of completely free 3rd party repos.
14:31:04 <mcatanzaro> I guess the long-term goal is to make enabling flathub as easy as possible, so maybe that will change in the future
14:31:28 <aday> for which i thought the plan was to create free/non-free flathubs
14:31:36 <mclasen> cmurf: it is your view that free vs non-free is the most important thing to inform users about. I believe many users would disagree
14:31:47 <mclasen> aday: yes, that is the plan
14:31:54 <aday> so what are we arguing about?
14:32:00 <langdon> mcatanzaro: because of the non-free stuff? why wouldnt the free stuff just go in fedora flathub?
14:32:02 <cmurf> I'm not talking about what users want. I'm talking about what Fedora stands for vis a vis the Council.
14:32:22 <mclasen> langdon: there is no fedora flathub
14:32:57 <cmurf> The users want it to be easier to install 3rd party software, the Council has agreed to that. But banners advertising it in GNOME Software whent the user hasn't make an explicit connection to a repo enabling non-free software availability?
14:33:00 <mclasen> unless you mean flatpaks in the registry, which is not and imo, should not, be a competitor to flathub
14:33:00 <langdon> ummm.. where do the flatpaks i get from "fedora" come from?
14:33:18 <cmurf> And I'm fine asking the Council about it before, as mcatanzaro says, this blows up on devel@
14:33:23 <langdon> mclasen: i did..
14:33:54 <aday> "the user hasn't make an explicit connection to a repo enabling non-free software availability?" um yes they have?
14:33:59 <mcatanzaro> aday, you can say "i don't see the controversy" but we all know the controversy: Fedora has not historically promoted nonfree software, we just had a small controversy when someone on devel@ noticed we were showing nonfree search results. But we contained it and handled it without too much trouble. This will be much, much harder. :/
14:34:31 <mclasen> letting the anticipated controversy guide your decisions is letting the bullys win
14:34:35 <cmurf> mcatanzaro: that's it in a nutshell
14:34:36 <langdon> mclasen: why couldnt "fedora flatpak registry" just be free flathub?
14:35:27 <mcatanzaro> It's going to be *very* controversial, we're going to get reamed on devel@, and on reddit, and a bunch of other places. This will (probably) be the first WG decision to be overturned. I think we are maybe not having realistic expectations about what FESCo and Council will allow and what it won't allow.
14:35:29 <aday> mcatanzaro, fedora isn't promoting nonfree. when someone enables a repo containing nonfree, it gets advertised
14:35:32 <langdon> * "provide" free flathub
14:35:41 <mclasen> langdon: because it is not as good. oci is awkward at best, and packing things twice is the opposite of what we want from flatpaks
14:35:58 <cmurf> mclasen: Not at all, it's about being proactive. Everyone knows I'm willing to beat bullies with a dead horse until they beg for mercy.
14:36:11 <langdon> aday: well.. if the ads are sitting on fedora servers, that is a bit arguable
14:36:16 <aday> this is just like any package manager exposing what's in a repo
14:36:30 <mcatanzaro> aday, Fedora (via GNOME Software) is hand-selecting curated banners advertising proprietary software. That's not in doubt....
14:36:48 <langdon> like i would be WAY more comfortable with this if the ads were coming from/being provided by flathub vs fedora
14:36:59 <langdon> mcatanzaro: right..
14:37:02 * mclasen is just not very interested in appeasing purists
14:37:09 <aday> mcatanzaro, on the assumption that they are only shown to users who explicitly add them
14:37:39 <mclasen> mcatanzaro: Fedora is not selecting anything. it is just packaging gnome-software
14:37:45 <langdon> mclasen: i think there is a fine line here.. the council is likely to be ok with it to some extent.. i think it will matter "who" is hosting them
14:37:52 <aday> mcatanzaro, you make it sound like it's a big operation. it's a few banners that are coming from upstream
14:38:18 <cmurf> mclasen: I'm not at all concerned with purity tests here. I *use* proprietary software and OS's routinely. I want to make sure the WG's product is consistent with the intent of the Council and by extension, legal.
14:38:42 <cmurf> OK how about we table this and I get more information? And we move on to the next issue?
14:38:51 <petersen> Sure
14:38:51 <langdon> aday: i don't think we package proprietary logos in much else, do we?
14:38:52 <mclasen> there's nothing legal in question here
14:39:01 <mcatanzaro> cmurf, what more information do you need?
14:39:05 * otaylor is here now - sorry - didn't realize we had already moved to weekly meetings
14:39:22 <aday> langdon, why are logos relevant?
14:39:47 <cmurf> mcatanzaro: I have a number of questions, I think it's best to take it offline since we only have 20 minutes to go, and we don't need group time to answer them.
14:39:56 <langdon> aday: maybe they aren't cause I guess we do packaged trademarked ones a lot
14:40:00 <mcatanzaro> OK
14:40:46 <cmurf> #info WG doesn't have any concensus to change the existing GNOME Software behavior, but there are some concerns
14:40:55 <cmurf> #topic Issue 110  Document the working group role and purpose
14:40:57 <cmurf> #link https://pagure.io/fedora-workstation/issue/110
14:41:11 <cmurf> The governance document says we're a working group of 9, but we are 10. How soon can it be updated and ready for a WG vote so it can be submitted to FESCo for approval?
14:41:13 <cmurf> #link https://fedoraproject.org/wiki/Workstation/Governance
14:41:37 <cmurf> aday mcatanzaro, status of your editing efforts?
14:41:54 <mcatanzaro> I have a proposed update here: https://pagure.io/fedora-workstation/issue/110#comment-610847
14:42:00 <mcatanzaro> Requires some horizontal scrolling, unfortunately
14:42:11 <aday> i gave a bit of feedback. i think there's more work to be done
14:42:18 <mcatanzaro> I tried to make it very lean so that we can change the details without changing the document itself
14:43:02 <mcatanzaro> I think I misread aday's comment in the issue, I didn't realize he was commenting on my draft. That's why I didn't respond
14:43:08 <cmurf> I'm happy to help, if it's helpful. Is there time this week to wrap this up and present the changes to the WG in the next two weeks?
14:43:16 <mcatanzaro> So action for me is to reread aday's feedback and incorporate it into the draft
14:43:35 <cmurf> #action mcatanzaro to re-read aday's feedback and incorporate
14:44:24 <cmurf> #info governance document says the WG is a group of 9 but in fact we're 10 so we need to update it to reflect reality
14:46:21 <mcatanzaro> Sorry, I guess now this is delayed a week because I didn't read properly :)
14:47:29 <cmurf> OK anything else?
14:48:12 <aday> cmurf, on this topic, or in general?
14:48:13 <cmurf> OK then.
14:48:17 <cmurf> on this topic
14:48:52 <cmurf> ok moving on...
14:48:55 <cmurf> #topic Open Floor
14:49:27 <aday> i'd really like us to make some progress on https://pagure.io/fedora-workstation/issue/106
14:49:47 <cmurf> aday: Yes that was my next issue priority wise.
14:50:18 <aday> it feels like we're not organised enough to have a discussion about getting better organised :D
14:50:30 <cmurf> That seems likely.
14:50:31 <petersen> Talking of which I will be away next week - can someone chair the meeting for me?
14:50:48 <petersen> I am happy to swap
14:51:00 * mclasen can do it
14:51:07 <mcatanzaro> Thanks mclasen!
14:51:08 <petersen> mclasen: okay thanks!
14:51:24 * mclasen puts it in the calendar to increase the chances of not forgetting it
14:51:32 <langdon> aday: so.... i am not sure what you think is "broken"..
14:51:41 <langdon> i think the attendance has been *much* better..
14:51:53 <langdon> perhaps not perfect but .. does it need to be?
14:52:10 <aday> langdon, various things - initiatives getting stalled or being super slow
14:52:23 <langdon> are the issues not getting addressed/ closed? are do you think we could be "doing more" than just ticket management?
14:52:31 <langdon> s/are/or
14:52:35 <aday> discussions happening that aren't properly prepared in advanced
14:52:39 <aday> *in advance
14:52:58 <aday> inconsistent priorities week on week
14:53:22 <aday> inefficient meetings, because they're slow, unfocused, confused
14:53:46 <aday> lack of strategic prioritisation
14:53:54 <mcatanzaro> We've had a couple tickets stalled for a while on cschalle, who is... not the greatest at attendance :)
14:53:56 <langdon> can you point to an examplar?
14:53:59 * mclasen watches aday empty the bucket
14:54:10 <cmurf> haha
14:54:50 <aday> langdon, well we had a big debate about flathub in this call, without knowing in advance how flathub and software work together
14:54:59 <aday> that's a waste of everyone's time
14:55:29 <aday> some of the big initiatives - disk encryption, low memory handling - seem to have been forgotten about by the group as a whole
14:55:39 <langdon> aday: ha..  i guess i am curious if you know a group that "does it right"?
14:55:43 <petersen> Would it help to have "shepards" for issues?
14:55:47 <aday> curf and mcatanzaro are the only people who seem to poke at those
14:56:13 <mcatanzaro> We've had a lot of discussion on low memory handling
14:56:17 <aday> petersen, assignees, and a chair, and a shortlist of priorities that we're working on? yes!
14:56:31 <mcatanzaro> Encryption is a bit stalled, yes. I think cmurf wanted to wait and see how systemd-homed evolves
14:56:39 <cmurf> The low memory handling stuff is super complicated, it's immediately in the weeds in the first like 2 minutes of a discussion.
14:56:47 <petersen> My feeling is that a lot of us are very busy, myself included, and may lack the time to stay on top of or even follow all the issues and discussions
14:56:54 <cmurf> Andn it's not at all clear to me any solution is something other than rearranging the deck chairs.
14:57:28 <mcatanzaro> FWIW I think aday is right that would could be more organized and efficient. Perhaps I'm more laid back though; I think we're doing OK as long as our ticket queue is getting smaller rather than bigger :)
14:57:34 <langdon> perhaps for the next meeting we can focus it on #106 completely and resolve to close it?
14:57:36 <cmurf> mcatanzaro: Speaking of which systemd-homed PR into systemd-244 has happened
14:57:45 <langdon> mcatanzaro: me too :)
14:58:10 <cmurf> #idea Announced WG issues a week in advance so we can properly be prepared for the next meeting
14:58:12 <langdon> as in .. let's make some changes and then see if they help.. if they don't we can open #112 :)
14:58:15 <mcatanzaro> Focusing the next meeting on #106 makes sense, but it would be even better if we take the time to respond to aday's proposals in the ticket so that we have some idea of where we stand before the meeting. Which is one of his points, anyway. ;)
14:58:20 <aday> what i'm proposing is just standard good practice imo
14:58:33 * mclasen adds #106 to next weeks agenda
14:59:19 <cmurf> I agree with aday, and we discussed it in person in London a few weeks ago - these are fairly common problems that can be fixed with a few protocol tweaks that help everyone get on the same page and use time more effectively
14:59:20 <aday> we could certainly trial the changes and see how it works out
14:59:45 <petersen> Sounds positive
15:01:09 <cmurf> I was going to make #110 and #106 the topics today, and I admit hijacking my own plan because I thought the GNOME Software banner advertising legitimately was something that needed to be addressed, not necesarily solved today.
15:01:25 <mcatanzaro> I'd like to suggest we try to avoid drawing more attention to the banner issue during the next week. And try to be cautious in mailing list and Bugzilla comments.
15:01:42 <mcatanzaro> Goal: no flamewar on devel@
15:01:49 <aday> langdon, some of this i'm basing on the gnome foundation board, of which i'm the chair
15:01:52 <langdon> mcatanzaro: i got that covered for you
15:02:06 <mcatanzaro> langdon, how so?
15:02:11 <langdon> mcatanzaro: modularity
15:02:17 <mcatanzaro> Oh, thanks :P
15:02:19 <cmurf> OK we're at time so I'm going to set the fuse :D
15:02:48 <mcatanzaro> If anybody says something about banners, our response: blame modularity! :D
15:03:04 <langdon> mcatanzaro: harsh.. but why not, everyone does it!
15:03:16 <cmurf> #endmeeting