workstation
LOGS
13:06:57 <stickster> #startmeeting Workstation WG
13:06:57 <zodbot> Meeting started Mon Jul 30 13:06:57 2018 UTC.
13:06:57 <zodbot> This meeting is logged and archived in a public location.
13:06:57 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:06:57 <zodbot> The meeting name has been set to 'workstation_wg'
13:07:02 <stickster> #meetingname workstation
13:07:02 <zodbot> The meeting name has been set to 'workstation'
13:07:02 <mclasen> .hello mclasen
13:07:03 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:07:07 <stickster> #topic roll call
13:07:11 <stickster> .hello pfrields
13:07:12 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:07:15 <ryanlerch> .hello ryanlerch
13:07:16 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:07:24 <juhp> .hello petersen
13:07:25 <zodbot> juhp: petersen 'Jens Petersen' <petersen@redhat.com>
13:08:00 <stickster> #chair mclasen ryanlerch juhp otaylor kalev
13:08:00 <zodbot> Current chairs: juhp kalev mclasen otaylor ryanlerch stickster
13:09:01 <stickster> #info Agenda is officially empty, see...
13:09:03 <stickster> #link https://pagure.io/fedora-workstation/issues?status=Open&tags=meeting
13:09:25 <stickster> Reminder, to get things on the agenda, just tag an open issue with the 'meeting' tag
13:09:35 <stickster> #info aday suggests we look at first run experience
13:09:40 <stickster> #topic First run experience
13:09:58 <aday> that's https://pagure.io/fedora-workstation/issue/57
13:10:52 <stickster> #link https://pagure.io/fedora-workstation/issue/57
13:11:16 <aday> the last comment summarises my view
13:12:00 <mclasen> the use of yelp was a stopgap solution all along...
13:12:14 * stickster just read it... I don't see anything there I disagree with, either
13:12:43 <mclasen> integrating the tour into the initial setup looks great
13:12:54 <stickster> The Yelp screen is helpful but yeah, there are more elegant (above line) and sophisticated (below) ways to be touring users
13:13:30 <aday> there are designs for a fancier first run tour, which endless were interested in working on, but that's all on the back burner currently
13:13:50 <aday> the new greeter is meant to be a quick a simple approach - basically just a gtk assistant that's launched on first run
13:13:55 <ryanlerch> is the greeter a seperate app? or part of initial setup?
13:14:20 <aday> ryanlerch: it's a separate assistant that's shown in the session
13:14:43 <otaylor> aday: Am I to take it, that the 3.30 / f29 plan is to fix as many of the listed bugs as possible, but not do the greeter, and not add the animations?
13:15:50 <mclasen> there is no plan, per se
13:16:05 <aday> i think there was a plan to add animations for f29
13:16:26 <aday> i'm essentially challenging that - saying that we need the greeter first
13:16:28 <mclasen> its not on anybody's list, afaik
13:17:34 <aday> mclasen: ah. the ticket says it's targeted for f29
13:17:46 <otaylor> aday: I don't actively see the *harm* in adding the animations now, especially since the first-run is not run on upgrade (so if you get it for f29, you won't get it for f30) but yes, the proposed tour looks much slicker than throwing a few animationsinto place
13:18:23 <aday> otaylor: only harm would be - we might need different animations, and it'd be doing some of the work twice
13:19:33 <otaylor> aday: certainly, with a longer term plan it doesn't seem like we should scramble to get the animations integrated into the g-i-s right now
13:20:08 <otaylor> aday: is there anything you think we *should* be scrambling to arrange for f29?
13:21:28 <mclasen> we should certainly fix the g-i-s to session transition
13:21:49 <mclasen> maybe thats a given
13:22:09 <stickster> How is that working right now? I haven't done e.g. a recent F28 clean installation, tbh
13:22:31 <otaylor> stickster: https://gitlab.gnome.org/GNOME/gnome-initial-setup/issues/2
13:22:50 <aday> otaylor: hard to say. auto flatpak updating is going to need attention - it's still rough. and we some nasty outstanding wayland issues
13:22:56 <aday> *we have some
13:23:22 * cschalle hi
13:23:31 <cschalle> sorry for being late
13:23:33 <stickster> #chair cschalle
13:23:33 <zodbot> Current chairs: cschalle juhp kalev mclasen otaylor ryanlerch stickster
13:23:35 <otaylor> aday: I was specifically asking about initial setup, but glad to hear more broad input too :-)
13:23:42 <aday> oh, ha ha
13:24:05 <otaylor> (input is the wrong word their, since it sounds like I'm formulating some sort of master plan)
13:24:12 <stickster> ATTENTION: EVERYTHING IS BROKEN
13:25:18 <juhp> To me the biggest problem with g-i-s now is the blank first page
13:25:19 <aday> otaylor: i think we do want some new artwork for the first and last pages. we experience regressed last cycle
13:25:26 <stickster> Actually, point of order, there was a wonderful Instagram story that @fedora posted this past week(end?) with a ton of happy input from users
13:25:35 <stickster> So I'm just kidding of course ;-)
13:26:20 <stickster> cschalle: Not sure if you can see scrollback -- we're looking at https://pagure.io/fedora-workstation/issue/57 since there is nothing else on agenda today.
13:26:45 <cschalle> stickster, ah ok, thanks, yeah I can't see the scrollback, but I check the ticket
13:26:47 <mclasen> I have one quick thing for the agenda, can wait to the end
13:28:04 * stickster not sure if the discussion here has ended :-)
13:28:55 <stickster> #info Seems like fixing g-i-s handoff to session probably will take precedence over new animation/tour work (which is bigger anyway)
13:29:21 <stickster> #info g-i-s has some experience regressions to deal with as well
13:29:34 <aday> if we don't have animations, we will need new artwork at the minimum
13:29:50 <aday> right now it looks sad
13:30:13 <stickster> #info aday proposes we need new greeter before we add animations, or else it will mean repeat/redundant work
13:30:37 <stickster> #info aday proposes new artwork is needed at minimum for stopgap, though
13:30:41 <juhp> juhp: it's not in gitlab issues
13:31:00 <stickster> talking to yourself is the first sign of imminent breakdown :-)
13:31:04 <aday> relevant upstream bug - https://gitlab.gnome.org/GNOME/gnome-initial-setup/issues/7
13:31:06 <juhp> haha
13:31:23 <juhp> well noone responded so I went to look
13:32:41 <juhp> aday: ah right so it is
13:37:20 <stickster> Um, OK mclasen. I guess we're switching topics.
13:37:52 <stickster> Does anyone take an #action on the above?
13:38:12 <stickster> Otherwise I guess this is all FYI.
13:38:28 <stickster> #topic All other business / Open floor
13:38:31 <stickster> go mclasen
13:38:42 <aday> stickster: i can take the lead on the design side, but i'm not sure if we have any developers assigned
13:38:53 <mclasen> there was a request on discourse that we should include the gnome-shell-chrome package
13:39:02 <mclasen> to make shell extension installation work in browsers
13:39:18 <mclasen> more relevant for silverblue, where it is annoying to package-layer it
13:41:04 <stickster> #info aday is lead on design side for greeter redesign, but needs help from devs
13:41:27 <mclasen> any opinions on that ?
13:41:52 <stickster> mclasen: given that about 50% of our users install Chrome (based on informal polls on e.g. Facebook), that seems like it would be a big help for users.
13:42:09 <mclasen> I think the package name is misleading - it is also needed for firefox, afaik
13:42:20 <stickster> maybe we need a rename?
13:42:23 <mclasen> otaylor: correct ?
13:42:37 <stickster> unfortunately that means a re-review for Fedora packaging, but that shouldn't be too onerous
13:42:50 <aday> i have to confess that i find the extension installation experience quite confusing at the moment. i generally end up using software
13:43:00 <otaylor> mclasen: I'm really out of the loop on this - haven't thought about it for a couple of years
13:43:09 <mclasen> ok
13:43:12 <aday> although that's quite poor too
13:43:34 <otaylor> mclasen: at some point there was a plan to deprecate the old firefox plugin system that the extension installation mechanism used to use
13:43:39 <otaylor> and the to remove it
13:43:42 * mclasen asks in #gnome-shell
13:43:58 <otaylor> mclasen: I'm not sure if that has happened yet
13:45:47 <mclasen> anyway, I got one 'sounds useful' so far. I guess I'll collect the facts about other browsers and bring it up for vote next time ?
13:45:59 <stickster> mclasen: That seems fair
13:46:08 <mclasen> although next time is delayed
13:46:23 <juhp> Firefox works for me but I forget how
13:46:26 <stickster> Oh right, due to Flock. In the spirit of helping I'll file a ticket for it, though
13:46:38 <stickster> mclasen: ^ we could always just vote there if you update the ticket.
13:46:48 <mclasen> good point
13:47:01 <mclasen> I'll send mail when I update the ticket
13:47:36 <stickster> cool
13:47:57 <stickster> #action stickster file ticket for gnome-shell-chrome inclusion (or renamed package)
13:48:17 <mclasen> oh, one other thing to mention here
13:48:22 <stickster> #action mclasen gather info on how g-s-chrome works across browsers and bring to ticket for vote
13:48:26 <stickster> go for it
13:48:31 <mclasen> silverblue composes have been failing for ~ a  month now
13:48:49 <mclasen> kalev and dusty looked  a bit last week, and fixed one comps issue
13:49:00 <mclasen> but they're still failing
13:49:20 <stickster> mclasen: Where do compose problems get notified to?
13:49:26 <stickster> Or anyone ^
13:49:34 <mclasen> I find it very hard to find out any facts or logs in this area
13:49:39 <mclasen> basically impossible for me
13:50:13 <stickster> The last time we had problems like this, in the Atomic area, it turned out that (a) the logging was problematic, and (b) even with that fixed, the failures weren't being notified anywhere so no one could notice or take action.
13:50:20 <mclasen> https://pagure.io/teamsilverblue/issue/22
13:51:13 <juhp> Is/was the situation better for Atomic Host?
13:52:14 <stickster> juhp: it is. I believe dustymabe took some steps to have issues auto-filed when problems happen.
13:52:23 <stickster> (interestingly he's the person who filed issue #22 above) ;-)
13:53:47 <stickster> mclasen: So the first thing to do here seems like, make sure we know how to find logs on the failures
13:53:48 <juhp> Yep
13:54:09 <stickster> Second being, see if dustymabe could help us rig up notifications to the silverblue issue queue for failures
13:54:38 <juhp> That might be a lot of issues...
13:54:41 <mclasen> https://pagure.io/dusty/failed-composes/issue/580#comment-523684
13:54:51 <mclasen> yay, python and unicode
13:55:46 <stickster> Ah, there's also possibly a koji version issue.
13:55:55 <stickster> So who has point on this?
13:56:02 * stickster needs to run in 2 minutes for another meeting setup.
13:56:38 <stickster> Anyone other than mclasen from silverblue who could try to solve the notifications issue?
13:56:51 <stickster> I mean, unless people don't want to know when things are messed up, until they're emergencies ;-)
13:57:47 <stickster> OK, I need to close up here. I'll send email to the list to ask that question ;-)
13:57:55 <stickster> Thanks for coming, everyone.
13:57:57 <stickster> #endmeeting