releng
LOGS
17:00:25 <mboddu> #startmeeting RELENG (2018-04-26)
17:00:25 <zodbot> Meeting started Thu Apr 26 17:00:25 2018 UTC.  The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:25 <zodbot> The meeting name has been set to 'releng_(2018-04-26)'
17:00:25 <mboddu> #meetingname releng
17:00:25 <zodbot> The meeting name has been set to 'releng'
17:00:25 <mboddu> #chair dgilmore nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu Kellin dustymabe
17:00:25 <zodbot> Current chairs: Kellin dgilmore dustymabe masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
17:00:25 <mboddu> #topic init process
17:00:34 <nirik> morning
17:00:38 <Kellin> .hello kellin
17:00:38 <masta> howdy
17:00:38 <zodbot> Kellin: kellin 'Kellin' <kellin@retromud.org>
17:01:02 <mboddu> I thought no one will show up :)
17:01:05 <mattdm> hello!
17:01:23 <mboddu> Hey mattdm
17:01:27 <mattdm> mattdm: Matthew "ship it!" Miller <mattdm@fedoraproject.org>
17:02:24 <mboddu> mattdm: Uhhh, I guess you are looking for Go/No-Go meeting?
17:03:06 <mattdm> mboddu: oh, yes -- isn't that normally in this channel?
17:03:15 <nirik> it's in -1
17:03:32 <mboddu> mattdm: Nope, its in #fedora-meeting-1
17:03:33 <mattdm> oh! thanks mboddu, nirik :)
17:05:10 <mboddu> So, I have two things to discuss for today, are you guys okay with continuing or should we look at Go/No-Go?
17:05:35 <nirik> sure, go for it
17:06:11 <mboddu> Cool
17:06:28 <mboddu> #topic #7457 Modular repos are unavailable on Rawhide
17:06:34 <mboddu> #link https://pagure.io/releng/issue/7457
17:06:58 <mboddu> So, https://pagure.io/releng/issue/7457#comment-508268 is what I think, but do you guys know if there is any other easy way, before I implement it?
17:07:20 * Kellin loads that, sec
17:07:51 <nirik> hum... can't we get mirrormanager to s/29/rawhide/ and have the same one work there?
17:08:10 <nirik> ie, the changes we have made in mirrormanager should in theory allow us to drop the rawhide special repos.
17:09:15 <nirik> so, I'd propose we ask adrian if we can do that and see if that works?
17:10:00 <mboddu> nirik: Okay, again my knowledge of mirrormanager is affecting to think about the solutions including it
17:10:03 * mboddu sighs
17:10:13 <mboddu> nirik: Can you check with Adrian?
17:10:47 <nirik> so basically the issue is that we have '28' and 'rawhide'... but we can tell mirrormanager to see '29' and return the repos for rawhide for it.
17:10:51 <nirik> yes, I can
17:11:23 <Kellin> 'special rawhide repos'?
17:12:19 <nirik> yeah... we have fedora-updates, fedora and fedora-updates-testing... all for stable release.
17:12:29 <nirik> but we also have fedora-rawhide
17:12:45 <nirik> we can nuke that if we get mirrormanager to handle the numbers (and people don't want to use local links)
17:15:25 <mboddu> nirik: I understand the snowflake of rawhide, but I just dont know how mirrormanager works and it kinda makes me annoyed
17:15:36 <mboddu> nirik: Anyway, thanks for the info and the action :)
17:15:53 <nirik> added a comment
17:16:03 <mboddu> #action nirik will check with Adrian if it can be fixed by mirrormanager
17:16:05 <mboddu> nirik: Thanks
17:16:15 <mboddu> And the next topic is also related to mirrormanager
17:16:57 <mboddu> #topic #7445 [RFE][PATCH] make $releasever return "rawhide" on Rawhide
17:17:03 <mboddu> #link https://pagure.io/releng/issue/7445
17:17:32 <nirik> I saw this, but havent had a chance to really read it and think things thru.
17:17:56 <nirik> I don't think it's the right approach tho off hand
17:18:25 <mboddu> nirik: Okay, we can punt it for now
17:19:35 * mboddu did read it, kinda understood it, but dont have experience to clearly think it through
17:19:38 <Kellin> we have a raft of requests from this same person as well, mboddu we should sit down and talk through them and arrange a meeting
17:20:07 <Kellin> because I feel like it's a one-sided push to solve issues that are universal and need more universal process consideration
17:20:28 <nirik> sure, they are looking at it from a QA side... meeting up to discuss might be of help.
17:21:19 <Kellin> indeed.  I just don't like the thought of having this go around and around in pagure issues when a 30-45 minute sit down might cut through to the core needs
17:21:52 <nirik> well, the desire I think is to make rawhide more like stable releases... so their tools don't have to do exceptions.
17:21:58 <mboddu> Okay, I can schedule a meeting with nirik, Adam W, Kellin, K Paral and me. Am I missing anyone?
17:21:59 <nirik> which I think is a fine goal
17:22:20 <mboddu> nirik: It is a good thing to do, its just figuring it out "how" part
17:22:26 <nirik> try and make it a few weeks out tho? if we have release next week, etc
17:22:48 <mboddu> nirik: Yes, I am planning 2 weeks after the release(when ever it happens)
17:23:15 <nirik> sounds good to me.
17:23:54 <mboddu> #action mboddu will schedule a meeting with the QA, Infra and RelEng people to go over it
17:24:04 <mboddu> Thats all I got
17:24:17 <nirik> I have one thing
17:24:21 <nirik> hopefully quick...
17:24:23 <mboddu> #topic Open Floor
17:24:27 <mboddu> nirik: Sure
17:24:48 <nirik> Does anyone object to moving gpg keys to /usr/share? they are read only data that users shouldn't ever have to modify... this is https://bugzilla.redhat.com/show_bug.cgi?id=1565682
17:24:54 <nirik> and the person did a PR also.
17:25:05 <nirik> https://pagure.io/fedora-repos/pull-request/74
17:25:31 <mboddu> nirik: I think we should get internal involved as well
17:25:33 <nirik> or can you think of anything that would break?
17:25:39 <mboddu> Its sorta a big change
17:25:58 <nirik> ok. If you could bring in whoever you think...
17:26:06 * mboddu cant think of anything other updating dnf and other package related tools
17:26:33 <nirik> well, they shouldn't need updating... they get the path from repo file
17:26:42 <nirik> they read the gpgkey var
17:26:45 <mboddu> nirik: Yeah, right
17:26:57 <mboddu> from the .repo file
17:27:19 <Kellin> hmm, does this move them away from where other GPG keys would get stored by the user or other apps?
17:27:28 <mboddu> #action mboddu will look into this and talk to people around and see what will be affected if we change it
17:27:32 <Kellin> my only thing would be 'splitting it up'; I'm pretty sure PKI stuff all lives in /etc too
17:28:11 <nirik> Kellin: sure, but many of those would be user generated content... which they update when they get new keys, etc.
17:28:28 <nirik> these should never be changed by end users
17:29:14 <nirik> thats all I had.
17:29:24 <mboddu> nirik: Thanks
17:29:35 <mboddu> Anybody got anything else?
17:32:55 <Kellin> not me
17:33:35 <mboddu> Okay, thats all I got, this is a quick meeting
17:34:42 <mboddu> nirik: Oh, quick question, I changed my email to non RH email for mailing list, I can send emails to the mailing with the new email right away or does someone has to approve it or I have to wait until it get recognized?
17:35:09 <nirik> I would think right away
17:36:32 <mboddu> nirik: Okay, thanks for the info
17:36:34 <mboddu> Thats all
17:36:39 <mboddu> Thanks guys for joining
17:36:46 <mboddu> #endmeeting