workstation
LOGS
13:01:49 <kalev> #startmeeting Workstation WG
13:01:49 <zodbot> Meeting started Mon Apr  9 13:01:49 2018 UTC.  The chair is kalev. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:49 <zodbot> The meeting name has been set to 'workstation_wg'
13:01:57 <kalev> #meetingname workstation
13:01:57 <zodbot> The meeting name has been set to 'workstation'
13:02:08 <kalev> #topic Roll call
13:02:18 <kalev> who's around today?
13:02:25 * satellit listening
13:02:35 <juhp_> .hello petersen
13:02:35 <zodbot> juhp_: petersen 'Jens Petersen' <petersen@redhat.com>
13:03:47 <mclasen> .hello mclasen
13:03:48 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:04:11 <rdieter> .hello rdieter
13:04:12 <zodbot> rdieter: rdieter 'Rex Dieter' <rdieter@gmail.com>
13:04:44 <cschalle> .hello cschalle
13:04:45 <zodbot> cschalle: Sorry, but you don't exist
13:04:51 <kalev> alright, let's get started
13:05:05 <mcatanzaro> .hello catanzaro
13:05:06 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
13:05:12 <kalev> #chair juhp_ mclasen rdieter cschalle mcatanzaro
13:05:12 <zodbot> Current chairs: cschalle juhp_ kalev mcatanzaro mclasen rdieter
13:05:22 <kalev> #info Agenda link: https://pagure.io/fedora-workstation/issues?status=Open&tags=meeting
13:05:39 <kalev> we have a bunch of things that are somewhat urgent to discuss if we want them to land in F28
13:05:44 <mcatanzaro> Yup :(
13:05:46 <kalev> the F28 final freeze is next week
13:05:48 <kalev> #chair otaylor
13:05:48 <zodbot> Current chairs: cschalle juhp_ kalev mcatanzaro mclasen otaylor rdieter
13:06:02 <mcatanzaro> I have one last-minute point to go through *real quick*, before we start, if that's OK kalev
13:06:07 <kalev> I think the most urgent is the suspend issue that mcatanzaro filed
13:06:08 <kalev> sure
13:06:11 <otaylor> sorry to be late!
13:06:13 <otaylor> .hello otaylor
13:06:14 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
13:06:21 <kalev> no worries, we're just getting started
13:07:00 <kalev> mcatanzaro: what's the point?
13:07:06 <mcatanzaro> I tested the initial setup changes on a real install ISO yesterday and noticed that g-i-s blocks user account creation until you've selected a strong password, which is not in accordance with FESCo's decision on the matter from back in 2015. We probably don't want to reopen that debate.
13:07:21 <kalev> oh yes, I noticed that too, but forgot to flag it up
13:07:21 <mcatanzaro> I'm going to try to change it before final freeze, wish me luck. I assume that's uncontroversial.
13:07:38 <kalev> +1 for changing that, thanks mcatanzaro
13:07:40 <cschalle> +1
13:07:42 <mcatanzaro> At least I know mclasen really hates enforcing the strength check
13:07:58 <mcatanzaro> That's all I have to say on this.
13:08:02 * kalev nods.
13:08:22 <cschalle> on an unrelated note could someone explain what is that 'Disable build of Wayland packages' thing from 1564210
13:08:27 <kalev> #info We accidentally ended up enforcing password strength check in gnome-initial-setup. mcatanzaro to look into fixing that before F28 final freeze.
13:09:03 * mclasen tired of revisiting old topics, just do it...
13:09:05 <juhp_> .bug 1564210
13:09:06 <zodbot> juhp_: Bug 1564210 – 18.0.0-3.fc28 build causes llvmpipe fallback on GNOME (Wayland) - https://bugzilla.redhat.com/1564210
13:09:07 <kalev> cschalle: libwayland-egl library moved from mesa package to wayland package
13:09:15 <cschalle> ah ok
13:09:35 <kalev> and this is a fallout of an attempt to stop building wayland-egl as part of the mesa build
13:10:02 <kalev> I'll make sure we get a fix for that out today, it's on my radar
13:10:15 <kalev> #info kalev to make sure https://bugzilla.redhat.com/1564210 gets a fix today
13:10:20 <kalev> ok, let's move on to the agenda
13:10:25 <kalev> the most pressing one is this:
13:10:27 <cschalle> kalev, ok, saw kem also mentioning that he will get it looked at in another channel
13:10:41 <kalev> ah cool
13:10:45 <kalev> #topic Defer new auto-suspend behavior
13:10:49 <kalev> https://pagure.io/fedora-workstation/issue/42
13:11:11 <kalev> mcatanzaro: want to talk about this? I know that this ended up being discussed in a fesco ticket as well
13:11:44 <mcatanzaro> GNOME now suspends your computer after 20m of inactivity
13:12:00 <mcatanzaro> Seems like a good idea to me, but there are some implementation problems
13:12:24 <juhp_> I find the notifications in VMs quite annoying...
13:12:26 <mcatanzaro> We could discuss them all here, but to save time, the TL;DR version is that I want us to have another six months to iron this out. Can I disable the new behavior please. :P
13:12:35 <sgallagh> FYI, mclasen and I have a meeting in 45 minutes to discuss how to deal with the impact on Server so that this can be relegated back to only being a Workstation decision
13:12:47 <cschalle> just reading the problem description in the ticket it seems a little undercooked atm and should prolly wait until next release?
13:12:50 <mcatanzaro> VMs are another good case that actually has not come up yet... juhp_ please leave a comment in the issue so we don't forget.
13:12:52 <mclasen> err, isn't that in 105 minutes ?
13:13:03 <sgallagh> mclasen: Sorry, you're right
13:13:07 <juhp_> mcatanzaro: ok...
13:13:09 <sgallagh> Got my meetings mixed
13:13:18 <juhp_> A bug might be better
13:13:27 <kalev> I suggested in the fesco ticket to turn it off globally to limit impact on server, and then turn it on with a gsettings schema override in workstation if we so desire
13:13:57 <mclasen> I would like us to turn it on when on battery, at least
13:14:13 <mclasen> since servers are never on battery, that should take care of that ?
13:14:18 <mcatanzaro> "I would like us to turn it on when on battery" sounds like a great way to address most concerns, yes.
13:14:26 <mcatanzaro> I actually had not thought of that one yet.
13:14:31 <kalev> ah yes, that's a good solution
13:14:59 <mcatanzaro> My other concern was SSH to a workstation, which I don't want to break; checking for battery power will handle that.
13:15:01 <kalev> someone mentioned that Ubuntu changed the default, is this what they did? disable on non-battery and enable on battery?
13:15:13 <mcatanzaro> kalev: I think they just installed an override to disable it entirely.
13:15:17 <kalev> aha
13:15:23 <juhp_> mcatanzaro: done
13:15:39 <juhp_> mclasen: sounds good
13:15:49 <cschalle> +1 from me too
13:15:57 <mclasen> still some issues to sort through
13:16:11 <mcatanzaro> Anyway, I still want an override to disable it entirely for now because suspend inhibitors are really broken currently. I'll remove it once (a) suspend inhibitors are fixed (https://gitlab.gnome.org/GNOME/mutter/merge_requests/54) and (b) mclasen has wrangled someone to implement the check for battery power. Does that sound good?
13:16:23 <mcatanzaro> Actually that doesn't help VMs, can we check for that as well, somehow?
13:16:48 * mclasen really doesn't want to make this all complicated
13:16:51 <mcatanzaro> There are other broken cases too (e.g. multiseat) but that should be covered by the battery power check.
13:17:04 <sgallagh> If "only enabled on battery" is the decision of the Workstation WG, that's going to satisfy my concerns as well
13:17:18 <mclasen> if we can't convince ourselves that this is worth doing, just turn it off and ignore me
13:17:46 * mclasen tired of wading through gobs of corner cases and unintentended not-designed-for uses that always come up when a change is made
13:17:58 <kalev> mcatanzaro: so, is the suggestion to disable globally for F28 and enable only on battery for rawhide (F29+)?
13:18:54 <mcatanzaro> kalev: Yes. Enable it in rawhide after fixing (a) and (b) above, and (c) VMs. (VMs are important, doesn't seem like a corner case to me.)
13:19:15 <mcatanzaro> I think that should address *almost* everyone's complaints... people who don't like the new behavior should be able to just turn it off, then.
13:19:17 <mclasen> vms are somewhat important yes, I grant you that
13:19:24 <mclasen> but whats the problem with vms ? are they on battery ?
13:19:30 * otaylor would vote for only-on-battery
13:19:33 <kalev> proposal: Workstation WG discussed the new auto-suspend behaviour and decided to disable auto-suspend for F28. In rawhide (F29) we'll enable auto-suspend when battery powered only, and disable when plugged in.
13:19:33 <mcatanzaro> The main problem currently is that it's really hard to change the setting globally, for technical reasons.
13:19:48 <kalev> can WG members vote please?
13:19:52 <juhp_> mclasen: I was going to say - I guess VM are not on battery, right?
13:19:52 <mclasen> +1
13:19:53 <rdieter> +1
13:19:54 <kalev> +1
13:19:56 <mcatanzaro> mclasen: I guess if you check for only-on-battery, that should fix VMs too? If so, great, one less problem. :)
13:19:57 <mcatanzaro> +1
13:19:58 <juhp_> +1
13:19:59 <mclasen> mcatanzaro: there's no global setting
13:20:09 <otaylor> -1
13:20:13 <sgallagh> juhp_: Last I checked, even if the vm host is on battery, that doesn't pass down to the VM
13:20:32 <kalev> otaylor: anything to change in the proposal above to make you change your vote?
13:20:36 <mcatanzaro> otaylor: Can you explain your vote please?
13:21:04 <juhp_> sgallagh: right so VM should be taken care of, right
13:21:27 <otaylor> I think we should keep auto-suspsend enabled for battery. leaving it off for battery strikes me as dishonest
13:21:52 <juhp_> ah
13:21:55 <rdieter> otaylor: that's not implemented (yet) though (or correct me if I'm wrong)
13:22:20 <juhp_> Was that not the previous default?
13:22:53 <otaylor> rdieter: you can definitely configure it htat way through the gui, and I expect experienced users to do so
13:23:16 <rdieter> ok, at least one comment above implied there was some extra work to do
13:23:31 <otaylor> rdieter: I didn't know it wasn't the default because I configured it that way years ago...
13:23:41 <otaylor> (and went back to the default for the last few weeks and keep having a out-of-battery laptop...)
13:24:34 <kalev> I think we'll get some positive feedback from media (a'la fedora listens to user feedback) if we revert back and then try again for F29, but with a more limited scope (only when battery powered)
13:25:11 <juhp_> +1
13:25:18 <otaylor> rdieter: I think there are corner cases that worry people ... like your downloads can be interrupted. But they don't strike *me* as fundamental. Anyways, I'm -1 to disable globally, but we don't need to be unanimous
13:25:40 <kalev> ok, let's move on in this case :)
13:26:08 <kalev> #agreed: Workstation WG discussed the new auto-suspend behaviour and decided to disable auto-suspend for F28. In rawhide (F29) we'll enable auto-suspend when battery powered only, and disable when plugged in. (+1:5, 0:0, -1:1)
13:26:16 <kalev> mcatanzaro: do you want to implement the changes?
13:26:23 <mclasen> right, I would have voted -1 too if the default had actually been to autosuspend-on-battery, as we thought
13:26:32 * kalev nods.
13:26:44 <kalev> I would have voted -1 as well then :)
13:26:53 <mcatanzaro> I'll implement the change
13:27:07 <kalev> #action mcatanzaro to implement the auto-suspend behaviour changes
13:27:10 <kalev> thanks mcatanzaro!
13:27:15 <mcatanzaro> I think the fact that suspend inhibitors are currently broken is a fundamental problem in F28.
13:27:25 <kalev> ok, next up, fonts
13:27:36 <kalev> #topic Live image size increased due to change of CJK fonts
13:27:39 <kalev> https://pagure.io/fedora-workstation/issue/46
13:27:46 <kalev> juhp_: do you want to summarize this?
13:27:56 <juhp_> okay
13:27:56 <mcatanzaro> Please go quick, we're running out of time already. :)
13:28:01 <juhp_> hehe
13:28:05 <mclasen> mcatanzaro: just a bug
13:28:23 <juhp_> So we have changed the default fonts for CJK (Chinese, Japanese, Korean)
13:29:03 <juhp_> to Google Noto CJK fonts which have Sans, Serif and Mono faces in 7 weights
13:29:11 <juhp_> and they take up quite a bit of space
13:29:21 <juhp_> I put some numbers in the ticket
13:30:00 <juhp_> This came up on devel list recently and though most of the thread did not seem overworried about the size increase
13:30:20 <juhp_> But I thought it would be good to run it by the WG here to avoid any surprises later
13:30:42 * mclasen is not overworried about the size either
13:30:47 * kalev neither
13:31:11 <kalev> juhp_: what's your own opinion, should we change anything for F28?
13:31:19 <otaylor> I think we should have caught it earler, and I think it's a bit of a waste, but I don't think it's anything we need to turn on blinking red sirens for at this point of the process
13:31:22 <mclasen> its not a good trend, but going from 1.6G to 1.9 is not actively breaking anything
13:31:45 <juhp_> Note that the glibc locales sieze has also increased in F28 due to collation updates to Unicode 9
13:32:15 <mclasen> juhp_: thanks for collecting the data, anyway. useful
13:32:19 <mcatanzaro> I don't mind being larger than expected for one release, but I really don't want this to set a precedent that 1.9 GB is OK for F29... juhp_, you mentioned you had some plan to address the size increase for F29?
13:32:38 <juhp_> kalev: I am somewhat divided - as such I wish we had gone for the more compact but nicer .ttc fonts earlier on
13:33:05 <juhp_> mcatanzaro: right the combined CJK fonts will save considerable about of space
13:33:07 <mcatanzaro> I'd like to be sensitive to users who may have limited bandwidth or data caps, + .3 GB can be quite significant.
13:33:20 <juhp_> using OpenType Collection fonts
13:33:22 <kalev> juhp_: I'd be +1 to try to implement this for F28, if we can get it done this week so that it gets testing before the freezes next week
13:33:34 <kalev> and have time to revert back if things don't work out as expected
13:33:38 <mclasen> juhp_: do you think it is worth revisiting font packaging practises and rules in the light of such behemoth font collections ?
13:33:42 <juhp_> kalev: implementing is easy - testing not so much
13:33:58 <juhp_> mclasen: possibly
13:34:00 <mclasen> no need to pull a texlive, but some breaking-up might be useful and practical
13:34:20 <otaylor> I don't know if any global change is needed, just an agreement that this is an exception
13:34:31 <juhp_> mclasen: ah yeah I wanted to propose subpackaging as a workaround but Fonts Packaging Guidelines...
13:34:42 <otaylor> it clearly wasn't in the mental model of the people creating the guideline
13:35:00 <juhp_> if we only shipped the Regular fonts it would actually reduce the footprint
13:35:06 <otaylor> they were imaging splitting -bold off a 100kb latin font
13:35:12 <juhp_> right
13:35:37 <juhp_> 7 fonts variants is not terribly meaningful to most users and those that need them can install...
13:35:55 <juhp_> I was even planning to add langpack weak deps to pull them in
13:36:15 <juhp_> However dunno if we can get an exception...
13:36:34 * mclasen still thinks that fonts might be better off avoiding packages altogether, but thats not a topic for today
13:36:45 <otaylor> Hopefully with variant support, all 7 variants can just be autogenerated in the future... but for now, just having regular and bold and splitting the other 5 to an -extra-weights subpackage or something should be fine
13:37:06 <juhp_> Yeah I feel so, I made a test copr repo
13:37:33 <juhp_> We could propose it to the FPC and the Fonts SIG
13:38:08 <juhp_> Though I agree with nimnim that it is not totally ideal
13:38:26 <kalev> anyway, sorry to interrupt, but I think it would be good if we could get to discussing the proposed 3rd party repos that are on agenda -- do we have any proposals for the fonts for F28, or is it all F29 material at this point?
13:38:35 <juhp_> Basically there are 4 options
13:38:41 <juhp_> (1) do nothing
13:39:03 <juhp_> (2) switch to OTC (.ttc)
13:39:09 <juhp_> (3) revert
13:39:15 <juhp_> (4) subpackage
13:39:51 <juhp_> (4) seems to give bang per buck though it is a slight packaging hack
13:40:17 <kalev> which would you prefer?
13:40:45 <juhp_> Probably (1) or (4) at this point
13:40:53 <otaylor> I agree 2) is not last-minute f28 material - it's exercising new code paths very late in the process.
13:41:07 <juhp_> Let's try to see if subpackaging can be allowed?
13:41:08 * kalev nods.
13:41:13 <kalev> sure
13:41:15 <cschalle> +1
13:41:19 <kalev> +1
13:41:56 <juhp_> I will follow up on the mailing lists then
13:41:59 <otaylor> +1 - I would suggest approaching the fonts sig with this as an exception rather than a change in the rules, and I don't think it actually needs to go to the fpc
13:42:05 * kalev nods.
13:42:07 <juhp_> otaylor: okay
13:42:07 <mcatanzaro> +0 from me... it sounds like (2) is the plan for F29 at that seems realistic, so I would just revert the change until that's ready.
13:42:34 <juhp_> True reverting is also an option
13:43:11 <kalev> so maybe try subpackaging first, and then revert for F28 if that doesn't work out?
13:43:15 <juhp_> Though it touches quite a few fonts but can be done (fontconfig priorities)
13:43:33 <juhp_> Okay we could I guess
13:43:34 <kalev> proposal: #agreed juhp_ to investigate if we can improve the situation for F28 by subpackaging, and if it doesn't work out, revert to F27 fonts
13:43:58 <juhp_> This also affects KDE, other spins etc
13:44:24 * juhp_ notes there is a proposed blocker for KDE Spin size
13:44:53 <mclasen> +1
13:44:58 <kalev> +1 to propsal above
13:45:04 <cschalle> +1
13:45:09 <juhp_> +1
13:45:11 <rdieter> +1
13:45:12 <otaylor> +1
13:45:23 <kalev> proposal: #agreed juhp_ to investigate if we can improve the situation for F28 by subpackaging, and if it doesn't work out, revert to F27 fonts (+1:6, 0:0, -1:0)
13:45:27 <kalev> ok, let's move on
13:45:41 <kalev> next, we have a bunch of 3rd party software tickets
13:45:54 <kalev> #topic 3rd party repository discussion
13:46:05 <kalev> cschalle: do you want to lead this?
13:46:18 <cschalle> sure
13:46:18 <kalev> we have 4 tickets in https://pagure.io/fedora-workstation/issues?status=Open&tags=meeting
13:46:45 <kalev> oh wait, forgot to #agree above
13:46:46 <kalev> #undo
13:46:46 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1d80ffd0>
13:46:53 <kalev> #agreed juhp_ to investigate if we can improve the situation for F28 by subpackaging, and if it doesn't work out, revert to F27 fonts (+1:6, 0:0, -1:0)
13:46:56 <kalev> #topic 3rd party repository discussion
13:46:58 <kalev> ok, go now :)
13:47:23 <cschalle> so as discussed last week rpmfusion did the work to split out a separate nvidia and steam repository for us. I also spoke with Simone of Negativo and he was fine with us going with the romfusion ones too
13:47:49 <cschalle> so I suggest we hammer through adopting these two rpmfusion repos and thus officially launch 3rd party software in Fedora
13:48:33 <kalev> fine with me. can we get these in this week? otherwise we'll miss F28 GA
13:48:41 <otaylor> cschalle: are they at a similar level for technical parts of packaging? whatever hans was working on with simone?
13:48:59 <cschalle> otaylor, yeah, their are more or less the same, based on the work Hans originally did
13:49:16 <cschalle> kalev, I think so, mlcasen can you get them added to the workstation-repos package?
13:49:28 <kwizart> otaylor, hans, simone and others were working with rpmfusion
13:51:15 <mcatanzaro> I've closed the two Negativo tickets just now, since it sounds like we all agree RPMFusion is the way to go (right?)
13:51:41 <rdieter> right
13:52:18 <mcatanzaro> #info I (mcatanzaro) am +1 to adding these, though I want to register my concern that Software isn't doing very much right now to educate users about the benefits of free software. I think we could be doing that in a way that's not overly annoying or preachy.
13:53:13 * mclasen is going to be annoyed at anything that puts philosophy in the ui
13:54:15 <kalev> if there's any concrete suggestions, then run them past aday please and if he agrees, I'm happy to help implement things for gnome-software 3.30
13:54:52 <mclasen> do we need to vote on this ? or do kalev and I just go and see about adding those 2 to the -repositories package ?
13:55:05 <kalev> let's vote, I think it's a big enough change that we need some legalese
13:55:09 <rdieter> +1
13:55:15 <juhp_> +1
13:55:16 <kalev> hold on, writing proposal
13:55:27 <rdieter> +1 to whatever kalev writes :)
13:55:37 <mclasen> +1
13:55:52 <cschalle> +1
13:55:55 <kalev> proposal: #agreed Workstation WG agrees to add Steam from RPM Fusion, and NVIDIA driver from RPM Fusion as 3rd party repositories
13:56:04 <kalev> +1
13:56:35 <otaylor> +1
13:56:46 <juhp_> +1
13:56:58 <rdieter> +1
13:57:19 <kalev> #agreed Workstation WG agrees to add Steam from RPM Fusion, and NVIDIA driver from RPM Fusion as 3rd party repositories (+1:7, 0:0, -1:0)
13:57:43 <kalev> #action mclasen and kalev to implement fedora-workstation-repositories changes, and update https://fedoraproject.org/wiki/Workstation/Third_Party_Software_Repositories wiki page
13:57:52 <kalev> ok, that's it from the agenda!
13:57:55 <kalev> #topic Open Floor
13:58:03 <kalev> anyone have anything to discuss?
13:58:27 <kalev> let me see who's up for chair duty next time
13:58:38 <satellit> f28 g-i-s does not allow root password ?
13:58:45 <mclasen> I have one thing lets see if I can find a link quickly
13:58:51 <juhp_> Probably no time now but I want to mention https://pagure.io/fedora-workstation/issue/27
13:59:12 <mclasen> https://pagure.io/fedora-atomic-workstation/issue/13
13:59:16 <kalev> * Monday Apr 23 - Ryan Lerch according to an email I found on desktop list
13:59:45 <mclasen> do we want to add a link to the atomic workstation iso on the download page ?
13:59:51 <kalev> I think I should be able to step in as a backup if he doesn't have time, I know rlerch hasn't been attending the meetings regularly these days
14:00:04 <mclasen> maybe that needs a paragraph of text though, to explain what it is and why you may or may not want to try it
14:00:52 <cschalle> I don't object to advertising the atomic workstation, but yeah I do think we need to provide some context for it as it is not a drop in replacement (yet)
14:01:49 <juhp_> Yeah
14:01:53 * kalev doesn't have strong opinions either way, but if we advertise it, it should have some good warnings so that unsuspecting users wouldn't get it and then complain that they can't install anything
14:02:04 <juhp_> Maybe in the sidebar?
14:02:15 <juhp_> or down below
14:03:09 <mclasen> I'll see if I can draft a text. if we don't get it in there for ga, I'll just write a blog post with the url...
14:04:14 <kalev> that may actually be a better option, as people who read our blogs are more likely to be the target users right now
14:05:02 <kalev> or putting it in the side bar with a good text explaining what it is sounds good too :)
14:05:08 <kalev> anyway, we're over time now
14:05:12 <kalev> thanks for coming everybody!
14:05:16 <kalev> #endmeeting