commops
LOGS
15:33:46 <jwf> #startmeeting Fedora CommOps (2017-11-06)
15:33:46 <zodbot> Meeting started Mon Nov  6 15:33:46 2017 UTC.  The chair is jwf. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:33:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:33:46 <zodbot> The meeting name has been set to 'fedora_commops_(2017-11-06)'
15:33:53 <jwf> #meetingname commops
15:33:53 <zodbot> The meeting name has been set to 'commops'
15:33:58 <jwf> #nick commops
15:34:03 <jwf> #topic Agenda
15:34:08 <jwf> #link https://infinote.fedoraproject.org/cgit/infinote/tree/meeting-templates/fedora-commops-meeting-next
15:34:14 <jwf> #info (1) Roll call / Q&A
15:34:18 <jwf> #info (2) Announcements
15:34:24 <jwf> #info (3) Action items from last meeting
15:34:30 <jwf> #info (4) Tickets
15:34:34 <jwf> #info (5) Open floor
15:34:42 <jwf> The agenda is a little dated because my editor is broken in F27
15:34:47 <jwf> So I can't edit it :P
15:34:51 <jwf> #topic Roll call / Q&A
15:34:57 <jwf> #info Name; Timezone; Sub-projects/Interest Areas
15:35:02 <jwf> #action commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
15:35:07 <jwf> If this is your first time at a CommOps meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
15:35:34 <bt0> .hello bt0dotninja
15:35:35 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
15:35:38 <bt0> #info Alberto Rodriguez S; UTC-5;CommOps (Metrics, Community engagement), DotNet (Testing), Infrastructure(Apprentice), Marketing (Member)
15:35:41 <jwf> #info Justin W. Flory (jflory7 / jwf); UTC-5; CommOps, Diversity, sysadmin-badges
15:36:09 * jwf waves to bt0
15:36:09 <bt0> hello o/
15:36:16 * Rhea waves
15:36:19 <jwf> Let's see who else we have for today
15:36:23 * jwf waves to Rhea
15:36:25 <jwf> #chair bt0 Rhea
15:36:25 <zodbot> Current chairs: Rhea bt0 jwf
15:38:07 * jwf thinks the tickets marked with `meeting` tag is accurate…
15:38:20 <jwf> We'll wait two more minutes and then start at 15:40 UTC
15:38:45 * jwf hopes skamath will be here for #114
15:40:01 <jwf> #topic Announcements
15:40:18 <jwf> #info === "What I have found interesting in Fedora during the week 44 of 2017" ===
15:40:23 <jwf> #link https://communityblog.fedoraproject.org/found-interesting-fedora-week-44-2017/
15:40:49 <jwf> #info Fedora 27 is still no-go, autumn elections in progress, new i686 SIG formed to deal with i686 issues
15:41:05 <jwf> #info === "Fedora Classroom Session: Fedora QA 101" ===
15:41:11 <jwf> #link https://fedoramagazine.org/fedora-classroom-session-fedora-qa-101/
15:41:34 <jwf> #info Fedora Classroom session tomorrow on Nov. 7th, 15:00 UTC, led by sumantrom[m]!
15:41:51 <jwf> sumantrom++ Looking forward to hearing about the classroom :)
15:41:52 <zodbot> jwf: Karma for sumantrom changed to 4 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:42:19 <jwf> #info === New comments about Grimoire Lab from a lead developer of Grimoire ===
15:42:21 <jwf> #link https://communityblog.fedoraproject.org/metrics-docs-flock-2017/#comment-5858
15:42:39 <jwf> More food for thought on the Grimoire vs. Grafana discussion… we can cover this deeper during the ticket discussion
15:42:46 <jwf> Any other announcements to share? Rhea bt0 x3mboy
15:43:01 <bt0> nope
15:43:04 <x3mboy> Nope
15:43:10 <jwf> Going once…
15:43:15 <jwf> Going twice…
15:43:20 <jwf> Going thrice…
15:43:26 <jwf> #topic Action items from last meeting
15:43:32 <jwf> Ah, give me a moment to dig thatup
15:43:36 <jwf> s/thatup/that up
15:44:04 <jwf> #link https://meetbot.fedoraproject.org/teams/commops/commops.2017-10-30-14.29.html
15:44:12 <sumantrom[m]> jwf: Also coremodule is my partner in crime for Fedora QA classroom :)
15:44:18 <sumantrom[m]> coremodule++
15:44:21 <jwf> coremodule++ for the support :)
15:44:21 <zodbot> jwf: Karma for coremodule changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:44:37 <jwf> sumantrom[m]: Might help to map the Matrix nick to your FAS for giving and receiving karma. :)
15:44:42 <bt0> coremodule++
15:44:43 <zodbot> bt0: Karma for coremodule changed to 2 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:44:55 <jwf> #info === [INCOMPLETE] "jwf Follow up with sayan about Fedora Badges related to Fedora Infrastructure (i.e. fedora-badges #434, #441, #442); update Infrastructure on-boarding ticket once new info is available" ===
15:45:01 <jwf> #action jwf Follow up with sayan about Fedora Badges related to Fedora Infrastructure (i.e. fedora-badges #434, #441, #442); update Infrastructure on-boarding ticket once new info is available
15:45:11 <jwf> #info === "bt0 work on Issue #48 and break the information into smaller actions for Marketing team, file tickets and/or contact Marketing team about it" ===
15:45:14 <jwf> bt0: Any updates there?
15:45:23 <bt0> no :(
15:45:30 <bt0> incomplete
15:45:36 <jwf> Okay, no problem. You just came back from a pretty busy trip. :) We'll re-action.
15:45:39 <jwf> #action bt0 work on Issue #48 and break the information into smaller actions for Marketing team, file tickets and/or contact Marketing team about it
15:45:50 <jwf> #info === "bee2502 open a new ticket for F27 Release party badge" ===
15:46:13 * jwf is scrolling through the Badges issue tracker
15:46:39 <jwf> Oh, sweet, it's already ready to be pushed!
15:46:40 <jwf> #undo
15:46:40 <zodbot> Removing item from minutes: INFO by jwf at 15:45:50 : === "bee2502 open a new ticket for F27 Release party badge" ===
15:46:46 <jwf> #info === [COMPLETE] "bee2502 open a new ticket for F27 Release party badge" ===
15:46:48 <jwf> #link https://pagure.io/Fedora-Badges/issue/573
15:47:03 <jwf> #action jwf Push badge ticket #573 (https://pagure.io/Fedora-Badges/issue/573)
15:47:08 <jwf> bee2502++
15:47:25 <jwf> #info === [COMPLETE] "bexelbie Initialize the Asciidoc environment in the Fedora CommOps repo" ===
15:47:38 <jwf> #link https://pagure.io/fedora-commops/pull-request/126
15:47:51 <jwf> bexelbie did the initial work, now I need to dive deeper into this. :)
15:48:19 <jwf> #info === [INCOMPLETE] "skamath file a RFE ticket against the Elections app for badge support" ===
15:48:24 <jwf> #nick skamath
15:48:26 <jwf> #action skamath file a RFE ticket against the Elections app for badge support
15:48:50 <jwf> #info === "x3mboy Set up Fedocal events for the upcoming F27 election cycle, set up automatic reminders for mailing lists mentioned in ticket #107 (due:2017-11-06)" ===
15:48:54 <jwf> x3mboy: Any updates here/
15:48:56 <jwf> *?
15:50:16 * jwf is digging into Fedocal
15:50:49 <jwf> I think it's yet to be done, so I'll re-action it for now
15:50:58 <x3mboy> jwf, Yes
15:51:14 <jwf> #action x3mboy Set up Fedocal events for the upcoming F27 election cycle, set up automatic reminders for mailing lists mentioned in ticket #107 (https://apps.fedoraproject.org/calendar/commops/)
15:51:27 <x3mboy> jwf since there is no date yet to the F27 release, the date for election is not fixed
15:51:59 <jwf> x3mboy: Oh, I see, that's good to know. Feel free to only file some of them for now, and we can keep this on the action item list for follow-up until the end of the cycle.
15:52:12 <jwf> #info === [INCOMPLETE] "skamath Add comment to ticket #114 about possible blocker with Grimoire / Kibiter" ===
15:52:19 <jwf> #action skamath Add comment to ticket #114 about possible blocker with Grimoire / Kibiter
15:52:37 <jwf> #info === [INCOMPLETE] "jwf Research and compare pros / cons between Grafana and Grimoire Labs, add overview comparison to ticket #114" ===
15:52:41 <jwf> #action jwf Research and compare pros / cons between Grafana and Grimoire Labs, add overview comparison to ticket #114
15:52:50 <jwf> #info === [COMPLETE] "jwf Outline CommOps Mindshare seat nomination process in ticket #120" ===
15:52:58 <jwf> #link https://pagure.io/fedora-commops/issue/120#comment-475785
15:53:03 <jwf> ^ will have time to discuss soon!
15:53:17 <jwf> #info === [INCOMPLETE] "jwf Review inactive CommOps FAS group members, send personalized emails to inactive accounts, remove from FAS group" ===
15:53:23 <jwf> #action jwf Review inactive CommOps FAS group members, send personalized emails to inactive accounts, remove from FAS group
15:53:30 <jwf> I actually think I will try to do this today
15:53:37 <jwf> <eof>
15:54:03 <jwf> That's all the action items from last week! I think this time of the year is a busy time for a lot of folks, and I know some people are also going through some major life changes, so I anticipated some of the slowness.
15:54:18 <jwf> My schedule was a little hectic, but I cleared some major time over the weekend and have a little more Fedora time. :)
15:54:24 <jwf> #topic Tickets
15:54:27 <jwf> #link https://pagure.io/fedora-commops/issues?tags=meeting
15:54:33 <jwf> #info === Ticket #114: "Use GrimoireLab tools to centralize metrics" ===
15:54:38 <jwf> #link https://pagure.io/fedora-commops/issue/114
15:55:02 <jwf> I'm going to take a sec to read both of the new comments here from the Grimoire Labs maintainer: https://communityblog.fedoraproject.org/metrics-docs-flock-2017/#comment-5858
15:57:28 <jwf> Without skamath or bexelbie here, it's tough for me to figure out where to jump in here. I'm due for a comparison between our two options, so that's blocking this ticket
15:57:53 <jwf> I may reach out to this guy who commented on our blog post and ask him for advice in our situation too, to see if Grimoire is still a good fit.
15:58:09 <jwf> Since I'm previously actioned for that, I'll work through this in the next week.
15:58:16 * bexelbie is lurking
15:58:18 <jwf> Anyone else have anything to add here, or questions they want to ask?
15:58:42 <jwf> bexelbie: tl;dr, a lead developer of Grimoire Labs commented on our CommBlog article and left some feedback / other thoughts
15:58:54 <bexelbie> There is a Grimoire con around FOSDEM if we want to look at getting someone to it
15:58:55 * bexelbie reads
15:59:01 <jwf> It's an interesting perspective, so I'm going to try driving forward on building the comparison
15:59:06 <jwf> bexelbie: …oh! That's convenient.
15:59:12 <jwf> bexelbie: Can you drop a #link for that?
15:59:22 <Rhea> I've no ide what's either about so no.
15:59:31 <Rhea> idea*
16:00:00 <jwf> No what?
16:00:16 <bexelbie> sure ... let me find one
16:00:44 <jwf> Rhea: Grimoire Labs and Grafana are both metrics dashboards that let you create visualizations, graphs, charts, etc. with different metrics. In our case, we were looking at tying our PostgreSQL back-end with fedmsg into one of these dashboards.
16:01:00 <jwf> With that, the ultimate goal is to make the fedmsg data more accessible.
16:01:11 <bexelbie> #link https://grimoirelab.github.io/con/
16:01:12 <jwf> Rhea: It's explained more in depth here. https://communityblog.fedoraproject.org/metrics-docs-flock-2017/
16:01:18 * jwf clicks
16:01:25 <bexelbie> I have had some short conversation with the CHAOSS folks
16:01:43 <bt0> I don't have much experience in these subjects but I can also try to compare
16:01:44 <bexelbie> I still believe that picking a tool (any tool) and figuring out what our next step for metrics would be nice
16:01:55 <bexelbie> this comes back to who wants to help :)
16:02:03 <jwf> Hah, amazing… will have to keep that date in mind with our FAD planning
16:02:26 <jwf> bexelbie: True, but I also want to spend some time doing a basic comparison of our options before jumping in, to prevent a lot of wasted work if we hit a major blocker
16:02:42 <jwf> I don't anticipate this being a difficult process, but it's time-consuming
16:02:46 <bexelbie> yes
16:02:47 <jwf> And someone needs to do it
16:02:50 * jwf looks at feet :D
16:03:01 <jwf> So, I'll put some more focus into this task for the coming week
16:03:06 <bexelbie> +1
16:03:09 <jwf> So we can spend less time on tooling, more time on doing
16:03:26 <bt0> jwf++ :P
16:03:45 <jwf> #info Grimoire's annual conference is conveniently near FOSDEM, so something to consider for choosing FAD dates / location
16:04:22 <jwf> #info #114 is blocked by research into tooling. We need a basic comparison between Grimoire and Grafana to establish our requirements and desires for a platform. jwf is working on research between the two and will have more in the ticket by next meeting.
16:04:57 <jwf> bt0: I think I can do the research here, but especially since your experience is less here, your feedback will be valuable once I have the comparisons. :)
16:05:03 <jwf> And feel free to poke around too, if you'd like
16:05:12 <bt0> ok :)
16:05:14 <jwf> These metrics dashboards are a lot of fun, once you start to play around with them
16:05:33 * jwf has a really cool Grafana dashboard that visualizes performance of his personal infrastructure
16:05:42 <jwf> Anyways, I think I got all of the important details in #info
16:05:45 <jwf> Next ticket…
16:05:52 <jwf> #info === Ticket #120: "Elect a CommOps Mindshare representative" ===
16:05:56 <jwf> #link https://pagure.io/fedora-commops/issue/120
16:06:17 <jwf> There's a short proposal of what the election process looks like in the ticket.
16:06:31 <jwf> I'm curious to know what the rest of you all think about it. +1/0/-1??
16:06:46 <jwf> Mostly the last bullet is the one that needs thought
16:06:51 <jwf> "If two candidates for seat, and one has just served for two terms, the incumbent is not eligible to run again"
16:06:59 <jwf> Not sure if that's a helpful thing or just makes things more complicated
16:07:08 <jwf> So… curious to know what you all think on the outlined process in the ticket
16:08:03 <bt0> +1
16:08:57 <jwf> #chair
16:08:57 <zodbot> Current chairs: Rhea bt0 jwf
16:09:00 <jwf> ^^
16:09:08 <jwf> #chair bexelbie
16:09:08 <zodbot> Current chairs: Rhea bexelbie bt0 jwf
16:09:39 * bexelbie has no opinoin on how CommOps wishes to select their rep
16:10:11 <jwf> bexelbie: I was mostly curious about if the last bullet is something that isn't sustainable / over-complicates the process
16:10:19 <jwf> But maybe I'm overthinking it and it's fine
16:10:27 * bexelbie reads
16:10:54 <jwf> Since we're short a few core members, I can ping some others to add a vote in the ticket too, but I can mark everyone in attendance as agreeing to the process
16:11:04 <bexelbie> the only two terms - sounds like a complication to solve a problem we don't have
16:11:19 <jwf> bexelbie: Okay, great, that was the feedback I was looking for…
16:11:38 <jwf> If anyone else thought that, I think it would fair to scratch that line
16:11:58 <jwf> * would be fair
16:12:14 <jwf> So, I can update the proposed process in the ticket and we can finalize that
16:12:52 <bt0> it's ok for me
16:13:06 <jwf> #agreed Proposed process for selecting CommOps Mindshare representative is good with one modification, removing the incumbent requirement; jwf will document and finalize this change in CommOps internal docs
16:13:24 <jwf> #action jwf Document process in upcoming internal docs writing
16:13:43 <jwf> On another note, is there anyone here that's interested in actually running for this seat?
16:14:05 * jwf was interested, but wanted to see if anyone else was too
16:15:15 <jwf> It'll probably be good for putting this out in the ticket, but I'll formally volunteer as a candidate, and we can give it another week for anyone else to decide to step up
16:15:26 * jwf is fine with someone else doing this too, if they're passionate for it :D
16:15:44 <jwf> #info jwf volunteers for CommOps Mindshare seat, will wait a week for others to volunteer in ticket
16:15:52 <bt0> that soundsIt sounds like something very serious, maybe later when I have more experience on Fedora :P
16:16:09 <jwf> bt0: Don't underestimate your own merit either. :D You've done quite a lot already, sir!
16:16:17 <jwf> Anyways, anything else for this ticket?
16:16:25 <jwf> Going once…
16:16:35 <jwf> Going twice…
16:16:40 <jwf> Going thrice…
16:16:47 <jwf> #info === Ticket #125: "[TRACKER TICKET] Organize a CommOps FAD" ===
16:16:54 <jwf> #link https://pagure.io/fedora-commops/issue/125
16:17:24 <jwf> Hmm, still marked as a meeting ticket, but I haven't had a chance to actually do work here
16:17:46 <jwf> This is something that will definitely require a team effort, but I think it needs more clear steps of how the organizing work is split up
16:18:15 <jwf> Like I know it will be helpful to have someone help with budgeting out the venue and others for helping come up with goals for the FAD too (and then lining up work to accomplish those goals)
16:18:40 <jwf> It sort of feels like this is blocking on me, so I'm inclined to skip and move on. Not sure if anyone else had thoughts they wanted to throw out here now?
16:19:01 <x3mboy> FAD or vFAD?
16:19:15 <jwf> #action jwf With FAD proposal, create a proposal draft and come up with new sub-tasks to divide and conquer among team members
16:19:15 <x3mboy> Can we change a FAD for a Hack Day like we did before?
16:19:19 <jwf> x3mboy: FAD. :)
16:19:48 <jwf> x3mboy: Well, that's actually something I'd like to start up too! Like the video / hack calls?
16:19:58 <x3mboy> jwf, yes
16:20:04 <x3mboy> That was awesome
16:20:12 <jwf> Good idea… let's actually cover this at open floor. :D
16:20:14 <x3mboy> We did a lot of job and was just a viedo call
16:20:24 <jwf> Which maybe we can jump to now, since I think there's not much to say on this ticket.
16:20:27 <jwf> #topic Open floor
16:20:35 <jwf> #info === Setting up hack sessions again! ===
16:20:45 <jwf> #link https://fedoraproject.org/wiki/Hack_session
16:21:00 <x3mboy> Yeah!!!
16:21:14 <jwf> I'd like to put this on the calendar, maybe even right now. :) I don't think it makes sense to block on people's calendars, since we can just change the days of the week to organize the hack session
16:21:29 <jwf> Oh, or, let me go look back at the WhenIsGood we used for the meeting time.
16:21:32 * jwf goes back to dih
16:21:36 <bt0> super
16:21:37 <jwf> s/dih/dig
16:23:22 <jwf> lol, I think skamath made the last one. I'm only finding ones from 2015
16:23:31 <jwf> So, we can pick a new time npw
16:23:33 <jwf> * now
16:23:56 <jwf> So… anyone have a preference for Mondays? :)
16:24:13 <jwf> 15:00 EDT == 20:00 UTC is a good time on Mondays for me.
16:24:30 <x3mboy> I can do it any day from Mon to Fri
16:24:37 <bt0> mondays and fridays are fine for me
16:24:38 <x3mboy> Weekends are too busy for my
16:25:20 <jwf> No worries, sometimes it's also good to take a break and spend time with family / friends :)
16:25:27 <jwf> So, seems with the folks here, Monday works well.
16:25:35 <jwf> I'm going to plug this into Fedocal **right now**
16:25:42 <x3mboy> Cool!
16:25:45 <jwf> We can always adjust the time later if we get more feedback
16:25:49 <jwf> Anyone opposed to starting this today?
16:27:02 <bt0> no problem
16:27:36 * jwf is plugging it in now :)
16:29:05 <jwf> #link https://apps.fedoraproject.org/calendar/meeting/8636/
16:29:08 <jwf> Bam!
16:29:35 <bt0> cool
16:29:40 <jwf> #info Hack sessions are back on the calendar, once a week, for a two hour block - attending for a part is welcome, it's meant to be come-and-go for working on CommOps tasks :)
16:29:49 <jwf> On that note, that's all I have for today's meeting.
16:29:54 <jwf> Anyone else have anything for open floor?
16:30:01 <bt0> no from me
16:30:05 <jwf> x3mboy++ Thanks for reminding about those, I've been meaning to get those on the agenda forever!!
16:30:10 <jwf> I always seem to forget
16:30:15 <bt0> x3mboy++
16:30:31 <jwf> Okay, meeting for today, going once…
16:30:40 <jwf> Going twice…
16:30:45 <Rhea> hmm
16:30:50 <jwf> Going thrice…
16:31:03 <jwf> Thanks all for coming out! :D bt0++ x3mboy++ Rhea++ bexelbie++
16:31:04 <zodbot> jwf: Karma for rhea changed to 12 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:31:06 <jwf> #endmeeting