workstation
LOGS
13:00:59 <stickster> #startmeeting Workstation WG
13:00:59 <zodbot> Meeting started Mon Aug 14 13:00:59 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:59 <zodbot> The meeting name has been set to 'workstation_wg'
13:01:02 <stickster> #meetingname workstation
13:01:02 <zodbot> The meeting name has been set to 'workstation'
13:01:04 <stickster> #topic Roll call
13:01:06 <stickster> .hello pfrields
13:01:07 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:01:26 <ryanlerch> .hello ryanlerch
13:01:28 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:01:49 <kalev> .hello kalev
13:01:50 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
13:02:23 <mcatanzaro> .hello catanzaro
13:02:24 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
13:02:39 <mclasen> .hello mclasen
13:02:40 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:02:56 <stickster> #chair ryanlerch kalev mcatanzaro mclasen
13:02:56 <zodbot> Current chairs: kalev mcatanzaro mclasen ryanlerch stickster
13:03:15 <mclasen> no sign of cschaller here
13:03:49 <stickster> *nod
13:03:57 <stickster> well, either he'll make it or he won't, I guess
13:04:13 <stickster> #info Agenda uses issues list
13:04:15 <stickster> #link https://pagure.io/fedora-workstation/issues?status=Open&tags=meeting
13:04:37 <mcatanzaro> Mine is the only issue?
13:04:39 <stickster> #topic Add new GNOME core apps
13:04:41 <mcatanzaro> Nobody else has issues?
13:04:41 <stickster> #link https://pagure.io/fedora-workstation/issue/25
13:04:55 <stickster> we'll have some open floor after this where we can hit anything missed
13:05:09 <stickster> I have a topic myself
13:05:51 <mcatanzaro> So I'll split this proposal in two. First should be uncontroversial: I want to add gnome-todo and simple-scan to the default install. We actually agreed a while back that I can do this without coming back here for permission, since they are new GNOME apps, but I figure it never hurts to ask.
13:05:56 <mcatanzaro> *new core apps
13:06:06 <stickster> mcatanzaro: So IIUC from the ticket, Music and Simple Scan are the ones that would be added, correct?
13:06:18 <stickster> sorry, and ToDO
13:06:31 <mcatanzaro> To Do, Music, and Simple Scan. Music is the second part of the proposal. That one we previously had some reservations about.
13:06:36 <mcatanzaro> The goal is to replace Rhythmbox with Music
13:06:51 * ryanlerch is surprised that simple scan was not already default
13:06:59 <kalev> for what it's worth, I think we should always discuss before adding new top level apps
13:07:01 * stickster too, I've been using that for years
13:07:02 <mcatanzaro> ryanlerch: It was several years ago
13:07:33 <mcatanzaro> I think it was removed... to save space in the image? Don't remember for sure why. Anyway we don't have a hard size constraint anymore.
13:07:41 <juhp> hi
13:07:43 <juhp> sorry I am late
13:07:47 <mcatanzaro> Hi juhp!
13:07:59 <mclasen> mcatanzaro: I haven't looked at simple-scan recently - did it actually get the facelift that Allan worked on ?
13:08:02 <mcatanzaro> We are discussing whether to add To Do, Music, and Simple Scan as default apps.
13:08:27 <stickster> #chair juhp
13:08:28 <zodbot> Current chairs: juhp kalev mcatanzaro mclasen ryanlerch stickster
13:08:34 <mcatanzaro> mclasen: I don't think so, but it already got a GNOME 3 facelift a couple years back, so I don't think we need to block on that.
13:08:42 <mcatanzaro> It lets you scan things. ;)
13:09:36 <ryanlerch> mclasen: yeah, it def looks like aday has been involved with it
13:09:45 * ryanlerch used it this morning
13:09:55 * stickster is solid +1 on ToDo and Scan, haven't looked at Music in a while though
13:10:09 <kalev> I think I'd like to ask Allan for guidance if we should install these in the default install. With gnome-software search provider being enabled, we don't really need to install all of the world's apps by default.
13:10:42 <mclasen> there was a bunch of redesign-related commits in simple-scan this cycle
13:10:57 <mclasen> so, hopefully in good shape
13:11:13 <mcatanzaro> mclasen: I really don't know. We decided to move it to core before Allan came out with the redesign.
13:11:34 <mcatanzaro> Right after Ubuntu announced they were switching to gnome-shell, I asked Robert if he'd be interested in moving to GNOME infrastructure... and he was.
13:12:15 * kalev asked aday to join here.
13:12:25 <ryanlerch> to me, these three are useful apps to have installed in a default image -- not just available via a download
13:12:36 <mcatanzaro> kalev: If you're curious about future plans you should look at the last paragraph of https://blogs.gnome.org/mcatanzaro/2017/08/13/gnome-3-26-core-applications/. We're not planning to add many more applications besides Credentials... at least not without removing some.
13:12:53 <ryanlerch> not sure how many people use workstation without a (or good) internet connection
13:13:00 <kalev> aday[m]: hey, thanks for joining
13:13:06 <aday[m]> np
13:13:12 <mclasen> http://imgur.com/a/bCUok
13:13:21 <mcatanzaro> #link https://blogs.gnome.org/mcatanzaro/2017/08/13/gnome-3-26-core-applications/
13:13:49 <aday[m]> mclasen: i need to speak to robert about that half blue button :/
13:13:50 <kalev> aday[m]: we're having a Workstation WG meeting here and discussing whether to (1) add To Do and Simple Scan to the default install, and (2) replace Rhythmbox with Music
13:13:53 <aday[m]> before lapo kills me
13:14:02 <mcatanzaro> mclasen: How did you do that... you hooked up your scanner to webcam input? :)
13:14:28 <mcatanzaro> #chair otaylor
13:14:28 <zodbot> Current chairs: juhp kalev mcatanzaro mclasen otaylor ryanlerch stickster
13:15:36 <mclasen> mcatanzaro: it still offers to use your webcam
13:16:03 <mcatanzaro> We should probably ask Robert to make it not do that?
13:16:29 <aday[m]> simple scan makes sense to me, although i wonder whether it would be better to give it a generic name if it's going to be included by default
13:16:35 <mcatanzaro> I mean we don't want Cheese to be redundant with Simple Scan, right? :D I've never seen that before but I always have a scanner hooked up when I open it, so....
13:16:36 <aday[m]> i'm less convinced by to do
13:17:23 <mcatanzaro> aday[m]: I wish we had included you in the core app conversation when we had it a few months ago. :(
13:18:21 <mcatanzaro> My logic with To Do was pretty simple: most people probably keep a To Do list somewhere, and the app is actually very nice for that, so it seems to have general appeal.
13:18:49 * rdieter waves late, sorry, hi
13:18:50 <mcatanzaro> And nobody objected when I proposed it, but I probably only asked release team since it was a moduleset decision....
13:18:56 <mcatanzaro> (Sorry.)
13:19:00 * ryanlerch cant even dinf to do in gnome-software
13:19:14 <stickster> I think both Scan and ToDo make sense in the domain of a workstation; Music does too but that's for the next part of this discussion
13:19:28 <stickster> ryanlerch: weird, it came right up for me in a shell search
13:19:56 <ryanlerch> oh, it must have been downloading something, its popped up now
13:20:03 <stickster> ah, cool
13:20:04 <mcatanzaro> ryanlerch: The search in Software is not very good... it is in there for me when I look on the Installed page, but the search does not find it even if I search for the exact app name "To Do"
13:20:07 <aday[m]> using a to do app is a bit specialised in my mind
13:20:21 <juhp> hi rdieter
13:20:40 <stickster> vs. something like Google Keep?
13:20:41 * mcatanzaro also wishes he did not just publish the core apps blog post last night
13:20:47 <ryanlerch> there is also many to-do apps, so having a good default might be a good thing too
13:20:49 <stickster> #chair rdieter
13:20:50 <zodbot> Current chairs: juhp kalev mcatanzaro mclasen otaylor rdieter ryanlerch stickster
13:21:05 <mcatanzaro> I wasn't expecting the choice to be questioned... it would have been so easy to reverse until yesterday. Sorry. :(
13:21:12 * stickster is putting a timer on this discussion, 10 minutes left
13:21:12 <ryanlerch> it is also something that may be of higher interest to the Workstation target user
13:21:38 <ryanlerch> i'm +1 for all 3 apps in question here
13:21:40 <aday[m]> calendar, email, calculator, notes are all standard apps. to do not so much
13:22:05 <kalev> mcatanzaro: I think it's one thing to have an upstream "good quality apps" lists (aka core apps) but it's somewhat orthogonal to whether we should install them by default
13:22:17 <mcatanzaro> aday[m]: Interesting! Because I wonder what is the utility of a notes app when you have a nicer organized To Do app? :)
13:22:29 <aday[m]> on a more basic level, to do is very much a personal project rather than something that the design team is actively involved in
13:22:33 <kalev> I'd rather install a subset of the good quality apps and have some installable through the software center
13:22:39 <mcatanzaro> Anyway I will make sure to consult aday[m] on any changes to the core apps list in the future.
13:22:59 <stickster> mcatanzaro: aday[m]: I wonder whether it would make sense to converge todo/notes in the future
13:23:06 <stickster> that's an upstream question, really
13:23:09 <juhp> I haven't tried To Do but I think "to do" is an important tool
13:23:42 <juhp> stickster: ah
13:23:45 <aday[m]> stickster: maybe, although i think to do is probably more powerful than you'd want it to be as a part of notes - it has scheduling capabilities and so on
13:24:28 <mcatanzaro> aday[m]: I think OneNote is popular on Windows, but that's because it's targeted at touch input. Our Notes app is keyboard input.
13:24:44 <stickster> in any case... Do I understand that we're agreed on simple-scan?
13:24:54 <mcatanzaro> Touch input Notes would no doubt be very useful (for touchscreen users).
13:24:57 <stickster> #proposed #agreed add Simple Scan to default workstation (please vote
13:25:01 <mcatanzaro> +1
13:25:02 <ryanlerch> +1
13:25:10 <stickster> +1
13:25:17 <kalev> +1 as per aday[m]'s recommendation
13:25:18 <otaylor> +1
13:25:22 <aday[m]> i'd suggest renaming it to Document Scanner
13:25:29 <stickster> *noted
13:25:38 <mcatanzaro> aday[m]: I had a conversation with Robert about that too. We did not think of that option.
13:25:45 <ryanlerch> aday[m]: that is an upstream change though, right?
13:25:58 <mcatanzaro> aday[m]: He did not want it to be named Scanner because he was worried users might confuse the concept of the app with the actual physical device.
13:26:09 <mcatanzaro> But I think he will be receptive if you suggest the name change to him.
13:26:17 <mcatanzaro> Oh wait, actually we did think of that option. :/
13:26:34 <mcatanzaro> His concern was that it can be used to scan both documents AND images. Pictures. You wouldn't think of those as documents.
13:26:37 <stickster> rdieter: juhp: mclasen: any vote here?
13:26:45 <aday[m]> not sure ryanlerch. it happens in other cases; although whether that's a good thing i'm not sure
13:26:46 <mclasen> +1
13:27:03 <juhp> +1
13:27:38 <stickster> #agreed add Simple Scan to default workstation (+1: 7, 0: 0, -1: 0)
13:27:50 <kalev> I can make it happen in comps
13:28:00 <stickster> #action kalev add Simple Scan to comps
13:28:07 <mcatanzaro> Thanks kalev! It goes in gnome-desktop, not workstation-product.
13:28:16 <kalev> right
13:28:30 <stickster> #action mcatanzaro work with upstream on naming issue; we can adapt as needed
13:28:54 <mcatanzaro> kalev: Also be sure to add <!-- gnome-todo --> and <!-- gnome-music --> commented out if we decide not to approve them so we can track our divergence from upstream.
13:29:11 <stickster> So what about To Do? It sounds less clear about consensus there.
13:29:17 <mcatanzaro> Indeed
13:29:39 <kalev> I'm -1 as per aday[m]'s comments
13:29:48 <ryanlerch> +1 from me
13:30:43 <stickster> +1 here
13:30:45 <mcatanzaro> Honestly I could go either way... I still see it as useful. But it certainly doesn't need to be there. It's really hard to backtrack one day after announcing it though and it won't harm anything, so +1.
13:31:18 <otaylor> 0 from me (partly because I missed the discussion - sorry for being late!)
13:31:25 <mclasen> I'm trying to use it currently
13:31:41 <mclasen> it has some rough edges, but it is clearly a useful app
13:32:17 <juhp> yes
13:32:19 <mcatanzaro> mclasen: The only part I don't like is that adding a priority to an event is very awkward... but no less awkward than adding a time to an event in Calendar (which is nuts BTW).
13:32:23 <kalev> if we don't install it by default, we should make it a featured app in gnome-software I think
13:32:41 <stickster> kalev: that's a good tradeoff, thanks
13:33:04 <mcatanzaro> kalev: Just like we should do with Firefox :)
13:33:32 <kalev> mcatanzaro: that doesn't make sense because we install firefox by default
13:33:33 <mclasen> mcatanzaro: adding a date to a task is also one click too many -  I always want dates on my tasks
13:33:49 <stickster> kalev: I think he was making a GNOME Web 1/2-joke :-)
13:33:51 <mcatanzaro> kalev: It was a joke. I'm just saying what we *should* do with it. ;) ;)
13:33:59 <stickster> *jinx
13:34:01 <kalev> :)
13:34:05 <kalev> got it now! :)
13:34:20 <stickster> OK, so missing opinions here from many people and we need to get done with this topic.
13:34:22 <mcatanzaro> mclasen: OK, I don't use that, but true.
13:34:44 <aday[m]> "useful" shouldn't be a qualification for an app being preinstalled
13:35:08 <stickster> mclasen: juhp: rdieter: any votes?
13:35:30 <juhp> +1
13:35:44 <rdieter> +1
13:37:07 <stickster> #agreed Add To Do to default apps (+1: 5, 0: 1, -1: 1)
13:37:08 <mcatanzaro> aday[m]: Right... I like the "general appeal" criterion more than "useful." Wish we had had this conversation earlier. :/
13:37:33 * mcatanzaro having second thoughts but will stand by +1
13:37:42 <mclasen> -1
13:37:47 <stickster> #undo
13:37:48 <zodbot> Removing item from minutes: AGREED by stickster at 13:37:07 : Add To Do to default apps (+1: 5, 0: 1, -1: 1)
13:37:48 <mcatanzaro> OK, stickster should we move on to Music or do you need the time for your next agenda point?
13:37:51 <stickster> #agreed Add To Do to default apps (+1: 5, 0: 1, -1: 2)
13:38:11 <stickster> mcatanzaro: I see your point about getting Music in because it won't get an audience without more visibility
13:38:30 <stickster> Basic functionality seems to be there, and as we all know RB is *super* long in the tooth
13:39:28 <stickster> However, we are short on time because I have another item to cover which is readiness of Changes in F27
13:39:41 <mcatanzaro> OK then
13:40:00 <stickster> So unless everyone is ready to just vote right now, we're going to have to either defer this to #fedora-workstation for more discussion (or list), or vote *right now*
13:40:15 <stickster> oops, single line entry makes it hard to be cogent without more caffeine
13:40:28 <stickster> So unless everyone is ready to just vote right now, we're going to have to either defer this to #fedora-workstation for more discussion (or list), or put it away until F28
13:41:02 <mcatanzaro> +1? :)
13:41:05 <stickster> lol
13:41:06 * mclasen suggests to defer it so we can actually try the current music before voting
13:41:08 <ryanlerch> +1
13:41:14 <mcatanzaro> Let's defer to next meeting.
13:41:26 <ryanlerch> okies
13:41:37 <mcatanzaro> We'll still have plenty of time before F27 to change out one app.
13:41:57 <stickster> mcatanzaro: I'll suggest we try to get consensus *before* that meeting since the 28th a number of us will be traveling to Flock
13:42:07 <mcatanzaro> FWIW I use Music on a regular basis and it's... mostly fine. Rough edges. Better than Rhythmbox.
13:42:07 <stickster> mcatanzaro: we could use the ticket to vote on Music IMHO
13:42:22 <kalev> aday[m]: what's your opinion on Music vs Rhythmbox?
13:42:26 <mcatanzaro> stickster: Oh that's right... should we just cancel the meeting on the 28th then?
13:42:27 <stickster> mcatanzaro: RB has plenty of rough edges still, I think, so that doesn't seem like a deal-killer
13:42:41 <stickster> mcatanzaro: We might have to. So that makes it important for us to get the discussion done elsewhere for Music
13:43:16 <stickster> #action mcatanzaro Drive discussion/vote on Music for default this week (-ish) so we can get decided
13:43:41 <stickster> #action stickster figure out whether to cancel Aug 28th WG meeting
13:43:49 <mcatanzaro> TBH from a strategic perspective, I feel like the odds of this being approved decrease if we put discussion on the list. :)
13:43:49 <stickster> #topic All other business -- open floor
13:43:54 <aday[m]> mcatanzaro: i obviously want us to move in the direction of music. i'm not entirely sure where the development effort is at currently, though
13:44:00 <mclasen> mcatanzaro: spotify here :-/
13:44:02 <mcatanzaro> I would just wait for the next meeting. Anyway next topic.
13:44:08 <kalev> is anyone actually working on Music upstream now? it seemed rather abandoned a year ago or so
13:44:31 <stickster> OK, here's an important point, Changes for F27. They must be code complete by *September 5* which is the Tuesday after Flock, also the day after Labor Day holiday in USA
13:45:06 <mcatanzaro> I've already deferred the installer change to F28 since I didn't notice the testable deadline until it had already passed during GUADEC, and wasn't going to work on it then.
13:45:07 <stickster> If memory serves, we have some Changes in the Workstation area that should really already be testable, but actually completed by then
13:45:26 <stickster> mcatanzaro: Ah, yes -- so noted
13:45:28 <mcatanzaro> I don't remember what other changes we have lined up.
13:46:11 <kalev> there's the Flatpak in koji change
13:46:15 <otaylor> It was agreed at the fesco meeting that we'd make the call on the flatpak building change 3 days before the deadline (sep 2)
13:46:34 <mclasen> and the atomic variant
13:47:08 <stickster> otaylor: OK, that's a Saturday then?
13:47:19 <stickster> #link https://fedoraproject.org/wiki/Changes/Graphical_Applications_as_Flatpaks
13:48:22 <otaylor> stickster: yeah - not sure why sgallagher proposed that exact day - but anyways "right after flock" more or less
13:48:55 <stickster> I don't see any others in the list at https://fedoraproject.org/wiki/Releases/27/ChangeSet that look Workstation specific other than the one mcatanzaro mentioned (reduce initial-setup redundancy)
13:49:51 <stickster> otaylor: is the "remove this change" outcome really more like just a delay on the capability, no scramble required to remove something else?
13:50:02 <stickster> or is there some other backing-out change that needs to be coordinated?
13:50:17 <otaylor> There's nothing that needs to be backed out, no.
13:50:31 <stickster> right, that's what I expected. thanks
13:50:44 <stickster> OK, so it sounds like we're not missing anything else to be tracked here, then.
13:50:54 * stickster is EOF on this topic then
13:51:40 <stickster> #info Anaconda coordination is deferred to F28, otaylor is tracking the flatpak change which will be assessed 2017-Sep-02
13:51:59 <stickster> Anything else we need to cover here? If not, mcatanzaro can always dive back into Music ;-)
13:52:11 <mcatanzaro> +1 Music! Woooo!
13:52:17 <ryanlerch> +1 music
13:52:56 <stickster> ol
13:53:03 <ryanlerch> RB is the current default, right?
13:53:10 <stickster> ryanlerch: correct
13:53:17 <ryanlerch> this proposal is to replace RB with gnome-music
13:53:36 <ryanlerch> still a +1 from me :D
13:53:46 <otaylor> so would the default helper for music files be totem or rhythmobx?
13:54:25 <ryanlerch> otaylor: is that because music cant just play a one-off file?
13:54:29 <mcatanzaro> otaylor: totem
13:54:41 <ryanlerch> becuase it is all tracker-based?
13:54:49 <juhp> I see
13:54:52 <mcatanzaro> We'd be removing Rhythmbox
13:54:56 <otaylor> ryanlerch: I'm just wondering the situation, since it used to be rhythmbox
13:55:08 <mcatanzaro> ryanlerch: Well that's not some limitation of tracker, it's a flaw in the app itself. It should learn how to open music files....
13:55:30 <mcatanzaro> In the meantime, we would have those files open in totem instead by default
13:55:34 <ryanlerch> mcatanzaro: yeah, sorry i worded that wrong
13:55:46 <mcatanzaro> *But* that's actually not a very bad regression! Because that's actually what you want to do now with Rhythmbox, too!
13:55:54 <aday[m]> otaylor, mcatanzaro: we have designs for music to be able to open audio files
13:56:02 <juhp> aha
13:56:08 <stickster> mcatanzaro: agreed, the single-file experience with RB as default is ugh
13:56:08 <mcatanzaro> Currently if you open an audio file in Rhythmbox it gets added to your music library, which is almost never what you want
13:56:24 <ryanlerch> 4mins!
13:56:36 <mcatanzaro> So we really want music files to open in Totem regardless of whether we have Music or Rhythmbox right now. And in the glorious future, hopefully Music will handle that better.
13:57:03 <mcatanzaro> (If we keep Rhythmbox then we should ask hadess to make totem the default audio file handler anyway.)
13:57:28 <ryanlerch> i've been using music for ages now, and IMHO it is better and more stable than RB
13:57:31 <ryanlerch> FWIW
13:57:37 <otaylor> mcatanzaro: so what's the development situation with gnome-music at the moment?
13:57:40 <stickster> the one big lack I see in Music atm is accessing network music share. So my huge 75000 song library is now missing and no way I can see to get to it :-)
13:57:56 <mclasen> ryanlerch: I think music has the same issue (with library vs random files) ?
13:58:33 <mcatanzaro> otaylor: "Lightly maintained" ;)
13:58:58 <stickster> hrm
13:59:08 <mcatanzaro> Well we are out of time, we will have to discuss at next month's meeting. I'd rather not move this to the list; we'll just see where we're at come next meeting. It's hardly urgent.
14:00:03 <ryanlerch> mcatanzaro: maybe the ticket tracker might be a better place to get concensus
14:01:04 <stickster> agreed
14:01:19 <stickster> OK, we'll wrap things up for today. juhp and ryanlerch, thanks for staying up late :-)
14:01:37 <stickster> #agreed continue Music discussion elsewhere, check WG temp next time
14:01:44 <stickster> Thanks for coming, everyone
14:01:46 <stickster> #endmeeting