workstation
LOGS
13:00:26 <stickster> #startmeeting Workstation WG
13:00:26 <zodbot> Meeting started Mon Apr 24 13:00:26 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:26 <zodbot> The meeting name has been set to 'workstation_wg'
13:00:28 <stickster> #meetingname workstation
13:00:28 <zodbot> The meeting name has been set to 'workstation'
13:00:31 <stickster> #topic Roll call
13:00:33 <linuxmodder> .fas linuxmodder
13:00:34 <stickster> .hello pfrields
13:00:35 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
13:00:38 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:00:40 <ryanlerch> .hello ryanlerch
13:00:41 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
13:00:46 <stickster> o/ Ryan!
13:00:48 <juhp_> .hello petersen
13:00:49 <zodbot> juhp_: petersen 'Jens Petersen' <petersen@redhat.com>
13:00:50 <kalev> .hello kalev
13:00:52 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
13:00:53 <ryanlerch> evening stickster
13:00:59 <stickster> wow, lots of folks here at the starting bell :-)
13:01:03 <juhp_> hi ryanlerch!
13:01:10 <ryanlerch> hi juhp_ !
13:01:18 <stickster> #chair ryanlerch juhp_ kalev mcatanzaro rdieter mclasen
13:01:18 <zodbot> Current chairs: juhp_ kalev mcatanzaro mclasen rdieter ryanlerch stickster
13:01:22 <ryanlerch> morning, kalev
13:01:28 <kalev> morning ryanlerch!
13:01:29 <mclasen> .hello mclasen
13:01:30 <zodbot> mclasen: mclasen 'Matthias Clasen' <mclasen@redhat.com>
13:02:16 <stickster> I think Owen is still out on paternity leave; not sure of Christian's whereabouts
13:02:35 <stickster> rdieter: mcatanzaro: You guys around?
13:03:21 <mcatanzaro> .hello catanzaro
13:03:22 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanzaro@gnome.org>
13:04:32 <stickster> #topic Agenda
13:04:53 <mclasen> owen is out
13:05:00 <mclasen> I can check in christians cube
13:05:01 <stickster> Thanks mclasen, I figured as much
13:05:34 <stickster> So regrettably I wasn't able to get an agenda out in time last week. Mainly this was due to managerial hoo-ha, but in good news, as a result relrod is joining the Fedora Engineering team full-time in a couple weeks :-)
13:05:53 <juhp_> nice
13:06:16 <ryanlerch> fantastic!
13:06:25 <stickster> Before we solicit topics, though, I also wanted to point out... I won't be available Monday May 8th to chair this meeting
13:07:02 <stickster> And it will be almost impossible for me to put together an agenda because the week before I'll be at the Red Hat Summit, and past experience shows I shouldn't promise things for that week
13:07:49 <mclasen> no cschalle I can find
13:07:49 <stickster> What I'm wondering is whether someone could chair on May 8th with a pre-decided agenda, such as checking status for the F26 Beta (blockers and such)
13:08:01 <stickster> mclasen: OK, I didn't see him on internal IRC either so we can just roll on
13:08:04 <stickster> thanks for checking
13:09:00 <stickster> #idea Any volunteers for chairing on May 8th?
13:09:43 <stickster> Heh, no one?
13:10:07 <mclasen> stickster: probably
13:10:42 <stickster> mclasen: sorry, not enough caffeine yet here, but are you volunteering?
13:10:57 <juhp_> if not I can be a backup I think
13:11:19 <mclasen> yes, scribble me in
13:11:25 <stickster> OK, cool, thanks guys
13:11:36 <stickster> #info mclasen to chair May 8th, backup is juhp_ in case something happens
13:12:09 <stickster> So for today, I don't want to waste people's time. Can we agree on a couple topics that need discussion/decision/action today?
13:13:36 <stickster> #idea issue tracker for Workstation -- do we want to use this for future meetings?
13:13:40 <ryanlerch> I asked on the list last week about maybe trying to use the fedora-workstation ticket queue a bit more
13:13:45 <stickster> ha, *jinx
13:14:04 <mcatanzaro> Pague seems like a good tool for tracking action items.
13:14:18 <stickster> #topic Issue tracker
13:14:32 <ryanlerch> #link https://pagure.io/fedora-workstation/issues
13:15:31 <stickster> Question for WG: Is there anyone *opposed* to using this queue to just track our agenda items/TODO stuff from here on out?
13:15:49 <mclasen> not opposed
13:15:52 <juhp_> I think it is a good idea - has occurred to me too
13:16:05 <stickster> ryanlerch: I assume you're not opposed since it was your idea ;-)
13:16:25 <stickster> kalev: sound OK?
13:16:29 <ryanlerch> my main motivation for this was that during the flatpack thread, someone mentioned that one of the points had been discussed before, but i couldnt find the thread in question easily
13:16:41 * mclasen has some issues with pagure in general, but thats not for this meeting
13:16:44 <puiterwijk> Idea: would it be useful to have a "meeting" tag?
13:16:59 <ryanlerch> my thought was that if we have tickets for this stuff, it might be more useful to track and plan
13:17:06 <kalev> stickster: sure, no opposition from me :)
13:17:09 <stickster> puiterwijk: Yes, for things that need WG meeting discussion/decision -- then we can strip the tag once decided
13:17:49 <stickster> #agreed Let's use the Pagure queue from now on for tracking WG meeting agenda, as well as other TODO
13:18:08 <stickster> In that case, let's pull up the moldiest ticket in the queue and see if we can shake the... mold? dust! off.
13:18:25 <stickster> #topic On-demand socket activation for services
13:19:03 <stickster> #link https://pagure.io/fedora-workstation/issue/8
13:19:44 <stickster> mclasen: Refreshing memory here... Was the problem here that we are seeking a workstation-specific preset? And we have to justify why it should be different?
13:20:55 <mclasen> I don't think there is a problem with shipping workstation-specific presets. we just need a fesco ok, it seems
13:20:56 * stickster is looking up latest cups build to see what the SRPM looks like
13:21:11 <sgallagh> mclasen: You do not need FESCo permission
13:21:27 <sgallagh> mclasen: The workgroups have been granted autonomy to make per-Edition preset decisions
13:21:54 <stickster> It seems like the kind of thing that does make sense for Workstation and not other editions... since we are trying to support general users who often have printers in their home/office, whereas other editions probably don't want to assume that
13:22:05 <mclasen> ah, ok.
13:22:16 <stickster> Hey cool! So we may be able to JFDI.
13:22:28 <mclasen> well, now
13:23:01 <sgallagh> stickster: Right, just submit a pull request against https://pagure.io/fedora-release amending the preset files.
13:23:07 <mclasen> that would be too easy - I guess we can write a patch for the fedora-release package and try to get it merged
13:23:08 <mcatanzaro> We already have Workstation-specific presets. E.g. we disable sshd.
13:23:13 <stickster> *nod
13:23:17 <sgallagh> (noting in the request that it's a Workstation WG decision)
13:23:22 <mcatanzaro> I don't think that has anything to do with socket activation.
13:23:31 <kalev> ah, then it should be trivial to add one more thing if we already have existing presets
13:23:54 <mcatanzaro> #link https://pagure.io/fedora-release/blob/master/f/80-workstation.preset
13:23:56 <stickster> kalev: correct -- we just add the three lines needed to the existing .preset file.
13:24:16 <stickster> #action stickster submit PR to get the changes in
13:24:17 <sgallagh> That said, the default preset for all of Fedora includes cups.* alreadty
13:24:47 <ryanlerch> excuse my ignorance here, but what does this actually do? is there an impact on a user?
13:25:33 <stickster> ryanlerch: It means the cups service only starts when someone hits the CUPS socket, IIUC
13:25:48 <kalev> sgallagh: I think the problem here is that the default preset has cups.*, but workstation would only want cups.socket and not cups.service
13:25:54 * sgallagh reads the original message. I'm not sure why the reporter thinks the packaging policy disagrees with this
13:26:10 <mclasen> ryanlerch: its a boot speed thing, basically
13:26:10 <stickster> sgallagh: it was filed > 2 years ago
13:26:18 <sgallagh> ah
13:26:27 <ryanlerch> thanks stickster
13:26:32 <mclasen> sgallagh: there used to be a rule  of sorts that we enable installed services ?
13:26:32 <stickster> sgallagh: I think the ticket got moldy while it actually got answered on the list, and was clear we could do something easily
13:26:36 <sgallagh> So, workstation could opt to disable the cups.service if they wanted.
13:27:00 <sgallagh> The other three lines there would be redundant
13:27:09 <stickster> mclasen: You're right, but I believe the latest policy is that WGs can override this if we choose
13:27:10 <sgallagh> s/they/you/
13:27:34 <stickster> sgallagh: I was thinking for clarity, just having them there verbatim is useful
13:27:37 <mclasen> I think enabling the socket should actually count as enabling for the purposes of that rule
13:27:51 <mclasen> the functionality will be available
13:28:02 <sgallagh> stickster: Sure, and it's future-compatible if we decide to remove cups from the defaults
13:28:04 * stickster thinks so too... the original policy was written in the days before systemd and on-demand activation
13:28:17 <stickster> ^ in response to mclasen re: what should count as enabling
13:28:21 <sgallagh> mclasen: That rule no longer exists, so we don't need to justify it :)
13:28:26 <stickster> \o/
13:28:31 <stickster> sounds like we're all in violent agreement here
13:28:43 <stickster> I have the #action here, so we can move on if desired
13:29:20 <mclasen> +1 for moving on
13:29:30 * kalev nods.
13:29:39 <sgallagh> stickster: It's probably worth also petitioning FESCo to disable cups.service globally if cups.socket is sufficient.
13:29:47 <sgallagh> I think we'd probably go ahead and do it
13:29:53 <stickster> sgallagh: I'll file that ticket too then
13:29:57 <sgallagh> Thank you
13:30:19 <stickster> #action stickster file ticket with FESCo to disable cups.service globally as well, since Workstation will have this change
13:30:43 <ryanlerch> the ticket also mentioned that there might be other service that benefit from this treatment too
13:31:25 <ryanlerch> is that something we should look into?
13:31:37 <sgallagh> mclasen: FYI, you should treat https://fedoraproject.org/wiki/Packaging:DefaultServices as providing the official stance on what qualifies as a "service" for enablement.
13:32:37 <mclasen> thanks, makes sense
13:32:38 <stickster> ryanlerch: Yeah, could be -- I don't know all the default services by heart but systemctl will tell us easily enough
13:34:09 * stickster not sure where it's safe to do on-demand or not
13:34:37 <stickster> sgallagh: So will FESCo change that wiki page with our cups decision here?
13:35:23 <sgallagh> stickster: What change do you think it requires?
13:35:54 <sgallagh> stickster: As long as the preset file includes a comment pointing to the decision, I think that's sufficient.
13:36:06 <stickster> *nod
13:36:21 <sgallagh> stickster: see https://pagure.io/fedora-release/blob/master/f/90-default.preset for examples
13:36:40 <sgallagh> Hmm, someone forgot to include the sssd.service decision link there.
13:36:42 * sgallagh will fix that
13:37:10 <sgallagh> Oops, it was me. *blush*
13:37:28 <stickster> heh
13:38:42 <stickster> #link https://pagure.io/fedora-release/pull-request/93
13:39:39 <stickster> ryanlerch: You filed the next three tickets, any preference for first here?
13:39:44 <stickster> and thanks for doing that :-)
13:40:10 <ryanlerch> stickster: probably #12
13:40:52 <ryanlerch> it is probably the oldest one, even though the newset filesd
13:41:07 <ryanlerch> #link https://pagure.io/fedora-workstation/issue/12
13:41:36 <stickster> #topic Provide clean set of wallpapers
13:42:09 <ryanlerch> this was something i proposed a while back, but it kinda got lost
13:43:16 <stickster> So the idea here AIUI is for us to have a better curated set of Fedora-flavored wallpapers -- always having the default for the current release from the Design team, along with the GNOME default for the current release, but then a curated set of WPs chosen from among the previous supplemental packages included
13:43:47 <ryanlerch> stickster: yeah, perfect
13:44:18 <stickster> I like this idea... the supplemental WPs have generally been quite good IMHO
13:44:18 <ryanlerch> the supplemental wallpapers will still be as they are now, just not installed by default
13:44:39 <ryanlerch> as they have always have been
13:44:53 <stickster> ryanlerch: Right, so what you're proposing is to go back through the supplementals from e.g. f22, f23, etc... and pull out 16 good exemplars for this standard set
13:45:04 <ryanlerch> stickster: exactly
13:45:08 <stickster> and that set would then survive for some number of releases?
13:45:17 <mcatanzaro> (Don't forget to leave the upstream lockscreen wallpaper)
13:45:27 <stickster> mcatanzaro: ah, good point
13:45:36 <ryanlerch> mcatanzaro: agreed. i will update the proposal
13:45:50 <juhp_> sounds fine to me
13:46:10 <ryanlerch> this will clear out all the other, older upstream backgrounds though
13:46:24 <ryanlerch> by default
13:47:12 <stickster> ryanlerch: So we'd put these in a fedora-backgrounds package, and stop including gnome-backgrounds package by default?
13:47:14 <mclasen> I think our wallpaper dialog is organized in 3 columns ? 16 is not the best number...
13:47:40 <stickster> yeah, it would end up being 19 with 16 + Fedora default + GNOME default + GNOME lock default
13:47:49 <mclasen> make it 15 or 18 or 21...
13:48:06 <stickster> agreed, this is a nitpick that appeals to my personal level of OCD ;-)
13:48:11 <ryanlerch> mclasen: 16 was an arbiatiry number :)
13:48:16 <mclasen> I know
13:48:21 <ryanlerch> lets go 81
13:48:22 <mclasen> just saying: make it fill the grid
13:48:25 <ryanlerch> *18
13:48:30 <ryanlerch> :D
13:48:31 <stickster> lol, 81 was funnier
13:48:34 <mclasen> for both the default install, and the extended set
13:49:04 <stickster> Ah, so for F27 we'd want to do 15 in the supplementals?
13:49:19 <stickster> (although it's kind of blown already since the other supplementals will knock everything out of alignment anyway)
13:49:31 <stickster> Maybe that's the point where we stop worrying about it
13:50:00 <ryanlerch> stickster: yeah, i think changing the supplemental process might be more hassle than it is worth
13:50:04 <stickster> agggghhhh OCD kicking in hard now http://i.imgur.com/yy19ljZ.jpg
13:50:25 <mclasen> once you go beyond a dozen or so, the grid filling is probably not that important anymore...
13:50:29 <stickster> *nod
13:50:33 <mclasen> the end will be scrolled far off at that point
13:50:48 <stickster> #idea we constrain the defaults, and let the supplemental stuff stand as is
13:50:53 <stickster> Anyone opposed ^
13:51:05 <stickster> sorry, that was a question -- Anyone opposed to that idea?
13:51:18 <juhp_> sounds alright to me
13:51:23 <mclasen> what does that mean, effectively ? we ship with less backgrounds by default ?
13:51:35 <stickster> mclasen: We would ship with something like 18 or 21 by default
13:51:36 <mclasen> but there are more (or the same number) available via packages ?
13:51:45 <stickster> and more available via packages
13:52:16 <ryanlerch> currently there is 18
13:52:35 <ryanlerch> including GNOME default, GNOME lock, & Fedora Default
13:52:59 * mclasen idly wonders about a package free way to get more backgrounds
13:53:16 <mclasen> we do have a flickr provider there, is that right ?
13:53:22 * mclasen maybe misremembering
13:53:46 <ryanlerch> mclasen: or installing new backgrounds in "Software" ?
13:54:05 <ryanlerch> thought its not really software
13:54:08 <mclasen> I'm not really a huge fan of that
13:54:17 <stickster> mclasen: that seems like a great opportunity for a nice feature :-)
13:54:19 <mclasen> its not great for fonts either
13:54:23 <stickster> *nod
13:54:30 * ryanlerch agrees
13:54:31 <juhp_> maybe the idea is to just download the background one likes?
13:54:57 * stickster notes he  has a hard stop in about 2 minutes to run another meetin
13:55:00 <stickster> *meeting
13:55:06 <mclasen> sure, you can do that. if you find it. we do have 'use as wallper' menuitems in various places
13:55:18 <stickster> It sounds like no one is opposed to this proposal, ryanlerch
13:55:35 <ryanlerch> stickster: okay, i will re-confirm with the design team
13:55:38 <stickster> #agreed proposal for wallpapers sounds good
13:55:39 <juhp_> mclasen, right
13:55:53 <stickster> #action ryanlerch double check with Design team and then start making changes/pull requests as needed
13:55:57 <ryanlerch> i asked a while back, and should really double-sheck
13:57:01 <stickster> #info Last note: If you have something for next week's meeting, drop it in the Pagure queue! Now the chair will be fully equipped for the next meeting agenda :-)
13:57:22 <stickster> I'm going to end meeting now
13:57:28 <stickster> Thanks for coming everyone!
13:57:30 <stickster> #endmeeting