releng
MINUTES

#fedora-meeting-2: RELENG (2017-04-24)

Meeting started by mboddu at 14:33:38 UTC (full logs).

Meeting summary

  1. init process (mboddu, 14:33:38)
  2. #6756 "ActionNotAllowed" when attempting "koji untag-build f27" (mboddu, 14:37:55)
    1. https://pagure.io/releng/issue/6756 (mboddu, 14:38:03)
    2. current state is that users can not untag builds from rawhide, and need to file a releng issue to untag builds (dgilmore, 14:54:53)
    3. ACTION: investigate adjusting hub policy to allow users to untag builds (dgilmore, 14:55:23)
    4. https://infrastructure.fedoraproject.org/cgit/ansible.git/tree/roles/koji_hub/templates/hub.conf.j2#n108 (nirik, 14:55:50)
    5. possible other solutions are a microservice to allow users request untagging of builds, that enforces policy. (dgilmore, 14:56:04)
    6. ACTION: document and communicate the current status with devel@ (dgilmore, 14:56:39)
    7. the f27 tag was limited in permsisons when we enabled autosigning to ensure only signed builds make it into rawhide (dgilmore, 14:57:41)
    8. likely worth filing some RFE's with koji to have finer graied controls (dgilmore, 14:58:48)

  3. #6739 F26 Alpha image paths and CHECKSUM files changed partially from underscore to dash (mboddu, 15:02:26)
    1. https://pagure.io/releng/issue/6739 (mboddu, 15:02:32)
    2. ACTION: Kellin will document the right values to be used for Alpha/Beta configs and for GA config (mboddu, 15:07:57)

  4. #6663 Create another new tag for Modularity (mboddu, 15:08:19)
    1. https://pagure.io/releng/issue/6663 (mboddu, 15:08:30)
    2. ACTION: jkaluza to reach out to koji devs to get the conversation started on figuing out how to drop the permissions of module builds and management (dgilmore, 15:28:40)
    3. https://fedoraproject.org/wiki/Releases/26/Schedule (dgilmore, 15:34:47)

  5. Open Floor (dgilmore, 15:37:02)
    1. https://koji.fedoraproject.org/koji/channelinfo?channelID=9 (dgilmore, 15:44:10)
    2. ARMv7 virt builders have been live in prod for nearly a week (mboddu, 15:46:31)
    3. Old arm builders will be disabled today (mboddu, 15:46:53)


Meeting ended at 15:48:48 UTC (full logs).

Action items

  1. investigate adjusting hub policy to allow users to untag builds
  2. document and communicate the current status with devel@
  3. Kellin will document the right values to be used for Alpha/Beta configs and for GA config
  4. jkaluza to reach out to koji devs to get the conversation started on figuing out how to drop the permissions of module builds and management


Action items, by person

  1. jkaluza
    1. jkaluza to reach out to koji devs to get the conversation started on figuing out how to drop the permissions of module builds and management
  2. Kellin
    1. Kellin will document the right values to be used for Alpha/Beta configs and for GA config
  3. UNASSIGNED
    1. investigate adjusting hub policy to allow users to untag builds
    2. document and communicate the current status with devel@


People present (lines said)

  1. dgilmore (113)
  2. mboddu (41)
  3. nirik (37)
  4. pbrobinson (22)
  5. jkaluza (21)
  6. contyk (7)
  7. masta (6)
  8. zodbot (6)
  9. puiterwijk (5)
  10. Kellin (3)
  11. sharkcz (1)
  12. tyll (0)
  13. pingou (0)
  14. maxamillion (0)


Generated by MeetBot 0.1.4.