f26-alpha-go-no-go-meeting-2nd
MINUTES

#fedora-meeting-2: F26 Alpha Go/No-Go meeting the 2nd round

Meeting started by jkurik at 17:00:13 UTC (full logs).

Meeting summary

  1. Roll Call (jkurik, 17:00:23)
  2. Purpose of this meeting (jkurik, 17:02:33)
    1. Purpose of this meeting is to check whether or not F26 Alpha is ready for shipment, according to the release criteria. (jkurik, 17:02:37)
    2. This is determined in a few ways: (jkurik, 17:02:41)
    3. No remaining blocker bugs (jkurik, 17:02:44)
    4. https://qa.fedoraproject.org/blockerbugs/milestone/26/alpha/buglist (jkurik, 17:02:48)
    5. Release candidate compose is available (jkurik, 17:02:53)
    6. https://pagure.io/releng/issue/6701 (jkurik, 17:02:57)
    7. Test matrices for Alpha are fully completed (jkurik, 17:03:01)
    8. https://fedoraproject.org/wiki/Test_Results:Fedora_26_Alpha_1.2_Summary (jkurik, 17:03:04)

  3. Current status (jkurik, 17:03:08)
    1. F26 Alpha RC Compose 1.2 is available (jkurik, 17:03:13)
    2. https://kojipkgs.fedoraproject.org/compose/26/Fedora-26-20170321.1/compose/ (jkurik, 17:03:17)
    3. We have 4 proposed and 2 accepted blockers for F26 Alpha. (jkurik, 17:03:22)

  4. Mini-Blocker Review (jkurik, 17:03:56)
    1. 4 Proposed Blockers (adamw, 17:04:12)
    2. 2 Accepted Blockers (adamw, 17:04:12)
    3. 3 Proposed Freeze Exceptions (adamw, 17:04:16)
    4. 8 Accepted Freeze Exceptions (adamw, 17:04:16)
    5. for the record, both the accepted blockers are verified fixed in RC2, which means we only have to worry about the proposed (adamw, 17:04:42)

  5. (1434977) Fedora 26 backgrounds are the same as Fedora 25 (adamw, 17:05:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1434977 (adamw, 17:05:02)
    2. Proposed Blocker, distribution, NEW (adamw, 17:05:03)
    3. we'll circle back to this one later (adamw, 17:06:02)

  6. (1433899) Workstation Live panics during boot (adamw, 17:06:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1433899 (adamw, 17:06:14)
    2. Proposed Blocker, kernel, NEW (adamw, 17:06:14)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1434462 is very likely the same bug (adamw, 17:10:24)
    4. https://bugzilla.kernel.org/show_bug.cgi?id=194911 may well be the same bug (adamw, 17:10:37)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=1430297 is also likely the same bug (adamw, 17:12:30)
    6. https://lkml.org/lkml/2017/3/23/38 (nirik, 17:26:40)
    7. AGREED: The group agrees in principle to move at least default virt guest requirements from Beta to Alpha criteria, and accepts this bug as a blocker as it often prevents the Alpha booting on default virt-manager / Boxes VMs (adamw, 17:31:00)

  7. (1434462) frequent kernel panic during VM boot (adamw, 17:31:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1434462 (adamw, 17:31:19)
    2. Proposed Blocker, kernel, NEW (adamw, 17:31:19)
    3. we're going to assume for now that this is the same as the previous bug (#1433899) (adamw, 17:32:32)
    4. we'll do bugzilla bureaucracy later (adamw, 17:32:40)

  8. (1435010) GNOME fails to start without modesetting (Fedora 'basic graphics') mode (adamw, 17:33:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1435010 (adamw, 17:33:09)
    2. Proposed Blocker, mutter, NEW (adamw, 17:33:09)
    3. AGREED: 1435010 - AcceptedBlocker - this is a clear violation of Alpha requirement "The boot menu for all supported installer and live images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer or desktop and attempting to use the generic driver." (adamw, 17:40:36)
    4. we're doing one quick FE review (adamw, 17:41:00)

  9. (1422247) Can't set crda with 4.10 kernel (adamw, 17:41:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1422247 (adamw, 17:41:42)
    2. Proposed Freeze Exception, kernel, MODIFIED (adamw, 17:41:55)
    3. AGREED: 1422247 - AcceptedFreezeException (Alpha) - the fix for this is safe and tested, and obviously it's bad for some folks not to be able to get on the network from netinst / live images (adamw, 17:47:29)

  10. (1434977) Fedora 26 backgrounds are the same as Fedora 25 (adamw, 17:48:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1434977 (adamw, 17:48:57)
    2. Proposed Blocker, distribution, NEW (adamw, 17:48:57)
    3. https://duffy.fedorapeople.org/hotdog/hotdogs-wallpaper.png (mizmo, 18:05:23)
    4. AGREED: 1434977 - AcceptedBlocker (Alpha) - this is clearly a violation of "The default desktop background must be different from that of the last two stable releases." there is some sentiment to adjust the criteria here, but as we have other blockers, we don't want to thrash that out in this meeting (adamw, 18:12:18)

  11. Test Matrices coverage (jkurik, 18:13:11)
    1. https://fedoraproject.org/wiki/Test_Results:Fedora_26_Alpha_1.2_Summary (jkurik, 18:13:15)

  12. Go/No-Go decision (jkurik, 18:16:02)
    1. ACTION: jkurik to publish the Go/No-Go result (jkurik, 18:17:11)
    2. The result of this meeting is No-Go due to present blockers. The whole release slips for one week (jkurik, 18:17:45)
    3. There will be one more Go/No-Go meeting the next Thursday at the same time (jkurik, 18:18:57)

  13. Open floor (jkurik, 18:19:04)


Meeting ended at 18:30:37 UTC (full logs).

Action items

  1. jkurik to publish the Go/No-Go result


Action items, by person

  1. jkurik
    1. jkurik to publish the Go/No-Go result


People present (lines said)

  1. adamw (183)
  2. jkurik (78)
  3. nirik (64)
  4. sgallagh (54)
  5. roshi (44)
  6. mizmo (36)
  7. linuxmodder (22)
  8. jforbes (20)
  9. dgilmore (12)
  10. zodbot (11)
  11. ignatenkobrain (1)
  12. mboddu (0)


Generated by MeetBot 0.1.4.