releng
LOGS
15:39:24 <mboddu> #startmeeting RELENG (2017-02-27)
15:39:24 <zodbot> Meeting started Mon Feb 27 15:39:24 2017 UTC.  The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:39:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:39:24 <zodbot> The meeting name has been set to 'releng_(2017-02-27)'
15:39:24 <mboddu> #meetingname releng
15:39:24 <zodbot> The meeting name has been set to 'releng'
15:39:24 <mboddu> #chair dgilmore nirik tyll sharkcz masta pbrobinson pingou puiterwijk maxamillion mboddu Kellin
15:39:24 <zodbot> Current chairs: Kellin dgilmore masta maxamillion mboddu nirik pbrobinson pingou puiterwijk sharkcz tyll
15:39:24 <mboddu> #topic init process
15:39:24 <mboddu> #topic #NNNN TICKET TITLE
15:39:57 <mboddu> #undo
15:39:57 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x5fb2410>
15:40:14 <nirik> morning.
15:40:18 <mboddu> Sorry, I copied an extra line
15:41:03 * sharkcz is on a call right now
15:41:47 <maxamillion> .hello maxamillion
15:41:48 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:44:19 <mboddu> okay, lets start
15:44:36 <mboddu> #topic #6601 Migrate the rel-eng tickets from (old) trac
15:44:58 <mboddu> nirik: seems like pingou is not in the channel, any updates?
15:45:14 <nirik> nope. I will ask him again
15:45:49 <mboddu> When is fedorahosted is planned for take down?
15:46:48 <nirik> wed
15:46:52 <nirik> he's working on it today
15:47:53 <mboddu> nirik: okay, we are on the edge, but the data will be still present except that there is no way to access them until they are migrated to pagure, is that right?
15:48:06 <nirik> yeah, we still will have the data...
15:49:33 <mboddu> nirik: can we just migrate the tickets that have no issues and deal with the email2trac tickets later assuming everything can't be done by tomorrow?
15:50:26 <nirik> I don't know, you would have to ask pingou about that.
15:51:34 <mboddu> nirik: okay, I will check with pingou about it
15:52:29 <mboddu> #action mboddu will check with pingou whether the tickets with no issues can be migrated into pagure and deal with the tickets that have issues later.
15:54:19 <mboddu> #topic #6600 Mock and sigined rawhides
15:54:44 <mboddu> #link https://pagure.io/releng/issue/6600
15:55:02 <nirik> I've been signing f26 with the f27 key over the weekend...
15:55:38 <nirik> so, hopefully by branch time we will have everything signed twice and there won't be a gap there. Of course mock will need to still do package updates.
15:55:40 <mboddu> nirik: awesome, can it done by branching? and is branching is going to affect it in anyway?
15:55:57 <nirik> shouldn't affect it... yeah, it's pretty close to done now
15:56:07 <mboddu> nirik: well, you answered it before I asked it
15:57:53 <nirik> I guess I can update that ticket...
15:58:19 <mboddu> #info nirik started signing f26 with f27 over the weekend and it will be done before branching.
15:58:28 <mboddu> nirik: that is helpful
15:59:19 <puiterwijk> Note that we will need to do an additional run, since autosigning for f27 key is not setup yet.  (which is an error on my end)
15:59:41 <puiterwijk> I was supposed to have done that last week, but I don't think I have
16:00:16 <mboddu> puiterwijk: okay
16:01:02 <mboddu> #info We need to rerun the signing again since autosigning for f27 is not setup yet.
16:01:10 <mboddu> anything else?
16:01:36 <nirik> yeah, I can re-run as we get closer...
16:02:15 <mboddu> nirik: thanks
16:02:34 <mboddu> okay, lets move on to next topic
16:02:43 <mboddu> # topic #6577 Fedora 26 mass rebuild
16:02:51 <mboddu> #topic #6577 Fedora 26 mass rebuild
16:03:01 <mboddu> #link https://pagure.io/releng/issue/6577
16:04:05 <mboddu> I dont think we need to discuss about it much, since I am still running the needs rebuild and failure scripts and I will run them for 3 more weeks
16:04:13 <mboddu> #link http://dl.fedoraproject.org/pub/alt/mass-rebuild/f26-failures.html
16:04:22 <mboddu> #link http://dl.fedoraproject.org/pub/alt/mass-rebuild/f26-need-rebuild.html
16:05:52 <maxamillion> mboddu: 3 more weeks?
16:06:01 <mboddu> maxamillion: yes
16:06:18 <mboddu> It should be run for 4 weeks at least
16:06:21 <maxamillion> ah
16:06:46 <maxamillion> I've never done a mass rebuild, for some reason I thought it was about a 1 week task
16:07:49 * sharkcz is here
16:08:27 <mboddu> maxamillion: I have never done it either :) but I came to know from our last weeks meeting
16:08:54 <mboddu> since sharkcz is here, we will do alt arches updates before he goes for another meeting ;)
16:09:07 <mboddu> #topic Alternative Architectures updates
16:09:38 <mboddu> sharkcz: ^ any updates?
16:10:26 <sharkcz> yup, things are moving towards the merger of s390 builders into the primary koji, but seems it's more complicated, requires new LPAR to be created, so we won't make it before the branching
16:10:55 <mboddu> sharkcz: when do you think it will done?
16:10:56 <sharkcz> so f26 will live with separate koji instance and koji-shadow
16:11:24 * mboddu dont know about koji-shadow
16:12:06 <sharkcz> no ETA :-( I thought it will be ready today/tomorow, so likely it's end of this week, or the next week
16:12:43 <nirik> even tho it's more work, could we still try and do f26?
16:12:53 <nirik> (as long as it's before alpha freeze)
16:12:55 <dgilmore> we could
16:13:03 <sharkcz> I would like ...
16:13:09 * nirik would really like to get it done
16:13:19 * dgilmore would like to kill off the secondary koji's sooner
16:13:51 <dgilmore> because slipping means 6 more months of running the s390 koji and associated work to sync builds and push updates
16:14:08 <nirik> yeah
16:14:31 <sharkcz> I'll check with the engops guys to see where they are
16:14:38 <nirik> anyhow, lets see when it's ready and do what we can. ;)
16:14:45 <mboddu> dgilmore: when do you think it should be done, since alpha freeze is on Mar 7th?
16:14:48 <dgilmore> Is there somoene I can talk to, in order to get it prioritised?
16:15:05 <nirik> there's a engineering ticket... can pm it to you...
16:15:35 <sharkcz> nirik: you are on the jira ticket too, right?
16:15:37 <dgilmore> mboddu: the schedule is busted :(
16:15:50 <dgilmore> there is supposed to be 2 weeks between branching and freeze
16:16:19 * dgilmore is really sick of people trying to make the schedule too tight
16:16:28 <nirik> sharkcz: not sure. Perhaps not.
16:16:34 <sharkcz> let me check ...
16:17:12 <mboddu> dgilmore: yep, thats what I was wondering, but I thought thats what they wanted.
16:18:05 <Kellin> mboddu: would you please define 'they' in this context if it's in relation to the tight schedule?
16:18:29 <dgilmore> Kellin: schedule is managed by jkurik and fesco
16:18:51 * dgilmore is on fesco but should step down
16:18:54 <mboddu> Kellin: fesco
16:21:22 * nirik accepts all the blame. :)
16:21:52 <nirik> but I don't recall why or if we wanted less time there... and there's lots of chance to point that kind of thing out usually
16:21:52 <sharkcz> and I have one alt-arch related questions - is pbrobinson still the only person who can do updates pushes for alt-arches?
16:23:11 <nirik> as far as I know
16:23:28 * nirik again would be happy to do those if given info on how.
16:23:33 <dgilmore> nirik: I am guessing jkurik did it to make things work, and we missed it
16:24:14 <Kellin> sharkcz: I should be doing it eventually, I still need to learn how from probinson as part of my onboarding
16:24:40 <sharkcz> Kellin: thx, it will be appreciated
16:25:37 <mboddu> Kellin: can you also document it?
16:25:48 <Kellin> mboddu: if there's no documentation, gladly?
16:26:26 <mboddu> Kellin: there is no documentation about it, please do so when you learn from pbrobinson, that will be helpful
16:27:07 * nirik nods
16:27:25 <Kellin> can-do.  is that process still something that will exist after the alternate-archs are merged?  (too new to know how the merge will affect daily processes)
16:27:39 <mboddu> sharkcz: coming back to s390, do you think it can be done before alpha freeze, even though it is scheduled for Mar 7th?
16:28:29 <nirik> Kellin: nope, it should go away with the merge. ;)
16:28:32 <mboddu> Kellin: I dont think so, but we will be keep doing that for older releases(f25,f24)
16:28:38 <nirik> it's only for the next year or so for f25/f24
16:28:47 <sharkcz> mboddu: I hope so, trying to get more info
16:29:41 <sharkcz> we could in theory temporarily reconnect the existing builders to primary koji, but would rather not do that
16:32:05 <mboddu> sharkcz: okay
16:32:44 <mboddu> #info sharkcz is working on the final steps for s390 merge into primary koji and he hopes to get it done before Alpha freeze
16:33:09 <mboddu> #info Kellin will learn and document the alt arches updates process
16:35:04 <mboddu> Sorry, but we went overboard here, lets wrap it up with Open floor
16:35:12 <mboddu> #topic Open Floor
16:35:20 <mboddu> anybody got anything?
16:35:56 <maxamillion> not I
16:37:14 <mboddu> Okay, I will give couple more minutes and end the meeting
16:37:33 <nirik> I have one quick item to mention:
16:37:40 <mboddu> nirik: sure
16:38:21 <nirik> I did a prod->stg koji db sync this weekend. We hit a number of issues, but it's back to working now. I need to adjust playbooks and probibly do another one this upcoming weekend (after the f26 branch)
16:38:42 <nirik> the alt arch builders are at least working ok now there.
16:39:01 <mboddu> nirik: cool
16:39:50 <nirik> hopefully we can get things so its all in the playbook and works
16:40:32 <mboddu> #info nirik did prod->stg koji db sync over the weekend and he hit some issues but its working now. He will run another sync next weekend.
16:41:17 <mboddu> okay, thank you all for joining.
16:41:42 <mboddu> #endmeeting