fedora-latam
LOGS
23:00:25 <athos> #startmeeting Fedora Ambassadors Latam meeting 2016-12-03
23:00:25 <zodbot> Meeting started Sat Dec  3 23:00:25 2016 UTC.  The chair is athos. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:25 <zodbot> The meeting name has been set to 'fedora_ambassadors_latam_meeting_2016-12-03'
23:00:36 <athos> #meetingname fedora-latam
23:00:36 <zodbot> The meeting name has been set to 'fedora-latam'
23:00:44 <athos> #topic Roll Call
23:00:59 <athos> .hello athoscr
23:01:00 <zodbot> athos: athoscr 'Athos Ribeiro' <athoscribeiro@gmail.com>
23:01:10 * athos from Brazil
23:02:44 <athos> do we have quorum?
23:03:00 <athos> yosef7, itamarjp, potty
23:03:09 <itamarjp> .fas itamarjp
23:03:10 <zodbot> itamarjp: itamarjp 'Itamar Reis Peixoto' <itamar@ispbrasil.com.br>
23:03:11 * itamarjp Brazil
23:03:24 <yulytas> .fas yulytas
23:03:24 <zodbot> yulytas: yulytas 'Julita Inca Chiroque' <yrazes@gmail.com>
23:03:47 <athos> alexove rosset ?
23:04:18 <mayorga> .hello mayorga
23:04:19 <zodbot> mayorga: mayorga 'Eduardo Augusto Mayorga' <e@mayorgalinux.com>
23:04:22 * mayorga Nicaragua
23:04:48 <athos> ok, let's get this going. We have one single topic for tonight
23:04:52 <athos> #topic Migration from Trac to Pagure
23:05:01 <athos> #link https://fedorahosted.org/fedora-latam/ticket/365
23:05:08 <echevemaster> Hi athos, did you started the meeting right?
23:05:15 <porfirio> Hi folks.
23:05:19 <alexove> .fas alexove
23:05:19 <zodbot> alexove: alexove 'Alex Irmel Oviedo Solis' <alleinerwolf@gmail.com>
23:05:22 <fredlima> .fas fredlima
23:05:22 <athos> #chair echevemaster
23:05:22 <zodbot> Current chairs: athos echevemaster
23:05:22 <zodbot> fredlima: fredlima 'Frederico Henrique Gonçalves Lima' <fred@fredericolima.com.br>
23:05:23 <rosset> .fasinfo filiperosset
23:05:25 <zodbot> rosset: User: filiperosset, Name: Filipe Rosset, email: rosset.filipe@gmail.com, Creation: 2008-10-30, IRC Nick: rosset, Timezone: America/Sao_Paulo, Locale: pt_BR, GPG key ID: F47674A0, Status: active
23:05:26 * alexove = Peru
23:05:28 <echevemaster> .fas echevemaster
23:05:28 <zodbot> rosset: Approved Groups: packager cla_fedora cla_done ambassadors fedorabugs proventesters cla_fpca provenpackager fedora-br cvsl10n
23:05:28 * fredlima Brazil
23:05:31 <zodbot> echevemaster: echevemaster 'Eduardo Javier Echeverria Alvarado' <echevemaster@gmail.com>
23:05:34 <alexove> hello guys
23:05:41 <potty> .hello potty
23:05:42 <zodbot> potty: potty 'Abdel G. Martínez L.' <abdel.g.martinez.l@gmail.com>
23:05:46 * echevemaster Colombia - Venezuela
23:05:46 <athos> #chair potty
23:05:46 <zodbot> Current chairs: athos echevemaster potty
23:06:02 <porfirio> .hello porfiriopaiz
23:06:03 <zodbot> porfirio: porfiriopaiz 'Porfirio Andrés Páiz Carrasco' <porfiriopaiz@gmail.com>
23:06:08 * porfirio from Nicaragua
23:06:31 <athos> ok, topic is migration from trac to pagure: I will talk a little about it and then you can assume, echevemaster
23:07:26 <athos> Ok, we are having a few problems with the migration, which we have been addressing through the week:
23:07:50 <echevemaster> continue chairing the meeting bro.
23:08:13 <athos> First we had problems with encoding on pagure-importer: it happens that we use non ascii characters which
23:08:34 <athos> ppl from other regions (english speakers) do not use
23:09:23 <athos> Whenever we had a filename with a special character, pagure-importer would abort. I patched it locally and will open a merge request soon
23:09:24 <echevemaster> there is a way for use UTF-8?
23:09:29 <athos> yes
23:10:05 <athos> I already addressed this one :) So, I have a working version here and I will send a MR asap :)
23:10:11 <echevemaster> who is the owner of pagure in infra?
23:10:21 <athos> pingou
23:10:39 <athos> the second problem:
23:10:59 <athos> all the ambassadors regions were using groups in pagure
23:11:15 <athos> they all named their groups: ambassadors-{region}
23:11:28 <athos> like ambassadors-emea or ambassadors-apac
23:11:42 <athos> well, we wanted to follow the pattern and name our group ambassadors-latam
23:12:07 <athos> there was a maximum length restriction in group names in pagure which is 16
23:12:18 <athos> ambassadors-latam has 16 characters :)
23:12:23 <athos> ops, 17
23:12:34 <athos> so we cannot create a group with that name
23:12:58 <athos> we oppened an issue here: https://pagure.io/pagure/issue/1616
23:13:03 <athos> #link https://pagure.io/pagure/issue/1616
23:13:35 <athos> It is already fixed upstream, but we need to wait untill it reaches production
23:14:03 <echevemaster> why it taking time to reach production?
23:14:05 <athos> pingou told me the next version to reach production will probably be 2.10.1
23:14:17 <echevemaster> oh ok, the packaging
23:14:42 <athos> the one in staging is still 2.10... so I believe it will take a few days (or weeks) untill we get that version in production
23:15:02 <itamarjp> athos, lets wait them,
23:15:26 <athos> yes
23:15:49 <echevemaster> ok still we have time, so there is no problem until the next year.
23:16:03 <athos> there was another bug in pagure-importer, where attachment links were broken for groups
23:16:09 <echevemaster> and we have almost all the job made thanks to you.
23:16:17 <athos> I just patched it this afternoon and will send a merge request later as well
23:17:08 <athos> The last thing is: I talked to itamarjp and potty during the week and we decided that we will not import the tags from Trac
23:17:23 <athos> there are too many tags and we never used half of them properly
23:17:31 <athos> so we came up with a new set of tags:
23:17:42 <athos> open, meeting, approved, rejected, reimbursement, closed
23:18:18 <athos> I will create these tags manually and we will only set tags to the OPEN tickets we have and to future tickets
23:18:31 <athos> meaning that old tickets will lose tag information.
23:19:07 <athos> We will have trac as read only for a while, so we will still have the information for some time before trac shuts down completely
23:19:15 <athos> are we all +1 on this?
23:20:25 <echevemaster> from me +1
23:20:46 <athos> what about the others?
23:20:50 <porfirio> +1
23:20:57 <athos> mayorga: itamarjp rosset fredlima yulytas
23:21:00 <itamarjp> +1
23:21:02 <athos> potty:  alexove
23:21:06 <fredlima> +1
23:21:21 <rosset> +1
23:21:21 <potty> +1
23:21:23 <alexove> +1
23:21:40 <yulytas> I think you do not need my +1 since everyone agree it is OK
23:21:58 <athos> #agreed We will create new tags. Trac tags will be lost
23:21:59 <potty> You know I'm closely following this initiative and you are doing en excellent job
23:22:00 <echevemaster> yulytas: all the +1 are important.
23:22:11 <potty> athos++
23:22:26 <fredlima> athos++
23:22:37 <_Teseu_> I can't really say, I don't know the other side of the coin
23:22:48 <athos> one last thing: We need whoever have some extra time this week to take a look at https://stg.pagure.io/fedora-latam/tickets4/issues and help us checking if everything is ok :)
23:22:49 <yulytas> yes echevemaster, but I do not know exactly what are you doing with pagure, I can not vote on this because I did not read at all about this
23:23:02 <athos> look for broken links, missing commets/text, encoding errors, etc
23:23:04 <echevemaster> _Teseu_: what do you mean?
23:23:07 <athos> #link https://stg.pagure.io/fedora-latam/tickets4/issues
23:23:07 <_Teseu_> After what you said, I can only trust your judgement
23:23:13 <yulytas> I will definitely read about it this week to support the athos work
23:23:15 <lorddemon> .fas lorddemon
23:23:16 <zodbot> lorddemon: lorddemon 'Gonzalo Nina Mamani' <g.nina.m@gmail.com>
23:23:49 <_Teseu_> echevemaster, I just don't have suficient info
23:23:54 <athos> so please, take a look at the current staging migration we have here:
23:23:56 <athos> https://stg.pagure.io/fedora-latam/tickets4/issues
23:24:06 <yulytas> sure
23:24:07 <athos> and give us some feedback in #fedora-latam
23:24:18 <yosef7> .hello josereyesjdi
23:24:19 <zodbot> yosef7: josereyesjdi 'Jose A. Reyes H.' <josereyes.jdi@gmail.com>
23:24:19 <athos> you can talk to me, potty, echevemaster or itamarjp if you find any problem
23:25:02 <yulytas> please let me know whenever I can post some work that one of my students did for Fedora
23:25:14 <echevemaster> athos: looks good, I think the problems you had are related with the code and not with the migration.
23:25:25 <_Teseu_> Just like yulytas , I'll read
23:25:37 <athos> Whenever  pagure >= 2.10.1 is deployed, we will perform the migration :)
23:25:47 <echevemaster> in addition the problem with the charset is something that could be solved easily.
23:26:29 <athos> oh yes, it actually was. It took a few minutes to find out where to tweak the code, but we got it done :)
23:26:59 <athos> ok, That was it from my part about the migration
23:27:07 <athos> does anyone have anything to say about it
23:27:08 <athos> ?
23:27:44 <echevemaster> please check all the staging instance, people
23:27:56 <echevemaster> and see if there are any problem before the migration.
23:28:08 <athos> #info we will wait for pagure > 2.10.1 to perform the migration
23:28:09 <echevemaster> please help to athos to check the staging
23:28:20 <yulytas> athos, did you write your work in a post or somewhere?
23:28:34 <yulytas> to find out more information please
23:28:35 <athos> #action LATAM will help checking the stg migration for problems
23:28:55 <echevemaster> yulytas: is something that should be made after the migration not before.
23:29:05 <athos> I am writing everything here yulytas, but I can write it in the Trac ticket after the meeting as well :)
23:29:19 <echevemaster> and should be published in Latam Magazine, I think
23:29:26 <athos> ;O
23:29:38 <athos> ok, shall we move on to open floor then?
23:29:38 <echevemaster> we should give visibility to the athos work.
23:29:39 <yulytas> I am just asking echevemaster, it might help if there a current status of his job
23:30:13 <echevemaster> there is another topic to discuss? athos
23:30:15 <echevemaster> ?
23:30:18 <athos> #topic OpenFloor
23:30:22 <echevemaster> if not, go ahead
23:30:25 <athos> not from here :)
23:30:37 <athos> does anyone want to bring in a topic tonight?
23:30:50 <yulytas> I want to ask a question
23:31:17 <athos> go on yulytas
23:31:25 <yulytas> it is related with a work of one of my students did for Fedora
23:31:44 <yulytas> he already wrote about it, even it is before committed
23:31:45 <yulytas> https://jalexanderi.wordpress.com/2016/11/30/colaborando-a-fedora/
23:32:27 <yulytas> I thought it is good to show to you, since is a work that have not worked in a year for usability problems
23:32:46 <athos> #link https://jalexanderi.wordpress.com/2016/11/30/colaborando-a-fedora/
23:33:32 <yulytas> I hope some of you can help me to contact peppa-peddler or genodeftest if you know them please
23:34:23 <echevemaster> what is happening with peppa-peddler?
23:34:23 <athos> this looks nice yulytas
23:34:34 <athos> did your student post anything in the ticket?
23:34:40 <yulytas> not my work though, it is my sudents work
23:34:55 <echevemaster> sometimes takes time review a pull request and reach production yulytas
23:35:06 <alexove> echevemaster: +1
23:35:27 <yulytas> hmmm I wanted to ask because he found it on git but he does not have a FAS, it is necessary?
23:35:38 <athos> yulytas: I mean, is peppa-peddler your student?
23:36:03 <echevemaster> yulytas: yes it is necessary
23:36:05 <athos> ohh
23:36:05 <echevemaster> why?
23:36:27 <echevemaster> because any contribution should be signed by a FAS+cla
23:36:29 <yulytas> no dear, my students are jaime miranda and jhon rojas, but the autorithy for this proeject seems is peppa-peddler, so I want to contact him
23:37:00 <yulytas> got it echevemaster, I will tell them so
23:37:03 <athos> "nuestro usuario es peppa-peddler"
23:37:03 <yulytas> thanks
23:37:08 <echevemaster> so, you have to wait for the answer of that guy.
23:37:10 <yulytas> yes athos
23:37:44 <yulytas> ok echeve
23:38:02 <athos> echevemaster: I did not get it
23:38:04 <echevemaster> for the answer of that guy to accept the pull request.
23:38:29 <echevemaster> not for the FAS+cla of your students.
23:38:33 <athos> as I read, yulytas students are using the peppa-peddler nickname to address that issue, no?
23:38:34 <echevemaster> athos: ?
23:38:58 <yulytas> no athos, I want to find out who is peppa-peddler, just that
23:39:56 <yulytas> It seems that he is from Fedora, but I do not know him or her
23:39:56 <echevemaster> yulytas: now I dont understand
23:40:04 <athos> but here https://jalexanderi.wordpress.com/2016/11/30/colaborando-a-fedora/, your students say: "nuestro usuario es peppa-peddler"
23:40:08 <echevemaster> peppa is the owner
23:40:14 <echevemaster> of the project
23:40:20 <athos> ohhh
23:40:20 <yulytas> we are waiting for his answer to continue, yes echeve
23:41:05 <echevemaster> this is the original project
23:41:06 <athos> ok
23:41:08 <echevemaster> https://github.com/fedora-infra/apps.fp.o
23:41:29 <yulytas> yes miranda is peppa and he asked me to ask about the commit in charge
23:41:31 <echevemaster> this is the fork
23:41:38 <echevemaster> https://github.com/Peppa-Peddler/apps.fp.o/
23:42:03 <yulytas> he is not online now, but I can ask to join next week? or should I ask in open floor?
23:42:14 <echevemaster> these are the changes from peppa
23:42:16 <echevemaster> https://github.com/fedora-infra/apps.fp.o/pull/45
23:42:22 <yulytas> if he is online, it is better to know what is next :)
23:42:24 <echevemaster> so who is the committer
23:42:26 <echevemaster> ?
23:42:32 <athos> yulytas:
23:42:42 <echevemaster> what is the pull request from your students
23:42:43 <echevemaster> ?
23:42:49 <athos> tell your students to attend the websites meeting AND the infra meeting next week
23:43:20 <echevemaster> yulytas: Jorge Miranda
23:43:20 <echevemaster> Peppa-Peddler
23:43:20 <athos> https://apps.fedoraproject.org/calendar/
23:43:25 <echevemaster> is from peru
23:43:28 <yulytas> great athos
23:43:38 <echevemaster> again peppa is who?
23:43:46 <athos> her students, echevemaster
23:43:55 <yulytas> Jaime Miranda
23:43:57 <athos> they have one accout for the 2 students
23:44:11 <echevemaster> athos: that was not her answer... :(
23:44:13 <echevemaster> ok
23:44:28 <yulytas> yes echeve, athos was so right
23:44:33 <yulytas> :)
23:44:34 <athos> echevemaster: but that's was what they said in the blog...
23:44:44 <echevemaster> no athos, I want to find out who is peppa-peddler, just that
23:44:51 <echevemaster> that was her answer
23:45:04 <echevemaster> so the owner of the project is pyngou
23:45:22 <echevemaster> ahd he decide if the pull reach production
23:45:28 <yulytas> the request from my student was to find @Grinnz and @ralphbean
23:45:48 <yulytas> I missed the nicknames echeve, sorry
23:45:59 <yulytas> I think athos got it!
23:46:17 <echevemaster> ok. ralphbean or pyngou always will answer on the repo.
23:46:23 <echevemaster> about commits.
23:46:31 <athos> ok yulytas: tell them to attend websites and infra meetings next week. They can ping me if they want and I will attend the meeting as well, if they need me to introduce them or sth
23:46:33 <yulytas> that is good
23:46:47 <yulytas> ok
23:46:56 <athos> eof?
23:47:03 <yulytas> yes athos, thanks!
23:47:03 <echevemaster> yulytas
23:47:14 <echevemaster> .fasinfo ralphbean
23:47:15 <zodbot> echevemaster: User "ralphbean" doesn't exist
23:47:19 <echevemaster> .fasinfo ralph
23:47:20 <yulytas> yes echevemaster EOF
23:47:21 <zodbot> echevemaster: User: ralph, Name: Ralph Bean, email: rbean@redhat.com, Creation: 2008-08-14, IRC Nick: threebean, Timezone: US/Eastern, Locale: en, GPG key ID: 9450 4C3A E11D D197 9200  58AB A90E D7DE 9710 95FF, Status: active
23:47:24 <zodbot> echevemaster: Approved Groups: @factory2 @pungi-devel @modularity-wg sysadmin-calendar @commops gitfedora-web web accounts +sysadmin-mote @gitfedoracommunity bzrpython-fedora gitbodhi cla_fedora fedorabugs sysadmin-tools cla_fpca cla_done gitmoksha gitfas bzrpackagedb gitfedorahosted sysadmin-web sysadmin-cvs sysadmin-noc gitfuss +fi-apprentice +packager @fedmsg-announce @gitofftrac sysadmin-main sysadmin-logs (1 more message)
23:47:31 <echevemaster> that is his email
23:47:38 <echevemaster> .fasinfo pyngou
23:47:39 <zodbot> echevemaster: User "pyngou" doesn't exist
23:47:47 <echevemaster> .fasinfo pypingou
23:47:49 <zodbot> echevemaster: User "pypingou" doesn't exist
23:47:51 <athos> it's pingou
23:47:53 <yulytas> :o
23:47:59 <echevemaster> .fasinfo pingou
23:48:00 <zodbot> echevemaster: User: pingou, Name: Pierre-YvesChibon, email: pingou@pingoured.fr, Creation: 2007-04-02, IRC Nick: pingou, Timezone: Europe/Paris, Locale: en, GPG key ID: 10E8730A, Status: active
23:48:03 <zodbot> echevemaster: Approved Groups: wikiadmin @sysadmin-datanommer +fi-apprentice sysadmin-calendar @gitpackagedb-cli fedorabugs cla_fedora cla_done bzrkitchen ambassadors @gitfedora-gather-easyfix @gitfedocal @gitr2spec @sysadmin-nuancier provenpackager +packager sysadmin-test gitelections sysadmin sysadmin-web bzrpackagedb cla_fpca @gittgcaptch2 @gitfedorareview gitfas @bzrhyperkitty gitcopr +bzrpython-fedora (1 more message)
23:48:10 <yulytas> France, ok
23:48:15 <echevemaster> that is the mail of him
23:48:23 <echevemaster> so, please tell to your students.
23:48:25 <yulytas> thank you so much for this
23:48:25 <echevemaster> EOF
23:48:43 <athos> ok
23:48:50 <athos> does anyone else want to bring a topic?
23:48:56 <echevemaster> not, from me
23:49:04 <linuxmodder> .hello linuxmodder
23:49:04 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
23:49:17 <echevemaster> hi linuxmodder o/
23:49:37 <athos> if not, I will end the meeting in 2 minutes :)
23:49:39 <echevemaster> and thanks for the short version :)
23:49:41 <echevemaster> hehehe
23:49:43 <linuxmodder> from famna but been trying to source some ideas from how you all are doing community stuff
23:50:24 <echevemaster> athos: go ahead, end the meeting
23:50:37 <athos> #endmeeting