env-and-stacks
MINUTES

#fedora-meeting-2: Env and Stacks (2015-09-24)

Meeting started by hhorak at 12:03:08 UTC (full logs).

Meeting summary

  1. Fedora dockerfiles -- versions, size, more involvement from E&S (hhorak, 12:04:30)
    1. https://github.com/fedora-cloud/Fedora-Dockerfiles/pull/128 (hhorak, 12:07:28)
    2. some PRs take too long to be merged in Fedora dockerfiles, let's help Scott with that work.. (hhorak, 12:08:12)
    3. ACTION: bkabrda to get in touch with scott tomorrow to see how he can help him (hhorak, 12:12:15)
    4. http://imgur.com/TnpcouY (vpavlin, 12:49:27)
    5. http://imgur.com/TnpcouY (vpavlin, 12:51:49)
    6. it is possible to configure in docker hub what tags should be used for automatically re(build) images (based on github branch and path) (hhorak, 12:56:32)
    7. every tag will require a new build on docker hub, but we can still set up something like git-branch+path -> { docker-tag-a, docker-tag-b } ... i will just create more builds than we'd expect... (hhorak, 13:15:08)
    8. Product Definition Center is a dependency for triggering Docker rebuilds on RPM updates (ncoghlan, 13:17:49)
    9. https://fedorahosted.org/fedora-infrastructure/ticket/4863 (ncoghlan, 13:17:59)
    10. ACTION: vpavlin will setup a demo process and document how we can build the versioned dockerfiles in from https://github.com/fedora-cloud/Fedora-Dockerfiles (hhorak, 13:18:28)

  2. open-floor (hhorak, 13:21:31)
    1. ACTION: hhorak to touch other topics (not covered today) on ML (hhorak, 13:22:00)
    2. https://fedoraproject.org/wiki/Env_and_Stacks/Projects/ImageAssemblyRecommendations (hhorak, 13:25:56)
    3. Layered images are special, since they're the ones that can bring in additional non-RPM bits (gem, maven); 1-to-1 mirrors for those could be implemented by RepoFunnel building on Pulp, but it's still not sure whether this middle step is necessary (hhorak, 13:36:25)
    4. fedora rel-eng plans to build at least the cockpit layered image for f24 and potentially others (hhorak, 13:42:38)


Meeting ended at 13:43:33 UTC (full logs).

Action items

  1. bkabrda to get in touch with scott tomorrow to see how he can help him
  2. vpavlin will setup a demo process and document how we can build the versioned dockerfiles in from https://github.com/fedora-cloud/Fedora-Dockerfiles
  3. hhorak to touch other topics (not covered today) on ML


Action items, by person

  1. bkabrda
    1. bkabrda to get in touch with scott tomorrow to see how he can help him
  2. hhorak
    1. hhorak to touch other topics (not covered today) on ML
  3. vpavlin
    1. vpavlin will setup a demo process and document how we can build the versioned dockerfiles in from https://github.com/fedora-cloud/Fedora-Dockerfiles


People present (lines said)

  1. hhorak (91)
  2. vpavlin (64)
  3. ncoghlan (53)
  4. bkabrda (26)
  5. praiskup (21)
  6. jkaluza (16)
  7. langdon (15)
  8. ttomecek (11)
  9. dgilmore (5)
  10. zodbot (4)
  11. phracek (1)
  12. juhp (0)
  13. walters (0)


Generated by MeetBot 0.1.4.