fedora_coreos_meeting
LOGS
16:31:06 <spresti> #startmeeting fedora_coreos_meeting
16:31:06 <zodbot> Meeting started Wed Oct 11 16:31:06 2023 UTC.
16:31:06 <zodbot> This meeting is logged and archived in a public location.
16:31:06 <zodbot> The chair is spresti. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:31:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:31:06 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:31:21 <dustymabe> .hi
16:31:22 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:31:22 <fifofonix> .hi
16:31:24 <zodbot> fifofonix: fifofonix 'Fifo Phonics' <fifofonix@gmail.com>
16:31:25 <spresti> #topic roll call
16:31:32 <dustymabe> .hi
16:31:33 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:31:35 <spresti> #chair dustymabe
16:31:35 <zodbot> Current chairs: dustymabe spresti
16:31:40 <dustymabe> sorry was a little too fast on my end
16:31:43 <spresti> #chair fifofonix
16:31:43 <zodbot> Current chairs: dustymabe fifofonix spresti
16:31:55 <marmijo> .hi
16:31:58 <zodbot> marmijo: marmijo 'Michael Armijo' <marmijo@redhat.com>
16:32:59 <spresti> #chair marmijo
16:32:59 <zodbot> Current chairs: dustymabe fifofonix marmijo spresti
16:33:14 <spresti> Hi all, just give a few more moments for people to trickle in
16:33:33 <aaradhak> .hello aaradhak
16:33:34 <zodbot> aaradhak: aaradhak 'Aashish Radhakrishnan' <aaradhak@redhat.com>
16:33:47 <spresti> #chair aaradhak
16:33:47 <zodbot> Current chairs: aaradhak dustymabe fifofonix marmijo spresti
16:33:54 <jmarrero> .hi
16:33:55 <zodbot> jmarrero: jmarrero 'Joseph Marrero' <jmarrero@redhat.com>
16:34:02 <spresti> #chair jmarrero
16:34:02 <zodbot> Current chairs: aaradhak dustymabe fifofonix jmarrero marmijo spresti
16:34:44 <mnguyen> .hello mnguyen
16:34:45 <zodbot> mnguyen: mnguyen 'Michael Nguyen' <mnguyen@redhat.com>
16:35:07 <jlebon> .hello2
16:35:08 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:35:10 <spresti> #chair mnguyen
16:35:10 <zodbot> Current chairs: aaradhak dustymabe fifofonix jmarrero marmijo mnguyen spresti
16:35:16 <spresti> #chair jlebon
16:35:16 <zodbot> Current chairs: aaradhak dustymabe fifofonix jlebon jmarrero marmijo mnguyen spresti
16:35:39 <spresti> Alright, I guess we can go ahead and get started
16:35:53 <spresti> #topic Action items from last meeting
16:36:23 <spresti> travier to create a change proposal for F40 for switching away from
16:36:23 <spresti> nss-altfiles for OSTree based systems
16:36:41 <dustymabe> I think travier said he wouldn't be able to come today
16:36:49 <dustymabe> re-action?
16:36:57 <spresti> Sure
16:37:29 <spresti> #action travier to create a change proposal for F40 for switching away from nss-altfiles for OSTree based systems
16:38:38 <spresti> alright, well there were no other action items. Lets move on to meeting topics
16:39:28 <spresti> Well there are no meeting topics to discuss. I guess we can move to open floor
16:39:39 <dustymabe> I think I can interject a few
16:39:42 <dustymabe> if you don't mind
16:39:46 <spresti> Sure
16:40:22 <dustymabe> #topic CVE-2023-38545: SOCKS5 heap buffer overflow in libcurl
16:40:25 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/issues/1593
16:40:42 <dustymabe> new curl CVE
16:40:58 <dustymabe> travier: did some analysis in the ticket: https://github.com/coreos/fedora-coreos-tracker/issues/1593#issuecomment-1757044740
16:41:19 <dustymabe> Based on his analysis I posted: Sounds like we can fast-track this to our development streams when an update is available but probably won't require any out of band releases?
16:41:38 <dustymabe> I'm bringing it up here to raise awareness and to see if anyone disagrees.
16:41:55 <jlebon> that sounds good to me
16:42:08 <mnguyen> sgtm
16:42:42 <jmarrero> sgtm too
16:42:44 <aaradhak> sgtm
16:43:11 <dustymabe> #info based on travier's analysis we will fast track the fix for this to our development streams but won't do any out of band production stream releases.
16:43:19 <jlebon> might be worth posting an `rpm-ostree override replace` example in the ticket once we have a bodhi update
16:43:37 <dustymabe> yeah, WFM
16:43:38 <jlebon> for anyone who wants to get it faster
16:43:56 <dustymabe> ok next up...
16:44:07 <dustymabe> #topic pending action tickets
16:44:13 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/labels/status%2Fpending-action
16:44:40 <spresti> Oh wow thats quite a few
16:44:42 <jlebon> yeah...
16:45:03 <dustymabe> We have a lot of tickets that are pending action. Some of them are decently easy work I think - wondering if anyone is interested maybe we can start to try to tackle some of these.
16:45:56 <jlebon> might be worth doing an early passthrough and label by complexity
16:46:03 <dustymabe> #info We have a lot of tickets that are pending action. Some of them are decently easy work I think - wondering if anyone is interested maybe we can start to try to tackle some of these.
16:46:22 <dustymabe> yeah, probably not something we need to do right here in the meeting. I just wanted to bring it up
16:46:22 <jlebon> i think some of them have clear implementation details while others still require investigation
16:46:27 <jlebon> right yeah
16:46:36 <spresti> +1
16:46:39 <dustymabe> and that was it for topics from me
16:46:56 <spresti> Awesome, thank you for that :) dustymabe
16:47:04 <jlebon> probably could use some ordering too
16:47:14 <spresti> #topic Open Floor
16:47:47 <spresti> Ah sorry jlebon, might have been trigger happy on switching to openfloor
16:47:57 <jlebon> np! was mostly done :)
16:48:23 <jlebon> spresti: re. the meeting ticket bot, one thing is that we sometimes tag the `meeting` label quite late
16:48:30 <spresti> Wanted to ask, what the normal time cutoff for meetings should
16:48:33 <spresti> yeah
16:48:42 <jlebon> i wonder if SOP should be to rerender the ticket just before the meeting starts
16:49:15 <spresti> we could change the cron timer to be right on at 16:30 UTC
16:49:19 <dustymabe> #info We are now in final freeze for Fedora 39. We will now produce `next` stream releases weekly to get rapid feedback on the latest F39 content to prepare for final release, which will coincide with `testing` switching to a F39 base.
16:49:56 <dustymabe> FYI we created some automation to generate our agenda for us. Here is today's: https://github.com/coreos/fcos-meeting-action/issues/26
16:50:06 <jlebon> spresti: so it would open the issue at that time? i think it's nice to have the issue ahead of time, but just have a way to rerender the description
16:50:07 <dustymabe> ^^ this is what jlebon and spresti are talking about
16:50:25 <dustymabe> jlebon: the open question there is: does it overwrite any changes someone might have made?
16:51:00 <jlebon> good question
16:51:13 <jlebon> trying to merge might get tricky fast
16:51:23 <dustymabe> yeah, I think it either needs to do one or the other
16:51:48 <jlebon> well, if it's just constrained to the meeting label bit, maybe it's not too bad
16:52:04 <dustymabe> yeah that's fine.. as long as we warn people not to update the description of the ticket directly
16:52:12 <dustymabe> just making it clear, whichever direction we go
16:52:36 <jlebon> no i mean, maybe merging isn't that hard if the only updating is the meeting label section
16:52:57 <dustymabe> ahh, ok.
16:53:14 <spresti> Hmm, yeah am not sure, but with github actions you can have event triggers for the repo the action resides; but can you have the same for exterinal repo's ie: meeting label added ?
16:53:56 <jlebon> i don't think so, i think it could just rerender once at meeting start time
16:54:39 <jlebon> anyway regardless, cool idea :)
16:54:56 <spresti> Ok, I can take care of that enhancement. and thank you!
16:56:25 <spresti> Well, with the silence, I assume we have no other topics to talk about?
16:57:15 <jlebon> yeah, seems like it. you can start a e.g. 1 minute timer
16:57:35 <dustymabe> +1
16:57:46 <spresti> Is there an automation for timers?
16:57:52 <dustymabe> no
16:57:54 <dustymabe> :)
16:57:55 <spresti> oh darn
16:58:01 <spresti> that would be nice
16:58:05 <spresti> for voting and such
16:58:07 <spresti> anyways
16:58:14 <spresti> I guess we can call it
16:58:26 <spresti> #endmeeting