docs
LOGS
18:31:50 <bcotton> #startmeeting docs
18:31:50 <zodbot> Meeting started Wed May 11 18:31:50 2022 UTC.
18:31:50 <zodbot> This meeting is logged and archived in a public location.
18:31:50 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:31:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:31:50 <zodbot> The meeting name has been set to 'docs'
18:31:58 <bcotton> #topic Roll call
18:32:10 <bcotton> #chair darknao pboy
18:32:10 <zodbot> Current chairs: bcotton darknao pboy
18:32:12 <pboy> hi.
18:32:22 <shaunm[m]> .hello shaunm
18:32:23 <copperi[m]> .hello copperi
18:32:23 <zodbot> shaunm[m]: shaunm 'Shaun McCance' <shaunm@gnome.org>
18:32:26 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
18:32:48 <darknao> .hi
18:32:49 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
18:33:00 <bcotton> welcome, friends!
18:33:00 <pboy> .hi
18:33:01 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:34:52 <bcotton> alrighty, let's get started
18:35:11 <bcotton> and hope that my daughter doesn't break her collarbone again this week ;-)
18:35:15 <bcotton> #topic Agenda
18:35:19 <bcotton> #info Announcements
18:35:19 <bcotton> #info Review action items
18:35:19 <bcotton> #info Content plan
18:35:26 <bcotton> #info GitLab followup
18:35:26 <bcotton> #info Revitalization status
18:35:26 <bcotton> #info Open floor
18:35:30 <bcotton> #topic Announcements
18:35:35 <bcotton> #info F36 Final was released yesterday
18:35:57 <bcotton> #help Some F36 release notes remain to be written: https://pagure.io/fedora-docs/release-notes/roadmap/F36
18:36:14 <bcotton> #info thanks to pbokoc and bcotton for getting release notes written
18:36:23 <bcotton> #info We're using the docs-fp-o repo to track meta-work
18:36:23 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issues
18:36:27 <bcotton> #info The Write the Docs Prague CfP is open (conference will be held online this year)
18:36:27 <bcotton> #link https://www.writethedocs.org/conf/prague/2022/cfp/
18:36:32 <bcotton> any other announcements that need to be shared?
18:37:31 <pboy> i just see, a release note for Cockpit file change would be my task. sorry
18:38:29 <bcotton> no worries. and if you want to write more, most of them do not require any deep subject matter expertise ;-)
18:38:31 <bcotton> #topic Previous action items
18:38:31 <bcotton> #info pboy to schedule office hours for the content plan
18:38:40 <bcotton> this leads us to the next topic...
18:38:44 <bcotton> #topic Content plan
18:38:44 <bcotton> #info https://discussion.fedoraproject.org/t/docs-meeting-agenda-2022-05-11/38990/2
18:39:29 <bcotton> the plan in the link above looked good to me
18:39:46 <bcotton> speeding it up a week wouldn't be bad, but we can work with either of those
18:39:59 <bcotton> so i'm  happy to defer to pboy's judgment
18:40:21 <pboy> How do you think could we speed up, what of the alternatives?
18:41:13 <bcotton> the most reasonable place to shorten the timeline would be to have the second office hours the same week as the first
18:41:13 <pboy> (I'm usually a little too impatient.)
18:41:36 <bcotton> i'm not sure we can reasonably shorten it much more than that
18:41:42 <pboy> That's my preference, too,
18:41:54 <pboy> No, we should hurry too much.
18:42:02 <bcotton> and, of course, we could start the work on stg a week or two earlier than in the draft plan
18:42:03 <pboy> should NOT hurry
18:43:00 <pboy> Can everyone join at 2 dates in the week?
18:43:09 <pboy> I don't like to be alone there :-)
18:44:10 <bcotton> i should be able to
18:44:30 <pboy> Thanks.
18:44:32 <bcotton> i'm moving the weekend before, so I may be cleaning my old house on the 31st, but I can take a break to be there for the office hours :-)
18:44:58 <pboy> office hour may be nicer as cleaning
18:45:31 <bcotton> if it's not, we have problems
18:46:17 <bcotton> anyone else have input?
18:46:25 <pboy> OK, 2 date in one week and then let's see, what the outcome is .
18:47:34 <bcotton> anything else on this topic?
18:49:12 <bcotton> #topic GitLab followup
18:49:13 <bcotton> #link https://discussion.fedoraproject.org/t/gitlab-migration-plan/38092
18:49:33 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issue/237
18:49:56 <bcotton> darknao suggested we not bother migrating this repo (flock2017-docs). i'm inclined to agree. any objections?
18:50:36 <pboy> not from me
18:50:49 <copperi[m]> no
18:51:11 <bcotton> darknao: one question that occurred to me: can we migrate open issues to gitlab?
18:51:42 <bcotton> there's something to be said for declaring bankruptcy if we have to, but i imagine there are some issues we'd want to keep
18:51:48 <darknao> well, I was going to ask the exact same thing :)
18:52:20 <darknao> we have few repos with issues and open pull requests
18:53:00 <bcotton> the pull requests are easier to manage since people can update their git remote and resubmit
18:53:32 <darknao> not sure what do to with that, we can either leave them here for now, or take a bit of time to review each of them and see if they are still relevant
18:53:57 <darknao> then choose to drop or move them over gitlab
18:54:08 <pboy> I think we are in the process to review?
18:54:40 <bcotton> yeah, for the MRs we should definitely accept or reject them. i'm not sure if we want to do that with issues. thoughts?
18:54:55 <bcotton> we could ask on the infrastructure list if anyone has already written a pagure-to-gitlab issue migrator. in theory it's a pretty simple matter of a couple of api calls and some field mapping
18:55:23 <pboy> Couldn't we let the open issues on pagure for the time they are open (hopefully not too long)?
18:55:43 <darknao> one example is the template repository i migrated last week: https://pagure.io/fedora-docs/template/issues
18:56:00 <darknao> most issues are 3 years old
18:56:20 <darknao> but still relevant for some of them
18:56:55 <pboy> But obviously nobody complained during the last year?
18:57:17 <darknao> i'm afraid if we decide to leave them on pagure, they'll remain here forever
18:57:38 <bcotton> maybe we should just close them all with a "if you still want this, open an issue at <NEW URL>"
18:57:58 <bcotton> sort of like we do with the EOL bugzilla reports
18:58:13 <copperi[m]> sounds good idea
18:58:22 <bcotton> i don't love it, but it lets us reset without having to spend a ton of time going through each issue. our effort is limited and i'd rather see progress
18:58:59 <darknao> yeah, that's unfortunate but I have to agree
18:59:35 <bcotton> anyone object?
18:59:42 <pboy> no
18:59:48 <darknao> are we going to delete these repo after the migration, or only archive them?
19:00:21 <bcotton> #agreed We'll declare issue bankruptcy when we migrate issues
19:00:33 <pboy> There are some repos not used for years,some empty, we should delete those.
19:00:55 <bcotton> for the active ones, i think we should disable issues and replace the README with a pointer to the new location. and then come back in 6-12 months and delete
19:01:27 <pboy> +1
19:01:44 <darknao> technical question: if we disable issues on a repo, can we still access (read only) the old ones?
19:02:10 <bcotton> we should also send a heads up (commblog post, devel & mindshare mailing lists) before we start in earnest. i can draft that and then we can start knocking them out
19:02:13 <bcotton> good question. i haven't tried
19:03:53 <darknao> I'll try on one of my repo to make sure it works as expected
19:03:53 <bcotton> oh, there's a read-only option
19:03:54 <bcotton> perfect
19:04:06 <darknao> good :)
19:04:10 <bcotton> #action bcotton to draft a "heads up" message about the gitlab migration
19:04:24 <bcotton> #action darknao to verify behavior of "issue tracker read only" setting in pagure
19:04:35 <bcotton> so it sounds like we have next steps. anything else on this one?
19:04:52 <darknao> so since last meeting, i've migrated the template repo
19:05:00 <darknao> it's here https://gitlab.com/fedora/docs/templates/fedora-docs-template
19:05:39 <darknao> it's also available on repo creation, we have a list of templates for the sub group (only 1 for now) that you can use
19:06:12 <darknao> https://gitlab.com/projects/new?namespace_id=15282411#create_from_template
19:06:28 <darknao> you should see the template in the Group tab
19:07:13 <darknao> I also added a basic GitLab CI template that can be used to build/preview your documentation component
19:07:21 <darknao> and publish it on gitlab pages
19:07:34 <darknao> like this: https://fedora.gitlab.io/docs/templates/fedora-docs-template
19:08:01 <darknao> (that's the preview for the template itself)
19:08:25 <bcotton> awesome
19:08:45 <pboy> yeah, looks nice and handsome
19:09:30 <darknao> and that's all I have for this topic
19:09:33 <bcotton> makes me hungry
19:09:39 <bcotton> anything else on GitLab?
19:10:17 <darknao> nothing from me
19:10:30 <pboy> no
19:10:45 <bcotton> #topic Revitalization status
19:10:45 <bcotton> #link https://discussion.fedoraproject.org/t/a-brief-resume-2-months-after-the-revitalization-session/38795/
19:11:50 <bcotton> i think it's fair to say we're not as vitalized as we'd hoped
19:12:27 <pboy> Maybe, how can we improve?
19:13:04 <pboy> Can wwe re-onbord those who we have lost in the last weeks?
19:13:08 <bcotton> good question. i think we have a good plan for getting some work done. so bringing on new contributors seems like a next step
19:13:27 <bcotton> as you noted, we had a bunch of people say they were interested but i haven't seen any chat or discussion or repo activity from them by and large
19:14:06 <pboy> Yes, e.g. py0xc3 , do we know where he is?
19:15:33 <bcotton> no. i see him make occasional comments on a discussion thread and then seemingly disappear for a few weeks (not meant negatively)
19:15:52 <pboy> what a pitty
19:18:04 <bcotton> maybe we're not "sticky" enough?
19:18:13 <pboy> Maybe, we compose a, obviously small, members list on our team page, and then write a commblog with asking for help for2 or 3 of our dedicated project ideas?
19:18:49 <pboy> Or call for members we lost?
19:18:55 <bcotton> my only concern with members lists is that they tend to be out of date pretty quickly in my experience
19:19:00 <bcotton> but it's worth a try
19:20:26 <pboy> Just a question (just curious) @copperi: do you have concrete plans to copntribute to a docs project?
19:22:24 <darknao> I think we all agree we need more contributors, but maybe we should first work on a small list of easy tasks for them to get started?
19:22:43 <pboy> darknao #1
19:22:51 <pboy> darknao +1
19:22:58 <pboy> grrrrh
19:23:25 <bcotton> the Release Notes would be that. maybe we don't have many people noticing our Discussion posts
19:23:29 <pboy> So we may start with a project list on our team pages ?
19:23:43 <bcotton> but there are a lot of un-written F35 notes still, so that might be a good thing for people to fill in before we move the repo?
19:24:49 <pboy> I suppose, writing a note for F35 is not overly cool. :-)
19:25:01 <bcotton> also true :-)
19:25:28 <darknao> well, you have to start somewhere :)
19:25:41 <bcotton> i'm not sure we'll solve this today, but let's keep thinking about it and discuss in that Discussion thread?
19:26:03 <pboy> Yes, we should collect ideas.
19:26:30 <bcotton> #topic Open floor
19:27:03 <darknao> I opened an easy one not so long ago (https://pagure.io/fedora-docs/docs-fp-o/issue/219) but doesn't look attractive enough
19:27:12 <bcotton> One thing that occurred to me is that we should document some of the release-related processes so that pbokoc doesn't need to make sure he's around on release day
19:27:29 <bcotton> between petr, darknao, and me we had things taken care of, but it would be good to write this down
19:27:40 <pbokoc> Yeah, that occurred to me too, about 18 releases ago. I'm just *that* lazy. :D
19:27:52 <bcotton> so i'm planning on writing up draft Standard Operating Procedures to share and let folks tell me where i'm wrong
19:28:03 <bcotton> pbokoc: not lazy, just making space for other contributors ;-)
19:28:17 <pboy> bcotton we should transfer the release guide by pbokoc to out contrib team pages
19:28:20 <pbokoc> bcotton, ah yes, my bad, that's obviously what I meant :-D
19:28:55 <pbokoc> pboy, what do you mean? It's open for PRs
19:29:28 <pboy> I mean the discussion thread. i think we need that permanently?
19:30:31 <bcotton> Ah, I understand
19:30:34 <pbokoc> Ah right.
19:30:37 <pboy> pbokic. this one https://discussion.fedoraproject.org/t/how-to-write-release-notes-fedora-36-edition/38311/2
19:30:47 <pboy> sorry, my keyboard
19:30:56 <pbokoc> Yeah, that would be useful too.
19:31:07 <bcotton> Okay, our hour is up. Anything else for this week?
19:31:26 <pbokoc> #action pbokoc to finally add a relnotes guide to the contributor docs
19:32:42 <bcotton> Okay, thanks everyone!
19:32:43 <bcotton> #endmeeting