fedora_mobility_sig
LOGS
15:30:13 <nirik> #startmeeting Fedora Mobility SIG
15:30:13 <zodbot> Meeting started Mon Apr 11 15:30:13 2022 UTC.
15:30:13 <zodbot> This meeting is logged and archived in a public location.
15:30:13 <zodbot> The chair is nirik. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:30:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:30:13 <zodbot> The meeting name has been set to 'fedora_mobility_sig'
15:30:13 <nirik> #meeting_name fedora_mobility_sig
15:30:13 <nirik> #chair torbuntu pbrobinson _Yoda_
15:30:13 <zodbot> Current chairs: _Yoda_ nirik pbrobinson torbuntu
15:30:13 <nirik> #topic init process
15:33:01 <_Yoda> Yo
15:33:07 <nirik> morning
15:33:16 * nirik waits for folks to arrive
15:33:46 <mph[m]> good morning
15:34:12 <marcin[m]> hi
15:34:52 <javierm> o/
15:35:14 <nirik> ok, lets go ahead and move forward...
15:35:31 <nirik> #topic remix status / issues / plans
15:36:00 <nirik> so, on remixes we have https://github.com/nikhiljha/pp-fedora-sdsetup/releases/tag/ppp-0 and javierm has a github repo with osbuild...
15:36:20 <marcin[m]> and there are Yoda's images
15:36:34 <nirik> yeep
15:36:38 <_Yoda> 5 images daily on ftp, yes
15:36:58 <nirik> have a link handy, I can't seem to find it....
15:37:19 <_Yoda> its in the topic of our channel
15:37:23 <nirik> ha. oops.
15:37:38 <mph[m]> ftp://pine.warpspeed.dk/nightly/pinephone-pro/
15:37:44 <nirik> thanks
15:38:00 <_Yoda> ftp://pine.warpspeed.dk/nightly/
15:38:22 <_Yoda> there is both a pinephone and a pinephone-pro subdir
15:38:25 <nirik> I've not had too much time to test/play with things of late. ;( I do know the keyboard isn't working for me with javierm''s image... haven't tried others or tracked down whats missing
15:38:46 <mph[m]> > I've not had too much time to test/play with things of late. ;( I do know the keyboard isn't working for me with javierm''s image... haven't tried others or tracked down whats missing
15:38:46 <mph[m]> yes
15:39:04 <_Yoda> should work on mine - but my keyboard doesn't seem to work at all
15:39:07 <mph[m]> ppp from ftp looks nice though
15:40:17 <nirik> does anyone know if anything is going upstream in the 5.18.x cycle?
15:40:24 <mph[m]> sure you guys are all over this but it made my day when I finally found the 'terminal' setting in squeekboard to get all the modifier keys
15:40:37 <_Yoda> not that I have heard about
15:40:43 <marcin[m]> ip5xxx_power is upstream now
15:40:49 <marcin[m]> this is keyboard powerbank driver
15:40:53 <nirik> marcin[m]: cool. good news.
15:41:47 <_Yoda> hmm, didn't he just update that driver a few days ago ?
15:41:49 <marcin[m]> other than that, megi basically refactored the power things, but unsure about if it's getting upstream
15:42:02 <nirik> so, I wondered this a long while back, but never did anything on it... shoudl we look at starting to put together a QA checklist? ie, all the things we expect to work, so we can then test images and check that they do work on those things? Or is that too big a task.
15:42:31 <mph[m]> > so, I wondered this a long while back, but never did anything on it... shoudl we look at starting to put together a QA checklist? ie, all the things we expect to work, so we can then test images and check that they do work on those things? Or is that too big a task.
15:42:31 <mph[m]> I'd be happy to help with that
15:42:44 <marcin[m]> yes, he refactored rk818 (2 drivers into 1) and the keyboard input driver
15:42:51 <_Yoda> who do you expect to do the check ?
15:43:25 <nirik> us? or if we can get it down well enough, we might be able to get openqa to run checks on images.
15:44:05 <_Yoda> the last thing sounds nice - but there is no way I can manually do those check on 5 images daily
15:44:33 <nirik> also perhaps a 'tips' page off the pagure project might be nice... like for the squeekboard tip above, or
15:45:24 <nirik> for the tip that I found: removing the phone from the keyboard. Face it away from you, makes it much easier to pry the little groove with your fingernail.
15:45:52 <nirik> _Yoda: yeah, understood... I would expect we would run these on some kind of weekly or monthly image to have a 'last known good' or something
15:46:24 <_Yoda> nirik, that sounds abit more reasonable
15:46:25 <mph[m]> Yeah lots of jigsaw pieces, good to keep organising into coherence
15:46:49 <nirik> yeah, I appologize that I haven't had much time, but I am slowly getting thru my backlog. ;)
15:47:06 <nirik> #topic fedora mainline plans
15:47:23 <nirik> so, I'm happy to write up a change, but we still need things upstreamed...
15:47:33 <be[m]> Hi
15:47:40 <nirik> hey be[m]
15:47:43 <marcin[m]> hi
15:47:45 <_Yoda> upstream will still take a long time
15:48:00 <nirik> yeah, although definitely a lot less so for the ppp
15:48:19 <_Yoda> that goes for ppp too
15:49:11 <javierm> so I wonder if those are orthogonal, like having a phosh spin even if only works on x86 or already supported aarch64 devices
15:49:14 <nirik> sure, nothing is fast. ;)
15:49:15 <_Yoda> last I read megi's log he predicted at least a year for some drivers
15:49:49 <nirik> javierm: I'm not sure the spin would be approved if it didn't work on mobile hw... but I guess we could see...
15:49:58 <_Yoda> I guess both Phosh and Plamo spins is a good idea for x86
15:50:18 <be[m]> I think it would be worth having upstream Phosh and Plasma Mobile spins even if they do not run on PP/PPP yet
15:50:21 <marcin[m]> pp actually has a lot of things upstreamed already, but i'm trying to find a table I inspected a long time ago
15:50:24 <javierm> nirik: but what is mobile HW :) I for example have a Qcom based HP X2 Chromebook, and Fedora workstation works pretty well there
15:50:41 <javierm> even 3d accel with panfrost and upstream mesa
15:50:45 <marcin[m]> javierm: perhaps tablets? qemu?
15:50:55 <nirik> sure, but what use cases are there for running phosh/pasmobile?
15:51:04 <nirik> (that are not phones/handhelds)
15:51:05 <mph[m]> The surface tablets run fedora really well but need touch optimising
15:51:09 <javierm> marcin[m]: yup, that was my point since that chromebook is a table with a detachable keyboard
15:51:14 <javierm> *tablet
15:51:38 <_Yoda> plenty of x86 tablets exist
15:51:45 <javierm> marcin[m]: so having phosh/plasma mobile instead of gnome shell would be neat on that chromebook
15:52:17 <nirik> ok, if you all think there's a userbase there, we could work on tha
15:52:19 <nirik> that
15:52:26 <javierm> just think that starting to put the image bits in place shouldn't be blocked by the lack of progress on the PPP upstreaming work
15:52:34 <_Yoda> and some have shown interest for that on netbooks too (some of them have touchscreens too
15:52:45 <be[m]> With those spins upstream all that should be needed downstream is a kernel package IIUC
15:52:46 <nirik> I just don't want to make offiicial images for them and take up compute and disk space and have 0 people use them
15:53:26 <nirik> be[m]: you mean a non fedora kernel package? not likely to happen for any official spin...
15:53:42 <marcin[m]> we would probably take those official images and create remixes
15:53:42 <be[m]> Yes that is what I mean
15:53:59 <nirik> sure you could.
15:54:02 <marcin[m]> and slowly upstream things from those remixes
15:54:24 <marcin[m]> from userspace there's not a lot of work remaining on the phosh side of things
15:54:31 <nirik> but probibly you would reuse the groups/config and make the remixes... the actual spin image itself wouldn't be of use for that
15:54:56 <marcin[m]> other than the configs, yes
15:55:32 <_Yoda> if the spin is made for arm64, it sure can be used directly to modify it to a remix
15:55:35 <be[m]> javierm: with regards to the osbuilder images, I would like to get them working with btrfs ztsd compression and minimize the size of the generated images so they don't take so long to flash
15:55:39 <nirik> alright, well, I am happy to write up a change for it and get everyones input on it... that part isn't too hard.
15:56:28 <nirik> I'm assuming the Fedora IoT using osbuilder change is approved, we can probibly just do this spins with osbuilder too officially...
15:56:40 <be[m]> I would work on that myself if I could get osbuilder working with btrfs on my machine...
15:56:42 <javierm> be[m]: sure, happy to accept patches. I'm not that familiar with btrfs
15:56:51 <marcin[m]> be: also perhaps people shouldn't use the tow-boot jumpdrive thing since it's slow
15:57:07 <marcin[m]> other distros do installer images for this purpose
15:57:23 <mph[m]> any thoughts of fedora waydroid? could be a huge enabler and bring many new users to linux touch devices
15:57:24 <_Yoda> yeah, so much faster to just flash it from an SD card
15:57:26 <marcin[m]> can we perhaps reuse the liveusb idea?
15:57:27 <be[m]> marcin[m]: Sure, but that is a lot more work
15:57:53 <_Yoda> waydroid is available in COPR
15:58:06 * nirik couldn't get it working last he tried.
15:58:10 <marcin[m]> (after all - pp/ppp with tow-boot from what I know can even boot from usb)
15:58:13 <marcin[m]> me too
15:58:19 <nirik> but yes, waydroid would be great to get going.
15:58:35 <marcin[m]> but things are active and progressing from what I see from my daily `dnf update`
15:58:46 * _Yoda haven't tried waydroid too
15:59:16 <nirik> there is always going to be niche android only apps people need for something or other. ;(
15:59:48 <nirik> #action nirik to write up a proposed change for a Phosh spin and get input from others on it.
16:00:05 <mph[m]> I think running apks only strengthens fedora, it's another option and removes vetos
16:00:30 <_Yoda> why not a plamo spin too ?
16:00:39 <marcin[m]> from what I heard in general, waydroid doesn't work on ppp as of now with hw accel, but things are also moving in this direction
16:01:26 <nirik> _Yoda: I'd be fine with that, but I have 0 idea whats left or what should be in the comps groups, etc. We need those folks to own that.
16:01:29 <scafir[m]> What is the process to add a new spin?
16:01:49 <marcin[m]> _Yoda: upstreaming of plamo parts is kind of behind the phosh efforts
16:02:48 <_Yoda> I'm aware a few packages are in copr yet - but they are not a crusial part of the base
16:03:24 <be[m]> Last I tried Plasma Mobile there was some missing configs or scripts that upstream didn't have neatly organized to package.
16:03:26 <nirik> file a fedora 'change', it goes to the devel list for discussion, then to FESCo (fedora engineering steering comittee) for voting on. If approved you then add kickstarts/osbuild files, comps groups (although those can be there already), and releng adds the spin to the nightly rawhide composes and it's built every day with rawhide. Websites then needs to add it to websites and then The group then needs to fix/adjust it and it releases with the
16:03:26 <nirik> next fedora release.
16:03:27 <_Yoda> I might be able to put a list together of the packages needed, nirik
16:04:05 <nirik> _Yoda: that would be great. If you could make it a fedora-comps PR that would be even better. ;)
16:04:47 <_Yoda> I have no idea about that part :-)
16:05:11 <marcin[m]> _Yoda: https://pagure.io/fedora-comps/pull-request/719
16:05:26 <nirik> as a side note, I tried sxmo the other week... not for me. :) But that is another thing for packaging for someone who likes that interface.
16:06:57 <nirik> alright... any other topics anyone would like to bring up?
16:07:02 <nirik> #topic Open Floor
16:08:34 <_Yoda> I don't really have anything this time
16:08:51 <scafir[m]> I'll try to work a bit this week with podman and osbuild to build ppp images from x86. Any tips or interest to have that shared?
16:09:07 <marcin[m]> yes
16:09:08 <nirik> sure...
16:09:13 <be[m]> If you figure that out, that would be great
16:09:40 <be[m]> So far I have only had partial success with osbuilder running it from my PPP
16:09:49 <mph[m]> nirik
16:09:49 <mph[m]> also perhaps a 'tips' page off the pagure project might be nice maybe expand the wiki https://fedoraproject.org/wiki/Mobility and tasks list?
16:09:52 * nirik has no hw to test, but I guess it could be tested on a laptop with touchscreen...
16:10:19 <nirik> mph[m]: we could... most things are moving off the wiki tho to docs.fedoraproject.org.
16:10:27 <be[m]> I have an x86 laptop with a touchscreen
16:10:55 <marcin[m]> there is a certain idea I have floating for a long time. there's at least a few variables for the different ways to run a pinephone os. one is pp vs ppp. other of those variables is the community modem firmware or stock modem firmware. another is perhaps routing call audio thru modem or via usb audio (but that's fresh as of now). all those need different configuration. so I thought about writing some kind of a configuration manager
16:10:55 <marcin[m]> to maintain this mess.
16:11:06 <nirik> I could look into whats needed to set us up a space on docs.fedoraproject.org... or someone else could? ;)
16:11:32 <marcin[m]> this could clean up the image creating process a little bit by abstracting all those differences in a single package perhaps
16:11:50 <marcin[m]> and enable future hardware someday
16:12:16 <marcin[m]> then this package could be upgraded, so less need to reinstall things
16:12:30 <be[m]> I thought all that was needed for the community modem firmware was to flash it via fwupd
16:12:36 <mph[m]> nirik: I'd be happy to engage with this
16:12:44 <nirik> sure, buf you need to decide to do that. ;)
16:13:01 <nirik> mph[m]: awesome, thanks. I hope fedora-docs folks can point you where you need to go for it.
16:13:14 <marcin[m]> be: oh well, that's the basic part. community modem firmware for example allows you to get from suspend to modem instantly
16:13:28 <marcin[m]> but this needs different configuration
16:13:45 <nirik> the only downside to the community modem fw is that it voids warentee. ;( I wish pine would just ship with it.
16:14:08 <_Yoda> yeah, that is a big issue
16:14:12 <mph[m]> nirik: So migrate wiki to docs and extend it...?
16:14:16 <marcin[m]> nirik: that's the idea I plan to expand on this month. the implementation would be helped by a Ruby script, since that's the environment I know best
16:14:49 <nirik> mph[m]: yeah, basically they just need to set us up a fedora mobility space / repo and we can commit to git there and update/add it.
16:15:04 <_Yoda> our docs are spread all over the place - it would be nice to get them all put together in one place
16:15:06 <nirik> marcin[m]: cool
16:15:30 <be[m]> Python is conventionally used for Fedora tooling, but hey if you're writing it, do what works for you
16:16:14 <nirik> ok, if nothing else will close out and we can all continue back in #fedora-mobility. Thanks everyone for coming! Slow progress is being made. ;)
16:17:17 <nirik> #endmeeting