fedora_prioritized_bugs_and_issues
LOGS
14:01:50 <bcotton_> #startmeeting Prioritized bugs and issues
14:01:50 <zodbot> Meeting started Wed Apr  6 14:01:50 2022 UTC.
14:01:50 <zodbot> This meeting is logged and archived in a public location.
14:01:50 <zodbot> The chair is bcotton_. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
14:01:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:50 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
14:01:52 <bcotton_> #meetingname Fedora Prioritized bugs and issues
14:01:52 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
14:01:56 <bcotton_> #chair bcotton
14:01:56 <zodbot> Current chairs: bcotton bcotton_
14:02:05 <bcotton_> #topic Purpose of this meeting
14:02:06 <bcotton_> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
14:02:08 <bcotton_> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
14:02:09 <bcotton_> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
14:02:13 <bcotton_> #topic Roll Call
14:02:24 <bcotton_> who's here for some fun?
14:02:29 <bittin> .hello bittin
14:02:30 <zodbot> bittin: bittin 'Luna Jernberg' <droidbittin@gmail.com>
14:03:16 * bcotton_ pokes mattdm
14:03:59 <bcotton> oh, wow, it's just that the bridge is...slowwww. ~3 minute lag right now
14:05:35 <bcotton_> well i guess luna and I have all the power today
14:05:41 <bcotton_> mwahahahaha
14:06:08 <bcotton_> #topic Nominated bugs
14:06:10 <bcotton_> #info 5 nominated bugs
14:06:11 <bcotton_> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
14:06:16 <bcotton_> #topic flathub filtered repo seems missing from F35 install
14:06:17 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2011274
14:06:22 <mattdm> I am here sorry
14:06:25 <mattdm> meeting went late
14:06:46 <bcotton_> welcome!
14:06:49 <bcotton_> just in time :-)
14:07:01 <bittin> having problems booting with Kernel 5.18-rc0 in Virtualbox in Rawhide, maybe should find out what exact is wrong and try to report it
14:08:29 <bcotton_> this feels like a pretty good candidate. we talked this up in the release announcement and it apparently...doesn't work?
14:09:45 <mattdm> I'm unsure about the prioritized bug process for this one.
14:10:16 <mattdm> It works for new installs, but needs manual intervention on upgrades, as I understand it.
14:10:17 <mattdm> Right?
14:10:37 <mattdm> It seems like this is something that should either be a priority for Workstation or not a priority for Workstation.
14:11:00 <bcotton_> that appears to be the latest state of it, yes
14:11:01 <mattdm> Am I making sense?
14:11:22 <bcotton_> are you saying "if Workstation WG doesn't think it's a priority, why should we?"
14:12:18 <bittin> what bug #? are we on (reported a bug myself)
14:12:33 <bcotton_> bittin: 2011274
14:12:57 <bittin> thx
14:13:28 <mattdm> Yeah, that's pretty much it. It's their feature....
14:13:57 <bcotton_> mattdm: if you're saying what I think you're saying, that's a reasonable question to ask. I think there's some benefit to the project's credibility to have it work on upgrades, etc. otoh, it's not making things worse so much as less-good, if that distinction makes sense
14:14:48 <bcotton_> given that Workstation is our biggest audience, I'm inclined to say it needs to be a priority even if Workstation doesn't think so :-)
14:15:21 <bcotton_> but i won't fight strongly on it. if they say "we really don't care that much", i'd be inclined to drop it
14:15:51 <bittin> maybe, something to bring up on the Workstation Tuesday meetings?
14:15:56 <mattdm> I guess the crucial question then is: is _this_ the thing we want to spend our "tell Workstation to alter their priorities" arm-twisting power on this month?
14:16:43 <mattdm> Because we don't have a lot of such power, and the less we use it the more we have.
14:17:00 <mattdm> Yeah, I'm inclined to say "Look, we think this is a headline feature, so...."
14:17:20 <mattdm> rather than "We request that you prioritize this."
14:18:07 <bcotton_> makes sense
14:18:46 <mattdm> action mattdm or action bcotton_?
14:18:55 <bcotton_> proposed #agreed BZ 2011274 is softly rejected as a Prioritized Bug. We would like to see this fixed in short order, but don't want to mandate it
14:19:34 <mattdm> +1
14:19:44 <bcotton_> #agreed BZ 2011274 is softly rejected as a Prioritized Bug. We would like to see this fixed in short order, but don't want to mandate it
14:19:54 <bcotton_> #topic kexec-tools built with gcc 12 will fail kexec/kdump jumping to 2nd kernel with kexec_load interface
14:19:55 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2057391
14:21:17 <bcotton_> maybe I just don't know the kernel well enough, but I don't see why this is important
14:22:08 <mattdm> It seems pretty important to kernel developers
14:22:28 <mattdm> Let's not break things for Linus :)
14:22:40 <bittin> seems a patch was provided 29th March (not sure how much job its to implement and test) as i don't do kernel development
14:23:41 <mattdm> It seems like maybe this should be a FE rather than a prioritized bug? I think we need some more info from the nominator.
14:23:42 <mattdm> I mean, +1 to them for using the process though :)
14:23:56 <mattdm> Imma post a question in the bug
14:24:12 <bcotton_> it's also reported against rawhide (although it presumably would affect F36?)
14:24:33 <bcotton_> #action mattdm to ask for more info in the bug
14:24:59 <bcotton_> proposed #agreed BZ 2057391 will be deferred to the next meeting, as the impact and affected releases are unclear
14:26:49 <mattdm> info requested in bug
14:28:19 * bcotton_ will take silence as agreement
14:28:21 <bcotton_> #agreed BZ 2057391 will be deferred to the next meeting, as the impact and affected releases are unclear
14:28:29 <bcotton_> #topic online accounts: can't disable sync on items
14:28:31 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2068470
14:29:09 <bcotton_> this one is also proposed as an F36 Final blocker, so we can either wait until next meeting or provisionally accept it in case it doesn't get accepted as a blocker (which I think it will)
14:29:33 <bittin> +1 FB
14:29:35 <mattdm> yes that was agreeing silence lol
14:29:35 <mattdm> I say provisionally accept if it's not a blocker.
14:29:37 <bcotton_> from a process standpoint, i'd favor just waiting until it's No Longer a Problem
14:29:52 <mattdm> sure. "defer" works. :)
14:30:16 <bcotton_> #agreed BZ 2068470 is deferred pending the outcome of the F36 Final blocker vote
14:30:28 <bcotton_> #topic kernels newer than 5.15.11-200.fc35 cause libgpiod to issue "Unknown error 517"
14:30:29 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2060490
14:31:38 <mattdm> mmmm raspberry pi
14:32:14 <mattdm> oh look I seem to recognize the person who proposed this as prioritized
14:32:26 <mattdm> It is blocking the work of the students as UMass Lowell
14:32:59 <bittin> Don't know enough about Kernels or Raspberry Pi so i go +-0 and let you decide
14:33:35 * bcotton_ activates the jforbes signal
14:33:46 <jforbes> yes?
14:34:40 <bcotton_> hi jforbes, we're talking about RHBZ 2060490
14:34:48 <bcotton_> I saw you posted this link in the BZ:
14:34:48 <mattdm> The Raspberry Pi bug https://bugzilla.redhat.com/show_bug.cgi?id=2060490
14:34:49 <bcotton_> https://lists.fedoraproject.org/archives/list/arm@lists.fedoraproject.org/thread/D5A7YLVSPXXOXGTNETIULVD4VW25EK5U/
14:35:00 <mattdm> one second brb
14:35:13 <bcotton_> but honestly, i'm having trouble keeping grokking the thread
14:35:55 <bcotton_> matthew says this blcoks some UMass Lowell work. do you think there's something we can do to advance this?
14:36:04 <bcotton_> matthew says this blcoks some UMass Lowell work. do you think there's something we can do to advance this?
14:36:07 <jforbes> Yes, I have no information outside of what is in the thread. I have assumed that the arm folks are working on
14:36:13 <bcotton_> whoops, why did i say that twice
14:36:35 <jforbes> Given the general workload, it is not something I will have any time to look at in the next week
14:36:42 <bcotton_> understood, thanks
14:36:54 <bcotton_> i'll check with the ARM folks and see if they are/can work on it
14:36:55 <jforbes> pbrobinson: do you have any update?
14:37:37 <mattdm> From the thread, the issue is the firmware? Or did I misunderstand that?
14:38:23 <mattdm> (and it sounds like the upstream firmware that might fix this also brings a bunch of regressions, which is ... frustrating.)
14:39:04 <jforbes> That is my understanding
14:40:28 <mattdm> Is it worthwhile to keep the kernel bug open at all? Or is there a different tracker for it?
14:40:39 <mattdm> (maybe pwhalen is around if peter isn't?)
14:42:33 <jforbes> I don't know how the arm folks feel about keeping the bug open, I have been following the thread on fedora-arm, but don't really look at old bugs, I look at updates and occasionally add issues to my upstream tracker with bugzilla
14:43:28 <jforbes> But the bug doesn't have any real relevant information that makes it more valuable than the thread that exists
14:44:40 <bcotton_> so it sounds like we probably shouldn't take it as a prioritized bug, but there's no real harm in leaving the BZ open among the many other kernel BZs?
14:45:26 <jforbes> That is my opinion on it, but that is my opinion on pretty much all kernel bugs.
14:45:36 <bcotton_> it's good to be consistent :-D
14:46:00 <mattdm> LOL yeahhhh. I think it's maybe something that would be best tracked as an IoT issue?
14:46:08 <jforbes> The prioritized process doesn't really work at all for kernel.
14:47:09 <bcotton_> proposed #agreed BZ 2060490 is rejected as a Prioritized Bug as it appears to largely be an issue in upstream firmware
14:48:09 <jforbes> It is being tracked on the arm list, I don't know that IoT has separate trackers
14:48:59 * bcotton_ adds the appropriate trackers to the BZ
14:49:10 <pwhalen> I've not been following the bug too closely, but it looks like a firmware issue and not completely in our control. We can discuss it at our next meeting
14:49:25 <bcotton_> #agreed BZ 2060490 is rejected as a Prioritized Bug as it appears to largely be an issue in upstream firmware
14:49:29 <bcotton_> thanks, pwhalen!
14:49:36 <bcotton_> and thanks jforbes for the input
14:49:46 <bcotton_> #topic GDM login screen does not display all users
14:49:48 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2021839
14:49:53 <jforbes> NP
14:50:17 <mattdm> pwhalen++
14:50:17 <zodbot> mattdm: Karma for pwhalen changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:50:33 <mattdm> jforbes++
14:50:34 <zodbot> mattdm: Karma for jforbes changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:50:41 <bcotton_> bittin: i appreciate the enthusiasm, but i'll need to update the flags on the bugs anyway, so i'll comment with links to the minutes after the meeting
14:50:50 <bittin> alright
14:51:57 <mattdm> Hmmm. I don't see how this gdm thing can be any different
14:52:06 <bcotton_> this one seems annoying but there's a workaround and the upstream bug is untouched in the last 5 months
14:52:11 <bcotton_> #link https://gitlab.gnome.org/GNOME/gdm/-/issues/743
14:52:32 <mattdm> If you have it configured with a remote identity provider with 20,000 identities, what is the right behavior?
14:52:43 <mattdm> I'm pretty sure it _can't_ be "list all 20,000 users with an icon"
14:52:56 <bcotton_> yeah, that would be ...suboptimal
14:52:58 <mattdm> And if not that, how does it know what to show?
14:52:59 * bittin agrees
14:53:22 <bittin> maybe the users, that has logged in to that machine before?
14:53:26 <bcotton_> there's something to be said for "remember the people who have logged in before"
14:53:30 <bcotton_> jinx!
14:53:38 <mattdm> And most identity providers won't show you a whole list _anyway_ unless you've authneticated (otherwise, that's a gigantic security/privacy hole"
14:53:40 <bittin> but thats more a feature request, if gdm does not do that
14:54:00 <bcotton_> but even then, there are some cases where that's not suitable either (e.g. a computer lab at a school)
14:54:51 <bcotton_> from the upstream bug: "Without selecting a session type "/var/lib/AccountsService/users/${NAME}" file will not be created"
14:54:53 <mattdm> Yeah.
14:55:27 <bcotton_> that seems like a bug (although again, it could be argued that fixing it makes things worse), but not something i'd prioritize
14:55:46 <mattdm> It's definitely odd behavior if it does create that if you create a session type.
14:55:49 <bcotton_> again "is this really what we want to spend our social capital with Workstation on?" except moreso imo
14:55:57 <bittin> guess its more up to the gdm developer, then the Fedora ones?
14:56:05 <mattdm> s/create/select/
14:57:02 <bcotton_> proposed #agreed BZ 2021839 is rejected as a Prioritized Bug. Although we recognize it's undesirable behavior in some circumastances, it's best left to upstream to decide if it's the behavior they want or if it should be modified in some way
14:57:32 <sobek81> fine with me
14:57:49 <pbrobinson> jforbes: this is the first time I've actually seen that bug report
14:57:49 <mattdm> we've got considerable GDM expertise. Like, halfline
14:57:55 <mattdm> (who I guess is not in this room)
14:57:59 <mattdm> +1
14:58:11 <bcotton_> #agreed BZ 2021839 is rejected as a Prioritized Bug. Although we recognize it's undesirable behavior in some circumastances, it's best left to upstream to decide if it's the behavior they want or if it should be modified in some way
14:58:47 <mattdm> but I'll also add, maybe: "If this is important for Fedora Workstation use cases, it may be useful to raise it with that team for discussion and design work"
14:58:57 <bcotton_> ack
14:59:00 <bcotton_> #topic Accepted bugs
14:59:02 <bcotton_> #info 2 accepted bugs
14:59:03 <bcotton_> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
14:59:05 <mattdm> I'll drop that in.
14:59:25 <bcotton_> we're out of time to go over these, but i'll continue to nudge on them as usual
14:59:33 <bcotton_> #topic Bugs fixed since last meeting
14:59:34 <bcotton_> #info This is to remind ourselves that the process works
14:59:36 <bcotton_> #info Flatpak using excessive space in /var/lib/flatpak/appstream
14:59:37 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2032528
14:59:39 <bcotton_> yay team!
14:59:50 <mattdm> Should we go back to the RPI for a minute while peter is here? :)
15:00:14 <bcotton_> we're out of time, but i'll tag it with the arm and iot trackers
15:00:17 <bcotton_> #topic Next meeting
15:00:18 <bcotton_> #info We will meet again on 20 at 1400 UTC in #fedora-meeting-1
15:00:24 <bcotton_> #undo
15:00:24 <zodbot> Removing item from minutes: INFO by bcotton_ at 15:00:18 : We will meet again on 20 at 1400 UTC in #fedora-meeting-1
15:00:34 <mattdm> pbrobinson: Is my interpretation that it's the firmware update correct?
15:00:35 <mattdm> thanks bcotton_
15:00:36 <bcotton_> #info We will meet again on 20 April at 1400 UTC in #fedora-meeting-1
15:00:45 <bcotton_> thanks everyone!
15:00:46 <bcotton_> #endmeeting