fpc
LOGS
16:00:06 <geppetto> #startmeeting fpc
16:00:06 <zodbot> Meeting started Thu Sep 30 16:00:06 2021 UTC.
16:00:06 <zodbot> This meeting is logged and archived in a public location.
16:00:06 <zodbot> The chair is geppetto. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:06 <zodbot> The meeting name has been set to 'fpc'
16:00:06 <geppetto> #meetingname fpc
16:00:06 <geppetto> #topic Roll Call
16:00:06 <zodbot> The meeting name has been set to 'fpc'
16:00:54 <carlwgeorge> .hi
16:00:55 <zodbot> carlwgeorge: carlwgeorge 'Carl George' <carl@redhat.com>
16:01:06 <decathorpe> .hello2
16:01:07 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
16:01:53 <geppetto> #chair carlwgeorge
16:01:53 <zodbot> Current chairs: carlwgeorge geppetto
16:01:56 <geppetto> #chair decathorpe
16:01:56 <zodbot> Current chairs: carlwgeorge decathorpe geppetto
16:09:06 <geppetto> #topic Open Floor
16:09:12 <geppetto> Anyone need to talk about anything?
16:09:27 <geppetto> I commented on https://pagure.io/packaging-committee/issue/1099 this morning
16:10:16 <geppetto> tibbs did too
16:10:34 <geppetto> I'm fine with leaving it or changing it or removing it
16:10:42 <decathorpe> I haven't followed that ticket yet, I'll catch up on it later
16:11:18 <geppetto> Yeh, I don't think it's a big deal … I know when legal wanted the license file shipped people were worried about the sizes of images etc.
16:11:32 <geppetto> but I don't think that's really been our problem there
16:12:03 <geppetto> Anyway … anything else we should get a ping on before I close for the week?
16:12:31 <tibbs> Damn, sorrty.
16:12:37 <decathorpe> I don't think so.
16:12:39 <geppetto> tibbs: no problem
16:12:45 <tibbs> I'm sitting here doing other things and didn't notice the time.
16:13:12 <tibbs> I tried to work on open PRs and any issues which were recent and got things a bit more under control.
16:13:47 <tibbs> There are a number of PRs tagged as meeting, but those won't show up in a ticket report, which is mildly annoying.
16:14:47 <geppetto> tibbs: They should show up in the PR report: https://pagure.io/packaging-committee/pull-requests?tags=meeting
16:15:09 <tibbs> Huh.
16:15:22 <tibbs> OK, well that's good.
16:15:41 <tibbs> I'm not sure we actually talked about some of them, though.
16:17:10 <tibbs> And at some point we really need to talk about the build constraints thing, because that's just a mess.
16:20:17 <decathorpe> yeah, I'd rather not document something that's broken and was not fixed after receiving negative feedback.
16:20:43 <Eighth_Doctor> I believe Michel is coming back from paternity leave soon
16:20:50 <Eighth_Doctor> so he can look at this when he's back
16:20:55 <geppetto> #chair Eighth_Doctor
16:20:55 <zodbot> Current chairs: Eighth_Doctor carlwgeorge decathorpe geppetto
16:21:02 <geppetto> #chair tibbs
16:21:02 <zodbot> Current chairs: Eighth_Doctor carlwgeorge decathorpe geppetto tibbs
16:21:04 <Eighth_Doctor> 👋
16:22:00 <geppetto> Technically that's 5 … if we want to do anything we need quorum for
16:23:21 <tibbs> Well, I wouldn't mind getting opinions on the build constraints thing.
16:23:38 <tibbs> Technically that's https://pagure.io/packaging-committee/pull-request/1094 but the issue is bigger than the PR.
16:23:43 <geppetto> This seems like a trivial change: https://pagure.io/packaging-committee/pull-request/1064
16:24:30 <tibbs> I didn't just merge 1064 because honestly I've forgotten most of the context around the hardened build stuff.
16:24:56 <tibbs> It does seem OK to me.
16:25:18 <tibbs> But an ack from someone who remembers more about it would be good.
16:27:17 <geppetto> Not sure who that would be :)
16:28:33 <Eighth_Doctor> I remember most of it :)
16:28:36 <decathorpe> The change looks good to me, but the line breaks look weird
16:28:56 <Eighth_Doctor> yeah
16:29:22 <tibbs> It's an attempt to use semantic line breaks as requested, but.... it's not.
16:29:23 <decathorpe> other than that ...
16:29:50 <tibbs> I can merge and then re-flow since that's most of what I've been doing lately anyway.
16:30:08 <decathorpe> that would be great
16:30:24 <tibbs> OK, I'll just do that.
16:30:30 <geppetto> Cool
16:30:42 <geppetto> Anything else?
16:30:59 <geppetto> If not I'll close early and give you all 30 mins. back
16:31:13 <tibbs> I mean, 1094 unless we really don't want to talk about it.
16:31:32 <geppetto> I had a look at it
16:31:39 <Eighth_Doctor> let's not and wait for salimma to get back first
16:31:46 <geppetto> It seems like it needs someone to talk to upstream a bunch and come up with a new patch
16:31:53 <geppetto> so ¯\_(ツ)_/¯
16:32:14 <geppetto> Is there anything we can do?
16:32:25 <Eighth_Doctor> I'm more annoyed at how unresponsive upstream is until someone does something to make them upset
16:32:30 <tibbs> We can remove the macros from redhat-rpm-config
16:32:32 <Eighth_Doctor> being proactive is almost not worth it
16:33:04 <geppetto> tibbs: Are there any downsides right now?
16:33:07 <tibbs> Panu raised objections well before this stuff was pushed.
16:33:19 <tibbs> I don't see how that's too late or unresponsive.
16:33:22 <geppetto> Can we just add a comment that says "this is a huge hack and upstream wants it down differently"?
16:33:32 <tibbs> And then they went and rewrote the macros and didn't even give him time to comment.
16:34:03 <tibbs> I agree that there have been issues with responsiveness in the past, but I just don't see that in this specific instance.
16:34:57 <tibbs> I tried to get a clear statement from Panu as to what he would prefer that we do, just so we can take it into consideration.
16:35:02 <tibbs> But I don't think we really got that.
16:35:25 <geppetto> yeh, hence the need to talk to upstream a bunch more
16:35:36 <tibbs> And I don't think I have the ability to personally implement what he outlined.
16:36:21 <tibbs> And the last statement he made seemed to me like "I wish it could have been done the right way" instead of "please remove it while we work up something that's more acceptable".
16:37:03 <tibbs> Which just doesn't help me make any kind of decision about what we should actually do.
16:37:06 <decathorpe> my understanding is that that the macro would need to be a "simple" lua script that set _smp_build_ncpus globally for it to be generally useful
16:37:37 <decathorpe> and right now it just evaluates to "-j N" with N depending on the argument and available memory
16:39:43 <tibbs> Looking at it more closely, I can say this: %limit_build is not intrusive and is limited in scope.  The underlying situation is unfortunate but really the macro is kind of a small thing which doesn't hurt anything.
16:40:24 <decathorpe> yeah, but it's just not all all like the feature that was proposed and approved by FESCo.
16:40:25 <tibbs> If we one day implemented what Panu wanted, which is some way to scale RPM's idea of the CPU count, then that wouldn't really interfere with this macro, and this macro wouldn't interfere with that unless we wanted to use the name.
16:41:02 <tibbs> To be fair I did not pay attention to that FESCo process.  (There are a lot of things that move through the feature process.)
16:41:26 <decathorpe> so, I mean, FPC can document this macro, but we shouldn't pretend that this is what was originally envisioned
16:41:39 <tibbs> Is FESCo is happy with how the the implementation matches the feature proposal?
16:42:45 <decathorpe> speaking for myself, no. it's just completely different in both usage and implementation.
16:45:05 <tibbs> Well if FESCo wouldn't be satisfied then that's a whole different conversation, I think.
16:45:28 <tibbs> Just shows how badly this was all done, even though it's not really a big thing.
16:45:45 <tibbs> Let me take a look and see if I can figure out what an implementation would look like.
16:45:53 <tibbs> But maybe FESCo should have its own conversation.
16:46:58 <decathorpe> I think it was this ticket: https://pagure.io/fesco/issue/2642
16:47:34 <decathorpe> should we add a comment there?
16:47:55 <geppetto> #action tibbs Will look at #pr-1094 and see if he can find out what an upstream happy implementation would look like.
16:48:10 <geppetto> decathorpe: You seem like the perfect person to do that
16:49:04 <decathorpe> yeah, given that I processed that ticket :)
16:49:29 <geppetto> Also that you are in both groups :)
16:50:07 <decathorpe> that also applies to two others here ;)
16:51:54 <geppetto> fair
16:52:26 <decathorpe> geppetto: https://pagure.io/fesco/issue/2642#comment-754095
16:53:16 <geppetto> Seems like an easy enough question
16:54:27 <decathorpe> I hope so
16:54:46 <decathorpe> as I seem to have problems communicating without upsetting people today shrug
16:55:28 <geppetto> eh, sometimes we have those days … and sometimes other people are heving them with us
16:56:02 <geppetto> Anyway … 5 mins. left so I'm really getting ready to close now ;)
16:58:58 <geppetto> #endmeeting