fedora_cloud_meeting
LOGS
16:07:11 <Eighth_Doctor> #startmeeting fedora_cloud_meeting
16:07:11 <zodbot> Meeting started Tue May 25 16:07:11 2021 UTC.
16:07:11 <zodbot> This meeting is logged and archived in a public location.
16:07:11 <zodbot> The chair is Eighth_Doctor. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:07:11 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
16:07:17 <jdoss> .hi
16:07:18 <zodbot> jdoss: jdoss 'Joe Doss' <joe@solidadmin.com>
16:07:21 <Eighth_Doctor> #topic roll call
16:07:31 <Eighth_Doctor> .hello ngompa
16:07:32 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:07:48 <jdoss> .hi
16:07:49 <zodbot> jdoss: jdoss 'Joe Doss' <joe@solidadmin.com>
16:08:17 <Eighth_Doctor> #chair jdoss
16:08:17 <zodbot> Current chairs: Eighth_Doctor jdoss
16:08:42 <michaelgugino> .hello2
16:08:43 <zodbot> michaelgugino: michaelgugino 'Michael Gugino' <gugino.michael@yahoo.com>
16:09:19 <Eighth_Doctor> #chair michaelgugino
16:09:19 <zodbot> Current chairs: Eighth_Doctor jdoss michaelgugino
16:11:58 <Eighth_Doctor> well, I guess that's everyone?
16:12:10 <Eighth_Doctor> davdunc had a meeting conflict so he's not here today
16:12:23 <davdunc> I am here in spirit.
16:12:32 <jdoss> \o/
16:12:34 <Eighth_Doctor> then say hello at least :)
16:12:51 <Eighth_Doctor> #chair davdunc
16:12:51 <zodbot> Current chairs: Eighth_Doctor davdunc jdoss michaelgugino
16:12:59 <davdunc> .hello2
16:13:00 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
16:13:25 <Eighth_Doctor> and dustymabe is off doing CoreOS things, I think?
16:13:58 <Eighth_Doctor> so I think that's it, so...
16:14:09 <Eighth_Doctor> #topic Action items from last meeting
16:14:55 <Eighth_Doctor> while it wasn't explicitly #action'd, davdunc and I did work on making the Change proposal for switching Fedora Cloud to Btrfs
16:15:35 <Eighth_Doctor> #info davdunc and Eighth_Doctor submitted Change for switching Fedora Cloud to Btrfs
16:15:48 <Eighth_Doctor> #link https://fedoraproject.org/wiki/Changes/FedoraCloudBtrfsByDefault
16:16:07 <davdunc> https://pagure.io/releng/issue/10129
16:16:28 <davdunc> should have used the meta tag.
16:16:31 <davdunc> #link https://pagure.io/releng/issue/10129
16:17:29 <Eighth_Doctor> The Change itself is very straightforward and simple
16:18:58 <Eighth_Doctor> I guess that's it for that, so...
16:19:29 <Eighth_Doctor> oh right, also note that this corresponds to a cloud-sig ticket
16:19:39 <Eighth_Doctor> #link https://pagure.io/cloud-sig/issue/308
16:19:53 <davdunc> thanks. That's important.
16:19:53 <Eighth_Doctor> anyone have any questions about it?
16:20:33 <Eighth_Doctor> I guess we're good here, so next one...
16:22:37 <Eighth_Doctor> #topic fedora cloud image: enable ipv6 (accept RAs by default)
16:22:42 <Eighth_Doctor> #link https://pagure.io/cloud-sig/issue/320
16:23:07 <davdunc> I think this was something I was supposed to provide a functional test for.
16:24:07 <Eighth_Doctor> yeah, there's a note by dustymabe that you were going to help us switch the networking to NM and make sure this is cleaned up: https://pagure.io/cloud-sig/issue/320#comment-705539
16:24:23 <davdunc> I'll pick that back up.
16:24:26 <Eighth_Doctor> awesome
16:24:49 <Eighth_Doctor> so next on the list...
16:24:55 <Eighth_Doctor> #topic Move Fedora cloud images to GPT
16:25:01 <Eighth_Doctor> #link https://pagure.io/cloud-sig/issue/330
16:25:25 <Eighth_Doctor> Fedora Infrastructure is requesting that we switch the cloud images to GPT because they're having issues with how it is now
16:25:54 <Eighth_Doctor> my thought is that we should bundle this and enabling hybrid UEFI support into the images with the Btrfs change
16:26:16 <Eighth_Doctor> #link https://pagure.io/cloud-sig/issue/309
16:26:20 <davdunc> that sounds like the best idea here.
16:26:36 <Eighth_Doctor> since we're going to have to fiddle with the storage for everything anyway
16:26:38 <Eighth_Doctor> we might as well do that
16:27:15 <Eighth_Doctor> davdunc: does that make sense to you?
16:27:33 <davdunc> it does. I am not being more vocal because I am in the other meeting.
16:27:37 <Eighth_Doctor> sure
16:28:04 <Eighth_Doctor> davdunc: it's probably worth making a self-contained change for that, so that the world knows we're doing it
16:28:17 <Eighth_Doctor> or system-wide change like we did for btrfs
16:28:30 <Eighth_Doctor> we can discuss it later when you're not double-booked :)
16:28:46 <cyberpear> can anaconda do the hybrid UEFI/BIOS supported disks?
16:28:59 <Eighth_Doctor> it can when you fiddle with it manually
16:29:11 <cyberpear> interesting
16:29:16 <Eighth_Doctor> since we'd be forcing GPT anyway, that makes things simpler
16:29:24 <Eighth_Doctor> that's already half the battle
16:29:40 <Eighth_Doctor> also, hello cyberpear
16:29:54 <Eighth_Doctor> don't think you said hi :)
16:29:58 <Eighth_Doctor> #chair cyberpear
16:29:58 <zodbot> Current chairs: Eighth_Doctor cyberpear davdunc jdoss michaelgugino
16:30:01 * cyberpear arrived late
16:30:57 <Eighth_Doctor> #agreed Fedora Cloud images will move to GPT and be configured as hybrid BIOS+UEFI images
16:31:43 <Eighth_Doctor> #info davdunc will work on a Change proposal for switching to GPT with hybrid BIOS+UEFI
16:31:58 <Eighth_Doctor> #undo
16:31:58 <zodbot> Removing item from minutes: INFO by Eighth_Doctor at 16:31:43 : davdunc will work on a Change proposal for switching to GPT with hybrid BIOS+UEFI
16:32:17 <Eighth_Doctor> #action davdunc will work on a Change proposal for switching to GPT with hybrid BIOS+UEFI
16:32:20 <davdunc> :D awesome.
16:33:03 <Eighth_Doctor> and our final topic for the day...
16:33:09 <Eighth_Doctor> #topic Fedora-34 nightly images in AWS do not boot
16:33:13 <Eighth_Doctor> #link https://pagure.io/cloud-sig/issue/331
16:33:35 <dustymabe> Eighth_Doctor: sorry this other meeting got me bogged down
16:33:53 <Eighth_Doctor> I have no idea what's going wrong here, but maybe someone has some idea?
16:34:06 <jdoss> I tried to boot everything last week and verified its hosed
16:34:17 <Eighth_Doctor> #chair dustymabe
16:34:17 <zodbot> Current chairs: Eighth_Doctor cyberpear davdunc dustymabe jdoss michaelgugino
16:34:24 <jdoss> via QEMU but I ran out of time to debug further.
16:34:39 <Eighth_Doctor> jdoss: do you want to take on investigating this and helping make a fix?
16:34:45 <jdoss> Not really lol
16:34:49 <Eighth_Doctor> hah
16:34:52 <jdoss> I don't have a lot of time for the next month
16:34:56 <Eighth_Doctor> :(
16:35:11 <jdoss> sorry, launching some stuff end of the month and I expect my FOSS free time to limited.
16:35:34 <Eighth_Doctor> I don't really know how to debug this myself :/
16:35:42 <jdoss> yeah I hit that wall myself last week.
16:35:43 <davdunc> jdoss: i'll keep you in the loop so you can provide input
16:36:05 <jdoss> how we fart out images is a blackbox to me.
16:36:14 <Eighth_Doctor> davdunc: so you want to look at this?
16:36:29 <davdunc> yes.
16:36:31 <davdunc> I do.
16:36:40 <jdoss> davdunc is the hero we need
16:36:55 <davdunc> I can dig into the problem
16:37:00 <Eighth_Doctor> indeed 🎉
16:37:35 <Eighth_Doctor> #action davdunc will investigate the issue with Fedora 34 Cloud nightly images not booting in AWS
16:37:54 <Eighth_Doctor> it's probably necessary to figure that out anyway since we want bootable images for F35 :)
16:38:14 <jdoss> I did notice that in the OpenQA system that shows some images booting.
16:38:20 <Eighth_Doctor> hmm
16:38:39 <Eighth_Doctor> so our images are built with Oz/ImageFactory, which orchestrates Anaconda
16:38:42 <jdoss> I am trying to find the link I saw
16:39:31 <Eighth_Doctor> anyway... with that topic over, we are now in...
16:39:35 <Eighth_Doctor> #topic Open Floor
16:39:43 <Eighth_Doctor> anyone have anything they want to bring up?
16:40:23 * Eighth_Doctor hears crickets
16:40:46 <jdoss> https://openqa.fedoraproject.org/tests/overview.html?distri=fedora&version=34&build=Fedora-Cloud-34-20210525.0&groupid=5
16:40:53 <jdoss> This shows it is as booting
16:41:23 <jdoss> on AArch64 but https://openqa.fedoraproject.org/tests/overview.html?distri=fedora&version=34&build=Fedora-Cloud-34-20210525.0&groupid=1 is failing.
16:41:25 <Eighth_Doctor> hmm, so it does
16:41:37 <jdoss> Might be a clue on what is busted. IDK
16:43:31 <jdoss> I am also fiddling with getting Ignition bolted into Fedora Cloud. No major progress yet but I did make a ticket on the SIG to track its work.
16:44:09 <Eighth_Doctor> #info jdoss is fiddling with getting ignition working on Fedora Cloud
16:44:53 <Eighth_Doctor> #link https://pagure.io/cloud-sig/issue/329
16:45:15 <Eighth_Doctor> anything from anyone else?
16:45:45 <Eighth_Doctor> If no one says anything in the next minute, I'll close the meeting
16:46:41 <Eighth_Doctor> Well, then... Thanks for coming, everyone!
16:46:44 <Eighth_Doctor> #endmeeting