fedora_cloud_meeting
LOGS
15:59:56 <dustymabe> #startmeeting fedora_cloud_meeting
15:59:56 <zodbot> Meeting started Tue Apr 27 15:59:56 2021 UTC.
15:59:56 <zodbot> This meeting is logged and archived in a public location.
15:59:56 <zodbot> The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:56 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
16:00:01 <dustymabe> #topic roll call
16:00:04 <dustymabe> .hello2
16:00:04 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:00:12 <otubo> .hello2
16:00:13 <zodbot> otubo: otubo 'Eduardo Otubo' <eterrell@redhat.com>
16:00:16 <cyberpear> .hi
16:00:17 <zodbot> cyberpear: cyberpear 'James Cassell' <fedoraproject@cyberpear.com>
16:00:26 <mcatanzaro> .hello catanzaro
16:00:27 <zodbot> mcatanzaro: catanzaro 'Michael Catanzaro' <mcatanza@redhat.com>
16:00:43 <nb> .hi
16:00:44 <zodbot> nb: nb 'Nick Bebout' <nick@bebout.net>
16:00:53 <Eighth_Doctor> .hello ngompa
16:00:55 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:02:06 <michaelgugino> .hello2
16:02:07 <zodbot> michaelgugino: michaelgugino 'Michael Gugino' <gugino.michael@yahoo.com>
16:02:20 <dustymabe> #topic fedora cloud test day
16:02:27 <dustymabe> we had a test day in the last two weeks
16:02:57 <dustymabe> #link https://communityblog.fedoraproject.org/fedora-linux-34-cloud-test-day/
16:03:15 <dustymabe> #info test day results are at http://testdays.fedorainfracloud.org/events/112
16:03:23 <dustymabe> #chair cyberpear mcatanzaro Eighth_Doctor michaelgugino
16:03:23 <zodbot> Current chairs: Eighth_Doctor cyberpear dustymabe mcatanzaro michaelgugino
16:03:56 <dustymabe> nb is going to work on giving everyone a cookie for participating
16:04:17 <nb> oh yeah
16:04:20 <nb> thanks for the reminder
16:05:02 <dustymabe> #action nb to hand out Fedora Badges to everyone who participated in the test day
16:05:30 <dustymabe> Thanks all for helping out
16:05:37 <dustymabe> #topic  packaging cloud agents for GCP
16:05:43 <dustymabe> #link https://pagure.io/cloud-sig/issue/313
16:05:50 <dustymabe> Eighth_Doctor: I think there are some updates here
16:06:17 <dustymabe> #chair otubo
16:06:17 <zodbot> Current chairs: Eighth_Doctor cyberpear dustymabe mcatanzaro michaelgugino otubo
16:06:22 <mcatanzaro> (note: please ping me when the DNS issue comes up)
16:06:45 <dustymabe> mcatanzaro: I think I know which one you are talking about
16:06:49 <dustymabe> will do
16:06:51 <Eighth_Doctor> yeah, so I approved the GCP packaging reviews
16:07:08 <Eighth_Doctor> I'm waiting for ericdens to import and build them in Rawhide, and then I'll retire my older packages
16:07:32 <dustymabe> #info GCP packaging reviews from ericedens has been approved. pending import and build in rawhide
16:07:45 <dustymabe> Eighth_Doctor: do you mind updating the ticket?
16:08:00 <Eighth_Doctor> yeah I can do that
16:08:56 <dustymabe> #topic cloud-init doesn't properly forward nameservers to systemd-resolved
16:09:01 <dustymabe> #link https://bugzilla.redhat.com/show_bug.cgi?id=1950770
16:09:11 <dustymabe> mcatanzaro: is this the one ?
16:10:25 <mcatanzaro> Um, yes. Somebody invited me here to discuss https://pagure.io/fedora-server/issue/10 but that bug looks like the same issue
16:10:32 <otubo> I'm seeing similar issues across different versions of cloud-init. This is on my backlog but no time to work on that right now.
16:10:46 <mcatanzaro> TL;DR: cloud-init doesn't know about systemd-resolved
16:11:00 <mcatanzaro> That's... kind of all that I have to say about the issue, unless you have questions :P
16:11:10 <dustymabe> nope, yeah that's it
16:11:30 <dustymabe> i've noticed cloud-init updates /etc/resolv.conf, but it's after systemd-resolved has already started
16:11:46 <dustymabe> basically cloud-init needs to push that information to systemd-resolved directly if it's running
16:11:55 <dustymabe> otubo: do you know if there is an upstream bug for this?
16:12:09 <otubo> dustymabe: no but I'm checking right now
16:13:34 <otubo> dustymabe: I see two fixes regarding systemd-resolved but they're too old.
16:13:52 <otubo> dustymabe: and no issue on lanchpad regarding systemd-resolved
16:13:58 <otubo> *launchpad
16:14:03 <dustymabe> cool, do you think that's something you can look at soon? I'm familiar with the problem so if you need help getting up to speed I can help
16:14:52 <mcatanzaro> IMO cloud-init should install a [Resolve] drop-in file into /etc/systemd.conf.d
16:15:12 <dustymabe> mcatanzaro: correct, that would be my preference
16:15:15 <otubo> dustymabe: not really soon. I have a customer problem in my hands at the moment, next a CVE and a rebase for RHEL-9. Probably two weeks I'll be able to get to that.
16:15:25 <dustymabe> two weeks is fine
16:15:53 <otubo> mcatanzaro: dustymabe: then it's a deal :)
16:16:09 <otubo> I'm also planning a rebase for Fedora Rawhide so we don't fall behind.
16:16:16 <dustymabe> otubo: perfect
16:16:22 <dustymabe> mcatanzaro: any other questions/concerns?
16:16:37 <mcatanzaro> Nope, plan sounds good
16:17:09 <dustymabe> cool
16:17:16 <dustymabe> #topic triage cloud-init bugs
16:17:28 <dustymabe> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&component=cloud-init&list_id=11836878&product=Fedora&query_format=advanced
16:17:43 <dustymabe> otubo: is there any low hanging fruit in that list of bugs?
16:17:57 <dustymabe> maybe we can roll at least the easy ones in to the cloud-init rebase in rawhide
16:18:41 <otubo> dustymabe:probably 1952568 and one that still needs to be filed to drop mock
16:19:01 <dustymabe> there are a couple of security related issues too - would be nice to look at those
16:19:11 <otubo> But I'll handle 1945886 once I backport it for RHEL
16:19:30 <otubo> Yeah, this is the CVE I was talking about ^^^
16:19:44 <dustymabe> ahh ok
16:20:00 <dustymabe> otubo: what about 1944175 ? is that on your radar too?
16:20:37 <otubo> dustymabe: so basically I'm slowly putting some order on the backlogs, I got 25% of time of a new guy on our team. So I might have some more time to triage and work on other branches as well
16:21:07 <dustymabe> perfect. maybe let's just revisit this bug list once a month and we'll see if we can help knock these out for f35
16:21:15 <dustymabe> sound good?
16:21:27 <otubo> dustymabe: 1944175 - I'm pretty sure this is already fixed for rhel, if IIRC. Might be easy to backport
16:21:35 <dustymabe> +1
16:21:39 <dustymabe> that's great news
16:21:43 <otubo> Sounds good :)
16:21:50 <dustymabe> #topic open floor
16:22:10 <dustymabe> any other topics for today? F34 has been released so we can take advantage of it now!
16:25:34 <dustymabe> I'll close out the meeting in a minute if no other topics
16:25:58 <dustymabe> #endmeeting