fpc
LOGS
16:01:10 <geppetto> #startmeeting fpc
16:01:10 <zodbot> Meeting started Thu Mar 25 16:01:10 2021 UTC.
16:01:10 <zodbot> This meeting is logged and archived in a public location.
16:01:10 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:10 <zodbot> The meeting name has been set to 'fpc'
16:01:10 <geppetto> #meetingname fpc
16:01:10 <geppetto> #topic Roll Call
16:01:10 <zodbot> The meeting name has been set to 'fpc'
16:01:54 * limburgher here
16:02:29 <geppetto> #chair limburgher
16:02:29 <zodbot> Current chairs: geppetto limburgher
16:02:40 * Eighth_Doctor waves
16:02:43 <Eighth_Doctor> .hello ngompa
16:02:44 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:02:48 <geppetto> #chair Eighth_Doctor
16:02:48 <zodbot> Current chairs: Eighth_Doctor geppetto limburgher
16:03:21 <austinpowered> hello
16:03:22 * carlwgeorge waves
16:03:45 <geppetto> #chair carlwgeorge
16:03:45 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto limburgher
16:05:06 <tibbs> Hey, folks.
16:05:15 <Eighth_Doctor> hey tibbs
16:05:28 <limburgher> yo
16:05:54 <geppetto> #chair tibbs
16:05:55 <zodbot> Current chairs: Eighth_Doctor carlwgeorge geppetto limburgher tibbs
16:06:30 <geppetto> #topic Schedule
16:06:34 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/NRAATGIVGN6M5BF5UKCTPL67SFFCCN3V/
16:07:33 <geppetto> #topic #1055 can't navigate to pkg instructions from fedoraproject.org
16:07:33 <geppetto> .fpc 1055
16:07:34 <zodbot> geppetto: Issue #1055: can't navigate to packaging instructions from fedoraproject.org - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1055
16:08:01 <tibbs> That ticket is weird because the title seems to say the opposite of the content.
16:08:24 <tibbs> Obviously we don't control what goes on fedoraproject.org, so we can't really add links there.
16:08:52 <tibbs> But we can add links from the guidelines to other places, in case people land there after searching.
16:09:51 <limburgher> We certainly need a link on fp.o...
16:10:04 <geppetto> I'm pretty sure bcotton wants links to the guidlines from other places
16:10:23 <Eighth_Doctor> there's a broader problem with fp.o that it doesn't offer an easy path to discover how to become part of the project
16:10:37 <Eighth_Doctor> I'm hoping the websites redesign will account for this
16:11:00 <tibbs> But if links are wanted to us from other places, why ask us to do that when others have far more ability to do so?
16:11:19 <limburgher> Is there an easy way we can put that in that bin? I'm a bit out of the loop on that.
16:12:58 <Eighth_Doctor> we could ask bcotton
16:13:04 <geppetto> Yeh, I ping'd him
16:13:05 <Eighth_Doctor> or riecatnor
16:13:13 <geppetto> But I assume he's at lunch or something
16:13:27 <geppetto> Can just ask him what he wants us to do in the ticket
16:14:57 <carlwgeorge> i read it as "link to the join wiki page from the guidelines"
16:15:55 <geppetto> ¯\_(ツ)_/¯
16:17:18 <geppetto> #info We don't really know what we need to do here
16:17:33 <geppetto> #topic #1058 How to handle %lang files in package owned directories?
16:17:36 <geppetto> .fpc 1058
16:17:37 <zodbot> geppetto: Issue #1058: How to handle %lang files in package owned directories? - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1058
16:18:23 * bcotton is here now
16:18:32 <tibbs> So this is the danger of saying "use this bit of magic" instead of saying "do this, which you may be able to accomplish by using this magic".
16:18:56 <Eighth_Doctor> the `%lang()` thing gets used for rpm lang filtering
16:19:13 <Eighth_Doctor> so files can be filtered out if the lang filter rule is activated
16:19:20 <geppetto> Yeh, or yum filtering (not sure if dnf still does it).
16:19:23 <tibbs> But.... how important is that, really?
16:19:23 <Eighth_Doctor> it's done when creating container images, for example
16:19:40 <tibbs> And do we want to back up to 1055 now that bcotton is here?
16:19:58 <Eighth_Doctor> yeah, probably
16:20:02 <geppetto> I'm pretty sure here that the locale files are just in the wrong place?
16:20:06 <Eighth_Doctor> geppetto: dnf can do it, it's not exposed to the user
16:20:17 <Eighth_Doctor> (which is kind of annoying)
16:20:31 <geppetto> Eighth_Doctor: Ahh, the best of both worlds.
16:20:47 <Eighth_Doctor> no API or CLI, but internally can do it
16:20:56 <Eighth_Doctor> which means hacky workarounds for everyone :D
16:21:04 <geppetto> #topic #1055 can't navigate to pkg instructions from fedoraproject.org
16:21:09 <geppetto> Ok, back to bcotton
16:21:16 <geppetto> What do you want us to do?
16:21:54 <bcotton> i don't have a strong opinion. i just moved the issue from BZ :-)
16:22:12 <geppetto> bcotton: What are the options :)
16:22:31 <bcotton> that said, the idea tibbs suggested seems reasonable https://pagure.io/packaging-committee/issue/1055#comment-723033
16:23:28 <tibbs> Unfortunately the ticket isn't really clear, so perhaps I was thinking that it was asking for something it wasn't.
16:23:34 <geppetto> So you want us to add links from the guidelines to other places?
16:23:50 <bcotton> sure, why not? :-)
16:24:02 <bcotton> that seems to be what the original request was getting at
16:24:14 <geppetto> bcotton: We are fine with that … it's just it reads link adding links from other places to the guidelines
16:24:33 <tibbs> The original request seems to want links to some document not associated with us, in places that we don't control.
16:25:55 <tibbs> Of course, if we are to add links to things, we need to know the things.
16:26:30 <tibbs> I've no problems with linking to the Join document, as that has been stable for years and seems to get community maintenance fairly regularly.
16:27:14 <tibbs> I don't know about other things to which we might link.  A community-maintained landing page in the wiki makes more sense than having us curate links.
16:27:28 <geppetto> #action tibbs to add link to Join document from packaging guidelines
16:27:56 <geppetto> I think maybe it's just the how to join (aka. how to become a maintainer)
16:28:16 <geppetto> Like you search for packaging and get the guidelines and want to know how to do that?
16:28:32 <geppetto> But I'm probably fine with other links too if bcotton has some :)
16:29:47 <bcotton> i think that wiki page is probably sufficient
16:30:20 <geppetto> ok, thanks
16:30:42 <geppetto> #topic #1058 How to handle %lang files in package owned directories?
16:31:06 <geppetto> Ok, so as I said … I think the package just installed the lang files in the wrong place here.
16:31:15 <geppetto> So I'd say we want:
16:31:16 <tibbs> I'm not sure that's really "wrong".
16:31:34 <geppetto> 1. Have it put them in the right place (and maybe have the rpm warning make that solution more obvious)
16:31:35 <tibbs> There is a long history of those translation files being all over the place.
16:31:49 <geppetto> 2. Change the macro to look where it's putting them
16:33:26 <geppetto> Eh, I'm not opposed to #2 … but it does seem like <python>/site-packages/<name>/locale/ is a weird place
16:34:17 <tibbs> So I guess for me the questions become: How do we know what a "locale file" is?  The guidelines don't actually say.
16:34:37 <tibbs> And: What locations are acceptable for "locale files"?
16:35:23 <geppetto> I assume rpm is looking for files ending in ".mo" or ".po" or whatever
16:35:23 <tibbs> Once we have that, we can make sure %find_lang works.  But we should also be clear about what we want (proper %lang tags in the %files list) and how %find_lang helps to get that.
16:35:46 <tibbs> And .qm if you ask it, and localized manpages.....
16:36:08 <tibbs> Sadly it's complicated, which is why this question came up in the first place.
16:36:25 * geppetto nods … magic macro should just dtrt ;)
16:37:23 <geppetto> I guess someone should kind of document what the macro is doing … but who wants to volunteer for that?
16:37:30 <tibbs> So perhaps this approach:  Reframe from what we are trying to accomplish.  That would be proper marking of language-specific stuff that doesn't break the package when it's not present.
16:37:52 <tibbs> With the goal of letting rpm filter out optional translations.
16:38:18 <tibbs> And then list categories of files that fall into that, like .mo and .po files.
16:38:31 <tibbs> And then say what %find_lang does and how it helps.
16:38:50 <geppetto> So the macro just runs: /usr/lib/rpm/find-lang.sh
16:39:06 <tibbs> Yeah, and that just generates a list that you can include with %files -f
16:39:09 <Eighth_Doctor> because the alternative would be a goopy horror show of a macro
16:39:20 <geppetto> But don't look at that file
16:39:30 <geppetto> the regexps escapped and took over.
16:39:35 <tibbs> Oh, find-lang.sh is... horrible.
16:41:36 <geppetto> tibbs: So you have a proposal?
16:42:10 <tibbs> Well, we can do it "right" or just try to tweak what we have.
16:42:29 <tibbs> I'm not opposed to doing it right but I have a bad history of saying I'll do stuff and then not getting it done.
16:42:41 <tibbs> Anyway, I can at least outline something and we can see if that's what we want to do.
16:43:16 <geppetto> Yeh, don't volunteer to fix everyting … but if you could outline what need to happen to fix it that'd be good
16:43:30 <tibbs> But I would like to know if it's important that these locale files live in some particular place or if it's OK that they get scattered under random directories like the package in question.
16:43:46 <tibbs> Honestly I have no idea if it even works to put them where that package puts them.
16:43:56 <geppetto> Also, from what I can see in the sh script … it kind of looks like what the package is doing should work … so maybe it's just a bug in find-lang.sh and someone can file that and it'll all go away
16:45:35 <geppetto> tibbs: I don't know … maybe the rpm team do?
16:46:11 <geppetto> Maybe filing a bug against find-lang.sh aka. rpm-build will solve this or get us an answer to that question?
16:47:00 <tibbs> I mean, I don't know how gettext actually finds these files.
16:47:28 <tibbs> How does it know to look way down underneath some python module?
16:48:17 <geppetto> I assume it has some kind of getextpath and will look for subdirs under any of the dirs in that?
16:48:18 <tibbs> Don't want to waste time on that here, but if anyone knows, it would inform what we should be doing.
16:48:52 <geppetto> with the common one being /usr/share/locale … but the app. can basically add anything to it.
16:49:07 <geppetto> that's my dim memory, anyway
16:49:36 <geppetto> But, yeh, I'm fine just having some kind of plan and moving forwards.
16:49:58 <geppetto> Anyone against just filing a bug against rpm-build and seeing what happens?
16:50:27 <geppetto> Or propose any other plan instead?
16:51:53 <tibbs> I can see if anyone knows.
16:52:54 <tibbs> Interestingly, I had to file a bug against find-lang.sh a while back because the license doesn't allow modification
16:53:18 <geppetto> #action tibbs to ask if anyone knows what gettext is supposed to do
16:53:53 <geppetto> Maybe it's generated from some other source?
16:54:01 <geppetto> That would kid of explain the code.
16:54:15 <tibbs> No, it's just from the last century.
16:54:24 <geppetto> lol
16:54:53 <tibbs> Feels like it's from the 80s, really, but it's from 1998.  Kind of surprising.
16:55:40 <tibbs> Anyway, I guess we should move on.  I have some video meeting in five minutes but I can still type here.
16:55:50 * geppetto nods
16:55:55 <geppetto> #topic Open Floor
16:56:09 <geppetto> Anyone have anything else to talk about, quickly?
16:56:25 <Eighth_Doctor> I'm working on the tilde/caret versioning PR
16:56:30 <Eighth_Doctor> asciidoc is "fun"
16:57:26 <cstratak> Hi. Wanted to talk about https://pagure.io/packaging-committee/issue/886 but it seems time is off. Basically if you think it's reasonable for the way forward to sent an email to fedora-devel asking for feedback and then drafting the proposal.
16:58:07 <cstratak> I believe the consensus is that this should be done, from previous comments at the ticket
16:58:49 <tibbs> Yeah, I think it would be great if we could finally get rpath checking turned on.
16:58:56 <geppetto> cstratak: Sure
16:59:17 <tibbs> But we do need to make sure the guidelines match what the BRP script actually does.
16:59:36 <cstratak> tibbs, want to start a thread or should I go ahead with it? Either way would work.
16:59:57 <geppetto> cstratak: Probably better for you to start it
17:00:10 <cstratak> Sure.
17:00:12 <geppetto> cstratak: feel free to ping tibbs though, to make sure he sees it
17:00:26 <cstratak> Will do. Thank you all.
17:00:31 <tibbs> Thanks.
17:00:36 <geppetto> And on that note of volunteering others, I shall end the meeting :)
17:00:41 <geppetto> #endmeeting