f34-beta-go_no_go-meeting
LOGS
17:02:08 <bcotton> #startmeeting F34 Beta Go/No-Go meeting
17:02:08 <zodbot> Meeting started Thu Mar 18 17:02:08 2021 UTC.
17:02:08 <zodbot> This meeting is logged and archived in a public location.
17:02:08 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:08 <zodbot> The meeting name has been set to 'f34_beta_go/no-go_meeting'
17:02:26 <mhroncok> bcotton: oh, but it just ended
17:02:41 <bcotton> #meetingname F34-Beta-Go_No_Go-meeting
17:02:41 <zodbot> The meeting name has been set to 'f34-beta-go_no_go-meeting'
17:02:45 <bcotton> mhroncok: yep :-)
17:02:50 <bcotton> #topic Roll Call
17:02:51 <nirik> morning
17:03:28 <mhroncok> .hello churchyard
17:03:29 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:03:30 * pwhalen is here
17:03:46 <adamw> .hello adamwill
17:03:47 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
17:03:57 <coremodule> .hello2
17:03:58 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
17:04:41 <mboddu> .hello mohanboddu
17:04:41 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:04:59 <bcotton> #topic Purpose of this meeting
17:05:04 <bcotton> #info Purpose of this meeting is to check whether or not F34 Beta is ready for shipment, according to the release criteria.
17:05:09 <bcotton> #info This is determined in a few ways:
17:05:14 <bcotton> #info 1. No remaining blocker bugs
17:05:19 <bcotton> #info 2. Release candidate compose is available
17:05:24 <bcotton> #info 3. Test matrices for Beta are fully completed
17:05:42 <bcotton> #topic Current status - blockers
17:05:47 <bcotton> #link https://qa.fedoraproject.org/blockerbugs/milestone/34/beta/buglist
17:05:56 <bcotton> #info 0 Proposed Blockers
17:06:04 <bcotton> #info 1 Accepted Blockers
17:06:11 <bcotton> #topic (1934124) F34: regressed from authselect to unavailable authconfig, joining AD domain fails: Couldn't join realm: Enabling SSSD in nsswitch.conf and PAM failed.
17:06:17 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1934124
17:06:20 <bcotton> #link https://pagure.io/fedora-qa/blocker-review/issue/313
17:06:24 <bcotton> #info Accepted Blocker, realmd, ON_QA
17:06:37 <bcotton> so the candidate fix for this was in last night's RC3
17:06:52 <bcotton> How's the testing of that going?
17:07:20 <adamw> looks good
17:07:28 <adamw> sgallagh has reported passes for the AD tests, which means this is fixed
17:07:32 <adamw> we can mark it verified most likely
17:08:07 <sgallagh> Yes
17:08:14 <bcotton> #info The candidate fix in RC3 results in AD tests passing. This bug can be marked VERIFIED
17:08:17 <bcotton> huzzah
17:08:48 <bcotton> and no one nominated a blocker in the 8 minutes since the blockerbug app refreshed
17:08:49 <bcotton> #topic Current status - test matrices
17:08:57 <bcotton> #link https://fedoraproject.org/wiki/Category:Fedora_34_Test_Results
17:09:14 <bcotton> Monsieur Williamson, the floor is yours
17:10:16 <mboddu> SHIP IT
17:10:21 <mboddu> :)
17:10:28 <adamw> points upwards
17:10:39 <adamw> broadly: we're mostly okay
17:11:08 <adamw> pwhalen: did you manage to check a 32-bit arm image?
17:11:13 <adamw> ahg
17:11:21 <adamw> coremodule says his image just finished writing
17:11:22 <adamw> so we should have that soon
17:11:22 <pwhalen> adamw: not yet
17:11:46 <lruzicka[m]> .hello lruzicka
17:11:46 <adamw> we're missing a couple of hw tests where we don't have easy access to the hw because pandemic or whatever - hardware RAID and SAS
17:11:46 <zodbot> lruzicka[m]: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
17:11:48 <pwhalen> test them in qemu, but not on hw
17:11:54 <bcotton> RC3 had an anaconda update, right?
17:12:07 <nirik> yeah.
17:12:08 <adamw> yes
17:12:12 <adamw> but we have very good anaconda coverage
17:12:22 <adamw> and it'd been in all the nightlies lately so it's not like it was untested
17:12:43 <adamw> i'm currently writing a stick with FMW on f33
17:12:59 <adamw> other than coremodule's 32-bit arm image test and that, i'd say we're pretty much 100%
17:13:04 <adamw> minus the hw tests we can't do
17:13:15 <coremodule> its booting, give me 30 seconds
17:13:32 <pwhalen> coremodule: minimal?
17:13:49 <adamw> fmw is verifying my stick
17:13:51 <coremodule> no, Fedora-Workstation-34_Beta-1.3.armhfp.raw.xz
17:13:59 <mhroncok> coremodule: 30 seconds are over
17:14:04 <pwhalen> oh, not release vlocking.
17:14:26 * pwhalen is writing out the minimal image now
17:14:44 <bcotton> mhroncok: its DST in the US, our seconds are longer now
17:14:59 <pwhalen> coremodule: workstation armhfp on which hw?
17:15:07 <coremodule> rpi3b+
17:15:13 <pwhalen> yikes :)
17:15:27 <mhroncok> bcotton: durable seconds time?
17:15:46 <bcotton> okay, anything else on this topic? should we let pwhalen test his minimal image first?
17:15:52 <bcotton> mhroncok: Dilated
17:15:57 <adamw> can we wait on my usb stick?
17:16:03 <adamw> it'll be a couple minutes
17:16:12 <adamw> everyone just go "doot doot doot" for a bit
17:16:45 <nirik> doot doot doot
17:17:21 * bcotton does a song and dance routine
17:17:28 <bcotton> it's a shame y'all can't see it
17:17:35 <cmurf> bcotton wins a prize
17:17:39 <adamw> ok it's written, booting it
17:18:11 <adamw> looks good.
17:18:31 * mboddu turns on the secret cam in bcotton's room :P
17:18:48 <adamw> so, i think we're looking good for coverage.
17:18:56 <adamw> thanks to everyone who got testing done at short notice!
17:19:02 <bcotton> hooray!
17:19:05 <bcotton> anything else, anyone?
17:19:06 * mhroncok brb
17:19:49 <bcotton> #topic Current status - RC
17:20:10 <bcotton> #info Beta1.3 is the current release candidate
17:20:27 <bcotton> this one FINSIHED_COMPLETE, yeah?
17:20:38 <mboddu> Nope, its FINISHED :D
17:21:17 <mboddu> One more complete compose to ship
17:21:22 <bcotton> you and your correctly-spelled words
17:21:25 <nirik> the f34 nightlys have also been FINISHEDing... (helps that there are 0 changes due to freeze :)
17:21:44 <bcotton> #info Beta1.3 is FINISHED (no missing deliverables)
17:22:05 <bcotton> It's so nice that we're not randomly missing 3 or 4 deliverables every release
17:22:30 <sgallagh> Indeed
17:22:56 <bcotton> anything else on the RC?
17:23:01 <pwhalen> armhfp minimal looks ok, booting now
17:23:26 * bcotton stalls just a little bit for pwhalen's armhfp test to boot
17:23:37 <adamw> i got nothing, i think it's good to go
17:23:47 <adamw> just sorry that we didn't catch the blocker earlier
17:23:49 <pwhalen> done, booted to initial-setup
17:23:55 <sgallagh> I can tell bad jokes while we wait?
17:23:58 <sgallagh> aww
17:24:05 <bcotton> saved by the boot!
17:24:12 <bcotton> #topic Go/No-Go decision
17:24:18 <bcotton> I will poll each team. Please reply “go” or “no-go”
17:24:22 <bcotton> FESCo?
17:24:29 <nirik> go
17:24:29 <sgallagh> Go!
17:24:37 <bcotton> #info FESCo is GO
17:24:40 <bcotton> Releng?
17:24:51 <nirik> go
17:24:59 <bcotton> #info Releng is GO
17:25:02 <bcotton> #info QA
17:25:06 <bcotton> #undo
17:25:06 <zodbot> Removing item from minutes: INFO by bcotton at 17:25:02 : QA
17:25:08 <bcotton> QA?
17:25:36 <lruzicka[m]> I would say GO
17:25:50 <bcotton> #info QA is GO
17:25:53 <bcotton> #agreed Fedora Linux 34 Beta is GO
17:25:59 <bcotton> #info Fedora Linux 34 Beta will release on 2021-03-23
17:26:07 <bcotton> #action bcotton to announce decision
17:26:08 <nirik> hurray
17:26:12 <bcotton> #topic Open floor
17:26:17 <bcotton> Anything else we need to discuss before closing?
17:26:51 <sgallagh> I have something
17:26:53 <mboddu> Did you record your dancing video?
17:26:53 <lruzicka[m]> Not here
17:26:56 <adamw> what are we drinking
17:27:04 <pwhalen> lots?
17:27:07 <bcotton> adamw: Coke Zero at the moment
17:27:11 <bcotton> sgallagh: go ahead
17:27:32 <nirik> coffee here. :)
17:27:32 <coremodule> the juice left in a can of canned chicken
17:27:34 <mattdm> balvinie double wood :)
17:27:37 <sgallagh> I'd like to give a huge shout-out to the Fedora QA team's efforts to automate so much of the validation process that we were able to do a last-day respin without breaking anyone's soul (that I know of).
17:27:37 * pwhalen is also drinking coke zero at the moment
17:27:49 <bcotton> sgallagh++
17:27:49 <zodbot> bcotton: Karma for sgallagh changed to 10 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:27:54 <sgallagh> Way to go, folks. My hat is off to you.
17:28:24 * nirik welcomes our new robot testing overlords.
17:28:37 <mboddu> sgallagh++ adamw++ lruzicka[m]++ coremodule++ pwhalen++ and all the others who helped in testing it
17:28:37 <zodbot> mboddu: Karma for sgallagh changed to 11 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:28:40 <zodbot> mboddu: Karma for coremodule changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:29:00 <sgallagh> adamw++ lruzicka[m]++ coremodule++ pwhalen++
17:29:00 <zodbot> sgallagh: Karma for adamwill changed to 9 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:29:03 <zodbot> sgallagh: Karma for coremodule changed to 9 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:29:04 <adamw> as long as only robots run the beta, we'll be safe!
17:29:06 <zodbot> sgallagh: Karma for pwhalen changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:29:18 <pwhalen> hhe, right
17:29:19 * mhroncok is back, missed the party mostly, sorry about that
17:29:26 <sgallagh> adamw: I think we've got the coveted Cyclon demographic down at this point.
17:29:28 <bcotton> mhroncok--
17:29:35 <lruzicka[m]> mhroncok: you missed pretty much everything :D
17:29:36 <mhroncok> bcotton: :D
17:29:36 <sgallagh> *Cylon
17:29:38 <mboddu> mhroncok: We are just thanking everyone and drinking :)
17:29:41 <nirik> by your command
17:29:43 <bcotton> okay, well i guess i have an email to send
17:29:49 <adamw> very important market segment, cyclons
17:29:56 <adamw> ...cylons.
17:30:09 <bcotton> thanks everyone! see you in like 3 weeks when we do this again for Final
17:30:10 <mhroncok> cyclons as well
17:30:15 * mboddu starts working on post GO part
17:30:24 <bcotton> #endmeeting