fedora_cloud_meeting
LOGS
16:00:29 <dustymabe> #startmeeting fedora_cloud_meeting
16:00:29 <zodbot> Meeting started Tue Oct 13 16:00:29 2020 UTC.
16:00:29 <zodbot> This meeting is logged and archived in a public location.
16:00:29 <zodbot> The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:29 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
16:00:32 <michaelgugino> .hello2
16:00:32 <zodbot> michaelgugino: michaelgugino 'Michael Gugino' <gugino.michael@yahoo.com>
16:00:36 <cyberpear> .hello2
16:00:37 <dustymabe> #topic roll call
16:00:37 <zodbot> cyberpear: cyberpear 'James Cassell' <fedoraproject@cyberpear.com>
16:01:13 <dustymabe> #chair michaelgugino cyberpear
16:01:13 <zodbot> Current chairs: cyberpear dustymabe michaelgugino
16:03:22 <dustymabe> waiting on neal one sec
16:03:52 <darkmuggle> .hello2
16:03:54 <zodbot> darkmuggle: darkmuggle 'None' <me@muggle.dev>
16:04:04 <dustymabe> #chair darkmuggle
16:04:04 <zodbot> Current chairs: cyberpear darkmuggle dustymabe michaelgugino
16:04:48 <dustymabe> he is supposedly on his way :)
16:05:19 <dustymabe> #chair King_InuYasha
16:05:19 <zodbot> Current chairs: King_InuYasha cyberpear darkmuggle dustymabe michaelgugino
16:05:25 <dustymabe> welcome \o/
16:05:30 <michaelgugino> o/
16:05:34 <King_InuYasha> .hello ngompa
16:05:35 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:05:37 <dustymabe> #topic Action items from last meeting
16:05:42 <dustymabe> We had a lot!!
16:05:48 <dustymabe> * King_InuYasha to discuss the options for packaging go applications
16:05:50 <dustymabe> that use go modules with the golang fedora SIG to see if there are any
16:05:52 <dustymabe> implications there.
16:05:54 <dustymabe> * michaelgugino to schedule some time for a few of us to get together to
16:05:56 <dustymabe> flesh out design and next steps for cloud image upload bits
16:05:58 <dustymabe> * dustymabe to give King_InuYasha access to a project in GCP to do
16:06:00 <dustymabe> testing
16:06:02 <dustymabe> * King_InuYasha to test out f33 fedora cloud base GCP images
16:06:04 <dustymabe> * King_InuYasha to work with davdunc on structure for files to add to
16:06:06 <dustymabe> the cloud-sig repo for AWS marketplace enablement
16:06:11 <dustymabe> #info dustymabe provided GCP credentials to King_InuYasha for testing
16:06:48 <jdoss> .hello2
16:06:49 <zodbot> jdoss: jdoss 'Joe Doss' <joe@solidadmin.com>
16:06:50 <King_InuYasha> oh man, and all on me too :P
16:07:02 <dustymabe> well there was one on michaelgugino and one on me :)
16:07:06 <King_InuYasha> I did at least do the cloud-sig repo thing
16:07:37 <King_InuYasha> I don't have the admin permissions to cloud-sig repo to finish setup though
16:08:02 <dustymabe> ok I can help with that. King_InuYasha will you be working through PRs or direct pushes ?
16:08:27 <King_InuYasha> dustymabe: initially PRs
16:08:38 <King_InuYasha> davdunc seemed more comfortable starting with that
16:08:47 <dustymabe> yeah PRs are preferred for now I think
16:08:56 <King_InuYasha> I just want to also get issue tag, board, and such set up and give him ticket perms
16:08:57 <dustymabe> King_InuYasha: you have admin access now
16:09:09 <King_InuYasha> cool
16:09:36 <dustymabe> anything else to report? anything we should re-action?
16:10:37 <King_InuYasha> dustymabe: do we need me to do GCP testing anymore?
16:10:44 <King_InuYasha> it seems like someone else did it during the test day
16:10:53 <dustymabe> I think michaelgugino may have done some as part of the test day
16:11:07 <King_InuYasha> I can still do it if I can get gcloud to work on my computer
16:11:12 <dustymabe> so we should be good there, but generally it would be nice to know the creds I gave you worked
16:11:16 <King_InuYasha> right
16:11:17 <michaelgugino> yes, I tested it, it was successful for me.
16:11:36 <dustymabe> King_InuYasha: I use the container image for gcloud (running in a rootless podman container)
16:11:37 <King_InuYasha> I wound up discovering issues from f33 resolved change on my particular network configuration for podman
16:11:37 <michaelgugino> My findings are on the test results page, with instructions on what I did if anyone else wants to try.
16:11:43 <King_InuYasha> I think I've got that sorted out now
16:11:53 <dustymabe> +1
16:11:56 <michaelgugino> https://gist.github.com/michaelgugino/e742b83d3950c6cdbfaa25fe262a86bf
16:12:03 <King_InuYasha> so yeah, I'm happy to try if you think it'd be useful
16:12:24 <dustymabe> #action King_InuYasha to discuss the options for packaging go applications that use go modules with the golang fedora SIG to see if there are any implications there.
16:12:41 <King_InuYasha> yup, I'll bring it up with them
16:12:48 <dustymabe> michaelgugino: do you want to give a short report from the video session to discuss the cloud image upload bits ?
16:13:12 <michaelgugino> Sure.
16:14:31 <michaelgugino> Initial plan is to iterate on GCP as first new platform.  We are going to leave fedimg in place and untouched for AWS uploads for now.  jdoss I think was interested in investigating uploading bits to GCP with ansible.  I think we left the how the upload part works TBD for now.  But that's the next item, figuring out how to actually upload the images.
16:14:56 <dustymabe> I took an action item from that meeting too
16:14:58 <michaelgugino> We'll use my new messaging library to watch for messages instead of fedmsg/fedimg.
16:15:19 <michaelgugino> I still need to clean up my repo and push it back upstream so it's more generally useful, builds with pip, etc.
16:15:24 <dustymabe> #action dustymabe to add example to the ticket that shows the command to run to do image uploads to GCP with ore
16:15:41 <dustymabe> sorry for the delay there ^^
16:16:17 <darkmuggle> `ore` is rather nice for doing uploads
16:16:43 <darkmuggle> the only problem is that ore is deep into CoreOS Assembler
16:16:59 <darkmuggle> it be nice to have stand-alone binaries
16:17:22 <King_InuYasha> I've just sent an email to Sean Marlow at SUSE asking for some assistance on Mash
16:17:35 <dustymabe> darkmuggle: honestly I think a pattern that would be OK would just be to have the "app" based off a container that pulled and built `ore` from source.
16:17:37 <King_InuYasha> I got him as a reference from Marcus Schaefer on the public cloud team at SUSE
16:18:08 <dustymabe> ok that looks like all the action items
16:18:14 <dustymabe> let me check for topics
16:19:16 <dustymabe> ok I've got one topic, but we did just start up some discussion on "upload implementation", do we want to make a topic for that now?
16:19:26 <dustymabe> darkmuggle: King_InuYasha? or was that all you wanted to say?
16:19:58 * King_InuYasha shrugs
16:20:11 <King_InuYasha> I thought we had switched topics already
16:20:17 <dustymabe> kk :)
16:20:18 <darkmuggle> I'm good :)
16:20:23 <dustymabe> #topic adding GCP image to the download page
16:20:28 <dustymabe> #link https://pagure.io/cloud-sig/issue/314
16:20:44 <dustymabe> Does anyone want to volunteer to add the GCP image to the cloud download page?
16:20:57 <dustymabe> or know someone who might be able to help us there?
16:21:36 <michaelgugino> To clarify, I did not test any GCP specific image, rather the standard qcow2 image.
16:21:50 <dustymabe> oh, interesting
16:22:04 <dustymabe> you tested that the standard qcow2 image launched in GCP?
16:22:21 <michaelgugino> yes
16:22:22 <King_InuYasha> then it probably still makes sense for me to test the GCP image?
16:22:30 <dustymabe> King_InuYasha: yes
16:22:37 <michaelgugino> previously, cloud-init didn't work (circa fedora 29 or so?) But now it does.
16:22:50 <dustymabe> michaelgugino: interesting, I thought they only accepted a tar.gz file to create an image off of
16:23:14 <michaelgugino> dustymabe: yes, you are correct.  Everything I did is outlined in that gist.
16:23:20 * dustymabe clicks
16:24:09 <dustymabe> well the good news is you shouldn't have to do those image conversion steps in the future
16:24:13 <dustymabe> we have a gcp image
16:24:21 <michaelgugino> I only followed major's steps to upload tar/upload the image, not any of the editing.
16:24:49 <dustymabe> ok. so back to the current topic
16:24:55 <michaelgugino> the only conversion step was qemu-img convert, because I had already downloaded the qcow2 image, no sense in downloading the .xz of the raw as it's the exact same thing.
16:25:47 <dustymabe> michaelgugino: now you should be able to just download the tar.gz (https://kojipkgs.fedoraproject.org/compose/branched/Fedora-33-20201013.n.0/compose/Cloud/x86_64/images/Fedora-Cloud-Base-GCP-33-20201013.n.0.x86_64.tar.gz
16:26:05 <dustymabe> ^^ that uses a separate kickstart that has some customizations for GCP
16:26:23 <dustymabe> and the image uses UEFI
16:26:28 <King_InuYasha> dustymabe: I'll try to test this after I finish writing my openSUSE Conference presentation
16:26:38 <King_InuYasha> I'm trying to get that done asap since I have to give it on Thursday
16:26:55 <michaelgugino> Okay.  Do those customizations include that GCP management agent?  The standard raw image works fine with the caveat of supplying the ssh keys in a more cloud-init way.
16:27:27 <dustymabe> it currently does not include the agent
16:27:33 <dustymabe> but there is work to make that happen in the future
16:27:45 <dustymabe> https://pagure.io/cloud-sig/issue/313
16:28:02 <dustymabe> ok back to the current topic
16:28:11 <dustymabe> anyone able to help us get the GCP image added to the download page?
16:28:26 <dustymabe> It's kind of invisible otherwise
16:29:44 <dustymabe> ok we'll move on from that
16:29:47 <dustymabe> #topic open floor
16:30:15 <dustymabe> King_InuYasha - there is that one action item left of working with the go SIG, do you mind trying to chew on that in this next cycle?
16:30:47 <King_InuYasha> yeah
16:31:03 <King_InuYasha> I didn't remember to talk to them in their meeting yesterday because of fedora-blocker-review
16:31:03 <dustymabe> a big thanks to everyone who participated in the test day
16:31:21 <dustymabe> nb: was going to work on getting a fedora badge created for those who participated
16:31:29 <nb> hi
16:31:46 <nb> The ticket has been created, I'm just waiting on design team to make the art
16:32:52 <dustymabe> thanks nb
16:32:56 <dustymabe> any other topics for open floor?
16:34:21 <dustymabe> #endmeeting