fpc
LOGS
16:00:29 <geppetto> #startmeeting fpc
16:00:29 <zodbot> Meeting started Thu Sep 10 16:00:29 2020 UTC.
16:00:29 <zodbot> This meeting is logged and archived in a public location.
16:00:29 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:29 <zodbot> The meeting name has been set to 'fpc'
16:00:29 <geppetto> #meetingname fpc
16:00:29 <geppetto> #topic Roll Call
16:00:29 <zodbot> The meeting name has been set to 'fpc'
16:00:32 * limburgher here
16:00:40 <King_InuYasha> .hello ngompa
16:00:41 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:01:17 <carlwgeorge> .hello carlwgeorge
16:01:18 <zodbot> carlwgeorge: carlwgeorge 'None' <carl@redhat.com>
16:01:21 <geppetto> #chair limburgher
16:01:21 <zodbot> Current chairs: geppetto limburgher
16:01:24 <geppetto> #chair King_InuYasha
16:01:24 <zodbot> Current chairs: King_InuYasha geppetto limburgher
16:01:27 <decathorpe> .hello2
16:01:28 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
16:01:29 <geppetto> #chair carlwgeorge
16:01:29 <zodbot> Current chairs: King_InuYasha carlwgeorge geppetto limburgher
16:01:33 <geppetto> #chair decathorpe
16:01:33 <zodbot> Current chairs: King_InuYasha carlwgeorge decathorpe geppetto limburgher
16:03:05 <King_InuYasha> mhroncok will be a bit late
16:04:25 <geppetto> Ok
16:04:29 <tibbs> Hey, folks.
16:04:30 <mhroncok> King_InuYasha: thanks :)
16:04:36 <geppetto> #chair tibbs
16:04:36 <zodbot> Current chairs: King_InuYasha carlwgeorge decathorpe geppetto limburgher tibbs
16:04:49 <mhroncok> .hello churchyard
16:04:50 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
16:05:05 <geppetto> #chair mhroncok
16:05:05 <zodbot> Current chairs: King_InuYasha carlwgeorge decathorpe geppetto limburgher mhroncok tibbs
16:05:07 <geppetto> Cool
16:05:11 <geppetto> #topic Schedule
16:05:14 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/YJ3JFWRT5B2AVP7LAHU2GVENA56TXSPJ/
16:05:52 <geppetto> So our open issues/PRs are way down now … nothing new, only 2 of each which are quite old
16:07:26 <limburgher> Nice!
16:07:40 <King_InuYasha> woot
16:08:55 <decathorpe> uuuh
16:09:07 <decathorpe> I see 63 issues and 15 PRs?
16:09:25 <geppetto> mhroncok: decathorpe tibbs … anything to talk about with PR 947?
16:09:54 <geppetto> decathorpe: I'm just counting ones tagged with meeting … if there are any other that aren't tagged that we should talk about feel free to bring them up
16:10:07 <decathorpe> nothing new
16:10:19 <mhroncok> geppetto: not from me.
16:10:32 <mhroncok> untaggign with meeting
16:11:43 <tibbs> There are multiple questions in that PR, and I don't think there's an accompanying ticket.
16:11:48 <geppetto> What about … https://pagure.io/packaging-committee/issue/909 … can that be closed?
16:11:59 <geppetto> Or is there something else we need to do?
16:12:20 <tibbs> The actual PR actually seems mostly fine, though we should decide between SHOULD or MUST.
16:13:04 <tibbs> 909 was accepted; not sure if it was implemented, though.
16:13:18 <mhroncok> 909 was accepted but needs a writeup
16:13:28 <mhroncok> relabeled
16:13:34 <geppetto> Yeh, needs to move from meeting to writeup I think
16:13:39 * geppetto nods
16:14:08 <tibbs> I've taken it.
16:14:36 <geppetto> ok
16:15:39 <geppetto> https://pagure.io/packaging-committee/issue/907 also looks like it might be done?
16:17:03 <geppetto> I'm not sure … maybe just the python it is solved and we need to decide/do something for everything else?
16:17:55 <mhroncok> pythhon was solved
16:17:59 <mhroncok> the others not so much
16:18:32 <tibbs> This is probably going to be a keep open mostly forever kind of thing.
16:18:52 <geppetto> :(
16:19:04 <geppetto> Do we have a solid next step?
16:19:56 <mhroncok> clean up all the instances of %__prel, %__nodejs etc
16:20:03 <tibbs> Maybe we could write the "%__XXX to set something, %XXX to get something" "general rule" into the guidelines, but I'm not sure.  It's more of the way upstream RPM would prefer that macro sets be written.
16:21:01 <tibbs> The idea that a double underscore macro shouldn't appear in a specfile unless it's value is being changed is useful, but assumes that macro sets all follow that convention, whcih they don't.
16:21:15 * geppetto nods
16:21:29 <mhroncok> I would keep that in mind when we design things
16:21:35 <mhroncok> but other than that, meh
16:22:00 <tibbs> I can't remember if I cleaned up the various places that I noted I would clean up in https://pagure.io/packaging-committee/issue/907#comment-580061
16:22:01 <mhroncok> not sure if we have meta-guidelines on macronzing things
16:22:11 <tibbs> So let me take the ticket and double check on that.
16:22:26 <geppetto> #topic Open Floor
16:22:30 * geppetto nods
16:22:39 <geppetto> Ok … that's all the meeting tagged things.
16:22:44 <tibbs> I can have another look and revise my list.
16:22:53 <geppetto> decathorpe: You see anything we should look at in the rest?
16:23:25 <decathorpe> I'll look through the tickets "offline" and tag anything important with "meeting"
16:24:12 <geppetto> sounds good
16:24:33 <geppetto> #action decathorpe Look through all the non-meeting tickets to see if any are stuck and need to be discussed.
16:26:29 <geppetto> Ok, unless anyone has anything to bring up I'll end the meeting at the half hour and give everyone some lunchtime back.
16:27:11 <limburgher> Nothing from me.
16:30:08 <geppetto> #endmeeting