fpc
LOGS
16:00:26 <geppetto> #startmeeting fpc
16:00:26 <zodbot> Meeting started Thu Aug 20 16:00:26 2020 UTC.
16:00:26 <zodbot> This meeting is logged and archived in a public location.
16:00:26 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:26 <zodbot> The meeting name has been set to 'fpc'
16:00:26 <geppetto> #meetingname fpc
16:00:26 <geppetto> #topic Roll Call
16:00:26 <zodbot> The meeting name has been set to 'fpc'
16:00:35 * limburgher here
16:00:47 <geppetto> #chair limburgher
16:00:47 <zodbot> Current chairs: geppetto limburgher
16:00:51 <King_InuYasha> .hello ngompa
16:00:52 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:01:23 <geppetto> Hey, Neal … is that nick from an anime?
16:01:29 <decathorpe> .hello2
16:01:30 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
16:01:36 <geppetto> #chair decathorpe
16:01:36 <zodbot> Current chairs: decathorpe geppetto limburgher
16:02:55 <defolos> .hello2
16:02:56 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
16:03:44 <mhroncok> hey
16:04:06 <geppetto> #chair mhroncok
16:04:06 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok
16:04:07 <geppetto> Hey
16:04:28 <geppetto> Very programing atm … one off error for quorum ;)
16:05:01 <decathorpe> ±1 depending on how we count? :)
16:05:34 <tibbs> Hey, sorry.
16:06:17 <geppetto> #chair tibbs
16:06:17 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
16:06:25 <geppetto> Het, better late than never ;)
16:06:35 <geppetto> And we have 5 now
16:06:43 <limburgher> :partyparrot:
16:09:28 <carlwgeorge> .hello2
16:09:29 <zodbot> carlwgeorge: carlwgeorge 'None' <carl@redhat.com>
16:09:37 <King_InuYasha> geppetto: yep
16:09:46 <King_InuYasha> InuYasha, of course ;)
16:10:17 <geppetto> #topic Schedule
16:10:20 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/DWIAFVVQVOFHJLSHJ4T6GUYUE5JPDPUH/
16:10:40 <geppetto> King_InuYasha: Cool, I wondered … as I've seen a few episodes. But wasn't sure :)
16:11:00 <King_InuYasha> it's a good show, though has a weak beginning
16:11:17 <geppetto> defolos: Hey, so did you turn up for s specific issue/PR/etc?
16:12:07 <defolos> geppetto: I was hoping I could "encourage" Igor Raits to work further on adding the list of packages to the mock build root
16:12:50 <defolos> so that I could find out which version of a package is currently in the buildroot without having to ask rpm directly, because that is apparently not a good idea
16:13:01 <geppetto> Ahh
16:13:43 <defolos> and if that list contained all the bconds, that would be even better
16:13:46 <geppetto> #topic #pr-954 Prohibit use of `rpm` command from specfile.
16:13:47 <geppetto> https://pagure.io/packaging-committee/pull-request/954
16:13:59 <King_InuYasha> I disagree with the premise that we should block it
16:14:04 <defolos> then I could have even more automated bootstrapping
16:14:15 <defolos> I too 😉
16:14:25 <King_InuYasha> and absent an alternative, we shouldn't even bother with this
16:14:29 <defolos> but I really don't know enough about this to have a qualified opinion on this
16:14:30 <geppetto> King_InuYasha: You think people should call rpm from mock/rpmbuild?
16:14:37 <King_InuYasha> why not?
16:15:01 <decathorpe> King_InuYasha: I really don't like it when .spec file evaluation runs arbitrary code on my system :(
16:15:06 <King_InuYasha> the only reason it *might* not work is that we don't have Koji running in bootstrap mode
16:15:19 <King_InuYasha> err running builds in bootstrap mode
16:15:20 <mhroncok> which we should enable :)
16:15:25 <decathorpe> I think Panu mentioned that with bootstrap chroot it's not a problem, but neither COPR nor koji do that, yeah
16:15:33 <King_InuYasha> COPR does use bootstrap chroot
16:15:39 <King_InuYasha> and Mock itself does by default too
16:15:42 <King_InuYasha> only Koji does not yet
16:16:06 <decathorpe> COPR does *NOT* by default, but you can enable it "experimentally"
16:16:14 <geppetto> King_InuYasha: https://pagure.io/packaging-committee/pull-request/954#comment-112881 ?
16:16:23 <King_InuYasha> huh, that's odd, I recall FrostyX telling me he was going to switch it
16:16:42 <decathorpe> There's a settings switch with this text: "Enable mock's use_bootstrap_container experimental feature"
16:16:43 <limburgher> We should at least have a 'Please don't', to avoid rpm recursion black holes...
16:17:09 <King_InuYasha> decathorpe: he was going to switch it to default to that behavior a while ago because of problems evaluating macros in spec files across chroots
16:17:20 <King_InuYasha> e.g. Mageia's %mkrel doesn't exist in Fedora
16:17:32 <King_InuYasha> so Mageia spec files don't work without bootstrap mode
16:17:49 <King_InuYasha> and openSUSE's %python_subpackages macro doesn't work for the same reason
16:18:15 <decathorpe> huh. a COPR I created two days ago doesn't have it enabled
16:18:33 <mhroncok> #chair mhroncok_mobile
16:18:33 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok mhroncok_mobile tibbs
16:18:35 <King_InuYasha> (%python_subpackages macro generates subpackages for various Python versions enabled out of the box by openSUSE for packaging, so they generate flavor builds)
16:19:02 <King_InuYasha> e.g. https://build.opensuse.org/package/view_file/devel:languages:python/python-iniparse/python-iniparse.spec?expand=1
16:19:35 <King_InuYasha> stuff like this simply fails without bootstrap chroot *anyway*
16:19:55 <decathorpe> so koji should enable bootstrap chroot is what you're saying? :)
16:19:57 <King_InuYasha> yes
16:20:00 <tibbs> Not sure what relevance these examples from other distros actually have.
16:20:15 <King_InuYasha> tibbs: we have variations of this in Fedora and RHEL too
16:20:24 <King_InuYasha> with %py3_dist macros for BRs and such
16:20:29 <tibbs> Maybe those things are just broken or are too fancy for their own good and make assumptions that aren't valid.
16:20:39 <King_InuYasha> sorry, I don't buy it
16:20:51 <tibbs> Which, since they don't work, is possible.
16:21:21 <King_InuYasha> in *general* spec files are written to be evaluated on the target distro
16:21:34 <King_InuYasha> the fact that Koji violates this rule pretty flagrantly is a problem
16:21:39 <tibbs> Remember that we work to document the interaction of the tools that we have.  If it doesn't work in koji then we don't tell people to use it.
16:21:57 <tibbs> Our interest here is not things from other distro, it is Fedora.
16:22:14 <King_InuYasha> well, again, I can come up with Fedora/EPEL cases too
16:22:31 <tibbs> You mean things that people do which they shouldn't be doing because they don't work?
16:22:40 <geppetto> Saying that if mock will change to use bootstrap mode by default, and koji goes with that too … then I'm fine with saying people can use things that work in that mode
16:22:52 <King_InuYasha> geppetto: I'm happy with that too
16:23:13 <King_InuYasha> and fwiw, koji *will* switch to this eventually
16:23:23 <geppetto> Can we define eventaully?
16:23:24 <tibbs> I mean, we can't put that in a packaging guideline.  "It doesn't work, but you could use it if somehow it starts working".
16:23:44 <King_InuYasha> geppetto: last I discussed it with them, probably within the next six months or so
16:23:59 <geppetto> tibbs: I was thinking more like … this should start working with F-33 or F-34 … please don't use it before then, as it might break
16:24:05 <King_InuYasha> once Fedora 34 drops bdb support, it needs to be in place
16:24:12 <King_InuYasha> (bdb rpmdb, that is)
16:24:14 <tibbs> Best to either put the whole thing on ice, or if it's going to be too long, document that it doesn't work and then change that when the time is right.
16:25:03 <decathorpe> tibbs: I agree, dealing with this now seems premature since the things the change depends on aren't ready yet
16:25:05 <King_InuYasha> geppetto: so I expect to see Koji able to do that by the time Fedora 34 lands
16:25:06 <geppetto> The big problem I see is what people do instead … getting rpm changes in the distro. isn't trivial. The lua mini package DB hasn't moved in 3 months?
16:25:35 <limburgher> Might be safe to wait until the oldest stable release is f34, so people keeping branches in sync don't shoot themselves in the foot.
16:25:43 <limburgher> safer^
16:26:15 <mhroncok> I suppose that if koji switch, it will affect all buildroots, no?
16:26:21 <King_InuYasha> yes
16:26:28 <King_InuYasha> koji changes affect all build roots
16:26:50 <King_InuYasha> basically we need to have this fixed in koji before builders are reprovisioned with Fedora 33 or 34
16:26:57 <tibbs> We don't usually wait until something is available in every supported release.
16:27:00 <King_InuYasha> definitely before F34, as we can hack around it for F33
16:27:18 <geppetto> tibbs: Yeh
16:27:19 <tibbs> But it's good to wait until things are at least close to being available in one supported release.
16:28:01 <geppetto> I mean I think it's likely that the buildroot changes to make rpm calls happy will happen before any other alternative gets implemented
16:29:28 <mhroncok> I think the best course of action is to make sure the bootsrap mode will actually be enabled in koji
16:29:54 <geppetto> King_InuYasha: Can you point to any koji issue where this is being tracked?
16:30:01 <King_InuYasha> let me see if I can find it
16:30:02 <King_InuYasha> one sec
16:30:09 <geppetto> 👍
16:31:01 <King_InuYasha> https://pagure.io/koji/issue/1017
16:31:14 <King_InuYasha> hey look, it's fixed already in koji: https://pagure.io/koji/c/1f1da58
16:32:01 <King_InuYasha> hah, I should know this, since I reviewed it :P
16:32:21 <King_InuYasha> that shows me and my scrambled brain :P
16:32:36 * limburgher hands King_InuYasha a coffee
16:32:47 <geppetto> Is that deployed?
16:32:52 <King_InuYasha> yes
16:33:00 <King_InuYasha> supported in koji 1.22 which was rolled out a couple weeks ago
16:33:01 <King_InuYasha> https://docs.pagure.org/koji/release_notes/release_notes_1.22/#builder-changes
16:33:07 <decathorpe> but the setting is not turned on yet?
16:33:18 <King_InuYasha> pretty much
16:33:22 <King_InuYasha> it's not configured, so koji doesn't use it
16:33:53 <King_InuYasha> so koji and copr are in the same situation at this point
16:33:54 <geppetto> #info This is already fixed in upstream koji, but the fix is not turned on yet in fedora infra (must be on by F34)
16:33:57 <King_InuYasha> just need to be configured
16:34:35 <geppetto> King_InuYasha: Can someone volunteer to poke both services to change sooner rather than later?
16:34:47 <King_InuYasha> I can talk to copr folks
16:35:00 <King_InuYasha> I talk to them semi-frequently already for other reasons
16:35:19 <geppetto> #action King_InuYasha will volunteer to talk to copr to get config. turned on
16:35:25 <geppetto> Anyone for fedora infra?
16:36:50 <tibbs> Sorry, I'm reading the docs.
16:37:27 <King_InuYasha> carlwgeorge: do you talk to fedora infra guys?
16:37:41 <tibbs> So koji needs mock.use_bootstrap=1 set on the relevant tags.
16:37:50 <King_InuYasha> tibbs: yes
16:37:50 <tibbs> I talk to them often enough.
16:37:51 <carlwgeorge> I imagine Fedora infra (CPE) will punt on that since koji is categorized as an app we run but don't maintain
16:38:00 <King_InuYasha> O.o
16:38:10 <King_InuYasha> who, umm, maintains it?
16:38:12 <tibbs> This whole CPE thing is... something.
16:38:27 <tibbs> I would say that's a releng thing, but it's OK, I talk to them as well.
16:38:38 <tibbs> The remaining question is what the relevant tags would be.
16:38:49 <geppetto> #action tibbs will volunteer to talk to releng to get config. turned on
16:38:58 <geppetto> tibbs: I'd assumed F34+ at least
16:39:13 <King_InuYasha> actually, probably the other direction once builders are F33
16:39:14 <geppetto> at least that should cause the least friction
16:39:30 <King_InuYasha> since host would be sqlitedb and chroots would be bdb
16:39:34 <geppetto> Ahh
16:39:47 <King_InuYasha> the straightforward answer is to just do it for all of them
16:39:59 <carlwgeorge> mboddu might know the best person to make that call for fedora's koji instance
16:40:04 <King_InuYasha> yeah
16:40:15 * mboddu reading back
16:40:38 <decathorpe> maybe somebody should make this a FNaN System Wide Change?
16:41:16 <geppetto> decathorpe: it's a builder change though, not a distro. change
16:41:32 <geppetto> Although I guess the mock default should change for F34 too
16:41:39 <King_InuYasha> mock *already* does bootstrap by defualt
16:41:43 <King_InuYasha> *default*
16:41:44 <geppetto> ha
16:41:50 * decathorpe shrugs, hasn't stopped us before
16:41:52 <geppetto> fair enough
16:42:03 <King_InuYasha> mock started doing bootstrap by default in version 2.0, iirc
16:42:19 <geppetto> decathorpe: eh, the FNaN process mostly confuses me
16:42:28 <King_InuYasha> https://github.com/rpm-software-management/mock/wiki/Release-Notes-2.0
16:42:49 * geppetto is kind of confused why everyone else didn't pick it up at that point
16:42:54 <geppetto> Oh, well.
16:43:03 <King_InuYasha> that's why I thought copr already did this
16:43:09 <King_InuYasha> because it was the copr devs that changed it in mock
16:43:49 <King_InuYasha> geppetto: koji hand-holds mock, so mock defaults don't necessarily apply to koji in all cases
16:43:55 <King_InuYasha> weird, but whatever
16:44:26 <tibbs> Makes some sense for stability.
16:44:52 <carlwgeorge> glancing at build logs makes it clear that koji leaves very little up to mock defaults (lots of flags are passed)
16:45:02 <tibbs> But for this, I'm not sure what the side effects might be or whether any of them might be negative.
16:46:08 <decathorpe> tibbs: I think most bug side effects have been solved since it's been the default for local builds for ages
16:46:39 <King_InuYasha> yup
16:46:40 <decathorpe> (not accounting for weird modes koji might run mock in)
16:47:01 <King_InuYasha> the lack of a koji staging env has really made testing that stuff painful
16:49:27 <geppetto> Hmm, ok
16:49:39 <mboddu> tibbs or someone: Can you create a ticket about this at pagure.io/releng so that I can take a look at it and check it with Kevin and other folks before we make the necessary changes?
16:50:05 <mboddu> Probably we will set it in stg once thats available
16:50:56 <geppetto> I think we are mostly ok with this then now … do we want to vote to undo the previous vote?
16:51:53 <limburgher> Seems ok to me.
16:51:55 <King_InuYasha> geppetto: yep
16:52:19 <mhroncok> there is some ticket thou... let em check
16:53:36 <tibbs> Need to see Panu's statement that this is OK if the chroot is set up so that the databases are guaranteed to match.  I wouldn't be for it otherwise.
16:53:55 <King_InuYasha> Panu has been the one pushing for it the most
16:54:16 <tibbs> He was quite against it previously and that didn't have much to do with database stuff.
16:54:58 <tibbs> I see it now.
16:55:02 <mhroncok> ha
16:55:02 <mhroncok> https://pagure.io/releng/issue/9308
16:55:06 <tibbs> "If mock bootstrap-mode is used, the reason for avoiding rpm queries from the spec simply vanishes."
16:55:28 <King_InuYasha> https://pagure.io/releng/issue/9308#comment-668692
16:56:13 <King_InuYasha> "We might not technically need bootstrap to keep things limping along for the time being, but we want to enable it the sooner the better."
16:56:48 <defolos> question from a noob: can I query bconds from rpm?
16:56:59 <King_InuYasha> sort of?
16:57:22 <tibbs> I think the answer depends on how you interpret the question.
16:57:38 <mhroncok> we are ta this topic for almost 1 hour
16:57:45 <defolos> sorry…
16:57:57 <geppetto> mhroncok: True, but it looks like it's resolved now
16:58:03 <mhroncok> it is
16:58:09 <tibbs> I think we know what needs to be done.
16:58:12 <King_InuYasha> yep
16:58:15 <defolos> tibbs: I want to find out if another package was built with tests or without tests
16:58:37 <mhroncok> defolos: from the resulting RPM packages? I don't think so
16:58:51 <decathorpe> defolos: uh I think the only way to do that would be to include RPM macros in built packages
16:59:00 <King_InuYasha> unfortunately, the only environment flags recorded in the rpm headers right now are compiler flags
16:59:13 <King_InuYasha> we don't (yet) record macros set in the build environment into the headers
16:59:20 <defolos> hm, darn
16:59:24 <geppetto> #info Given the changes in koji/copr the need to ban rpm calls from build time specfiles is unnecessary
16:59:30 <defolos> so back to integrating fm-orchestrator into koji
16:59:33 <geppetto> #topic Open Floor
16:59:45 <geppetto> So, we have 20 seconds left :)
16:59:58 <mhroncok> please vote on the Python prs
17:00:04 <mhroncok> in the tickets or here
17:00:10 <decathorpe> defolos: echo "%_with_tests" > %buildroot/usr/lib/rpm/macros/macros.%name.tests ;)
17:00:33 <geppetto> https://pagure.io/packaging-committee/pull-request/1011
17:00:37 <geppetto> https://pagure.io/packaging-committee/pull-request/1013
17:00:38 <geppetto> ?
17:00:49 <mhroncok> indeed
17:00:53 <mhroncok> geppetto++
17:00:53 <zodbot> mhroncok: Karma for james changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:03 <King_InuYasha> geppetto: there's some interest from the openSUSE side about collaborating on a shared packaging guidelines doc that can spit out Fedora or openSUSE guidelines by "building" with an argument
17:01:05 <limburgher> +1
17:01:16 <King_InuYasha> since the differences between the two are increasingly minor
17:02:00 * defolos is in favor of that ;-)
17:02:02 <tibbs> I think we might actually want to get all of the conversion bugs out of our existing documents before we try to do that.
17:02:05 <geppetto> King_InuYasha: I think there might be some interest in adding macros or something so that the same specfile works in both … but a pre-processor step I can't see being accepeted
17:02:08 * jwf waves
17:02:17 <tibbs> Plus the bureaucracy would be kind of crazy.
17:02:20 <geppetto> jwf: Sorry, blame koji ;)
17:02:24 <mattdm> (should we move the fedora council meeting to #fedora-meeting?)
17:02:35 <mhroncok> jwf: waves to say hello or to have another meeting? :D
17:02:39 <geppetto> mattdm: We'll be another minute … not longer
17:02:50 <geppetto> mhroncok: Another meeting
17:02:52 <King_InuYasha> geppetto: I think it'd mostly be some extra pages for openSUSE specific things like group tags and such
17:02:53 <jwf> geppetto: :)
17:02:55 <tibbs> Yes, let's stop.  Can review those two PRs and comment in the ticket.
17:02:59 <jwf> mhroncok: Both!
17:03:00 <decathorpe> yeah I think we're done :)
17:03:05 <King_InuYasha> anyway, we're done here
17:03:13 <mhroncok> jwf: o/
17:03:29 <mattdm> ok :)
17:03:30 * dgilmore glares at bcotton
17:03:31 <geppetto> Ok, everyone go vote on 1011 and 1013 now …
17:03:34 <mattdm> lol
17:03:41 <King_InuYasha> geppetto: basically, we're at the point where openSUSE wants to refork fedora guidelines again...
17:03:43 <geppetto> #endmeeting