council
LOGS
14:00:08 <bcotton> #startmeeting Council (2020-05-27)
14:00:08 <zodbot> Meeting started Wed May 27 14:00:08 2020 UTC.
14:00:08 <zodbot> This meeting is logged and archived in a public location.
14:00:08 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:08 <zodbot> The meeting name has been set to 'council_(2020-05-27)'
14:00:09 <bcotton> #meetingname council
14:00:09 <zodbot> The meeting name has been set to 'council'
14:00:11 <bcotton> #chair jonatoni riecatnor contyk dgilmore mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:11 <zodbot> Current chairs: asamalik bcotton contyk dgilmore jonatoni mattdm pbrobinson riecatnor sumantrom tyll
14:00:12 <bcotton> #topic Introductions, Welcomes
14:00:15 <contyk> .hello psabata
14:00:16 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
14:00:18 <asamalik> .hello2
14:00:19 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:00:25 <riecatnor> .hello riecatnor
14:00:27 <zodbot> riecatnor: riecatnor 'None' <mnordin@redhat.com>
14:00:27 <sumantro> .hello2 sumantrom
14:00:30 <zodbot> sumantro: sumantro 'Sumantro Mukherjee' <sumantro@outlook.com>
14:00:34 <mattdm> .hello
14:00:37 <zodbot> mattdm: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
14:00:41 <mattdm> hahaha
14:00:45 <mattdm> hi though
14:00:58 <tyll> .hello till
14:00:59 <zodbot> tyll: Something blew up, please try again
14:01:03 <tyll> .hello till
14:01:05 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
14:01:13 <contyk> Haven't seen that before.
14:01:55 <mattdm> My kid is going in to the hospital for surgery this morning. due to covid only one parent is allowed with so Karen is going and I'm staying home. But I'm going to need to step out mid-meeting to send her off
14:02:16 <contyk> Hope it goes well.
14:02:32 <tyll> sure, yes, good luck!
14:02:35 <bcotton> mattdm++ please pass the cookie to your child
14:02:35 <asamalik> oh I hope everything goes fine!
14:03:05 <mattdm> Thanks. Prognosis is good and it's at one of the best hospitals in the world, so it should be smooth
14:03:15 <mattdm> bcotton she's not allowed to eat right now :)
14:04:27 <bcotton> well in that case
14:04:33 <bcotton> #topic Today's agenda
14:04:35 <bcotton> #info CPE's Q3 planning
14:04:36 <bcotton> #info Project directory
14:04:38 <bcotton> #info Stalled tickets
14:04:39 <bcotton> #info Your topics here!
14:04:55 <bcotton> anyone want to toss topics into the stack?
14:05:09 <jwf> mattdm: Best wishes for your daughter's surgery.
14:05:15 <mattdm> thanks jwf!
14:05:22 <mattdm> riecatnor: Nest update?
14:05:28 <jwf> bcotton: re, stalled tickets. Maybe the policy proposal ticket if there is time and anything to discuss there
14:05:34 <mattdm> riecatnor: also, telegram?
14:05:36 <jwf> It is a low priority for me right now though…
14:05:47 <dgilmore> hey all
14:06:05 <bcotton> jwf: that one's on you, i think. there's feedback that afaict you haven't responded to
14:06:11 <riecatnor> nothing for nest
14:06:25 <riecatnor> there is a email on council-discuss re: moderator guidelines
14:06:27 <jwf> bcotton: Ah okay. Then can follow up when I have time to circle back around to the feedback…
14:06:32 <bcotton> jwf: ack
14:07:16 <bcotton> riecatnor: do you want to add it to the agenda or should we leave it for later? (i believe the discussion is mostly happening elsewhere for now)
14:07:45 <riecatnor> We can leave it for another day.
14:08:04 * pbrobinson is here
14:08:58 <bcotton> rock
14:09:00 <tyll> I was wondering recently, if we are aware about the health of Fedora/of the different teams. Not sure if this is something to discuss right now, e-mail or a ticket
14:09:30 <bcotton> tyll: we're not, which is part of the reasoning behind the directory topic
14:09:37 <bcotton> #topic CPE's Q3 planning
14:09:39 <bcotton> #info CPE will begin the Q3 planning process soon. Are there projects we want to send into the hopper?
14:09:40 <bcotton> #link https://teams.fedoraproject.org/project/fedora-council-infrastructure-priorities/timeline
14:10:03 <bcotton> #undo
14:10:03 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f477441ced0>
14:10:09 <bcotton> better link coming!
14:10:15 <bcotton> #link https://teams.fedoraproject.org/project/fedora-council-infrastructure-priorities/kanban
14:10:37 <bcotton> amoloney: are you around?
14:11:03 * pingou happy to fill in if there are questions
14:11:28 <tyll> pingou: do you know which authentication methods Fedora Infra will support in the future?
14:12:05 <pingou> tyll: I believe we want to move more towards oidc
14:12:05 <bcotton> bonjour, pingou. what's the deadline for submitting epic briefs for Q3?
14:12:17 <pingou> and noggin will rely more on kerberos
14:12:28 <pingou> (which has pros and cons, that I've flagged to the team)
14:12:36 <pingou> bcotton: give me a sec to look for this info
14:12:46 <tyll> pingou: I mean for the user, will it be password + 2FA for everyone or only someone? Will there still be SSH keys?
14:13:01 <pingou> tyll: password + 2fa for who wants
14:13:06 <pingou> ssh keys, still for the moment
14:14:48 <pingou> so the quaterly planning session is scheduled for June 18th
14:15:06 <bcotton> #info CPE's Q3 planning session is scheduled for 18 June
14:15:09 <tyll> pingou: thx, do you know which kind of 2FA? Will SSH keys be deprecated in the foreseeable future?
14:15:26 <pingou> submitting before the 9th would be nice
14:15:42 <bcotton> #info Epic briefs should be submitted by 9 June
14:15:52 <pingou> tyll: I know noggin doesn't support yubikey atm, but does otp
14:15:59 <bcotton> do we have anything we want to put in this time?
14:16:17 <pingou> tyll: I don't know that a decision has been made for ssh key, but I believe our security officer wanted to get ride of them a little while ago
14:16:22 <bcotton> tyll: are your questions related to the nitrokey ticket you took, or are they general?
14:16:33 <tyll> bcotton: about the nitrokey ticket
14:16:43 <pingou> submitting b/w the 9th and 18th is likely still possible, just may be tight timing wise
14:16:46 <bcotton> tyll: great :-)
14:16:57 <bcotton> pingou: shh. don't tell us that because then we'll do it :p
14:17:08 <pingou> bcotton: sorry, beginner's mistake :D
14:17:21 <pingou> tyll: if you want a specific key supported I'd log a request at: https://github.com/fedora-infra/noggin/issues
14:17:37 <pingou> https://github.com/fedora-infra/noggin/issues/202 this is the ticket for yubikey support
14:17:50 <pingou> which may share some lights on what is possible and what the dependencies are
14:18:07 <pingou> (which basically comes down to: support in FreeIPA)
14:18:12 <tyll> pingou: ok, thanks
14:19:04 <bcotton> mattdm: do you want to get the image builder as a service moved out of "writing" by then, or should we look at it for Q4?
14:19:08 <bcotton> (or later)
14:20:31 * pingou takes a task to build a timeline page where are listed the deadlines and info for each quaters/sessions
14:20:32 <bcotton> anyone else have ideas?
14:20:37 <bcotton> pingou++
14:21:18 <pingou> Aoife, Sarah and I have also been working on an email that should be sent shortly documenting our workflow and asking for input/feedback on it
14:21:27 <asamalik> pingou++
14:21:27 <zodbot> asamalik: Karma for pingou changed to 18 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:21:32 <tyll> improving the packager experience would be nice but I am not sure what is most pressing there nowadays (which is why I was wondering about the health of our teams)
14:21:55 <asamalik> huh, I'd swear I gave you a cookie already :D
14:22:01 <pingou> the idea being: let's try XXX, tell us what you think of it and we'll see/adjust as we go
14:22:28 <sumantro> pingou++
14:22:28 <zodbot> sumantro: Karma for pingou changed to 19 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:22:34 <pingou> tyll: this is on my personal radar as well, though we should look at what that means more specifically
14:22:48 <bcotton> tyll: yeah. i think that should be an Objective to coordinate various pieces across the stuff (iirc there was an attempt at one but it stalled)
14:22:52 <pingou> (today bodhi is misbehaving for example, but we don't yet know why)
14:23:13 <pingou> tyll: do you consider rpmautospec in this scope?
14:23:32 <pingou> or are we only speaking of the current fedpkg/dist-git/koji/bodhi stack?
14:23:46 <pingou> do we include polishing side-tags usage for stable releases in there?
14:23:49 <bcotton> okay, let's move on
14:23:53 <bcotton> #topic Project directory
14:23:54 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/295
14:24:13 <tyll> pingou: whatever helps packagers
14:24:21 <bcotton> you may recall we came up with this idea in November and then did nothing with it. so we decided last meeting to make asamalik work on it :-)
14:24:27 <bcotton> asamalik: any updates or blockers?
14:25:10 <asamalik> I'm embarrassed to say no progress happened here. I gave all my Docs time to translations going to production (which is now all in place and will be announced very soon).
14:25:12 <asamalik> This is next.
14:25:21 <contyk> Deja vu :)
14:25:26 <bcotton> asamalik++ translations to production are good, too  :-)
14:25:36 <sumantro> asamalik++
14:25:36 <zodbot> sumantro: Karma for asamalik changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:25:36 <jwf> pingou++
14:25:39 <zodbot> jwf: Karma for pingou changed to 20 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:26:00 <contyk> l
14:26:14 * pingou should join more often, the cookies are good here :)
14:26:28 <riecatnor> pingou++
14:26:28 <zodbot> riecatnor: Karma for pingou changed to 21 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:26:28 <asamalik> But we discussed this with bcotton who gave me ideas!
14:26:31 <jwf> asamalik++ on translations!
14:26:31 <zodbot> jwf: Karma for asamalik changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:26:33 <bcotton> so once we have a directory in place, it will be up to sumantrom and contyk (or their successors if they're not re-elected) to start building out the directory, which will then help us figure out 1. what teams exist and 2. if they're healthy
14:26:34 <asamalik> bcotton++
14:26:34 <zodbot> asamalik: Karma for bcotton changed to 14 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:26:43 <riecatnor> asamalik++
14:26:43 <zodbot> riecatnor: Karma for asamalik changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:27:03 <sumantro> bcotton, copied :)
14:27:19 <sumantro> bcotton++
14:27:19 <zodbot> sumantro: Karma for bcotton changed to 15 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:27:19 <bcotton> anything else on this topic?
14:27:28 <jwf> This ticket reminds me of various wiki pages that have existed across the last decade :)
14:28:01 <jwf> This idea has been tried before but nobody ever officially owned the responsibility of maintaining such resources
14:28:06 <bcotton> jwf: the idea is to 1. consolidate those and 2. have an active check a few times a year to make sure they're still up to date
14:28:20 <bcotton> yep, but now the FESCo and Mindshare reps have responsibility for maintaing them :-)
14:28:20 <jwf> Documentation on point #2 is key for sustainability, I think
14:28:44 <contyk> Yep.
14:29:08 <jwf> bcotton: True – although that is just diverting responsibility on someone else. Those committees need guidance and structure for how to maintain these very similar documents
14:29:22 <jwf> Not that diverting responsibility is inherently bad, but it is not an answer in itself :)
14:29:23 <jwf> I digress
14:29:26 <jwf> Just a historical thought
14:29:35 <asamalik> we definitely need docs for docs :P
14:29:37 <bcotton> it's assigning responsibility that was previously unassigned
14:29:39 <tyll> bcotton: what is the plan to find out if they are healthy?
14:30:37 <jwf> bcotton: To acknowledge the work of volunteers who have tried to maintain info like this over the years, it has been assigned but never formally :)
14:30:40 <bcotton> ask the FESCo and Mindshare reps ;-)
14:30:40 <jwf> tyll: Also curious about that
14:30:43 <jwf> Ah
14:31:02 <jwf> Is that sumantro for Mindshare and who for FESCo?
14:31:26 <sumantro> tyll, is for FESCo
14:31:31 <tyll> jwf: contyk for FESCo
14:31:32 <contyk> Me.
14:31:35 <bcotton> sumantro: no, tyll is elected. contyk is the fesco rep
14:31:36 <sumantro> sorry contyk
14:31:37 <tyll> I am elected
14:31:46 * jwf nods
14:31:51 <sumantro> my bad!
14:32:05 <bcotton> hm. maybe we should check to see if the council is healthy ;-)
14:32:10 * bcotton assigns that to mattdm :p
14:32:24 <jwf> I am very curious about the Mindshare-related health checks. Can follow-up after the meeting with someone on that
14:32:29 <bcotton> but for now, speaking of unhealthy, let's take a look at some tickets that we've let sit for too long
14:32:43 <contyk> Yes, we should.
14:32:45 <bcotton> #topic Stalled tickets
14:32:47 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issues
14:32:48 <bcotton> Can we advance any of these?
14:32:53 * tyll was wondering if we should have some kind of survey to get some input about what people would change in Fedora to make their contributions easier or so
14:32:53 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/297
14:33:13 <bcotton> i saw a couple of votes come in in the last few minutes on this one
14:33:36 <bcotton> anyone have strong feelings against? it's currently at (+3,0,-0)
14:33:59 <contyk> I'm +1.
14:34:10 <sumantro> +1
14:34:38 <bcotton> #info contyk is +1 on #297
14:34:45 <bcotton> #info sumantrom is +1 on #297
14:34:45 <asamalik> +1
14:34:54 <bcotton> #info asamalik is +1 on #297
14:35:54 <bcotton> okay, i'm not seeing any -1
14:36:16 <bcotton> #agreed 297 is approved (+6,0,-0)
14:37:39 <bcotton> #info bcotton is working on #296
14:37:44 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/296
14:38:21 <bcotton> #info bcotton met with adamw, mattdm, pbrobinson, and mboddu yesterday to figure out what is needed and will now turn that into words
14:40:18 <bcotton> we should really figure out what to do about #262 and #280. any ideas on what we should do to close those out one way or another?
14:40:39 <bcotton> or is anyone willing to accept responsibility for leading the charge on either of those?
14:42:59 <bcotton> okay, i'll take a look at them again and see if we can advance the conversation :-)
14:43:04 * asamalik would love to look into "What is Fedora" but can't commit to it now :(
14:43:22 <bcotton> #action bcotton to look at #262 and #280 to see if we can advance the conversation to some sort of closure
14:43:31 * sumantro will have a look at it and see if we can bring it to a closure
14:43:45 <bcotton> are there any other stalled tickets that we can unstall right now?
14:44:58 <contyk> Doesn't seem so.
14:45:00 <mattdm> I'm back now. Did I miss anything good? :)
14:45:19 <bcotton> mattdm: yes, we decided to need to fix everything
14:46:08 <mattdm> oh good!
14:46:20 <bcotton> alrighty
14:46:30 <bcotton> #topic Next meeting
14:46:31 <bcotton> #info The next Fedora Council meeting is 10 June. It will be a video meeting featuring the Fedora Modularity team
14:46:43 <bcotton> it seems like we just had a video meeting, but here we are again!
14:47:01 <contyk> Good. I have something about it for the open floor.
14:47:05 <bcotton> #link https://fedoraproject.org/wiki/Council/Video_Meetings
14:47:25 <bcotton> i'm going to start trying to schedule the july meeting, so if you have suggestions, please add them to the wiki page
14:47:28 * mattdm will get the last video meeting to social media!
14:48:28 <bcotton> #action mattdm to get the May meeting onto YouTube et al
14:48:41 <bcotton> #topic Do we have anything to announce?
14:48:43 <bcotton> #info This is a regular check to make sure we're communicating to the contributor (via CommBlog) and user (via Magazine) communities
14:48:44 <bcotton> #info Election voting begins at 0000 UTC Thursday - CommunityBlog posts will go live shortly before voting opens
14:48:54 <bcotton> anything else to announce?
14:49:02 <sumantro> bcotton++
14:49:20 <sumantro> bcotton, thanks for all the work with election interview blogs
14:49:29 <mattdm> yes indeed!
14:49:39 <asamalik> bcotton++
14:49:45 <asamalik> we need more cookies per release
14:49:48 <bcotton> i'm just glad i figured out to start putting them in wordpress as they come in instead of waiting until the end. so much less stressful this way :-D
14:50:19 <riecatnor> bcotton++
14:50:20 <zodbot> riecatnor: Karma for bcotton changed to 16 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:51:13 <bcotton> okay, i don't see any other announcements, so....
14:51:14 <bcotton> #topic Open floor
14:51:25 <bcotton> contyk: did you have a thing?
14:51:42 <contyk> Yes; it appears that FESCo is leaning towards making modularity optional.
14:52:01 <contyk> Banning modular-only packages, forbidding default permanently, disabling the modular repository by default...
14:52:10 <contyk> #link https://pagure.io/fesco/issue/2114
14:52:35 <contyk> I reminded the committee that this is still our objective and I view all those proposals as steps backwards.
14:52:47 <mattdm> *nod*
14:52:54 <contyk> It will be discussed on Monday.
14:53:05 <bcotton> i mean technically there is no active modularity objective, but....
14:53:16 <contyk> No one from the new modularity team has chimed in yet.
14:53:36 <contyk> Well, technically there isn't right now.
14:54:17 <bcotton> has FESCo checked with the Edition teams on their stance?
14:54:57 <contyk> Nope, that might be a good point.
14:55:25 <jwf> BTW is the Council still using Jitsi for video meetings?
14:55:35 <bcotton> if Server and Workstation are strongly in favor of Modularity, then making it optional by FESCo decision might not have much practical effect
14:56:10 <mattdm> I had a meeting with the RH packaging tools team today and they're feeling very under-resourced -- covid-19 has put a freeze on planned hiring.
14:56:17 <bcotton> the other question is if the Council should make a decision here or just offer FESCo our opinions
14:56:31 <riecatnor> jwf I believe we have been using bluejeans
14:56:55 <mattdm> (jwf: we switched back to bluejeans because of problems. I'm interested in trying jitsi again once the firefox issue is resolved)
14:57:00 <jwf> Gotcha. Thought I'd mention, Firefox 76, 77, and 78 all have better support for WebRTC and the video experience might be a lot better than it once was :)
14:57:16 <jwf> mattdm: FF 76 is a big improvement, but the real fixes are coming in FF 78 for WebRTC
14:57:31 <contyk> We could also run our own Jitsi instance, since we love running services.
14:57:35 <jwf> I have been using Firefox with Jitsi happily for the last week or two with 76, but might still be some edge cases until 78
14:57:37 <jwf> contyk: lol no :P
14:57:38 <x3mboy> .hello2
14:57:39 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
14:57:40 <x3mboy> !
14:57:42 <bcotton> contyk: what do you think? do you want the Council to make a stand here or just an opinion?
14:58:01 <mattdm> on Modularity: I definitely am disappointed to see the goals not met and things feeling like they're moving backwards. But if the project isn't being resourced for what we need to go forward for it to succeed in Fedora, we're kind of stuck.
14:58:25 <contyk> I think we should just offer opinions in the current situation, considering there's no active objective.
14:58:34 <jwf> contyk bcotton: If y'all are serious, I think it makes more sense to see if the OpenSUSE folks are interested in collaborating on their Jitsi Meet server instead of Fedora doing its own thing yet again
14:58:41 <contyk> But we shouldn't be reverting all the work as soon as we drop objectives as "complete".
14:58:47 <jwf> https://meet.opensuse.org/
14:59:08 * jwf digresses
14:59:14 <bcotton> contyk: agreed. do you want to draft an opinion for us to sign on to?
14:59:30 <contyk> I could give it a go.
14:59:40 <mattdm> contyk sounds good
15:00:03 <bcotton> #action contyk to draft an statement representing Council's opinion on FESCo's Modularity discussion (FESCo #2114)
15:00:07 <mattdm> I think the problem here is that we never really got to complete on this objective. :(
15:00:28 <bcotton> okay, that's all the time we have today. if there's anything else, let's move it to #fedora-council
15:00:30 <bcotton> thanks, everyone!
15:00:50 <tyll> seems like modularity provies opportunities to improve the packager experience
15:00:53 <bcotton> #endmeeting