fpc
LOGS
16:00:06 <geppetto> #startmeeting fpc
16:00:06 <zodbot> Meeting started Thu May 21 16:00:06 2020 UTC.
16:00:06 <zodbot> This meeting is logged and archived in a public location.
16:00:06 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:06 <zodbot> The meeting name has been set to 'fpc'
16:00:06 <geppetto> #meetingname fpc
16:00:06 <geppetto> #topic Roll Call
16:00:06 <zodbot> The meeting name has been set to 'fpc'
16:00:15 <decathorpe> good evening o/
16:00:18 <ignatenkobrain> .hello2
16:00:19 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Raits' <igor.raits@gmail.com>
16:00:52 <geppetto> #chair decathorpe
16:00:52 <zodbot> Current chairs: decathorpe geppetto
16:00:56 <geppetto> #chair ignatenkobrain
16:00:56 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain
16:01:01 <ignatenkobrain> this time of a year still feels like afternoon
16:01:18 <ignatenkobrain> it is 6 PM, but outside looks like just around 3-4pm
16:01:20 <ignatenkobrain> :)
16:01:23 <geppetto> ignatenkobrain: To be fair, it's just after noon here ;)
16:01:24 <decathorpe> true
16:01:28 <mhroncok> here here
16:01:34 <geppetto> #chair mhroncok
16:01:34 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain mhroncok
16:01:58 <geppetto> But, yeh, we have the same problem where can look up from some work and realize it's not 4pm but 7pm :-o
16:08:14 <geppetto> #topic Open Floor
16:08:23 <geppetto> So here's the schedule … https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/CHSHZMMQZP4ZS4LXFSAI4GANN75TAW6Q/
16:08:34 <ignatenkobrain> I think we need to discuss the fonts thing
16:08:42 <geppetto> 982 is the only new/recent thing happening
16:08:45 * geppetto nods
16:09:33 <geppetto> .fpc 982
16:09:34 <zodbot> geppetto: Issue #982: Font packaging stopped working in rawhide/F33 - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/982
16:11:07 <decathorpe> nim_: I think you're here as well?
16:11:40 <nim_> decathorpe, yes I am, thanks for the reminder
16:12:12 <geppetto> I'm not sure why people are suggesting reverting fonts instead of rpm?
16:12:49 <geppetto> Has anyone spoken to rpm maintainers to say "Yo, you just broke everything … why?"
16:13:26 <nim_> geppetto, they don’t see it that way
16:13:44 * mhroncok doesn't see it that way either
16:13:46 <ignatenkobrain> geppetto: heh, I guess so. The problem was that there was no reproducer. so pmatilai was fed up with those lenghty tickets and just quit discussion by adding warning about unexpanded macro
16:14:04 <nim_> ignatenkobrain, that is false
16:14:40 <nim_> ignatenkobrain, there were multiple reproducers, but he did not want to deal with real fedora spec files
16:15:53 <ignatenkobrain> nim_: can you point to the comment in any FPC ticket that has link to the spec that is broken & steps how to observe breakage?
16:16:02 <decathorpe> nim_: is this the same issue as https://pagure.io/packaging-committee/issue/968 ? I have kinda lost the big picture here ...
16:16:03 * limburgher here but busy
16:16:15 <geppetto> #chair limburgher
16:16:15 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok
16:16:17 <decathorpe> ignatenkobrain: I think here, for example https://pagure.io/packaging-committee/issue/968#comment-641295
16:16:21 <nim_> ignatenkobrain, it is all in the initial rhbz
16:16:39 <geppetto> #topic #982 Font packaging stopped working in rawhide/F33
16:16:39 <nim_> ignatenkobrain, anyway this is long past
16:16:45 <geppetto> .fpc 982
16:16:46 <zodbot> geppetto: Issue #982: Font packaging stopped working in rawhide/F33 - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/982
16:17:15 <ignatenkobrain> decathorpe: sorry, there are at least 4 tickets in FPC, at least 2 bugzillas and I think few tickets in RPM upstream and I guess 1 in redhat-rpm-config... So I am a bit lost too :)
16:17:27 <nim_> ignatenkobrain, since all this forced me to rewritea huge amount of code to deal with the new rpm behaviour
16:18:06 <nim_> ignatenkobrain, at this point there is no need to revert the rpm change, just to merge the adaptatio in redhat-rpm-config
16:18:34 <geppetto> nim_: Can you point to that PR or patch?
16:18:35 <nim_> ignatenkobrain, that pmatilai is sick enouh to NAK
16:18:40 <mhroncok> the rationale for the redhat-rpm-config is not understandable and nobody has the information needed to make the decision
16:18:53 <nim_> ignatenkobrain, after suggesting this approach himself to avoid changing rpm
16:19:16 <ignatenkobrain> mhroncok: +1
16:19:31 <nim_> mhroncok, basically rpm 4.15 changed rpm parser evaluation rules
16:20:11 <nim_> mhroncok, it forced declaring things in a very strict and rigid order
16:20:23 <mhroncok> nim_: you keep repeating that
16:20:35 <nim_> mhroncok, just adding a stupid patch to an existing spec would make it blow up
16:20:37 <mhroncok> nim_: yet I hear RPM devs say: first declare macros, than use the macros
16:20:42 <mhroncok> *then
16:21:01 <mhroncok> and frankly, that soudn *very reasonable*
16:21:20 <decathorpe> mhroncok: thankfully, rpm.specs are not haskell :)
16:21:23 <nim_> mhroncok, that’s not as simple as that because the existing spec codebase and rpm codebase was not designed that way
16:21:39 <mhroncok> yes, it's not simple
16:21:43 <mhroncok> and everyhting is on fire
16:21:48 <mhroncok> yet there is no breakage
16:22:19 <ignatenkobrain> nim_: RPM codebase was designed as RPM developers designed it. That includes pmatilai as he is a one of the biggest contributors there.
16:22:31 <mhroncok> I've read about 5 different tickets and bugzillas and it's full of text
16:22:40 <ignatenkobrain> let
16:23:02 <mhroncok> nim_: you keep saying how everything is in danger and broken, yet I don't see it
16:23:05 <nim_> ignatenkobrain, you had to workaround the warning  pmatilai added today yourself today
16:23:07 <ignatenkobrain> let's put it other way around. which packages in Fedora are broken due to different ordering of Name and other macros.
16:23:12 <geppetto> mhroncok: So at the bottom of https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/83 pnemade seems to agree soemthing is broken and fonts can't be built now
16:23:21 <ignatenkobrain> nim_: I did not workaround. I fixed it.
16:23:39 <ignatenkobrain> geppetto: because nim_ broke it specifically. not because it was broken before that
16:23:53 <ignatenkobrain> geppetto: see https://pagure.io/packaging-committee/issue/982#comment-651685
16:24:19 <ignatenkobrain> fonts-rpm-macro was updated that uses %new_package that is not merged in redhat-rpm-config
16:24:36 <mhroncok> which is the oposite of what nim_ is saying
16:24:51 <ignatenkobrain> but this specific breakage is fault of fonts-rpm-macros.
16:24:53 <mhroncok> I'd love to help nim_, bt I don't see how
16:25:07 <ignatenkobrain> what I want to hear is how many packages broke because of change in RPM.
16:25:11 <nim_> anyway, to make fonts and go rpm safe WRT to the new rigid rpm parser ordering
16:25:37 <nim_> it needs first to move sources and patches to %sourcelist and %patchlist
16:26:09 <nim_> so rpm sees sources and patches after the preamble that sets the variables those use
16:26:37 <nim_> and second to wrap away Name and %package in %new_package
16:26:50 <mhroncok> I am sorry, this is not helping
16:27:02 <nim_> so there is a safe %{source_name} variable that can be used in the preamble logic
16:27:21 <nim_> without depending on the new ordering constrain on %{name} evaluation
16:27:30 <nim_> that’s all
16:27:47 <nim_> rpm 4.15 wants variables to be set before they are used
16:27:48 <geppetto> nim_: I think some of the problem here might be that you know more about fonts than anybody and you are skipping things that are obvious to you, but that is confusing other people?
16:28:22 <ignatenkobrain> nim_: not sure if you saw my questions or ignoring them. Let me repeat one of it: which packages in Fedora are broken due to different ordering of Name and other macros?
16:28:25 <mhroncok> honestly, maybe I am a dinosaur already, but since we call our spec files %{name}.spec, can we just stick with "all packages have Name: " declared in a visble space near the top of the spec file, not hidden by magic?
16:28:35 <nim_> geppetto, I’m summing up the useful constructive bits of the various tickets
16:28:37 <geppetto> Like I have no idea what rpm changed, and what it broke … and thus. trying to work out what the workaround does is very complicated.
16:28:49 <mhroncok> what's the benefot of dynamic Name declaration when we have a static filename?
16:29:20 <geppetto> mhroncok: I believe fonts generates dynamic sub packages
16:29:31 <mhroncok> dynamic subpackages are fine
16:29:41 <mhroncok> have Name: foo and later, dynamic subpackages
16:30:03 <nim_> mhroncok, that removes the special case when the first subpackage and the srpm are the same thing
16:30:30 <mhroncok> nim_: and that cannot be figured out with static Name declaration?
16:30:46 <nim_> mhroncok, most font packages have srpm = first dynamic subpackage
16:30:50 <mhroncok> anyway
16:30:58 <mhroncok> nim_: have you seen ignatenkobrain's question?
16:31:42 <nim_> mhroncok, unfortunately no that can not be done with static name because the new rpm behaviour forces a very specific ordering in the preamble
16:32:02 <mhroncok> nim_: ignatenkobrain's question...
16:32:14 <mhroncok> "which packages in Fedora are broken due to different ordering of Name and other macros?"
16:32:19 <nim_> ignatenkobrain, all go and font packages
16:32:32 <nim_> ignatenkobrain, as soon as you add a Patch line they blow up
16:32:42 <ignatenkobrain> nim_: I know that pmatilai checked dozen of them and none were broken
16:32:52 <nim_> ignatenkobrain, my initial ticket was dejavu blowing up when I added a patch
16:33:14 <nim_> ignatenkobrain, they’re not broken as long as you do not add any patch
16:33:30 <nim_> ignatenkobrain, which means they are not safe maintenance-wise long term
16:33:37 <mhroncok> AFAIK dejavu was building just fine before you updated the macros to use unmerged redhat-rpm-config
16:34:16 <ignatenkobrain> so they are not broken. if something builds and works - it is not broken. if you add patch and it breaks, we need to see how to make that work. does moving Name tag to the top help with that issue?
16:34:18 <nim_> mhroncok, no it was not building just fine. I got it to build with an horrible construct while investigating the initial ticket
16:34:36 <ignatenkobrain> please show me concrete example which is broken now in rawhide
16:34:39 <ignatenkobrain> that was working before and does not work now
16:34:53 <nim_> ignatenkobrain, again moving Name does not work. Those spec files do not have a Name line in the first place
16:35:11 * limburgher blinks
16:35:12 <ignatenkobrain> once more, specific example.
16:35:22 <ignatenkobrain> so that we can look into it rogether here
16:35:43 <geppetto> nim_: Again, if you can show a "normal" package (even with a patch added) that worked before tha rpm change and is broken now … that will help a lot of people understand what the issue is
16:36:18 <geppetto> nim_: And we can push panu or someone else to either revert the rpm change, or come up with a solution that lets the package build.
16:36:20 <nim_> you take sil-mondulkiri-fonts and sil-mondulkiri-extra-fonts as stated a gazillon time in the tickets
16:36:44 <ignatenkobrain> ok, I took it and it is broken because fonts-rpm-macros is broken. any other package/
16:36:48 <ignatenkobrain> ❯ rpmspec -P sil-mondulkiri-extra-fonts.spec
16:36:48 <ignatenkobrain> error: line 165: Unknown tag: %new_package
16:36:50 <mhroncok> nim_: can you show us how it worked before and how it is borken now?
16:37:10 <mhroncok> all I see is breakage by the font macros update
16:37:15 <geppetto> nim_: Do you have a URL to the package before the changes?
16:37:36 <nim_> mhroncok, because the rpm change is silent breakage as long as you do not add patch lines
16:38:09 <decathorpe> nim_: what about existing Patch lines ?
16:38:10 <mhroncok> nim_: I am sorry. Maybe my English is bad, I am not a native speaker... :/
16:38:24 <geppetto> nim_: Ok, that's fine … can you take a package (before the new_package changes) and add a patch as you would have normally done … and then that will build befor ethe rpm change and fail after?
16:38:31 <nim_> geppetto, just take those two packages before this all mess, add a patch line and they will blow up just like dejavu did
16:38:48 <mhroncok> can you show me a specfile that would build fine before the "silent breakage in rpm" and does nto after?
16:38:56 <geppetto> nim_: Ok, can you do that and create an srpm on a copr or people.fedoraproject page?
16:40:11 <geppetto> nim_: I just want something concrete to argue with rpm maintainers about … If I can say here is an srpm that you broke, everything will be much easier
16:40:23 <nim_> geppetto, I can do that (I’m sure koji also recorded the initial dejavu breagae that caused me to investigate this stuff)
16:40:46 <geppetto> nim_: Sure, that's fine … grab the srpm from koji
16:41:06 <decathorpe> nim_: which version of fonts-rpm-macros introduced %new_package?
16:41:34 <nim_> geppetto, rpm maints initially argued that since existing specs were still building there was not problem, that people should not add patches, or if they did add patches to those specs they should jump through hoops
16:41:35 <geppetto> Note that I'm not saying I can get the rpm maintainers to do exactly what you want, but I'm pretty sure we can get them to fix it in some usable way.
16:42:06 <nim_> geppetto, anyway please let me explain, I’m not asking anything from rpm maints now
16:42:26 <geppetto> nim_: Again, if we have something concrete to point at then "you can't add patch to specfiles anymore" seems like something we can push to revert changes for.
16:42:53 <ignatenkobrain> RPM maintainers are on vacation this week, so my proposal is: Ask nim to provide SRPM that worked before and does not work with new RPM. Ask nim to revert usage of %new_package because that is breaking fonts packages for no reason (aka potential breakage). FPC will review provided SRPM and figure out how to proceed from there and talk about that next week
16:43:08 <nim_> all the ugliness in the tickets at least resulted in rpm maints identifying a solution in two stages
16:43:40 <nim_> ffesti, suggested moving all sources and patches in those specs to %sourcelist and %patchlist
16:44:20 <nim_> that solves variable declaration order between the preamble and sources/patches
16:44:35 <geppetto> nim_: But even assuming everyone just let you patch things, nobody knows what those patches workaround … or how. So there's a high probability someone will accidentally break it in the future
16:45:44 <decathorpe> nim_: what I don't understand are the last two commits here. the second one fixed the package *with* patch, but the latest one *broke* things by using %new_package which doesn't exist yet? https://src.fedoraproject.org/rpms/dejavu-fonts/commits/master
16:45:46 <geppetto> nim_: As I said, if we just have a concrete starting point we can maybe all understand the problems … and which solutions look better.
16:45:49 <ignatenkobrain> geppetto: decathorpe mhroncok limburgher  shall we vote on my proposal or you feel that we did not finish basic discussion here?
16:46:00 <nim_> and panu suggested using another variable instead of %{name} to workaround the fact %{name} is set by Name: but Name: has very specific constrains in rpm parser logic
16:46:19 <geppetto> ignatenkobrain: Yeh, I'm +1 on that … AFAIU the problems
16:46:32 <mhroncok> ignatenkobrain: I don't thnk you proposal needs a vote
16:46:35 <nim_> so all I am asking now is to get the new_package thing merged in redhat-rpm-config
16:46:53 <mhroncok> nim_: nobody understands why is that thing needed, sorry
16:46:53 <nim_> becayse that automates the resolution panu proposed for name
16:47:09 <ignatenkobrain> mhroncok: well, just want to be sure that we are all on the same page.
16:47:24 <geppetto> nim_: See above … even if we all just voted yes, without understanding anything … it just sets everything up to fail in the future
16:47:29 <limburgher> ignatenkobrain: which proposal?
16:47:34 <decathorpe> nim_: can you answer my last question? the only breakage I see for dejavu-fonts is caused by adding %new_package.
16:47:50 <ignatenkobrain> limburgher: few lines above. > RPM maintainers are on vacation this week, so my proposal is: Ask nim to provide SRPM that worked before and does not work with new RPM. Ask nim to revert usage of %new_package because that is breaking fonts packages for no reason (aka potential breakage). FPC will review provided SRPM and figure out how to proceed from there and talk about that next week
16:48:13 <geppetto> #action  nim to provide SRPM that worked before and does not work with new RPM.
16:48:27 <limburgher> I agree, and agree with mhroncok that it doesn't need a vote.
16:48:32 <mhroncok> FTR the "new RPM" is not 4.16
16:48:48 <geppetto> #action  nim to revert usage of %new_package because that is breaking fonts packages for future patch breakage
16:48:48 <nim_> geppetto, there are not of those, you need to add a patch for them to blow up
16:49:18 <geppetto> #action  FPC will review provided SRPM and figure out how to proceed from there, pushing back on rpm maintainers etc. if needed
16:49:26 <nim_> geppetto, so yougre asking me to revert the solution ffesti and panu asked me to use?
16:49:42 <geppetto> nim_: As I said … that's fine … just create a dummy package with an empty patch added
16:49:49 <nim_> geppetto, then just revert the rpm change too and things will work as they did before this change
16:50:15 <geppetto> nim_: Being able to add patch is a fine requirement … we just want a concrete srpm that worked before the rpm change, and doesn't after.
16:50:19 <ignatenkobrain> nim_: no, we are asking you to not use %new_package because that IS breaking packages. So far there is no other identified breakage.
16:50:57 <nim_> ignatenkobrain, it’s only breaking packages because you did not merge the code I wrote following panu’s resolution in the ticket
16:51:24 <ignatenkobrain> nim_: because I am not a maintainer of redhat-rpm-config, but pmatilai is.
16:51:42 <nim_> ignatenkobrain, of course I was going to use this code in the macros once it was coded. That’s the whole point of coding it
16:52:03 <geppetto> nim_: Again, can you just provide an srpm that worked before and fails after the rpm change … even if you have to add a dummy patch etc. … we can then see what needs to be fixed on the rpm and how (maybe just revert things, maybe something else)
16:52:38 <nim_> ignatenkobrain, not my fault if panu states one day that’s how he wants things to be done and naks it two days later
16:52:57 <decathorpe> nim_: I only see a successful dejavu-fonts build *with* a Patch in koji ...
16:53:12 <nim_> ignatenkobrain, of course I don{t think he expected his solution to land in a package he maintained
16:54:07 <nim_> decathorpe, honestly I don’t remember if the breakage was sever enoug I needed to borg the spec just for it to land in koji
16:54:49 <decathorpe> uh ... according to koschei, the only thing that broke dejavu-fonts was fonts-rpm-macros 2→3 update.
16:55:13 <ignatenkobrain> decathorpe: I guess that was a %new_package introduction there?
16:55:15 <geppetto> nim_: Can you create a new srpm then and put it on your people site? Again, just a simple package that worked before and fails after the rpm change (feel free to add an empty/useless patch).
16:55:19 <nim_> decathorpe, yes, then it was sever enough the spec could not even make it past fedpkg
16:55:33 <geppetto> nim_: It doesn't need to be dejavu-fonts … anything will do.
16:55:37 <decathorpe> huh?
16:56:08 <nim_> geppetto, yes I stated I will do it. Just, do not have access to anything except the chat window now, seems mutter blew up
16:56:12 <decathorpe> I just don't see any evidence that anything other than fonts-rpm-macros 3 broke anything ...
16:56:43 <mhroncok> this discussion is moveing in circles
16:56:53 <geppetto> nim_: Ok, that's fine
16:57:11 <nim_> decathorpe, the rpm change is latent breakage that triggers when adding a patch or some other operation that conflicts with the new ordering constrains
16:57:11 <geppetto> nim_: Just update the ticket with a URL to the srpm
16:57:16 <nim_> in the parser
16:57:23 <limburgher> I have a hard stop in 3 minutes.
16:57:43 <geppetto> limburgher: No problem, I don't think much else is going to happen today anyway
16:57:45 <decathorpe> but the patch was already there when the package built successfully, and it started to break with fonts-rpm-macros 3?
16:57:47 <ignatenkobrain> #action ignatenkobrain to clean up the tickets around this and keep just one place for discussion
16:58:20 <geppetto> nim_: Then can you remove the workarounds for future patch related breakage, that are breaking things now without redhat-rpm-config updates?
16:59:05 <geppetto> nim_: I realize that means you can't add patches easily but hopefully we can get some traction on a fix for that after people see the problem srpm
16:59:06 <nim_> geppetto, I’m not epoching things, you need to remove the build from koji
16:59:32 <ignatenkobrain> you can't remove builds from koji. you just bump epoch
16:59:35 <geppetto> Can you not just bump release and git revert the change?
16:59:47 <nim_> geppetto, and I’m not rewriting back all the specs i had to change to apply ffesti and panu’s solutions
17:00:05 <limburgher> Thanks all, stay safe!
17:00:18 <ignatenkobrain> thanks limburgher
17:00:20 <nim_> geppetto, so at this point, either the merging gets done, or I orphan the 80 packages
17:00:23 <geppetto> nim_: It shouldn't be manual work … just git revert and then bump releases
17:01:02 <nim_> geppetto, you need to remove the build from koji
17:01:11 <ignatenkobrain> nim_: merging of redhat-rpm-config PR?
17:01:14 <geppetto> I have no idea how to do that, or if it's possible
17:01:17 <decathorpe> nim_: you can't remove builds from koji
17:01:23 <mhroncok> removing builds from koji is not possible
17:01:38 <nim_> geppetto, because I could not apply the solutions panu and ffesti proposed without breaking the API of the fonts macro
17:02:03 <nim_> geppetto, therefore the fonts macro package that uses new_package is a new major version
17:02:37 <nim_> geppetto, and will take precedence no matter what the release is
17:02:48 <ignatenkobrain> nim_: so we need to revert to a version that was not using new_package until the agreement with redhat-rpm-config maintainers is there
17:02:52 <geppetto> Ok, so bump major version too?
17:03:17 <nim_> I had fontpackages 2 that worked fine before this mess
17:03:23 <geppetto> nim_: AFICS we can't let the current state stay around for a week or two
17:03:37 <nim_> I released fontpackages 3 applying panu‘s first half of the solution
17:03:56 <mhroncok> nim_: and built it without the other half by mistake?
17:03:58 <nim_> then I released fonts macros 3 to apply ffesti half of the solution
17:04:36 * mhroncok has a hard stop in 3 minutes
17:04:37 <geppetto> nim_: So we have to git revert back to fontpackages 2 somehow … either via. epoch (that's what it's for) or bumping the major version on the old code.
17:04:44 <nim_> how many major version bumps need I do in my projects just because rpm maints do not want to look at the redhat-rpm-config PR coding their own proposed solution
17:04:46 <nim_> ?
17:05:02 <geppetto> nim_: That's what epoch is for
17:05:37 <nim_> geppetto, wonderful, now I get to drag and epoch for a decade too?
17:05:49 <mhroncok> actually, forever
17:05:54 <nim_> woould not it be loads simpler just to look at the pr and merge it?
17:06:04 <geppetto> Yeh, but that's what epoch is for
17:06:12 <decathorpe> nim_: no?
17:06:15 <mhroncok> nim_: no
17:06:21 <ignatenkobrain> nim_: please let's not go into the discussion about Epoch here. That is the way how we solve this problem. Fullstop here.
17:07:08 <mhroncok> nim_: I don't understand. have you updated the package by mistake?
17:07:11 <geppetto> If you really hate epoch I'm fine with you just bumping your major version instead … but AFAICS we need the old code back, and there's a limited number of ways we can do that.
17:07:17 <nim_> ignatenkobrain, no thaþs not a resolution that’s a way to give you time to look at the redhat-rpm-config pr
17:07:46 <nim_> if you want to blackhole it there’s not point in the exercise, I can just orphan the all package base directly
17:08:03 <mhroncok> that's not helpful
17:08:05 <decathorpe> I don't think blackmail is the way to go here.
17:08:15 <mhroncok> sorry, I need to go
17:08:21 * mhroncok out
17:08:39 <ignatenkobrain> nim_: that will fix problems that exist now. The will unblock pnemade and petersen and other folks who are affected by this issue. the improvement (aka v3) should be solved when not in fire.
17:08:43 <geppetto> nim_: Nobody wants you to do that, but we also can't do what you are demanding we do instead
17:08:46 <ignatenkobrain> now we need to fix breakage that was caused by fonts-rpm-macros
17:09:10 <nim_> decathorpe, it’s no more blackmail when I write it than when ignatenkobrain writes it
17:09:22 <nim_> as he di 2 3 times in the tickets
17:10:15 <ignatenkobrain> I have to leave in like 5-10 minutes. nim_ , will you revert fonts-rpm-macros to v2 or revert patch(es) with %new_package or not?
17:10:37 <nim_> ignatenkobrain, stop claiming that, the only breakage in fonts-rpm-macro is the code that relies on the solution panu proposed to avoid changing rpm
17:10:56 <nim_> ignatenkobrain, I’m fed up with rpm maints trying to put the blame on other people
17:10:59 <ignatenkobrain> nim_: yes or no?
17:11:12 <tibbs> Damn it.
17:11:14 <nim_> ignatenkobrain, at this point I do not know
17:11:26 <nim_> ignatenkobrain, will you look at the PR or no ?
17:11:53 <geppetto> nim_: I'm not sure what ignatenkobrain said in all the tickets, but somebody has to revert the %new_package changes (at least temporarily)
17:11:55 <geppetto> #chair tibbs
17:11:55 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok tibbs
17:11:57 <tibbs> I had a contractor at the house.  They came early.
17:12:12 <decathorpe> tibbs: you missed all the fun!
17:12:12 <geppetto> nim_: It would be much better if that was you, and you didn't orphan them all.
17:12:34 <ignatenkobrain> nim_: which PR? redhat-rpm-config? I am not going to merge it since I am not a maintainer of redhat-rpm-config. How relevant is it to what we are discussion here?
17:12:36 <nim_> geppetto, I’m fine with temporary as long as the other people involved do their part
17:12:54 <nim_> geppetto, and do not use temporary as an excuse to avoid doing their part
17:13:07 <nim_> geppetto, blaming me and my macros in the meanwhile
17:13:12 <geppetto> nim_: As soon as you get the srpm link in the ticket demonstrating the problem, the FPC can push for a resolution
17:13:33 <geppetto> nim_: I'm not blaming you, I just don't understand
17:14:10 <nim_> geppetto, I have no problem with what your wrote. I have lots of problems with what ignatenkobrain wrote repeatedly
17:14:29 <geppetto> nim_: Some of that is probably language translation
17:15:03 <geppetto> nim_: And ignatenkobrain also doesn't understand the problem to the same degree you do … getting the srpm demonstrating the problem will help him too.
17:15:34 <nim_> geppetto, so, I’m fine doing what FPC asks as long as it’s not a validation of people ignoring the problem because it is temporarily hidden
17:15:45 <geppetto> It 100% is not that
17:16:11 <geppetto> It's just the easiest way to get things so they can build again, and people can see the problems you know about.
17:16:31 <nim_> geppetto, unfortunately, most of the investigation was done by panu, with lots of recriminations, and now he’s NAKing his own solution
17:17:15 <ignatenkobrain> ok, I need to run now. nim_ , as we discussed above - please revert breaking changes from fonts-rpm-macros (or any other package that are broken) so that pnemade and petersen are unblocked and send link to SRPM in the ticket that shows RPM breakage and we will try to help you with pushing right solution
17:17:29 <geppetto> Well when we can see that easier we can fix it in some way … it might even be that Panu is confused about it all, and only understands after you create the demonstration package.
17:17:53 <nim_> panu just wants the whole thing to go away so he can pretend it never happened
17:18:01 <geppetto> As I said, that package will help everyone understand the problem better
17:18:24 <nim_> and I also want it to go away but it can not go away before the whole fix is merged
17:18:33 <geppetto> I'm sure that's true … but FPC will defintely make sure font packages can add patches.
17:18:38 <tibbs> OK, I've quickly read through teh backlog.
17:18:49 <ignatenkobrain> tibbs: you were quite fast ;)
17:19:32 <ignatenkobrain> in the worst case, I will revert fonts-rpm-macros during the weekend myself.
17:19:33 <ignatenkobrain> now really need to run, see you around folks!
17:19:35 <tibbs> Is there actual objection to the change needed to redhat-rpm-config, or is the issue just one of timing?
17:19:37 <nim_> geppetto, and I don’t want  pnemade and petersen to go whole steam way with spec files that will need chnaging after the solution lands
17:19:47 <nim_> geppetto, that’s why it needs to land fast
17:19:56 <geppetto> tibbs: AFICS nobody else understands what it does
17:20:15 <nim_> geppetto, the whole thing happened just when i18n and me were gearing to change a huge number of spec files
17:20:30 <tibbs> I haven't spent the time to evaluate it.
17:20:58 <geppetto> nim_: Ahh, that definitely sucks timing wise … but there's not much we can do to fix that now
17:22:24 <tibbs> If this were the kernel, that PR would need to be broken down into functional elements.
17:22:27 <nim_> geppetto, I will create specs with dummy patches, and post them, and work on the pR if tibbs wnats some changes in it, and try to revert in koji
17:23:06 <nim_> that’s just a huge amount of work. I so wish rpm maints had not forced me tu push a new fonts macro packager just so they could evaluate the result
17:23:28 <nim_> because they did not want to discuss anything that was not in koji
17:23:33 * geppetto nods
17:24:08 <geppetto> Next time you could ping someone to get them to discuss things you can see will be problematic, but aren't in koji yet
17:24:18 <petersen> +1
17:24:20 <geppetto> Or create "fake" demonstration packages in koji
17:24:44 <nim_> geppetto, I did ping FPC. That’s another FPC ticket that was ignored
17:24:57 <nim_> in the end I had to push to koji to get things to move
17:25:24 <geppetto> nim_: Ignored is strong … we are on limited members, and the global pandemic isn't helping
17:25:30 <nim_> the next day ffesti proposed his half of the solution, which was a great help, it just should not have needed koji breakage to get to ti
17:25:34 <nim_> it
17:26:04 <nim_> geppetto, I understand, but I could not wait forever, time was ticking for  pnemade and petersen
17:27:04 <nim_> tibbs, the seconf patch in the PR is not 100% baked yet, i will push a fix today
17:27:21 <tibbs> Bottom line here is that RPM isn't going to change back, and complaining about the RPM change is not productive at this point.  That has led to tickets about this filling with pointless argument which makes them hard to follow.
17:27:26 <nim_> probably a missing , somewhere, as the logic is dead simple
17:27:35 * geppetto nods … I understand but it's probably better to escalate to emailing people directly or even ping matt or FESCo members or something
17:27:54 <tibbs> That's a good reason why the potential fixes aren't getting the attention they need.
17:28:11 <tibbs> Well that and the state of the world right now.
17:28:18 <geppetto> The problem is when 6 things have happened, and things don't work anymore it's much harder to see where the best solution is in those 6 changes.
17:28:26 <nim_> tibbs, if you read the tickets you’ll see that from the start up I did not ptopose a revert, just ask people to help find a solution with the new rpm behaviour
17:29:03 <nim_> tibbs, I think I only formally asked for a revert after I got fed up with panu’s stonewalling
17:29:17 <geppetto> So everyone is pointing fingers at a different one of the six changes, and pointing to different solutions … and people from the outside can't see which is best.
17:30:19 <geppetto> anyway, it looks like we have a way forward now … hopefully we can get a consensus on a solution by next week
17:30:29 <nim_> will go away for 30s, need to kill the session to get mutter back and work on all those things
17:30:36 * geppetto nods
17:30:41 <geppetto> It's the end of the meeting anyway
17:31:16 <geppetto> At least it was 30 minutes ago :)
17:31:55 <geppetto> Ok, I assume everyone is good with the meeting ending?
17:32:17 <nim> anyway, I’m back now
17:32:44 <tibbs> I have to run to physical therapy (back injury) but I will see if there is any understanding I can distill from the redhat-rpm-config PR.
17:33:15 <geppetto> nim: Hey, so if there's anything you need to talk about quick feel free to ping me on IRC or email me … also consider applying for one of the seats on the FPC, at least one person on the team will understand fonts as well as you do then :)
17:33:23 <decathorpe> I added a comment to the ticket that should explain why I am confused.
17:33:36 * geppetto nods
17:33:57 <nim> geppetto, I am qualified it’s just I’m not sure I can commit the time FPC needs
17:34:24 <nim> the fonts forge and g o stuff is already a huge Fedora timesink
17:35:28 <geppetto> nim: Yeh, we try to not take a huge amount of time and almost everyone skips the meeting some weeks
17:35:30 <nim> decathorpe, I will answer you too, first test the spectool part
17:35:55 * geppetto nods … ok, cool. Thanks everyone who is left (and those who had to leave early)
17:36:08 <geppetto> #endmeeting