f32-final-go_no_go-meeting
LOGS
17:00:10 <bcotton> #startmeeting F32 Final Go/No-Go meeting
17:00:10 <zodbot> Meeting started Thu Apr 23 17:00:10 2020 UTC.
17:00:10 <zodbot> This meeting is logged and archived in a public location.
17:00:10 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:10 <zodbot> The meeting name has been set to 'f32_final_go/no-go_meeting'
17:00:12 <bcotton> #meetingname F32-Final-Go_No_Go-meeting
17:00:12 <zodbot> The meeting name has been set to 'f32-final-go_no_go-meeting'
17:00:17 <sgallagh> .hello2
17:00:18 <bcotton> #topic Roll Call
17:00:18 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:00:33 <frantisekz> .hello2
17:00:35 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
17:00:37 <mattdm> .hello
17:00:37 <zodbot> mattdm: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:00:37 <pwhalen> .hello2
17:00:40 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
17:00:41 <adamw> .hello adamwill
17:00:41 <michel_slm[m]> .hello2
17:00:42 <mattdm> .hello2
17:00:43 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
17:00:45 <nirik> morning
17:00:47 <zodbot> michel_slm[m]: Sorry, but you don't exist
17:00:50 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:00:59 <bcotton> uh oh, mattdm is here. everyone behave
17:01:03 <mattdm> hahahaha
17:01:12 <adamw> welcome cardinal Matt
17:01:12 <lruzicka> .hello2
17:01:13 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
17:01:16 <mattdm> lol adamw
17:01:20 * sgallagh salutes sharply
17:01:22 <michel_slm[m]> salimma: Michel Salim <michel@fb.com>
17:01:22 <coremodule> .hello2
17:01:23 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
17:01:25 <mattdm> now i'm going to need a fancy hat
17:01:28 <sgallagh> (Thereby cutting his forehead)
17:01:29 <adamw> do you salute cardinals?
17:01:47 <pbokoc> .hello
17:01:47 <zodbot> pbokoc: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:01:48 <lruzicka> I think I feel some positive moods?
17:01:49 <sgallagh> adamw: I do, but it's usually a rude gesture.
17:01:51 <michel_slm[m]> .hello2 salimma
17:01:53 <zodbot> michel_slm[m]: Sorry, but you don't exist
17:01:56 <pbokoc> .hello2
17:01:57 <zodbot> pbokoc: pbokoc 'None' <pbokoc@redhat.com>
17:02:01 <lruzicka> pbokoc, hello <nick> nebo hello2
17:02:05 <cmurf> .hello chrismurphy
17:02:06 <zodbot> cmurf: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
17:02:32 <bcotton> michel_slm[m]: you want `.hello salimma`
17:02:52 <michel_slm[m]> .hello salimma
17:02:55 <zodbot> michel_slm[m]: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:03:01 <michel_slm[m]> wow this is embarrassing
17:03:17 <mattdm> heh
17:03:28 <bcotton> zodbot is cruel
17:03:45 <bcotton> you're probably wondering why i called you all here today
17:03:51 <bcotton> #topic Purpose of this meeting
17:03:52 <bcotton> #info Purpose of this meeting is to check whether or not F32 Final is ready for shipment, according to the release criteria.
17:03:53 <bcotton> #info This is determined in a few ways:
17:03:55 <bcotton> #info 1. No remaining blocker bugs
17:03:56 <mboddu> .hello mohanboddu
17:03:56 <bcotton> #info 2. Release candidate compose is available
17:03:56 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:03:58 <bcotton> #info 3. Test matrices for Final are fully completed
17:04:01 <bcotton> #topic Current status - blockers
17:04:02 <bcotton> #link https://qa.fedoraproject.org/blockerbugs/milestone/32/final/buglist
17:04:18 <bcotton> #info 6 Accepted Blockers
17:04:31 <bcotton> #info 5 of them are VERIFIED (yay!)
17:04:55 <frantisekz> I think we can say even the last one is verified
17:05:04 <bcotton> looks like the last one should be verified, too
17:05:10 <frantisekz> just kparal being too strict
17:05:11 <adamw> yeah, we have two verifications with 1.5, and no rason 1.6 should be different
17:05:13 <adamw> i'll update it
17:05:19 <bcotton> adamw++
17:05:20 <kparal> I let it in ON_QA to gather more feedback
17:05:28 <kparal> we didn't receive any negative one, just positive
17:05:39 <bcotton> kparal just likes blockers :-)
17:05:45 <frantisekz> :)
17:06:34 * mboddu finds another blocker for kparal :D
17:06:43 <bcotton> #info All 6 accepted blockers are now in a VERIFIED state
17:07:01 <bcotton> #topic Current status - test matricies
17:07:02 <bcotton> #link https://fedoraproject.org/wiki/Category:Fedora_32_Test_Results
17:07:36 * sumantro is here
17:07:38 <bcotton> so last week we looked at RC 1.3(?) and it was well tested. how's the testing since then?
17:07:48 <jforbes> .hello2
17:07:52 <adamw> we did change a *lot* of stuff since RC 1.3, for the record
17:07:57 <frantisekz> I've copied lot's of results from rc 1.3-.5
17:08:03 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
17:08:10 <bcotton> yeah, but it's trivial stuff like the kernel and the installer ;-)
17:08:13 <adamw> nothing major, you know, just the installer and the partitioning library and the blivet gui and the kernel and the GNOME display manager and efivar
17:08:18 <frantisekz> the stuff that wasn't or shouldn't be affected by changes in later RCs
17:08:25 <adamw> all the usual normal stuff you change 12 hours before you release an OS right?
17:08:33 <jforbes> this is the way
17:08:36 <frantisekz> :D
17:08:42 <mattdm> there is a reason "this is fine" is our motto
17:08:43 <sumantro> :D :D
17:09:03 * adamw swings censer, chants THIS IS FINE
17:09:14 <jforbes> FWIW, the feedback on F31 for the kernel update has been good too
17:09:24 <adamw> so, we did have to carry some results forward between RCs just because they came so fast and RC 1.6 is very new
17:09:34 <adamw> but i think we have re-tested the most important stuff, enough to cover the things that changed
17:09:51 <bcotton> and 1.6 only had one update from 1.5, right?
17:09:56 <adamw> yeah, efivar
17:10:00 <adamw> but we carried some results forward from 1.3
17:10:11 <hansg> FWIW, the efivar change is isolated to the eMMC code path, which was broken in 1.5 and earlier
17:10:25 <bcotton> hansg++ for a quick fix
17:10:26 <zodbot> bcotton: Karma for jwrdegoede changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:10:33 <frantisekz> the only thing that could've been broken by recent composes and not tested again in RC 1.6 is Mac OS X dualboot
17:10:40 <adamw> i think pretty much everything mandatory is covered, one "missing" thing is ARM desktop upgrade tests but as discussed at previous meetings Workstation wasn't blocking on previous ARM releases so that's kinda 'expected'
17:10:41 <sgallagh> hansg++
17:10:41 <zodbot> sgallagh: Karma for jwrdegoede changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:10:48 <mboddu> hansg++
17:10:48 <zodbot> mboddu: Karma for jwrdegoede changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:10:53 <frantisekz> hansg++
17:10:53 <zodbot> frantisekz: Karma for jwrdegoede changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:10:54 <King_InuYasha> .hello ngompa
17:10:56 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:10:58 <mboddu> nirik: Mac OS X dual boot?
17:11:10 <mboddu> And now he hides
17:11:10 <nirik> sorry, my macbook is too new. ;(
17:11:20 <nirik> I need to poke at it to get it working at all.
17:11:22 <sumantro> hansg++
17:11:22 <zodbot> sumantro: Karma for jwrdegoede changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:11:27 <jforbes> I have an OSX dual boot, but it is not apple hardware
17:11:52 <frantisekz> I wasn't able to make it in time, also, it's mac mini 2012 with High Sierra, I don't think it's too representative
17:12:13 <adamw> we're also missing printing testing with a real printer on ARM, but meh. we have virt printer on ARM and real pritner on x86_64, that should be fine
17:12:22 <nirik> I got it to boot, but the keyboard/touchpad are some weird thing and don't work...
17:12:25 <adamw> (real printing testing turned up a couple of bugs, but netiher really looks like a blocker)
17:12:46 <adamw> thanks to dustymabe for last-minute cloud testing, and pwhalen for all the arm testing of course
17:13:13 <pwhalen> adamw, I had a lot of help this time. thanks coremodule, frantisekz, lbrabec
17:13:32 <adamw> pwhalen: next cycle i'll try and make openqa results actually show up in the wiki...that should help!
17:13:37 <bcotton> pwhalen++ coremodule++ frantisekz++ lbrabec++
17:13:38 <zodbot> bcotton: Karma for lbrabec changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:13:53 <pwhalen> adamw, I tend to move them over too, but thats awesome
17:14:46 <bcotton> any other questions or comments on the test coverage?
17:15:09 * cmurf can vouch for RC 1.2 booting older macs, keyboard and mouse stuff works in GRUB and Shell, but did not test an actual installation for a while
17:15:41 <pwhalen> Working on IoT now, I dont expect any issue with the reaming tests
17:15:44 <pwhalen> https://fedoraproject.org/wiki/User:Pwhalen/QA/IoT/Fedora-IoT-32-20200423.1
17:15:46 <cmurf> usually the issue with macs relate to firmware and booting
17:16:19 <frantisekz> yeah, I've tested RC 1.3, worked just fine (including installation, dualboot...)
17:16:27 <frantisekz> can vouch for that too :)
17:16:37 <adamw> pwhalen: thanks for that, i am still working on automatic matrix creation for IoT as it sort of involved doing huge amounts of work on wikitcms first...:/
17:16:41 <jforbes> As someone who has set up a hackintosh and had to make EFI do unnatural things, this makes sense
17:17:57 <pwhalen> adamw, understood. :(
17:18:15 <nirik> my mac needs a out of kernel spi driver for keyboard/touchpad apparently, and no escape key because thats on the touchbar.
17:18:24 <King_InuYasha> :(
17:18:31 <King_InuYasha> I'm glad my macbook predates that
17:18:42 <pjones> nirik: someone did make linux work on the touchbar now
17:19:01 <pjones> nirik: so it's really just a question of how we want to package up a whole second operating system to run your escape key
17:19:02 <nirik> pjones: yeah, I saw some out of tree stuff floating around... haven't had time to poke at it yet. :)
17:19:07 <bcotton> #topic Current status - RC
17:19:20 <bcotton> #info RC1.6 is the current release candidate
17:19:23 <nirik> yep. escape ios. ;)
17:19:31 <bcotton> mboddu: what can you tell us about this wonderful RC?
17:19:53 <adamw> pjones: oooo i know can we put it in a flatpak? inside coreos?
17:20:02 <mboddu> bcotton: Everything great, missed some images, just like RC 1.2/1.3 but not we got ppc64le silverblue workstation as well
17:20:14 <pjones> adamw: oh and we can make it communicate with the normal OS through aws actions
17:20:23 <adamw> we only missed a couple of live spins, right? just about everything else is there
17:20:30 <King_InuYasha> no guiz, it needs to be inside of Docker!
17:20:38 <bcotton> did Comp Neuro Lab make it?
17:20:49 <mkonecny> 707551
17:20:51 <mattdm> i hope so because it's mentioned in the press release :)
17:20:53 <mboddu> bcotton: Yes, scientific_kde, robotics didn't work
17:20:57 <adamw> https://pagure.io/releng/failed-composes/issue/1336
17:21:05 <bcotton> #link https://pagure.io/releng/failed-composes/issue/1336
17:21:06 <mkonecny> sorry, bad window
17:21:06 <adamw> note the 'failed' 32-bit ARM images there are a lie
17:21:07 <King_InuYasha> :'(
17:21:18 <bcotton> #info scientific_kde, robotics didn't work
17:21:20 <adamw> it's something like 'they always fail in those tasks but we actually get images from some other task'
17:21:33 <adamw> so we do have those. only the three lives at the top really failed.
17:21:43 <nirik> we should fix that.
17:21:46 <pwhalen> and we hope to get that fixed, RSN
17:21:47 <cmurf> pjones: we'll just ship per make/model GRUB blobs and dm-verity images, i'll have the code ready in say two days?
17:21:52 * nirik really wants a FINISHED compose someday.
17:22:04 <pjones> cmurf: I'm glad you're on it
17:22:06 <bcotton> nirik you're so selfish
17:22:24 <bcotton> any other questions or comments about the RC?
17:22:24 <adamw> nirik: we have some! just...not "Fedora" composes...
17:22:25 * nirik bows
17:22:33 <mboddu> nirik: Haha, imagine that for a release :D
17:22:50 <adamw> nope.
17:22:52 <adamw> oh
17:22:55 <adamw> i guess for the record
17:23:08 <adamw> IoT is still not in the main compose and there still seems to be no Official plan for if/how to ship it
17:23:24 <adamw> so I guess that's up to pbrobinson / pwhalen / the websites team / whoever.
17:23:28 <mattdm> I talked to pbrobinson and #thisisfine for F32
17:23:34 <King_InuYasha> yey?
17:23:36 <mattdm> We promise to have a better answer for F33
17:23:41 <adamw> sounds good
17:23:42 <King_InuYasha> pinky promise?
17:24:06 <mattdm> It's still going to be "shipped" in however pbrobinson is doing it now for this release
17:24:17 <King_InuYasha> ah, good, so there will be "something"
17:24:24 <jforbes> Fedora has a history of this type of thing back to FC1. The x86_64 isos were composed at my house and shipped after the fact
17:24:32 <mattdm> yeah it's just not integrated into The Process
17:24:32 <King_InuYasha> :D
17:24:56 <mattdm> jforbes: We'll have to add that the #fedorasocialhour trivia game :)
17:25:16 <bcotton> okay, so let's make a decision then
17:25:26 <bcotton> #topic Go/No-Go decision
17:25:27 <bcotton> I will poll each team. Please reply “go” or “no-go”
17:25:29 <bcotton> FESCo?
17:25:35 <jforbes> mattdm: I think I still have a link to the release announcement
17:25:50 <sgallagh> Go!
17:25:53 <nirik> go
17:25:56 <bcotton> #info FESCo is GO
17:25:59 <bcotton> Releng?
17:26:26 <nirik> go go
17:26:27 <mboddu> Go
17:26:28 <bcotton> #info Releng is GO
17:26:31 <bcotton> QA?
17:26:36 <adamw> per our policy, GO
17:26:37 <King_InuYasha> :D
17:26:44 <bcotton> #info QA is GO
17:26:44 <adamw> (test coverage complete, no outstanding blockers)
17:26:47 <bcotton> #agreed Fedora 32 Final is GO
17:26:48 <bcotton> #info Fedora 32 Final will release on 2020-04-28
17:26:56 <bcotton> #action bcotton to announce decision
17:26:57 <mboddu> Woot woot
17:27:01 <sgallagh> Woo!
17:27:07 <mattdm> thanks everyone!
17:27:07 <bcotton> #topic Open floor
17:27:08 <Defolos> YEAH!
17:27:09 <bcotton> Anything else we need to discuss before closing?
17:27:09 <nirik> 🎉🎉🎉🎉🎉
17:27:10 <pwhalen> W00t!
17:27:13 <jforbes> Woot!
17:27:19 <sumantro> yaay!
17:27:20 <mattdm> how many on-time releases does this make?
17:27:21 <coremodule> Woot!
17:27:30 <mboddu> bcotton: So, I found this blocker... :P
17:27:37 <bcotton> mattdm: 100% of releases since I became FPgM :-p
17:27:41 <bcotton> mboddu: sorry, too late :p
17:27:45 <mattdm> .fire mboddu
17:27:46 <zodbot> adamw fires mboddu
17:27:52 <mattdm> bcotton++
17:28:12 <bcotton> not to get all In These Uncertain Times on you, but i appreciate the hard work everyone has put in, especially in these uncertain times
17:28:12 <mboddu> mattdm: 5th on time release, if I am not wrong
17:28:17 <adamw> mattdm: Teh Intarwebs told me that it doesn't count as on time unless we hit the preferred date
17:28:18 <adamw> sorry
17:28:24 <mattdm> adamw: FALSE
17:28:32 <adamw> but the interwebs are never wrong!
17:28:34 <mattdm> that counts as _early_
17:28:39 <cmurf> exactly
17:28:43 <King_InuYasha> so then we've done it since Fedora 28
17:28:50 <bcotton> 5 sounds right
17:28:56 <King_InuYasha> the interwebz broke when that happened :D
17:29:03 <adamw> on-time, heavily tested releases
17:29:04 <adamw> koffkoff
17:29:05 <mattdm> Seriously though I am half serious about renaming "preferred target" to "phoronix target"
17:29:06 <jforbes> Does this mean the F32 test push can happen now so I don't supercede the release kernel and it goes away?
17:29:07 <pbokoc> wait, is this on time? I thought we slipped by a week - was Apr 28 the original plan?
17:29:07 <kk4ewt> lets say instead on schedule
17:29:19 <mattdm> kk4ewt++
17:29:28 <adamw> jforbes: yeah, we will do a stable push this afternoon
17:29:29 <kk4ewt> pbokoc;  second scheduled
17:29:30 <King_InuYasha> pbokoc: we didn't have to edit the F32 schedule
17:29:35 <adamw> mboddu and i just need to line up the ducks
17:29:42 <bcotton> i'm 75% serious about calling them "early target" and "preferred target"
17:29:44 <King_InuYasha> mattdm: iirc, the rule is we didn't have to edit the schedule wiki page, right?
17:29:45 <King_InuYasha> :P
17:29:46 <pbokoc> ah, right :)
17:29:47 <adamw> all the packages from RC 1.6 will be pushed stable, including kernel 5.6.6
17:29:47 <jforbes> I just need a test push so I can mark it for stable
17:30:00 <kk4ewt> bcotton;  then you will be late
17:30:17 <nirik> bcotton++
17:30:37 <kk4ewt> but at least when we say we will release there is a set time whereas ubuntu is releasing sometime today
17:30:48 <King_InuYasha> it's already out, iirc
17:30:57 <King_InuYasha> they're waiting for mirror sync for the announcement
17:31:10 <King_InuYasha> the isos spin at midnight UTC for them, iirc
17:31:15 <bcotton> alright, y'all. i'm going to bang the gavel so we can set this ball in motion
17:31:18 <bcotton> last call
17:31:18 <mboddu> jforbes : All the packages that went into RC will be pushed stable today, but remaining everything will start from tomorrow
17:31:41 <bcotton> #endmeeting