fpc
LOGS
17:00:20 <geppetto> #startmeeting fpc
17:00:20 <zodbot> Meeting started Thu Feb 13 17:00:20 2020 UTC.
17:00:20 <zodbot> This meeting is logged and archived in a public location.
17:00:20 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:20 <zodbot> The meeting name has been set to 'fpc'
17:00:20 <geppetto> #meetingname fpc
17:00:20 <geppetto> #topic Roll Call
17:00:20 <zodbot> The meeting name has been set to 'fpc'
17:00:30 <mhroncok> hey
17:00:34 <geppetto> hey
17:00:36 <geppetto> #chair mhroncok
17:00:36 <zodbot> Current chairs: geppetto mhroncok
17:00:46 <decathorpe> I'm here o/
17:01:05 <ignatenkobrain> .hello2
17:01:06 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
17:01:09 <ignatenkobrain> I'm partially here
17:01:38 <nim> .hello2
17:01:38 <zodbot> nim: nim 'None' <nicolas.mailhot@laposte.net>
17:02:07 * limburgher here
17:02:37 <geppetto> #chair decathorpe
17:02:37 <zodbot> Current chairs: decathorpe geppetto mhroncok
17:02:41 <geppetto> #chair ignatenkobrain
17:02:41 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain mhroncok
17:02:55 <geppetto> #chair limburgher
17:02:55 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok
17:05:48 <geppetto> Well we have quorum and I don't think tibbs will be here … so
17:05:51 <geppetto> #topic Schedule
17:05:55 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/ZBANUQPPU3O3X6T2D7ELUTMW4JS4NCQ2/
17:07:52 <geppetto> #topic #935 Fonts packaging policy rewrite
17:07:57 <geppetto> .fpc 935
17:07:58 <zodbot> geppetto: Issue #935: Fonts packaging policy rewrite - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/935
17:08:09 <geppetto> So by my count, decathorpe, mhroncok and myself are +1
17:08:34 <geppetto> So it'd be pretty cool if limburgher and ignatenkobrain could vote :)
17:08:54 <nim> yes!
17:09:22 <nim> or, alternatively, tell what they want to be changed
17:11:02 <ignatenkobrain> I'm +0
17:11:38 <nim> I’d like to get the basic packaging bit out of the way so people that want to work on console fonts can define their own guidelines
17:11:39 <geppetto> ignatenkobrain: any changes you'd like to see that would push you to +1 ?
17:11:50 <nim> and i can work with tagoh on the fontconfig part
17:13:13 <nim> ignatenkobrain, the rpm part in a thin layer over the macro core already used by go and forge macros
17:13:27 <ignatenkobrain> geppetto: just making the whole thing less magic :) but you can count me for +1
17:13:59 <ignatenkobrain> nim: by those overwngineered and magic macro which nobody except of you can maintain?
17:14:38 <nim> ignatenkobrain, it's just basic lua code
17:15:08 <nim> ignatenkobrain, if you want to document how to write the generated specs manually, be my guest
17:15:43 <nim> ignatenkobrain, the magic is here so contributors do not have to do things by hand
17:15:46 <ignatenkobrain> nim: no, we are working in RPM upstream on dynamic packages creation.
17:15:54 <geppetto> limburgher: I think that just leaves you then?
17:15:59 <nim> ignatenkobrain, and because everyone here hates to document how to do things by hand
17:16:12 <limburgher> I'm +1
17:16:27 <geppetto> Cool …
17:16:47 <geppetto> #action Fonts packaging policy rewrite (+1:5, 0:0, -1:0)
17:16:59 <geppetto> nim: Go forth and console font :)
17:17:08 <nim> thanks all!
17:17:24 <nim> I will create a review request for the macro package
17:17:42 <nim> the srpm part will need to be in the default buildroot like other srpm macro packages
17:18:28 <geppetto> nim: Ok
17:18:30 <nim> and then I guess I have to write a script to open review requests for all the font packages that were waiting on it
17:19:00 <geppetto> #topic #pr-938 Add Package Review Process page
17:19:12 <geppetto> #link https://pagure.io/packaging-committee/pull-request/938
17:19:23 <nim> geppetto, as for console fonts I don’t want to car about them at all but others do and may propose guidelines :)
17:19:43 <geppetto> nim: :)
17:20:22 <ignatenkobrain> I didn't have time to look at this PR yet, but I think this is something what should be in FPC docs
17:20:44 <mhroncok> the wiki vs docs is a mess :(
17:21:04 <mhroncok> and I love git and PRs, but working with this is so tedious
17:21:36 <decathorpe> what's the progress of packaging antora for fedora? ;)
17:21:40 <mhroncok> generally +1 to move it, but I haven't reviewed it yet
17:21:53 <mhroncok> decathorpe: does it require gradle?
17:22:02 <geppetto> The PR seems fairly simple, and I can't see anything that would make me want to do anything but +1
17:22:20 <geppetto> We can spend a few minutes on this while people read it, as there's not much else pending
17:22:23 <decathorpe> mhroncok: I hope not. it's NodeJS, IIRC
17:22:43 <limburgher> I like it.
17:23:13 <decathorpe> sembr would be nice to have, though. it's hard to read it like this
17:24:24 <geppetto> yeh, reading markdown diffs isn't ftw
17:24:29 <mhroncok> I relaize that asking contributors to do sembr is hard. we should do it instead
17:32:51 <decathorpe> how relevant is this line: "* Packages merged from the old Fedora Core repository"
17:33:39 <mhroncok> decathorpe: we can drop it later
17:33:51 <mhroncok> decathorpe: I mean, perfect is the enemy of good
17:35:17 <decathorpe> true
17:36:57 <mhroncok> ship it +1
17:38:11 <decathorpe> some "should" should be replaced by "SHOULD" or "MUST", but that's not important right now
17:40:02 <geppetto> I'm +1
17:41:45 <decathorpe> yeah, looks good to me. +1
17:41:55 <limburgher> Official +1
17:42:51 <geppetto> ignatenkobrain: It's all on you :)
17:47:28 * mhroncok brb
17:47:32 <mhroncok> puppy needs to go out
17:53:36 * mhroncok is back
17:54:50 <limburgher> I have a hard stop in 6min.
17:55:44 <geppetto> limburgher: You want to vote on the above?
17:56:03 <geppetto> Sorry … wrong person … who didn't vote
17:56:24 <limburgher> I mean, I *do* live near Chicago...
17:56:25 <geppetto> ignatenkobrain: It's you?
17:57:03 <geppetto> yeh, I got it right above … nevermind … we can pick it up next week, I know ignatenkobrain said he was only sort of here this week.
17:58:18 <geppetto> #topic Open Floor
17:58:28 <geppetto> Only got a couple of minutes … but anything pressing?
17:59:26 <mhroncok> please vote on the python PR?
17:59:29 <mhroncok> in the pr
17:59:45 <mhroncok> #link https://pagure.io/packaging-committee/pull-request/940
17:59:46 <geppetto> That's #940
17:59:52 <geppetto> yeh, that one
18:00:23 <decathorpe> oof I somehow missed that PR. I'll vote on the ticket
18:01:10 <geppetto> #endmeeting