fesco
LOGS
15:00:16 <contyk> #startmeeting FESCO (2020-01-06)
15:00:16 <zodbot> Meeting started Mon Jan  6 15:00:16 2020 UTC.
15:00:16 <zodbot> This meeting is logged and archived in a public location.
15:00:16 <zodbot> The chair is contyk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:16 <zodbot> The meeting name has been set to 'fesco_(2020-01-06)'
15:00:19 <contyk> #meetingname fesco
15:00:19 <zodbot> The meeting name has been set to 'fesco'
15:00:28 <contyk> #chair nirik, ignatenkobrain, decathorpe, zbyszek, bookwar, sgallagh, contyk, mhroncok, dcantrell
15:00:28 <zodbot> Current chairs: bookwar contyk dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
15:00:31 <decathorpe> hey guys o/
15:00:34 <contyk> #topic init process
15:00:38 <contyk> .hello psabata
15:00:38 <zbyszek> .hello2
15:00:39 <sgallagh> .hello2
15:00:39 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:42 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:00:45 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:47 <ignatenkobrain> .hello2
15:00:49 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
15:00:54 <sgallagh> Happy New Year!
15:00:56 <mhroncok> .hello churchyard
15:00:57 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
15:01:23 <contyk> Happy New Year indeed.
15:01:53 <bcotton> .hello2
15:01:55 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:02:08 <contyk> Well, we have quorum; suppose we can start.
15:02:20 <nirik> morning
15:02:22 <contyk> #topic #2303 F32 System-Wide Change: Drop Optical Media Release Criterion
15:02:29 <contyk> https://pagure.io/fesco/issue/2303
15:02:35 <contyk> .fesco 2303
15:02:36 <zodbot> contyk: Issue #2303: F32 System-Wide Change: Drop Optical Media Release Criterion - fesco - Pagure.io - https://pagure.io/fesco/issue/2303
15:03:45 <frantisekz> I (change proposer) am here, in case anybody wanted to ask me anything
15:03:53 <nirik> so, I am mostly ok with zbyszek's proposal...
15:04:04 <nirik> https://pagure.io/fesco/issue/2303#comment-617872
15:04:18 <zbyszek> ... and I'm OK with the clarifications that people submitted.
15:04:42 <zbyszek> In particular, booting from virtual optical media must remain blocking, since that's prolly the most often used boot method.
15:04:57 <sgallagh> zbyszek: I agree
15:05:19 <nirik> I'm not sure it makes sense to ' boot from physical optical media is removed from QA matrices" since it still needs to be tracked somehow right? just QA doesn't need to run that test...
15:05:20 <mhroncok> frantisekz: are you ok with zbyszek's+adamw's changes?
15:05:28 <frantisekz> mhroncok: yes
15:05:52 <zbyszek> nirik: right
15:06:10 <mhroncok> proposal: frantisekz will update the proposal to reflect the changes requested in the ticket, we will vote after that happens
15:06:12 <sgallagh> So to rephrase the current proposal succinctly: We no longer block on issues that result in *only* physical CD/DVD media from being uninstallable. Virtually attaching ISO files remains blocking.
15:06:18 <sgallagh> Does that miss anything?
15:06:19 <dcantrell> .hello dcantrel
15:06:20 <zodbot> dcantrell: dcantrel 'David Cantrell' <dcantrell@redhat.com>
15:06:45 <nirik> sgallagh: no, we still would block according to the current proposal I thought?
15:06:48 <contyk> sgallagh: uninstallable?
15:06:59 <zbyszek> sgallagh: by "current proposal" do you mean the Change text, or what I wrote, or ?
15:07:05 <nirik> just that QA doesn't run those tests, interested community members do.
15:07:11 <frantisekz> sgallagh: As I see it, optical is still blocking, but it's not needed to be tested by QA before GA
15:07:12 <sgallagh> contyk: Incorrect word. "fail to install"
15:07:41 <sgallagh> zbyszek: I'm trying to get an abbreviated explanation of the current proposal we are expected to vote on.
15:07:42 <contyk> Blocking and not tested doesn't make sense to me.
15:07:57 <sgallagh> contyk: That's how we deal with SAS as well
15:08:01 <zbyszek> sgallagh: then no, that's not correct.
15:08:25 <sgallagh> It's blocking to fix it if anyone notices that it's broken, but it isn't regularly tested by QA (because it requires specialized hardware)
15:09:20 <zbyszek> Right, and we should do something like this with Optical media.
15:09:33 <mhroncok> that is what I agree with
15:09:38 <sgallagh> zbyszek: OK, then is it "All currently-blocking optical media remains blocking, but physical tests are no longer required for release approval"?
15:09:39 <frantisekz> nowadays, we can use that exact wording... :D
15:09:49 <contyk> Optical media installation is probably way more common, though.
15:09:53 <mhroncok> there are rules in place for late reported bugs
15:10:28 <sgallagh> contyk: Almost no consumer devices ship with optical drives for the last several years (probably fewer than ship with serial-attached SCSI, frankly)
15:10:44 <mhroncok> contyk: if they are so common, surely there will be community memebers who will test it instead of our QA
15:10:58 <zbyszek> sgallagh: yes
15:11:12 <contyk> mhroncok: I was expecting this argument; surely we could stop testing anything then :)
15:11:16 <sgallagh> zbyszek: I can be on board with that.
15:11:26 <mhroncok> contyk: "we"? or fedora qa?
15:11:26 <sgallagh> contyk: I thought we already had!
15:11:28 * sgallagh runs
15:11:31 <contyk> sgallagh: Well, I don't know; we keep hearing from people who run pretty old hardware.
15:11:38 <zbyszek> FWIW, I just bought a computer a few weeks ago (used) with a DVD-RW drive...
15:11:44 <mhroncok> this is the i686 problem again
15:11:57 <mhroncok> either they will participate, or it will not eb tested and eventually might break
15:12:10 <nirik> zbyszek: did you install from it? or use usb? ;)
15:12:15 <zbyszek> usb ;)
15:12:35 <frantisekz> also, some member of QA will probably test the physical optical media boot somewhere in the release cycle, purpose of this proposal is not to require such testing, so we won't block our testing desktops by burning dvds and installing from them during hero testing
15:12:50 <sgallagh> contyk: I don't think any x86_64 hardware exists that CANNOT boot from USB, so that should be an acceptable workaround.
15:13:07 <dcantrell> sgallagh: that's a dangerous thing to assume
15:13:35 <sgallagh> dcantrell: How so?
15:13:41 <dcantrell> (also I joined late because I forget the meeting was in -1)
15:13:42 <frantisekz> there are broken firmwares out in the wild that have borked usb boot, but lot's of them are able to boot at least in legacy/bios mode from usb
15:13:53 <sgallagh> IIRC, the ability to boot from USB predates the first public release of x86_64 hardware
15:14:01 <frantisekz> and also, I've never seen such a broken machine
15:14:11 <dcantrell> sgallagh: what frantisekz said basically.  it's the firmware problem, which is always a problem
15:14:27 <dcantrell> sgallagh: that doesn't mean any vendor implemented it correctly.
15:14:38 <sgallagh> That would (even today) fall into the category of "we can't guarantee every system"
15:14:38 <zbyszek> sgallagh: examples were given on the list
15:14:41 <dcantrell> my only point is that providing more options to users allows them to probably find something that will boot for them
15:14:47 <contyk> There are other ways to boot; USB is not the only alternative.
15:14:50 * sgallagh has been on PTO for three weeks. I am way behind on the list
15:15:27 <mhroncok> are we getting aywhere?
15:15:29 <contyk> I just still feel optical media is still pretty relevant, even today. I don't have any statistics to back that claim, of course.
15:15:42 <dcantrell> my comment was really just meant to point out sgallagh's statement of not thinking there's an x86_64 that cannot boot USB....I guarantee there is, even if we've never seen it
15:15:45 <contyk> If we don't want to test it, fine, I guess.
15:15:54 <contyk> mhroncok: And "we" includes Fedora QA :)
15:15:58 <frantisekz> :)
15:16:00 <dcantrell> contyk: agreed, I think plenty of people use it, like it, whatever
15:16:06 <nirik> mhroncok: perhaps we should vote and see where everyone is at?
15:16:19 <mhroncok> perhaps
15:16:30 <sgallagh> dcantrell: Ok, I overstated my positiion, but bugs will always exist.
15:16:39 <dcantrell> sgallagh: yes, we work in software. we'
15:16:39 <contyk> So, any specific proposal we could vote on?
15:16:39 <sgallagh> I mostly meant that it is standard that all such systems support it.
15:16:43 <dcantrell> re paid to write bugs  :)
15:16:55 <dcantrell> sgallagh: ah yes, standards will save us  :)
15:17:08 <sgallagh> So many to choose from, at least one must work!
15:17:13 * dcantrell works on finishing his morning coffee
15:17:34 <nirik> lets make a new one! it will be so much better than the old ones!
15:17:48 <sgallagh> Proposal: Blocking status remains unchanged, however FESCo no longer requires QA to test and report on physical media as part of the formal release criteria.
15:18:03 <nirik> +1
15:18:16 <dcantrell> +1
15:18:16 <mhroncok> that's the same proposal as I had, in different words, +1
15:18:17 <zbyszek> +1
15:18:22 <decathorpe> +1
15:18:26 <contyk> 0
15:18:40 <sgallagh> mhroncok: That was my goal; to make sure I understood what you were saying.
15:18:45 <mhroncok> (better words actually, as it requires less digging)
15:18:51 <mhroncok> sgallagh++
15:18:51 <zodbot> mhroncok: Karma for sgallagh changed to 9 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:18:52 <smooge> ok side question
15:19:01 <contyk> ignatenkobrain: ?
15:19:18 <ignatenkobrain> +0
15:19:34 <sgallagh> smooge: Go ahead
15:19:55 <smooge> does this mean that releng needs to make compose sizes of media below certain thresholds for booting on un-tested physical media
15:19:56 <contyk> #agreed Blocking status remains unchanged, however FESCo no longer requires QA to test and report on physical media as part of the formal release criteria. (+6, 2, -0)
15:20:19 <nirik> smooge: no changes to sizes based on this...
15:20:31 <smooge> aka the DVD needs to remain below N GB depending on what DVD size is
15:20:33 <sgallagh> smooge: Rephrased, is the question whether to stop failing composes if the size grows? No
15:20:39 <zbyszek> smooge: I don't think this matters much, because current limits are actually pretty far from the media limits
15:20:55 <smooge> even if the virtual boot would work with a 16GB iso
15:21:02 <nirik> well, we only actually have one dvd media... the server dvd.
15:21:17 <mhroncok> now, can we still get that change proposal page updated with what we have actually approved?
15:21:22 <mhroncok> otherwise it is a mess
15:21:29 <sgallagh> nirik: What about the Workstation Live?
15:21:37 <smooge> ok skip DVD.. we have to keep those other isos below cdrom size
15:21:39 <nirik> it targets a usb...
15:21:46 <sgallagh> ok
15:21:48 <contyk> mhroncok: I'll note that in the ticket
15:21:49 <nirik> it works on dvd media, but the size is for usb
15:22:10 <zbyszek> https://fedoraproject.org/wiki/Releases/31/ReleaseBlocking has the limits
15:22:45 <contyk> Okay.
15:22:52 <contyk> #topic Next week's chair
15:23:04 <contyk> Any volunteers?
15:23:19 <mhroncok> I cannot and will not attend
15:23:22 <zbyszek> smooge: e.g. Fedora-server-dvd has specified limit of 4.7GB, but is actually 2GB in F31.
15:23:30 <zbyszek> I can do it.
15:23:37 <smooge> ok thanks
15:24:03 <contyk> Well, I could do it again.
15:24:09 * contyk shrugs
15:24:18 <contyk> #action contyk will chair the next meeting.
15:24:23 <contyk> #topic Open Floor
15:24:30 <mhroncok> there were two more "meeting" tagged tickets but they were not part of the agenda: https://pagure.io/fesco/report/meeting_agenda - was that deliberate?
15:25:04 <sgallagh> zbyszek: yeah, I went through it and shrunk it down quite a bit this cycle
15:25:31 <contyk> mhroncok: yes, they were too new
15:26:02 <mhroncok> contyk: ack
15:26:02 <sgallagh> contyk: If a FESCo member adds the `meeting` keyword, it's not "too new"
15:26:29 <contyk> Alrighty.
15:26:37 <sgallagh> It's a statement that said member feels it needs active discussion.
15:26:38 <contyk> Let's discuss them then.
15:26:48 <sgallagh> (If mhroncok disagrees, he can drop it)
15:26:53 <mhroncok> sgallagh: it's added with first -1 vote actually
15:26:58 <mhroncok> by policy
15:27:04 <contyk> #topic #2310 F32 System-Wide Change: Use update-alternatives for /usr/bin/cc and /usr/bin/c++
15:27:10 <contyk> .fesco 2310
15:27:11 <zodbot> contyk: Issue #2310: F32 System-Wide Change: Use update-alternatives for /usr/bin/cc and /usr/bin/c++ - fesco - Pagure.io - https://pagure.io/fesco/issue/2310
15:27:14 <mhroncok> I am fine discussing it in the tickets or next weeks
15:27:20 <sgallagh> mhroncok: Ah, I missed igor's -1
15:27:50 <contyk> So this one has two -1s
15:28:00 <contyk> Three.
15:28:07 <mhroncok> but if we don't want to put stuff to meeting agenda immediatelly after -1, we can change ti so it is tagged with meeting after the first 7 days, if it has negative votes
15:28:28 <contyk> No, it's fine.
15:28:32 <mhroncok> (honestly, there is not much difference, as we can always say "too new")
15:28:49 <contyk> It was just three days and I didn't expect anyone to be fresh and ready to discuss stuff.
15:28:51 <zbyszek> I'm not too happy about more alternatives use, but I don't think we can get rid of alternatives, so I don't think this is enough to reject the proposal.
15:28:52 <nirik> it's fine, but IMHO we don't want to discuss things that were too new for anyone to have read up on them.
15:29:13 <ignatenkobrain> I'm fine with discussing them either way.
15:29:24 <sgallagh> So, I assume this one is intended to make it easier for things like the Developer Tool Set to define a "system compiler"
15:29:33 <ignatenkobrain> One thing I would like is if we discuss it here, we invite owners of a change
15:29:55 <dcantrell> that's a reasonable idea, but we could ask for more explanation in the ticket too
15:30:05 <dcantrell> from the change owner
15:30:06 <contyk> ignatenkobrain: That would normally happen.
15:30:10 <mhroncok> I'm not against alternatives if they are deemed appropriate to achieve a goal
15:30:16 <sgallagh> Yeah, that would happen if it was on the agenda.
15:30:25 <mhroncok> here, the goals can be achieved differently, by better ways. all listed benefits of the change
15:30:31 <sgallagh> So probably we should punt to next week to give them time to attend if they wish
15:30:34 <contyk> Pinging tstellar.
15:30:58 <zbyszek> mhroncok: the problem with the alternative approaches is that none of them work completely (though neither do alternatives).
15:31:18 <zbyszek> So it might be useful to allow alternatives *and* the other approaches in combination.
15:31:59 * contyk has no issues with alternatives.
15:32:04 <mhroncok> Alternatives MAY be used to allow parallel installation of software when:
15:32:04 <mhroncok> the software can be used as a drop-in replacement and functions with sufficient similarity that users and other programs would, within reason, not need to know which variant is currently installed
15:32:04 <mhroncok> AND
15:32:04 <mhroncok> the selection of the software is only performed system-wide by the system administrator and end users do not have a need to switch between the variants.
15:32:08 <mhroncok> https://docs.fedoraproject.org/en-US/packaging-guidelines/Alternatives/
15:32:11 <dcantrell> mhroncok: if not alternatives, what can do it?
15:32:15 <ignatenkobrain> My -1 was because this is just for c compiler.. if we want to make this more useful, we should develop standard way of creating such alternatives.
15:32:19 <mhroncok> so is this true here or are we approving an exception?
15:32:23 <ignatenkobrain> Imagine chromium and chromium-freeworld
15:33:08 <ignatenkobrain> If we will develop and advertise method for other people to override Fedora things and have gcc as a pioneer, I'm fine
15:33:12 <mhroncok> I think that it is the user who decides whther they want gcc or clang, not admin
15:33:26 <contyk> ignatenkobrain: Isn't alternatives the standard method already?
15:33:26 <ignatenkobrain> But just using this for gcc exclusively, I'm not.
15:33:29 <mhroncok> admins might decided what they use to compile software for that installation, but not what users will use
15:33:50 <dcantrell> I like the idea of alternatives in this case because the system could lack gcc and only have clang, but the admin could set up /usr/bin/cc anyway
15:33:58 <zbyszek> dcantrell: +1
15:33:59 <dcantrell> so a non-admin user would still be able to find a 'cc'
15:34:11 <mhroncok> clang depnds on gcc
15:34:17 <sgallagh> dcantrell: Well, not currently in Fedora, but I know what you mean
15:34:30 <mhroncok> "End users will care which variant they are using. If a non-root user would gain value by switching between the variants then alternatives MUST NOT be used."
15:34:31 <sgallagh> mhroncok: Yeah, but if they brought in someone else's clang...
15:34:38 <dcantrell> right, so putting aside current implementation, the frontends of either gcc or clang could be called 'cc'
15:34:48 <contyk> I don't think the change owner will make it.
15:34:56 <dcantrell> so why let gcc own that if we're in a world where some users may want that to be gcc and others clang?
15:35:11 <contyk> Proposal: Discuss the Change proposal next week with the Change proposal owner being present.
15:35:11 <mhroncok> rain check, this was not on the agenda
15:35:17 <nirik> contyk: +1
15:35:20 <mhroncok> contyk: -1
15:35:21 <dcantrell> sounds good
15:35:26 <dcantrell> next week
15:35:27 <ignatenkobrain> +1
15:35:33 <dcantrell> +1
15:35:37 <mhroncok> counter Proposal: Discuss the Change proposal next week
15:36:13 <mhroncok> we don't generally make it a MUST for the change owners to be present. do we know they will be, to amke ti a requirement?
15:36:22 <nirik> I think the intent was to invite the change owner...
15:36:23 <contyk> Noted.
15:36:34 <mhroncok> *make it
15:36:36 <decathorpe> +1 to discuss next week
15:36:45 <contyk> Yes, the intent is to invite stellar, not make their presence a requirement.
15:37:49 <frantisekz> FYI: I've just updated the optical media criterion proposal to reflect discussed changes : https://fedoraproject.org/wiki/Changes/Drop_Optical_Media_Criterion
15:38:21 <contyk> sgallagh, zbyszek: Next week?
15:38:24 <bcotton> frantisekz++
15:38:24 <zodbot> bcotton: Karma for frantisekz changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:38:38 <zbyszek> contyk: I'm fine with that.
15:38:40 <sgallagh> contyk: Yes
15:39:02 <contyk> #agreed FESCo will discuss #2310 next week (+8, 0, -0)
15:39:20 <contyk> Do we want to cover 2309 today then?
15:39:34 <mhroncok> frantisekz: "This means." leftover in summary
15:40:08 <frantisekz> yeah, fixed, thanks
15:40:09 <contyk> I'd leave it for next week.
15:40:14 <mhroncok> contyk: I don't need to. I only wanted to know whether this was on purpose
15:41:09 * zbyszek voted in the ticket already
15:41:29 <dcantrell> I am ok discussing 2309 now or next week
15:41:32 <contyk> Let's try next week with the proposal owner, if possible :)
15:41:42 <dcantrell> contyk: sounds good
15:41:49 <contyk> Anything else for the open floor?
15:42:09 <zbyszek> contyk: can we vote on the optical media criterion now?
15:42:54 <dcantrell> contyk: I have a question about meeting agenda emails.  Do they go out and if so where?
15:43:16 <nirik> zbyszek: we already did?
15:43:25 <contyk> zbyszek: I think we did before; do you want to ack it again?
15:43:31 <contyk> dcantrell: devel@lists.fpo
15:44:01 <dcantrell> contyk: thanks, gonna make sure those are getting enough attention in my MUA
15:44:08 <mhroncok> dcantrell: https://fedoraproject.org/wiki/FESCo_meeting_process
15:44:26 <zbyszek> contyk, nirik: sorry, for some reason I thought we wanted to re-ack the final text.
15:44:29 <zbyszek> Sorry for the noise.
15:44:49 <contyk> zbyszek: No worries; do you think it's necessary?
15:44:50 <nirik> ah, ok.
15:45:37 <dcantrell> mhroncok: thanks
15:47:27 <contyk> Okay, let's close this.
15:47:36 <contyk> #endmeeting