fpc
MINUTES

#fedora-meeting-1: fpc

Meeting started by mhroncok at 16:00:07 UTC (full logs).

Meeting summary

  1. Roll Call (mhroncok, 16:00:07)
  2. Open Floor (mhroncok, 16:08:35)
    1. SELinux people approached me to ask what they can do to move https://pagure.io/packaging-committee/pull-request/814 forward (mhroncok, 16:09:30)

  3. Schedule (mhroncok, 16:18:11)
    1. https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/NFH4A6XZLFQCL7XGYJJSZF3HZ5TU4E42/ (mhroncok, 16:18:17)

  4. #902 Cleanup & enhance spec files (mhroncok, 16:18:25)
    1. https://pagure.io/packaging-committee/issue/902 (mhroncok, 16:18:25)
    2. We should document that man pages are automatically marked as %doc and the packagers don't need to mark them as such (mhroncok, 16:30:04)

  5. #904 Caret versioning (mhroncok, 16:31:24)
    1. https://pagure.io/packaging-committee/issue/904 (mhroncok, 16:31:25)

  6. #907 Which %__foo macros for executables are acceptable? (mhroncok, 16:35:50)
    1. https://pagure.io/packaging-committee/issue/907 (mhroncok, 16:35:50)
    2. we should revisit our use of %__* macros in the guidelines, at least (possibly removing it where appropriate) (mhroncok, 16:38:15)
    3. ACTION: mhroncok to update the https://src.fedoraproject.org/rpms/python-rpm-macros/pull-request/27 in a line of what was said on this meeting (tl;dr use %python3, %python3_version, %python3_sitearch... to GET information, redefine %__python3 to SET information) (mhroncok, 16:47:36)

  7. #909 Suggest that linting/measuring-coverage is not for %check (mhroncok, 16:47:50)
    1. https://pagure.io/packaging-committee/issue/909 (mhroncok, 16:47:50)
    2. https://pagure.io/packaging-committee/issue/909#comment-584794 (decathorpe, 16:48:59)
    3. AGREED: https://pagure.io/packaging-committee/issue/909#comment-584794 (+5,0,-0) (mhroncok, 16:50:36)

  8. #914 Automatic R runtime dependencies (mhroncok, 16:50:53)
    1. https://pagure.io/packaging-committee/issue/914 (mhroncok, 16:50:53)
    2. https://pagure.io/packaging-committee/issue/914#comment-588089 (mhroncok, 16:52:52)
    3. We'd like to see an example about filtering the extra suggest, so we can document it (mhroncok, 16:58:37)
    4. FPC has no problem with dangling suggests as long as approved by legal and FESCo (mhroncok, 16:59:10)

  9. Open Floor (mhroncok, 16:59:41)


Meeting ended at 17:00:59 UTC (full logs).

Action items

  1. mhroncok to update the https://src.fedoraproject.org/rpms/python-rpm-macros/pull-request/27 in a line of what was said on this meeting (tl;dr use %python3, %python3_version, %python3_sitearch... to GET information, redefine %__python3 to SET information)


Action items, by person

  1. mhroncok
    1. mhroncok to update the https://src.fedoraproject.org/rpms/python-rpm-macros/pull-request/27 in a line of what was said on this meeting (tl;dr use %python3, %python3_version, %python3_sitearch... to GET information, redefine %__python3 to SET information)


People present (lines said)

  1. mhroncok (106)
  2. tibbs (35)
  3. decathorpe (21)
  4. zodbot (18)
  5. ignatenkobrain (14)
  6. limburgher (5)
  7. jlebon (1)


Generated by MeetBot 0.1.4.