fpc
LOGS
16:00:46 <geppetto> #startmeeting fpc
16:00:46 <zodbot> Meeting started Thu Sep 19 16:00:46 2019 UTC.
16:00:46 <zodbot> This meeting is logged and archived in a public location.
16:00:46 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:46 <zodbot> The meeting name has been set to 'fpc'
16:00:46 <geppetto> #meetingname fpc
16:00:46 <geppetto> #topic Roll Call
16:00:46 <zodbot> The meeting name has been set to 'fpc'
16:00:54 <tibbs> Hello.
16:00:59 <tibbs> It's a bit exciting in Houston at the moment.
16:01:00 <geppetto> #chair tibbs
16:01:00 <zodbot> Current chairs: geppetto tibbs
16:01:20 <geppetto> yeh, here too
16:01:26 <decathorpe> Hey guys. I'm in bed with a pretty high fever, so I won't be of use today I think
16:01:28 <geppetto> although probably not for everyone
16:01:33 <geppetto> #chair decathorpe
16:01:33 <zodbot> Current chairs: decathorpe geppetto tibbs
16:01:55 <mhroncok> tibbs: what's going on?
16:02:12 <geppetto> decathorpe: that's fine, I think the meeting will be short unless someone has something important … new tickets and no PRs
16:02:15 <tibbs> Tropical storm went overhead yesterday and is still dumping rain over the area.
16:02:17 <geppetto> #chair mhroncok
16:02:17 <zodbot> Current chairs: decathorpe geppetto mhroncok tibbs
16:02:33 * limburgher here
16:02:37 <geppetto> #chair limburgher
16:02:37 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
16:02:38 <mhroncok> Tropical Depression Imelda continues to cause heavy rain over most of southeast Texas.
16:03:14 <mhroncok> decathorpe: get well soon
16:03:23 <tibbs> We're used to storms here but there is always minor flooding.  And it's completely dark outside at 11AM.
16:03:53 <tibbs> There was one new ticket about builds optimized for specialized instruction sets like AVX.
16:04:23 <geppetto> not marked as meeting
16:04:29 <tibbs> Yeah, it's new.
16:04:31 <geppetto> But we can certainly talk about it, if you want
16:05:01 <tibbs> I just think FESCo needs to set some policy relating to that kind of thing before we get too deep into it.
16:05:45 <decathorpe> I only wanted to bring up the outdated tmpfiles.d guidelines
16:05:50 <geppetto> #topic Schedule
16:06:25 <geppetto> There was no schedule this week, too busy, but it was the same tickets as last week and nothing has been modified for a while
16:06:33 <geppetto> #topic #926 Haswell-specific libraries
16:06:38 <geppetto> .fpc 926
16:06:39 <zodbot> geppetto: Issue #926: Haswell-specific libraries - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/926
16:07:52 <mhroncok> As said in the ticket, from the packaging part, the suggestion is OK. whether or not we want this might be a fesco decision, but I see no hram in it
16:09:06 <decathorpe> this looks straightforward from the packaging perspective, yes. the performance improvements would be nice too
16:09:15 <geppetto> I'm fine with it as long as a glibc person confirms the dynamic loader bits are correct
16:09:40 <decathorpe> this is coming from clear linux, right?
16:10:12 <mhroncok> at least the linked blogpost
16:11:15 <tibbs> Last time I chatted with anyone who knew the glibc internals relating to this, it wasn't looked upon favorably.
16:11:45 <tibbs> But if we're going to go down this road, someone should actually ask.  And then test.
16:12:13 <tibbs> It's a bit premature to talk about guidelines alterations until someone's confirmed that this actually works and is something that the glibc maintainers say we should be using in Fedora.
16:12:18 <geppetto> tibbs: as in the glibc didn't like using directories to load different optimised libraries?
16:13:26 <tibbs> I'm going from memory, but basically it was at the level of "there's a bit of support for this in the source, but it probably isn't tested and might not actually work".
16:13:54 <geppetto> #info Need input from glibc developers to confirm facts. Maybe have FESCo set some kind of CPU optimization policy … guideline changes themself seem fine.
16:14:00 <tibbs> Still, asking is the best way, and starting the discussion with FPC is a bit premature until it's been investigated.
16:14:11 <geppetto> fair enough
16:14:46 <geppetto> #topic  #927 Guidelines for Tmpfiles.d outdated
16:14:50 <geppetto> .fpc 927
16:14:51 <zodbot> geppetto: Issue #927: Guidelines for Tmpfiles.d outdated - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/927
16:15:34 <geppetto> So I think the issue here is that #ghost let's the file not exist, and the verify(not …) thing says the file should exist, just don't know what the contents are
16:15:59 <geppetto> But I wouldn't be shocked if everyone just used #ghost anyway
16:16:28 <mhroncok> if this indeed is required, why don't we create a %tmpfile macro ;)
16:16:39 <geppetto> yeh, +1 to that
16:17:16 <mhroncok> note that I haven't yet examined this in any way, so I'm not sure on the "if this indeed is required" part
16:17:20 <geppetto> decathorpe: You want to volunteer for that, after you are well again?
16:17:44 <decathorpe> I can do that
16:18:30 <geppetto> #action decathorpe will look at creating tmpfie macro. Possibly not using #ghost because files should always be there.
16:18:35 <geppetto> #topic Open Floor
16:18:47 <decathorpe> I think the issue is that tmpfiles are on volatile storage and might not necessarily exist
16:22:21 <geppetto> Ok, anything else from anyone?
16:23:14 <mhroncok> nope
16:23:38 <limburgher> No.
16:24:30 <geppetto> Ok, I'm going to end the meeting then. Everyone enjoy your extra 35 minutes
16:24:36 <geppetto> #endmeeting