fpc
LOGS
16:00:08 <geppetto> #startmeeting fpc
16:00:08 <zodbot> Meeting started Thu Sep 12 16:00:08 2019 UTC.
16:00:08 <zodbot> This meeting is logged and archived in a public location.
16:00:08 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:08 <zodbot> The meeting name has been set to 'fpc'
16:00:08 <geppetto> #meetingname fpc
16:00:08 <zodbot> The meeting name has been set to 'fpc'
16:00:08 <geppetto> #topic Roll Call
16:00:12 * limburgher here
16:00:20 <tibbs> Hello.
16:00:33 <geppetto> #chair limburgher
16:00:33 <zodbot> Current chairs: geppetto limburgher
16:00:35 <geppetto> #chair tibbs
16:00:35 <zodbot> Current chairs: geppetto limburgher tibbs
16:00:36 <geppetto> Hey
16:00:37 <decathorpe> hey :)
16:00:37 <ignatenkobrain> .hello2
16:00:37 <mhroncok> hey
16:00:37 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
16:00:41 <geppetto> #chair decathorpe
16:00:41 <zodbot> Current chairs: decathorpe geppetto limburgher tibbs
16:00:44 <geppetto> #chair ignatenkobrain
16:00:44 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher tibbs
16:00:46 <geppetto> #chair mhroncok
16:00:46 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok tibbs
16:00:49 <geppetto> woo
16:01:16 <limburgher> yassss
16:02:38 <geppetto> #topic Schedule
16:02:42 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/YA5DLPA76J7KYKM4XXW2LPG5ZBVONDQU/
16:03:02 <geppetto> #topic #894 PR: Add rules for Cython
16:03:12 <geppetto> https://pagure.io/packaging-committee/pull-request/894
16:03:45 <ignatenkobrain> my comment still stands :)
16:04:25 <mhroncok> is everebody OK with the PR when ignatenkobrain's comment is reflected?
16:04:29 <limburgher> Yes.
16:04:32 <tibbs> Yes.
16:04:44 <geppetto> +1
16:04:55 <limburgher> +1
16:05:47 <geppetto> We all know what it means, but I'm like 1% worried that people would use ignatenkobrain new words to mean they can regenerate their specific cython
16:06:13 <geppetto> but I can't think of better words
16:06:29 <tibbs> Perhaps just add something like "(possibly indirectly via a build system)" after the "MUST be invoked" bit.
16:06:40 <limburgher> I like that.
16:06:47 <geppetto> I'm fine with it
16:06:49 <decathorpe> I'm +1 either way
16:06:58 <ignatenkobrain> what tibbs says works for me. I just wanted to point out that most of the time, people don't invoke cython themselves
16:06:59 <mhroncok> rebased
16:08:09 <mhroncok> "They MUST be deleted in `%prep` and regenerated with Cython."
16:08:37 <mhroncok> is there same ambiguity?
16:10:23 <tibbs> Is it necessary to say "with Cython" at all?
16:11:01 <mhroncok> "They MUST be deleted in `%prep` and regenerated during the build."
16:11:28 * decathorpe shrugs
16:11:31 <mhroncok> (so nobody regenerates them locally and adding as extra sources)
16:11:50 <tibbs> Seems OK to me.
16:12:09 <mhroncok> ok. let's move on
16:12:14 <geppetto> sounds good
16:12:27 <geppetto> #topic #903 PR: Update Python guidelines for Fedora 31
16:12:32 <geppetto> https://pagure.io/packaging-committee/pull-request/903
16:13:30 <tibbs> Are the statements in there true now?
16:13:34 <mhroncok> yes
16:13:58 <tibbs> Then I guess it's time.
16:14:02 <ignatenkobrain> It would be also good to change to sembr as we change docs, but this is definitely not blocking PR
16:14:07 <ignatenkobrain> +1 from me
16:14:10 <limburgher> +1 also
16:14:14 <tibbs> +1
16:14:18 <geppetto> +1
16:14:58 <decathorpe> +1
16:15:12 <mhroncok> ack. I'll rebase an merge after meeting
16:15:24 <geppetto> #action merged
16:15:36 <geppetto> #topic #915 PR: Modernize python spec file example
16:15:42 <geppetto> https://pagure.io/packaging-committee/pull-request/915
16:16:32 <mhroncok> since there are 2 changes, maybe we should discuss / vote them separately
16:16:36 <tibbs> Does this need redoing given that we just approved 903?
16:17:29 <geppetto> The description one feels ugly, but if you think it's the lesser evil then I'm fine with it
16:17:42 <tibbs> To me this is mainly stylistic so it may be best for it to reflect what is used by the majority of python package maintainers.
16:18:04 <mhroncok> tibbs: doesn't
16:18:11 <decathorpe> the %{expand: stuff} is definitely nice for deduplicating the description, and I'm using it for all my new packages
16:18:28 <mhroncok> it's nicer than \ newlines
16:18:28 <tibbs> It would be counterproductive for the guidelines to list as examples something that new packagers won't actually see when they look at existing packages.
16:18:29 <geppetto> I can't see the non-description change?
16:18:48 <tibbs> geppetto: There are two commits.
16:18:49 <mhroncok> geppetto: BuildRequires
16:18:52 <limburgher> The BR movement is just from the subpackage to the main block.
16:18:55 <decathorpe> and I'm fine with moving BRs to the top. it makes it easier to see them at a glance
16:19:19 <tibbs> I personally always put all dependencies together near the top, but I don't particularly care either way.
16:19:32 <geppetto> limburgher: Oh, I hadn't realized it was more than just moving within the same package
16:19:55 <limburgher> Yeah, it's still not a huge deal.
16:20:08 <limburgher> You can make a solid argument for either method.
16:20:09 <geppetto> yeh, I don't care either way … so +1
16:20:22 <limburgher> +1 here for both.
16:20:48 <tibbs> What bugs me is that these are basically nitpicking.
16:21:11 <ignatenkobrain> I usually put BRs under subpkg. But +1 in any case
16:21:22 <mhroncok> +1 expand, +-0 BRs
16:21:43 <decathorpe> yeah, same for me
16:21:56 <mhroncok> decathorpe: same as who?
16:22:03 <tibbs> I guess it's just the "send pointless nitpicks, then complain when they aren't addressed" attitude that bugs me.
16:22:05 <decathorpe> (meaning +1 for expand description, 0 for moving BRs) sorry
16:22:43 <decathorpe> tibbs: right ... well, we might as well deal with it
16:24:46 <geppetto> I think we are at +4 for the description and +2 for the BR
16:25:06 <geppetto> Ahh, missed ignatenkobrain  … so +5 and +3
16:25:24 <tibbs> I will say that the description change also fixes the "An python module" error.
16:25:36 <geppetto> #action Merge description change, not BR change.
16:25:54 <geppetto> #topic #914 Automatic R runtime dependencies .fpc 914 https://pagure.io/packaging-committee/issue/914
16:26:58 <ignatenkobrain> I would say "send PR to guidelines and we can review it"
16:27:27 <decathorpe> yep. but I think if it's not difficult to filter out missing deps from Suggests, it should be done
16:27:54 <geppetto> ignatenkobrain: So you think spot will be able to do this?
16:28:07 <tibbs> And I still think that absent word from the lawyers and a FESCo decision, it _must_ be done.
16:28:25 * geppetto nods
16:28:31 <ignatenkobrain> well, I have talked to spot.... He promised to come back with some answers some time soon :)
16:29:12 <geppetto> And I'd bet that lawyers wouldn't be happy with unfilled suggests, esp. if/when those get filled from rpmfusion
16:29:24 <ignatenkobrain> I would like to avoid speculating here what is allowed and what is not from legal POV. There is no easy way how to filter automatic Suggests which are not in Fedora.
16:29:29 <limburgher> Neither would I. :)
16:29:54 <ignatenkobrain> geppetto: suggests are not shown anywhere. they are not even installed by default.
16:30:12 <geppetto> ignatenkobrain: You can turn them on though
16:30:35 <tibbs> Avoiding speculation means moving on from this until we get a legal opinion and a FESCo vote.
16:30:36 <ignatenkobrain> no, you can't
16:30:47 <ignatenkobrain> DNF is missing any capabilities to show Suggests :)
16:30:50 <ignatenkobrain> tibbs: +1
16:30:55 <geppetto> ignatenkobrain: Oh, fair enough then
16:31:29 <geppetto> We need to not have it in meeting then … needinfo on lawyers
16:31:42 <geppetto> #action Need info from lawyers before we can do anything
16:32:12 <geppetto> #info DNF doesn't have the sapability to act (or show) on suggests anyway.
16:32:40 <mhroncok> can we just not do the suggests?
16:33:02 <ignatenkobrain> mhroncok: it is more complicated than that. it means we need to turn off all dependency generators :)
16:33:17 <mhroncok> ignatenkobrain: heh
16:33:32 <geppetto> ignatenkobrain: no big deal then ;)
16:33:42 <geppetto> #topic Open Floor
16:34:09 <geppetto> Ok, so the other tickets don't seem to have moved enough we can do anything … but if you want to talk about any of them (or anything else) speak up now
16:34:18 <limburgher> I have nothing.
16:34:28 <tibbs> I'm still overburdened with work....
16:34:31 <tibbs> Maybe one day.
16:35:00 <decathorpe> I got nothing
16:35:18 * geppetto nods
16:35:43 * mhroncok overheard a 10 year old speaking to a phone: "I don't have much time those days" :D
16:36:00 <geppetto> Ok, I'll give you all 25 minutes back.
16:36:03 <ignatenkobrain> Nothing from me. Being busy with $dayjob lately.
16:36:13 <geppetto> #endmeeting