fedora_coreos_meeting
LOGS
16:30:00 <bgilbert> #startmeeting fedora_coreos_meeting
16:30:00 <zodbot> Meeting started Wed Jul 24 16:30:00 2019 UTC.
16:30:00 <zodbot> This meeting is logged and archived in a public location.
16:30:00 <zodbot> The chair is bgilbert. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:00 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:30:05 <bgilbert> #topic roll call
16:30:11 <bgilbert> .hello2
16:30:12 <zodbot> bgilbert: bgilbert 'Benjamin Gilbert' <bgilbert@backtick.net>
16:30:26 <andrew_> .hello2
16:30:27 <zodbot> andrew_: Sorry, but you don't exist
16:30:34 <ajeddeloh> .hello2
16:30:35 <zodbot> ajeddeloh: ajeddeloh 'Andrew Jeddeloh' <andrew.jeddeloh@redhat.com>
16:31:14 <slowrie> .hello2
16:31:15 <zodbot> slowrie: slowrie 'Stephen Lowrie' <slowrie@redhat.com>
16:31:33 <rfairley> .hello2
16:31:33 <zodbot> rfairley: rfairley 'None' <rfairley@redhat.com>
16:31:42 <ed_packet> howdy
16:32:14 <ksinny> .hello sinnykumari
16:32:15 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
16:32:17 <mnguyen_> .hello mnguyen
16:32:21 <zodbot> mnguyen_: mnguyen 'Michael Nguyen' <mnguyen@redhat.com>
16:32:47 <kaeso[m]> .hello lucab
16:32:50 <zodbot> kaeso[m]: lucab 'Luca Bruno' <lucab@redhat.com>
16:33:43 <ed_packet> .hello ed_packet
16:33:44 <zodbot> ed_packet: Sorry, but you don't exist
16:33:48 <ed_packet> hm
16:33:55 <bgilbert> ed_packet: it's looking for your Fedora Account System ID
16:34:23 <bgilbert> #chair ajeddeloh slowrie rfairley ed_packet ksinny mnguyen_ kaeso[m]
16:34:23 <zodbot> Current chairs: ajeddeloh bgilbert ed_packet kaeso[m] ksinny mnguyen_ rfairley slowrie
16:34:39 <bgilbert> #topic Action items from last meeting
16:34:47 <bgilbert> rfairley to improve visibility of Fedora signing key on download page
16:34:54 <bgilbert> rfairley to link AMI IDs on download page to AWS console launch page
16:34:59 <bgilbert> rfairley to add advice to download page on verifying downloads
16:35:07 <bgilbert> ajeddeloh to file tickets for FCCL online translator and for linking FCC examples to that translator
16:35:16 <bgilbert> bgilbert to follow up on marketing infographics: intro to FCOS, FAH/CL/FCOS differentiation, hands-on cheatsheet
16:35:21 <bgilbert> bgilbert to file ticket for launch-on-this-cloud shortlink redirector
16:35:25 <bgilbert> red_beard to file ticket for virt-install --location support
16:35:55 <bgilbert> #action bgilbert to follow up on marketing infographics: intro to FCOS, FAH/CL/FCOS differentiation, hands-on cheatsheet
16:36:15 <bgilbert> #info bgilbert filed https://github.com/coreos/fedora-coreos-tracker/issues/226 for shortlink redirector
16:36:23 <bgilbert> (and the discussion so far is trending against it)
16:36:56 <bgilbert> #info red_beard filed https://github.com/coreos/fedora-coreos-tracker/issues/221 for virt-install --location support
16:36:56 * ajeddeloh forgot, will do that today
16:37:05 <bgilbert> #action ajeddeloh to file tickets for FCCL online translator and for linking FCC examples to that translator
16:37:23 <bgilbert> rfairley?
16:37:23 <red_beard> .hello red_beard
16:37:24 <rfairley> +1 - opened a PR for the first 3, https://pagure.io/fedora-web/websites/pull-request/46. this does require https://pagure.io/fedora-web/websites/pull-request/44, where we may want to investigate a different approach for long-term (see comments)
16:37:26 <zodbot> red_beard: Sorry, but you don't exist
16:37:42 <bgilbert> #chair red_beard
16:37:42 <zodbot> Current chairs: ajeddeloh bgilbert ed_packet kaeso[m] ksinny mnguyen_ red_beard rfairley slowrie
16:37:46 <jlebon> .hello2
16:37:47 <red_beard> .hello redbeard
16:37:47 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:37:50 <zodbot> red_beard: redbeard 'Brian 'redbeard' Harrington' <bharring@redhat.com>
16:38:07 <bgilbert> #chair jlebon
16:38:07 <zodbot> Current chairs: ajeddeloh bgilbert ed_packet jlebon kaeso[m] ksinny mnguyen_ red_beard rfairley slowrie
16:38:17 <rfairley> short-term we could get https://pagure.io/fedora-web/websites/pull-request/46 in, to add the enhancements
16:38:54 <bgilbert> #info rfairley opened https://pagure.io/fedora-web/websites/pull-request/46
16:39:14 <bgilbert> rfairley: +1.  discuss further in the PRs?
16:39:25 <rfairley> bgilbert: +1, let's discuss in comments there
16:39:47 <bgilbert> #topic Open Floor
16:40:56 <ed_packet> I'd like to offer up help / look for support for getting FCOS running well at Packet. Dustin at Packet (not on this meeting) will be assisting me.
16:41:18 <bgilbert> ed_packet: thanks!
16:41:32 <bgilbert> ed_packet: Packet support (and not _just_ Packet support) is currently blocked on https://github.com/coreos/fedora-coreos-tracker/issues/24
16:41:37 <bgilbert> which was deferred until after the initial preview
16:41:40 <ed_packet> My best guess at where to start is with some combo of the bare metal installer and the IPXE installer. Any pointer to a specific repo to anchor on is welcomed
16:41:45 <ed_packet> tnx
16:42:09 <bgilbert> oh right, you use live PXE support with Container Linux
16:42:25 <bgilbert> which is https://github.com/coreos/fedora-coreos-tracker/issues/105
16:42:56 <bgilbert> in principle you don't need the latter if you run coreos-installer on another distro, at least for now
16:43:28 <kaeso[m]> I'm not too familiar with Packet provisioning, but does it support pre-imaged machine? That is, just starting a machine with our "metal" image as the primary disk?
16:43:47 <bgilbert> you'll also need https://github.com/coreos/coreos-installer/pull/52 and the corresponding work in coreos-assembler
16:44:16 <ed_packet> Packet provisioning does have some setting for a "pre-imaged" machine, which we currently use to support 60-second Ubuntu installs.
16:45:02 <bgilbert> kaeso[m]: AIUI Packet PXE-boots a provisioner which installs the distro image and reboots into it
16:46:48 <ed_packet> yes, as bgilbert says the usual path for custom installs and for new operating systems starts with the PXE boot process. Supported OS versions wrap a layer of UI/API around that to make it easier.
16:47:02 <kaeso[m]> I guess that if we could use the pre-imaged approach, then we just have to solve the "how to inject Ignition userdata" part
16:47:26 <bgilbert> ed_packet: so my advice is to wait a bit.  once we resolve the blockers, you'll have a clearer path toward proper Packet support in FCOS.
16:47:47 <bgilbert> the actual Packet-specific part is small.  we already support Packet userdata in Ignition, and fetching network config in Afterburn.
16:48:01 <bgilbert> we'll need to update Afterburn for https://github.com/coreos/fedora-coreos-tracker/issues/24
16:48:21 <ed_packet> OK. I'll point Dustin at Packet at 24 and 105 just to give him a sense for the project and so we can watch to be ready when those issues are resolved.
16:49:38 <kaeso[m]> ah, that's true, I forgot we already have a "packet" platform in both of the above
16:49:56 <bgilbert> and thanks for checking in.  it would have been great to have more clouds available for the initial preview, but there wasn't enough time.  :-(  adding more cloud support is a priority for FCOS.
16:51:40 <ed_packet> Yup, all good. Reach out when you're ready for the next round, I think you already have test accounts set up.
16:52:12 <bgilbert> +1, thanks!
16:53:15 <fos> Hi, Ignaz from openSUSE Kubic here. We're currently trying to integrate Ignition in openSUSE; most things are working perfectly fine so far, except for a hard /boot dependency in ignition-dracut.
16:53:55 <ajeddeloh> hi, sorry I've been slow to respond to that ticket, it is on my radar
16:54:17 <fos> ah, thanks, I was starting to get worried :-)
16:54:35 <ajeddeloh> I haven't had time to dive in yet, so unfortunately I don't have anything off hand right now
16:54:53 <jlebon> same, apologies for the delay :)
16:55:14 <fos> No problem. I'm not attached to that code / solution by the way - I just tried to come up with *something*
16:55:39 <jlebon> gotcha
16:56:38 <ajeddeloh> I'll try to find some time before next meeting to take a look
16:56:49 <fos> Thanks a lot!
16:57:17 <ajeddeloh> #action ajeddeloh to look into removing the hard /boot dependency for ignition-dracut
16:57:23 <bgilbert> #link https://github.com/coreos/ignition-dracut/pull/80
16:57:49 <fos> Based on how the solution will look like I'd also try to solve the read-only root problem in a similar way
16:58:33 <fos> #link https://github.com/coreos/ignition-dracut/issues/39
16:59:03 <bgilbert> hmm, you're not chaired, so I'm not sure if that works
16:59:04 <bgilbert> let's see
16:59:05 <bgilbert> #undo
16:59:05 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f6d2fbd6c90>
16:59:10 <bgilbert> ...unhelpful
16:59:19 <bgilbert> #link https://github.com/coreos/ignition-dracut/pull/80
16:59:24 <bgilbert> #link https://github.com/coreos/ignition-dracut/issues/39
16:59:26 <bgilbert> #chair fos
16:59:26 <zodbot> Current chairs: ajeddeloh bgilbert ed_packet fos jlebon kaeso[m] ksinny mnguyen_ red_beard rfairley slowrie
17:03:20 <bgilbert> any other topics for open floor?
17:04:00 <bgilbert> oh yes
17:04:01 <bgilbert> #link https://github.com/coreos/fedora-coreos-tracker/issues/215
17:04:13 <bgilbert> the first preview release will not be able to update itself without assistance :-(
17:04:51 <bgilbert> it's fixed in Git and there will be a new release soon
17:05:25 <jlebon> right, just merged the prereqs to have a new release out
17:06:00 <ajeddeloh> Oh, I've got an ignition bug I'm working on fixing that we ought to include in that
17:06:22 <jlebon> ajeddeloh: ok, let's coordinate on that
17:06:40 <bgilbert> jlebon: once that release is out, we should email coreos-status with workaround instructions.  would be good to exercise that mechanism.
17:06:42 <ajeddeloh> +1, still working on the fix, should have a PR up this afternoon
17:07:04 <jlebon> hmm, might be time for a github project board to track this stuff
17:07:22 <jlebon> (or some other tracking mechanism)
17:07:41 <bgilbert> +1
17:08:23 <jlebon> bgilbert: yup will do re. workaround
17:09:51 <bgilbert> #action jlebon to email coreos-status about upgrade workaround once the next release is out
17:10:31 <bgilbert> anything else?  will close in 90s
17:11:59 <bgilbert> thanks for coming, all!
17:12:02 <bgilbert> #endmeeting