fpc
LOGS
16:00:56 <geppetto> #startmeeting fpc
16:00:56 <zodbot> Meeting started Thu May 16 16:00:56 2019 UTC.
16:00:56 <zodbot> This meeting is logged and archived in a public location.
16:00:56 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:56 <zodbot> The meeting name has been set to 'fpc'
16:00:56 <geppetto> #meetingname fpc
16:00:56 <zodbot> The meeting name has been set to 'fpc'
16:00:56 <geppetto> #topic Roll Call
16:01:08 <mhroncok> hey
16:01:12 <geppetto> #chair mhroncok
16:01:12 <zodbot> Current chairs: geppetto mhroncok
16:01:14 <geppetto> hey
16:01:45 <mhroncok> geppetto: BTW there was a request to add a ticket to the agenda
16:01:53 * geppetto nods
16:03:37 <decathorpe> hey o/
16:03:51 <geppetto> #chair decathorpe
16:03:51 <zodbot> Current chairs: decathorpe geppetto mhroncok
16:03:57 <redi> hi
16:04:02 <geppetto> #chair redi
16:04:02 <zodbot> Current chairs: decathorpe geppetto mhroncok redi
16:04:17 <redi> sorry I could make it last week, was looking after a sick child
16:06:34 * geppetto nods
16:07:34 <mhroncok> doesn't look good
16:07:43 <geppetto> need one more or it's going to be a quick talk only meeting
16:07:44 <geppetto> yeh
16:08:41 <tibbs> Hey, folks.
16:08:49 <geppetto> hey number 5 :)
16:08:50 <tibbs> Sorry; another busy day here.
16:08:53 <geppetto> #chair tibbs
16:08:53 <zodbot> Current chairs: decathorpe geppetto mhroncok redi tibbs
16:09:08 <geppetto> no problem
16:09:14 <geppetto> #topic Schedule
16:09:18 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/5TS5QLTP5QDZ35OVTKSUAULKOKHUMRSD/
16:10:21 <mhroncok> + 890 requested by zbyszek
16:10:25 <geppetto> #topic PR#890 Stop using %systemd_requires for packages which only install unit files
16:10:31 <geppetto> yeh, doing that first
16:10:41 <geppetto> https://pagure.io/packaging-committee/pull-request/890
16:10:45 * zbyszek is here
16:10:48 <mhroncok> zbyszek: hi
16:11:52 <geppetto> zbyszek: So the ordering thing is for the first transaction … it means that if something doesn't require systemd but can use it then it happens in the transaction after systemd
16:12:30 <redi> semantic breaks in the new paragraph (lines 34-40) would make it easier to review
16:12:37 <tibbs> I'm certainly OK with trimming the dependencies.
16:13:21 <mhroncok> I haven't got time to read this properly, but I think the change makes sense
16:13:21 <zbyszek> geppetto: there's two "ordering things": %systemd_requires, and %systemd_ordering, and both create ordering constraints. Which one do you mean?
16:14:14 <geppetto> zbyszek: Your question about using %systemd_ordering instead of nothing
16:15:38 <zbyszek> geppetto: Oh, that. My question was a reply to ngompa's suggestion to recommend %systemd_ordering.
16:16:04 * geppetto nods
16:16:23 <zbyszek> What you said is true, but I doesn't seem to apply to the common case, i.e. using the macro is not useful most of the time.
16:16:58 <tibbs> The real question is what happens outside of "most of the time"?
16:17:19 <tibbs> What's the breakage?  How do you detect it?  Is it common enough that we need to document it?
16:17:35 <zbyszek> %systemd_ordering was originally created to cater to this specific case which has been obsoleted by the call to preset-all which was added later on.
16:18:49 <zbyszek> tibbs: if a tool is used and mandatory, the spec file must declare dependencies on it. This general rule applies here.
16:20:01 <geppetto> but my understanding was that if you are putting systemd files down you should still use ordering
16:20:03 <zbyszek> That's why I didn't want to turn %systemd_requires into a noop, but instead to prefer to remove its use from a) guidelines for %systemd_post* scriptlets, b) individual spec files after review.
16:20:59 <zbyszek> geppetto: that used to be true, but there's no technical reason anymore.
16:21:04 <geppetto> ok
16:21:15 <geppetto> fair enough, I'm +1 then
16:22:09 <decathorpe> I guess I am +1 too
16:22:14 <mhroncok> +1
16:22:34 <tibbs> +1
16:23:06 <mhroncok> redi
16:23:11 <zbyszek> If you want me to repush the branch with more breaks, I can do it quickly.
16:23:15 <tibbs> Now I just wish I understood why ngompa wanted %systemd_ordering to be used.
16:23:30 <redi> +1
16:23:52 <geppetto> #action PR#890 Stop using %systemd_requires for packages which only install unit files  (+1:5, 0:0, -1:0)
16:24:11 <tibbs> To be fair, I don't completely understand what OrderWithRequires: does.
16:24:31 <geppetto> #topic #886 Enable BRP for detecting RPATH
16:24:35 <geppetto> .fpc 886
16:24:36 <zodbot> geppetto: Issue #886: Enable BRP for detecting RPATH - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/886
16:24:53 <tibbs> I have long wondered why that's not enabled.
16:24:55 <geppetto> tibbs: it does the ordering part of requires … without doing the requires part.
16:25:13 <zbyszek> tibbs: it's supposed to affect transaction order if both packages happen to be present in the transaction
16:25:38 <mhroncok> tibbs: maybe because it used to have an extra dependency?
16:26:25 <tibbs> mhroncok: It's only recently that we started caring so much about buildroot dependencies.
16:26:40 <geppetto> I'm +1 on this
16:26:50 <mhroncok> I'm +1 obviously
16:26:56 <mhroncok> ignatenkobrain is +1
16:27:05 <decathorpe> me too
16:27:11 <tibbs> My only fear is breakage.
16:27:43 <tibbs> Do we need to tweak the "beware of rpath" section to mention disabling this check?
16:28:00 <redi> yeah I think so
16:28:13 <tibbs> We would definitely need to change that section to remove mention of turning it on.
16:28:22 <redi> any check should have a documented way to disable it, because somebody always needs to
16:29:25 <mhroncok> of course
16:29:37 <tibbs> Yes, we switched to a consistent way to disable things in %__os_install_post a while back.
16:29:49 * geppetto nods
16:30:05 <mhroncok> is __arch_install_post something that is only called for arched packages?
16:30:13 <tibbs> In this case you would %global %__brp_check_rpaths %nil
16:30:41 <tibbs> mhroncok: No, not really.
16:30:56 <tibbs> The real macro is %__spec_install_post
16:31:01 <mhroncok> omg
16:31:05 <mhroncok> so many install posts
16:31:28 <tibbs> Which includes %__debug_install_post (if defined), %__arch_install_post and %__os_install_post.
16:31:32 <tibbs> The latter two unconditionally.
16:31:52 <tibbs> So... I don't know.  I'll look deeper to see how those get defined just in case.
16:32:28 <tibbs> %__spec_install_post is simply appended to the end of the %install section as if it had been pasted there.
16:32:44 <tibbs> Which is why adding 'exit 0' screws up the world so badly.
16:33:48 <tibbs> So %__arch_install_post is defined in platform/XXX/macros file, so it can change definition depending on which platform you're building for.
16:34:30 <tibbs> But.. so is %__spec_install_post.  So, I mean, whatever.  If I look any deeper I will hurt myself.
16:34:54 <mhroncok> :D
16:35:20 <tibbs> Anyway, it looks like the "beware of rpath" section is completely out of date.
16:35:32 <tibbs> The things it suggests that you add are already there in Fedora.
16:35:45 <tibbs> Or will be if we approve this.
16:35:54 <tibbs> (check-buildroot is there now)
16:36:00 <tibbs> ANyway, +1.
16:36:16 <redi> +1, but needs moar docs
16:36:17 <geppetto> Ok, that's +4 … I think
16:36:24 <geppetto> +5 now .. wooo
16:36:44 <geppetto> decathorpe: you want to vote?
16:37:46 <decathorpe> I said, +1 me too :)
16:38:57 <tibbs> I can do some docs since that section needs to be cleaned up anyway.
16:39:10 <geppetto> ahh, missed that … looking for the +1 symbols :)
16:39:17 <geppetto> #action Enable BRP for detecting RPATH (+1:6, 0:0, -1:0)
16:39:31 <geppetto> #topic #887 Review Process Exemption: colcon - collective construction
16:39:37 <geppetto> .fpc 887
16:39:38 <zodbot> geppetto: Issue #887: Review Process Exemption: colcon - collective construction - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/887
16:40:36 * mhroncok was +1 in the ticket
16:41:07 <geppetto> yeh, got to the end and I'm +1 too
16:41:18 <decathorpe> the "examples" got approved already?
16:41:24 <geppetto> yeh
16:41:29 <decathorpe> then I'm #1 too
16:41:31 <decathorpe> +1
16:41:43 <tibbs> +1
16:42:12 <tibbs> I'm OK for exceptions to fully templated packages _as long as license checks were done_.
16:42:50 <decathorpe> yes, I assume that has been done
16:43:24 <redi> +1
16:43:28 <tibbs> You know what they say about assuming.  I should have asked the question in the ticket.
16:43:36 <redi> gotta go now, sorry
16:43:47 <decathorpe> right :D
16:43:52 <decathorpe> bye redi
16:44:00 <mhroncok> the packages generally are all Apache licensed
16:44:10 <mhroncok> of course they might be some hidden gems in them
16:44:14 <mhroncok> *there
16:44:25 <tibbs> At least according to the LICENSE files on github, everything but the docs site is ASL2.
16:45:19 <tibbs> But certainly, stuff could be in there.  It would be an interesting question to spot and the legal team: how much checking needs to be done before importing things?
16:45:27 <geppetto> #action Review Process Exemption: colcon (+1:5, 0:0, -1:0)
16:45:39 <geppetto> #topic Open Floor
16:45:57 <geppetto> Ok, with redi gone we only have 4 … and we are nearing the end of the hour anyway
16:46:05 <geppetto> anything anybody wants to talk about?
16:47:23 <decathorpe> nope
16:48:55 <tibbs> Not me.
16:49:52 <geppetto> Ok, see you next week.
16:49:55 <geppetto> #endmeeting